Tardat - obsah

Tarifikační systém Tardat 4

Podrobná dokumentace

©Ing. David Motl, Ing. Petr Zdražílek PhD., TARTEK

Obsah

1 Přenos dat a konfigurace zařízení
  • 1.1 Přenosový modul Tarwin
    • 1.1.1 Seznam podporovaných protokolů
    • 1.1.2 Spouštění programu Tarwin
    • 1.1.3 Uživatelské rozhraní
    • 1.1.4 Síťové rozhraní
    • 1.1.5 Technické požadavky pro provoz programu
    • 1.1.6 Doporučené postupy
    • 1.1.7 Řešení problémů s přenosy z bufferu Tarflex
    • 1.1.8 Licence k programu Tarwin
  • 1.2 Konfigurační nástroj Tarkonfig
    • 1.2.1 Konfigurace zařízení
    • 1.2.2 Editace parametrů zařízení
    • 1.2.3 Konfigurace síťového rozhraní
    • 1.2.4 Spouštění programu Tarwin
  • 1.3 Konfigurační soubory zařízení
    • 1.3.1 Struktura konfiguračních souborů
    • 1.3.2 Hlavní konfigurační soubor
    • 1.3.3 Definice zařízení
  • 1.4 Konfigurace zařízení v programu Tardat
    • 1.4.1 Spouštění přenosů
2 Zpracování tarifních dat, konfigurace ústředen a databáze hovorů
  • 2.1 Konfigurace ústředen a související tabulky
    • 2.1.1 Ústředny
    • 2.1.2 Průchodové sítě
    • 2.1.3 Uživatelské sítě
    • 2.1.4 Skupiny poboček a střediska
    • 2.1.5 Interní seznam
  • 2.2 Zpracování hovorů
    • 2.2.1 Postup při zpracování tarifních dat
    • 2.2.2 Autodetekce během zpracování
    • 2.2.3 Program Zpracuj a služba systému Zpracujs
    • 2.2.4 Grafické uživatelské rozhraní
    • 2.2.5 Síťové rozhraní
    • 2.2.6 Další funkce
  • 2.3 Popis databázových tabulek
    • 2.3.1 Obecná nastavení
    • 2.3.2 Konfigurace ústředen
    • 2.3.3 Tarifní sítě
    • 2.3.4 Databáze hovorů
3 Přehledy hovorů, konfigurace uživatelů, webový server
  • 3.1 Přehledy hovorů
    • 3.1.1 Nastavení přehledu
    • 3.1.2 Okno přehledů
    • 3.1.3 Nastavení požadovaných vlastností přehledu
    • 3.1.4 Nastavení vzhledu
    • 3.1.5 Nástroje v okně přehledů
    • 3.1.6 Tisk přehledu
    • 3.1.7 Tisk faktury
    • 3.1.8 Tisk účtenky
    • 3.1.9 Export přehledu
  • 3.2 Konfigurace uživatelů
    • 3.2.1 Vlastnosti uživatelů
    • 3.2.2 Editace uživatelů v programu Tardat
    • 3.2.3 Editace rolí v programu Tardat
    • 3.2.4 Postup při přihlašování do programu Tardat
  • 3.3 Popis databázových tabulek
    • 3.3.1 Obecná nastavení
    • 3.3.2 Konfigurace uživatelů
    • 3.3.3 Databáze hovorů
    • 3.3.4 Přehledy
  • 3.4 Malý webový server
    • 3.4.1 Konfigurace serveru
    • 3.4.2 Instalace a ovládání modulů
    • 3.4.3 Ovládání webového rozhraní
4 Nástroje
  • 4.1 Nástroje pro správu konfigurace
    • 4.1.1 Import konfiguračních tabulek
    • 4.1.2 Formáty vstupních souborů
    • 4.1.3 Export konfiguračních tabulek
    • 4.1.4 Formáty výstupních souborů
    • 4.1.5 Záloha konfigurace
    • 4.1.6 Obnova konfigurace
  • 4.2 Nástroje pro správu databáze
    • 4.2.1 Archivace hovorů
    • 4.2.2 Zpětné zpracování databáze
    • 4.2.3 Zpětné zpracování souborů 'chybne'
    • 4.2.4 Zpracování dat ze souboru
    • 4.2.5 Vymazání duplicit
    • 4.2.6 Import hovorů ze souboru CSV
  • 4.3 Rozšiřující moduly
    • 4.3.1 Minihotelový provoz
5 Univerzální vyrovnávací paměti řady Tarflex
  • 5.1 Přístroj Tarflex-E
    • 5.1.1 Úvod
    • 5.1.2 Instalace přístroje a programů
    • 5.1.3 Techická specifikace
    • 5.1.4 Konfigurace bufferu pomocí programu Telnet
  • 5.2 Přístroj Tarflex-S
    • 5.2.1 Úvod
    • 5.2.2 Instalace přístroje a programů
    • 5.2.3 Techická specifikace
  • 5.3 Program Tarflex
    • 5.3.1 Instalace programu
    • 5.3.2 Spuštění programu a připojení bufferu
    • 5.3.3 Nastavení síťových parametrů bufferu
    • 5.3.4 Nastavení ostatních parametrů bufferu
    • 5.3.5 Další funkce
    • 5.3.6 Servisní menu
Přílohy
  • A Licence k programu Tardat 4
  • B Licence ke knihovnám Zip32.dll a Unzip32.dll
  • C Zapojení konektorů a kabelů
  • D Přehled adresářů a souborů v adresáři programu
  • E Použitá literatura a užitečné odkazy
  • F Popis databázových tabulek


Program Tarwin

V této kapitole je popsáno ovládání programu Tarwin, který slouží k příjmu dat z bufferu Tarflex nebo jiného zařízení.

Obsah

  1. Seznam podporovaných protokolů
  2. Spouštění programu Tarwin
  3. Uživatelské rozhraní
  4. Síťové rozhraní
  5. Technické požadavky pro provoz programu
  6. Doporučené postupy
  7. Řešení problémů s přenosy z bufferu Tarflex
  8. Licence k programu Tarwin

Viz také:

  • Konfigurační soubory zařízení
  • Konfigurace zařízení v programu Tardat


Program Tarwin - seznam podporovaných protokolů

Program Tarwin

Seznam podporovaných protokolů

Program Tarwin podporuje v současné době tato zařízení:

  • TARFLEX na sériovém portu - buffer Tarflex nebo Tarflex plus připojený přímo k sériovému portu počítače.

  • TARFLEX přes síť TCP/IP - buffer Tarflex nebo Tarflex plus s rozhraním Ethernet zapojený do sítě nebo obyčejný buffer připojený přes sériový port k jinému počítači zpřístupněný do sítě pomocí programu RSEth.

  • TARFLEX přes telefonní modem - buffer Tarflex nebo Tarflex plus připojený přes telefonní modem.

  • TARFLEX-E - nový buffer Tarflex se síťovým rozhraním.

  • Ústředna Alcatel 4400 přes TCP/IP - získávání tarifních dat z ústředny Alcatel 4400 připojené přes síť.

  • Ústředna Alcatel OmniPCX přes TCP/IP - získávání tarifních dat z ústředny Alcatel OmniPCX (OXO) připojené přes síť.

  • Ústředna Alcatel 4400 přes SLIP - získávání tarifních dat z ústředny Alcatel 4400 připojené přes vytčené připojení sítě protokolem SLIP.

  • Ústředna Siemens 100, 300 přes TCP/IP - získávání tarifních dat z ústředny Siemens, která je vybavena rozhraním pro připojení do sítě TCP/IP.

  • Přímé propojení PC s ústřednou nebo jiný buffer - zachytávání příchozích dat ze sériového portu, ke kterému je přímo připojen tarifikační výstup pobočkové ústředny nebo buffer jiného výrobce.

  • Zachytávání znaků na TCP portu - program se chová jako server protokolu TCP a na síťovém portu čeka na příchozí spojení. Přijatá data od klienta ukládá je do souboru.


Program Tarwin - spouštění programu Tarwin

Program Tarwin

Spouštění programu Tarwin

Ve většině případů se program Tarwin spouští při startu počítače. Tím se zajistí, že se data z bufferu Tarflex budou pravidelně stahovat a nedojde k přetečení jeho paměti. Pokud používáte protokol "Přímé propojení...", pak zachytávání znaků pracuje pouze tehdy, když je Tarwin spuštěný.

Spouští-li se přenos na serveru a požaduje se, aby komunikace probíhala i když na něm není přihlášen žádný uživatel, pak je vhodné využít modul, který se instaluje jako služba systému.

K instalaci programu lze využít konfigurační nástroj (viz kapitola 1.2) nebo provést nastavení ručně:

Instalace zástupce do složky "Po spuštění":

Otevřete si "Tento počítač" a vyhledejte složku "Po spuštění". Obvykle bývá na disku C: v adresáři Windows\Nabídka Start\Programy\Po spuštění. Pravým tlačítkem myši otevřete nabídku funkcí a zvolte "Nový" -> "Zástupce". Spustí se průvodce pro vytváření zástupců. Stiskněte tlačítko "Procházet" a v navigačním okně vyhledejte program Tarwin.exe (obvykle C:\tardat\tarwin.exe), jako název zástupce vložte Tarwin.

Odstranění zástupce ze složky po spuštění:

Otevřete nabídku "Start" a vyhledejte v podnabídce programy složky "Po spuštění". V ní označte položku Tarwin a pravým tlačítkem myši vyvolejte nabídku funkcí. Zvolte položku "Odstranit" a podvrďte odstranění zástupce.

Instalace služby systému:

Spusťte program tarwins.exe s parametrem /INSTALL. Otevřete správce služeb a označte položku "Tarwin" a stiskněte tlačítko "Spustit".

Odstranění služby systému:

Pomocí správce služeb nejprve službu "Tarwin" vypněte. Pak spusťte program tarwins.exe s parametrem /UNINSTALL.


Program Tarwin - uživatelské rozhraní

Program Tarwin

Uživatelské rozhraní

Program Tarwin obsahuje jednoduché uživatelské rozhraní, které umožňuje sledování stavu a řízení přenosu. Následující text se netýká služby systému Tarwins.

Ikona programu

Spuštění program je indikováno modrým sluchátkem vpravo dole u hodin. Probíhá-li právě komunikace s nějakým zařízením, je u sluchátka zobrazena malá zelená šipka. V případě, že došlo k chybě, obshuje ikona malý červený vykřičník. Na operačních systémech Windows ME, XP a 2000 se při chybě zobrazuje nad ikonou také bublinová nápověda; tuto funkci je možné zakázat v konfiguračním souboru.

Kliknutím pravým tlačítkem myši na ikonu programu se otevře základní nabídka funkcí:

  • Otevřít - otevře ovládací panel programu
  • Spustit přenos - zahájí přenos nových dat ze všech zařízení
  • Ukončit přenos - ukončí činnost programu

Ovládací panel programu

Základní okno programu obsahuje několik záložek. První se jmenuje "Stav" a obsahuje tabulku všech definovaných zařízení a jejich aktuální stav. Další záložky se jmenují stejně jako zařízení a je v nich zobrazen podrobný protokol o právě probíhajícím nebo posledním přenosu dat.

V tabulce zařízení jsou důležité ikony u jednotlivých řádků. Zelená šipka indikuje, že s tímto zařízením se právě komunikuje, červený vykřičník znamená, že při posledním přenosu došlo k chybě. (obr)

Okno také obsahuje několik ovládacích tlačítek:

  • Spustit přenos - zahájí přenos dat na zařízení označeném v tabulce
  • Přerušit přenos - ukončí přenos dat na zařízení označeném v tabulce
  • Přenést vše - zahájí přenos dat ze všech zařízení
  • Podrobnosti - otevře okno s podrobnými informacemi o označeném zařízení. Totéž lze vyvolat dvojklikem na příslušném řádku v tabulce.
  • Minimalizovat - zavře uživatelské rozhraní programu a minimalizuje jej zpět do ikony
  • Ukončit - přeruší všechny přenosy a ukončí činnost programu


Program Tarwin - síťové rozhraní

Program Tarwin

Síťové rozhraní

Program Tarwin i služba Tarwins obsahují jednoduchý webový server. Toto rozhraní umožňuje sledovat činnost přenosového modulu a spuštět přenos dat na dálku pomocí běžného internetového prohlížeče. Počítač, na kterým běží prohlížeč a počítač s běžícím modulem musí být navzájem propojeny sítí TCP/IP. Rozhraní se konfiguruje buď pomocí konfiguračního nástroje (viz kapitola 1.2) nebo přímo v souboru tarwin.ini (viz kapitola 1.3). Současná verze programu podporuje použití kaskádních stylů (CSS) a možnost vložit uživatelské záhlaví a zápatí na webové stránky. To umožňuje graficky začlenit tento modul do informačního systému zákazníka.

Příklad:

Program Tarwin je spuštěn na počítači s IP adresou 192.168.1.1 a síťové rozhraní je nainstalováno na portu 1112 (standardně). Na jiném počítači si otevřete internetový prohlížeč a jako adresu zadejte http://192.168.1.1:1112/. V případě, že je vyžadována autorizace při vstupu, prohlížeč zobrazí výzvu pro zadání uživatelského jména a hesla. Po ověření hesla by se otevře výchozí stránka modulu obsahující tabulku definovaných zařízení. Obsah stránky se automaticky po 10 sekundách obnovuje.

V prvním sloupci tabulky jsou zobrazeny ikony indikující stav zařízení. Zelená šipka indikuje právě probíhající přenos dat, červený vykřičník značí, že při posledním stahování dat došlo k chybě. V posledním sloupci je několik odkazů na další stránky:

  • Info - zobrazí podrobné informace o zařízení
  • Podrobnosti - protokol o právě probíhajícím nebo posledním ukončeném přenosu
  • Spustit přenos - zahájí přenos nových dat
  • Přerušit přenos - přeruší probíhající přenos dat

Kliknutím na odkaz "Přenést vše" pod tabulkou zahájíte přenos nových dat ze všech zařízení.


Program Tarwin - požadavky na vybavení počítače

Program Tarwin

Požadavky na vybavení počítače

Program Tarwin vyžaduje pro nastavení a provoz minimálně:

  • osobní počítač s procesorem Pentium 150Mhz
  • operační systém počítače či stanice sítě Microsoft Windows 98 SE, 2000, NT, ME nebo XP
  • operační paměť 64 MB
  • volné místo na pevném disku 5 MB
  • grafická karta SVGA s rozlišením 800x600 bodů
  • sériový port (COM) pro připojení vstupního zařízení (ústředny, bufferu...)
  • myš nebo jiné kompatibilní polohovací zařízení
  • podpora protokolu TCP/IP


Program Tarwin - doporučené postupy

Program Tarwin

Doporučené postupy

V této kapitole jsou uvedeny pracovní postupy v nejběžnějších případech.

Instalace - příklad 1

Program Tarwin se používá jako součást programu Tardat, který je nainstalován v adresáři C:\tardat. K pobočkové ústředně zákazníka je připojen buffer Tarflex, který je připojen k sériovému rozhraní COM 1 počítače. Ke stejnému počítači je připojen také hardwarový klíč programu Tardat. Ústředna vysílá tarifní data rychlostí 9600 Bd. Přenosový modul se bude spouštět ze složky "Po spuštění".

  1. Spusťte program Tardat a z hlavní nabídky vyberte z menu Konfigurace položku Zařízení.

  2. Záložka Zařízení obsahuje tabulku se seznamem definovaných zařízení. Jestliže byl program Tardat nainstalován do prázdného adresáře (tj. čistá instalace), bude tabulka prázdná. Stiskněte tlačítko Přidat a otevře se průvodce pro zadání vlastností nového zařízení.

  3. Zvolte typ zařízení (TARFLEX na sériovém portu) a stiskněte tlačítko Pokračovat.

  4. Na další straně se nastavují vlastnosti zařízení, které se liší podle typu. V tomto případě se volí komunikační port (COM 1) a komunikační rychlost na vstupu bufferu (9600). Stiskněte tlačítko Pokračovat.

  5. Na poslední straně se nastavují vlastnosti společné pro všechny typy zařízení. Hodnoty nechte tak, jak je program přednastavil a uložte konfiguraci tlačítkem Uložit. Tím se vrátíte do tabulky zařízení.

  6. Označte řádek dev.a v tabulce a stiskněte tlačítko Test. Program se pokusí navázat komunikaci s bufferem Tarflex a přečte jeho konfiguraci. Zároveň se v okně vypisuje podrobný protokol. Je-li vše v pořádku, program by měl vypsat následující text:

    Žádost o zahájení komunikace
Žádost o přidělení portu COM1 s rychlostí 9600Bd
Port COM1 úspěšně otevřen
Příjem konfigurace bufferu
Připojen TARFLEX  výr.č. 1016 s kapacitou paměti 1048512 B
Zaplnění paměti :0 B, tj. 0 %
Žádost o uzavření portu COM1
Port COM1 úspěšně uzavřen

    V případě, že buffer Tarflex není správně připojen k počítači nebo jste zvolili špatný komunikační port, program vypíše následující text. Zkontrolujte buffer, jeho připojení k počítači a konfiguraci zařízení a test opakujte.

    Žádost o zahájení komunikace
Žádost o přidělení portu COM1 s rychlostí 9600Bd
Port COM1 úspěšně otevřen
Příjem konfigurace bufferu
Buffer nekomunikuje
Chyba během komunikace
Žádost o uzavření portu COM1
Port COM1 úspěšně uzavřen

    Pokud zvolený port neexistuje nebo je obsazen jinou aplikací, objeví se v protokolu následující text:

    Žádost o zahájení komunikace
Žádost o přidělení portu COM4 s rychlostí 9600Bd
Port COM4 nejde otevřít !
Chyba na komunikačním rozhraní
Žádost o uzavření portu COM4
Port COM4 úspěšně uzavřen

  7. V okně konfigurace zařízení přejděte na záložku Spouštění modulů. Zatrhněte volbu Ze složky "Po spuštění". Tím zajistíte, že při příštím spuštění počítače bude automaticky nastartován také přenos dat z bufferu.

Instalace - Příklad 2

Stejný případ jako v příkladu 1, ale přenosový modul se spouští jako služba systému.

Stejný postup jako v příkladu 1, body 1 až 6.

  7. V okně Konfigurace zařízení přejděte na záložku Spouštění modulů. Zatrhněte volbu Jako službu systému. Tím zajistíte, že při příštím spuštění počítače bude automaticky nastartována také služba pro přenos dat.

Instalace - Příklad 3

Program Tarwin se používá jako součást programu Tardat, který je nainstalován v adresáři C:\tardat. Buffer Tarflex je připojen na sériové rozhraní jiného počítače než na kterém je nainstalován program Tardat a jeho hardwarový klíč. Oba počítače jsou propojeny počítačovou sítí a funguje mezi nimi protokol TCP/IP a sdílení souborů. Počítač, ke kterému je připojen buffer Tarflex má v počítačové síti IP adresu 192.168.1.9.

Stejný postup jako v příkladu 1, body 1 až 6.

  7. V okně Konfigurace zařízení přejděte na záložku Spouštění přenosů. Volba Při spuštění Tardatu... by měla být zatržená.

  8. V tabulce označte řádek 127.0.0.1 a v editačním poli změňte IP adresu počítače na 192.168.1.9 a stiskněte tlačítko Nahradit. Tím programu zadáte, že při spuštění programu Tardat se odešle přenosovému modulu na adrese 192.168.1.9 požadavek na přenos dat mimo časový plán.

  9. Povolte sdílení složky C:\Tardat do sítě, oprávnění nastavte na Plné řízení.

  10. Přejděte k počítači, ke kterému je připojen buffer Tarflex, vyhledejte nasdílenou složku v síti a spusťte program TarKonfig.

  11. Přejděte na záložku Spouštění modulů. Zatrhněte volbu Ze složky "Po spuštění" nebo volbu Jako službu systému. Tím zajistíte, že při příštím spuštění počítače bude automaticky nastartován také přenos dat z bufferu.

Instalace - Příklad 4

Program Tarwin se používá samostatně pro příjem dat z bufferu Tarflex, který je připojen na sériové rozhraní počítače. Přijatá data se budou ukládat do souboru C:\data\data.txt.

  1. Vložte do mechanicky instalační CD. Automaticky se spustí úvodní program, ve kterém zvolte v levém sloupci sekci "Tarflex", v seznamu vyberte položku "Nainstalovat program Tarwin" a stiskněte tlačítko "Provést".
  2. Postupujte podle instrukcí v instalátoru.
  3. V cílovém adresáři spusťte program Tarkonfig.

  4. Přidejte nové zařízení a nainstalujte přenosový modul podle postupu v příkladu 1 (jestliže se má program spouštět ze složky "Po spuštění") nebo příkladu 2 (jestliže chcete spouštět přenos jako službu systému). Na poslední straně průvodce, v bodě 5, změňte jméno cílového souboru na C:\data\data.txt.

Aktualizace programu Tarwin

Používáte-li program Tarwin jako součást programu Tardat, aktualizují se přenosové moduly zároveň s aktualizací programu Tardat. V případě, že používáte program Tarwin samostatně, doporučujeme následující postup:

  1. Ukončete činnost programu Tarwin nebo služby Tarwins.
  2. Proveďte zálohu obsahu adresáře programu Tarwin.
  3. Spusťte instalační balíček programu Tarwin
  4. Spusťte program Tarwin nebo službu Tarwins a zkontrolute, že přenos běží bez problémů.

Odinstalování programu Tarwin

Pokud používáte program Tarwin samostatně:

  1. Ukončete činnost programu Tarwin nebo služby Tarwins.
  2. Odstraňte ze složky "Po spuštění" zástupce programu Tarwin nebo spusťte program Tarwins s parametrem /UNINSTALL pro odinstalování služby systému.
  3. Proveďte zálohu souborů s přijatými daty, pokud se ukládají do adresáře programu Tarwin.
  4. Smažte adresář programu Tarwin.


Program Tarwin - řešení problémů s přenosy

Program Tarwin

Řešení problémů s přenosy z bufferu Tarflex

V okně Konfigurace zařízení klikněte na záložku Zařízení, v tabulce označte myší řádek zařízení, které chcete otestovat (dev.a nebo dev.b atd.) a stiskněte tlačítko Test. Otevře se dialogové okno "Test zařízení", do kterého se postupně vypisují hlášení o probíhajícím testu. Na základě hlášení vyberte z následující tabulky:

Port COM... nejde otevřít!

Příčina: Operační systém odmítl programu povolit přístup na port, protože tento port neexistuje, je používán jinou aplikací (např. myš nebo modem) nebo je zakázán v uživatelském profilu nebo v BIOSu počítače.

Řešení: Ukončete aplikaci, která požadovaný sériový port používá nebo zkuste použít jiný sériový port. V případě, kdy není volný žádný sériový port a na PC je k dispozici rozhraní USB, lze použít převodník USB<-->COM (připojením do USB se vytvoří další COM, přes který je také možno komunikovat).

Buffer nekomunikuje!

Příčina: Nedaří se navázat komunikaci s bufferem. Buďto je kabel od bufferu odpojen od PC, buffer je připojen do jiného portu, než je nastaveno, nebo je poškozený kabel. Ve vyjímečných případech může být příčinou poškozený sériový port bufferu Tarflex či počítače (např. po bouřce). Toto hlášení se vypíše také v případě, že buffer Tarflex je celkově mimo provoz (je bez napájení případně má poruchu).

Řešení: Na předním panelu bufferu Tarflex musí svítit zelená kontrolka (žlutá může blikat). Zkontrolujte, zda je buffer Tarflex propojen s PC, zda je připojen do požadovaného portu. Překontrolujte kabel mezi PC a bufferem, zda není přerušen. Odšroubujte krytky konektorů a zkontrolujte, zda nedošlo k přetržení přívodních drátů ke konektoru. Nejlepší je kabel "prozvonit" (piny 2-2, 3-3 a 5-5). Pokud je i zde vše v pořádku, musí se přistoupit k ověření celé přenosové trasy. To se provede pomocí programu Hyperterminál, který je součástí instalačního balíku Windows (tlačítko Start > Programy > Příslušenství > Komunikace > Hyperterminál) nebo podobného programu, který umí posílat a přijímat znaky po sériovém portu.

  1. Spusťte program Hyperterminál, zvolte přímé připojení na port COM1 (resp. COM2 nebo jiný, na který je připojen buffer Tarflex). V parametrech spojení nastavte rychlost na 9600Bd, 8bitů, bez parity, HW řízení přenosu žádné.

  2. Na spodní straně přístroje Tarflex je papírová přelepka s nápisem "Přepínání způsobu komunikace". Pod touto přelepkou jsou dva miniaturní DIP přepínače. Tyto přepínače přepněte do polohy "ON".

  3. Po stisku jakékoliv klávesy v programu Hyperterminál by měl buffer pípnout a znak vrátit do PC (zobrazí se na monitoru). Zde je několik možností:

    1. Hyperterminál napíše, že port nelze použít = port je buďto obsazený nebo neexistuje.
    2. Buffer při stisku klávesy pípne, ale nic se nezobrazí = chyba na trase ve směru buffer->PC (pin č.2)
    3. Buffer nereaguje, nic se nezobrazuje = chyba na trase ve směru PC->buffer (pin č.3)

    V případě b) nebo c) je možné zjistit chybné místo následujícím postupem: odpojte kabel od přístroje Tarflex a přímo v konektoru odpojeného kabelu zkratujte piny 2 a 3 (číslo bývá vylisováno přímo u jednotlivých pinů). Po stisku kláves by měl hyperterminál zobrazovat stisknuté klávesy. Pokud tomu tak je, je vadný buffer Tarflex. Pokud se nic neopisuje, je vadný spojovací kabel nebo port počítače. Zde je ještě možnost odpojit kabel od PC a přímo na konektoru PC zkratovat piny 2 a 3.

    4. Pokud ani v tomto případě hyperterminál neopisuje stisknuté klávesy, je vadný port PC. Vadný kabel je možné nahradit jakýmkoliv přímým (tedy ne kříženým!) prodlužovacím kabelem, např. od telefonního modemu. Využívané signály jsou RXD, TXD a GND (piny 2,3 a 5).

  4. Nezapomeňte vrátit DIP přepínače na přístroji Tarflex do původní polohy!


Program Tarwin - licence

Program Tarwin

Licenční podmínky

  1. Zakoupením přístroje Tarflex, Tarflex Plus, Tarflex-E nebo Tarflex-S získává kupující licenci na použití programů (programového díla) Tarwin. Uživatel se stává majitelem licence dnem zakoupení přístroje. Uživatel přestává být majitelem licence v případě, že o to písemně požádá výrobce.

  2. Instalací programů uživatel vyjadřuje svůj souhlas s plným zněním licenčních a záručních podmínek tak, jak jsou uvedeny v návodu k obsluze přístroje.

  3. Uživatel je oprávněn používat programy pouze k nastavení a obsluze přístrojů Tarflex, Tarflex Plus, Tarflex-E a Tarflex-S. Použití programů k obsluze jiného zařízení je porušením licenčních podmínek.

  4. Uživatel se zavazuje používat programy tak, aby nedošlo k porušení či ohrožení autorských práv výrobce.

  5. Uživatel smí pořizovat archívní kopie programů a instalačního CD pouze pro potřeby archivace a vytvoření záložních kopií.

  6. Uživatel nesmí poskytnout programy osobě, která není majitelem licence, bezplatně ani za úplatu.

  7. Uživatel nesmí provádět žádné změny do programů ani provádět zpětný překlad programů.


Program Tarkonfig

V této kapitole je popsáno ovládání programu Tarkonfig, což je konfigurační nástroj umožňující nastavení parametrů modulu TarWin pomocí grafického uživatelského rozhraní. Je nutné zdůraznit, že veškeré změny v nastavení se projeví teprve po restartu programu Tarwin. To lze provést ukončením a opětovným spuštěním programu Tarwin nebo služby Tarwins.

Program Tarkonfig musí být umístěn ve stejném adresáři, kde je umístěn hlavní konfigurační soubor tarwin.ini. Může být spouštěn z lokálního disku nebo adresáře sdíleného po síti, ale neumožňuje konfiguraci na dálku pomocí síťového rozhraní.

Obsah

  1. Konfigurace zařízení
  2. Editace parametrů zařízení
  3. Konfigurace síťového rozhraní
  4. Spouštění programu Tarwin

Viz také:

  • Program Tarwin
  • Konfigurační soubory zařízení
  • Spouštění přenosů


Program Tarkonfig - konfigurace zařízení

Program Tarkonfig

Konfigurace zařízení

V základním okně programu Tarkonfig klikněte na záložku Zařízení. Zobrazí se přehledná tabulka se seznamem definovaných zařízení, která obsahuje tři sloupce. V prvním sloupci je uveden pracovní adresář zařízení, relativně vůči základnímu adresáři, ve kterém se nachází hlavní konfigurační soubor tarwin.ini. Druhý sloupec obsahuje jméno zařízení, v případě, že bylo zadáno. Ve třetím sloupci je uveden používaný přenosový protokol (typ zařízení) a další údaje o připojení, například IP adresu ústředny nebo bufferu, případně sériový port.

Vkládání nových zařízení

  1. V tabulce zařízení klikněte do prázdného řádku a stiskněte tlačítko Přidat, tím se spustí průvodce přidáním nového zařízení.

  2. Zvolte typ připojeného zařízení a stiskněte tlačítko "Pokračovat". Bližší informace o podporovaných zařízeních najdete v kapitole 2.1.

  3. V následujícím dialogu jsou volby specifické pro dané zařízení. Aby byl průvodce co nejpřehlednější, jsou nabízeny pouze nejdůležitější volby, bližší informace o jednotlivých parametrech najdete v kapitole 1.2.5. Více nastavení je přístupné v editačním dialogu (viz dále), některé málo používané nebo servisní volby se editují přímo v konfiguračních souborech (viz. kap. 5). Vyplňte požadované údaje a stiskněte tlačítko "Pokračovat".

  4. Poslední dialog obsahuje volby společné pro všechny typy zařízení. Podrobnější popis jednotlivých položek najdete v kapitole 1.2.5 odstavec "Společné parametry".

  5. Stisknutím tlačítka "Uložit" se vytvoří nový adresář zařízení a uloží se jeho konfigurační soubor. Průvodce se zavře a nové zařízení je připraveno. Nyní můžete konfiguraci otestovat (viz dále). Přenos dat z nového zařízení začne teprve po restartu programu Tarwin.

Test zařízení

V základním okně programu Tarkonfig přejděte na stránku "Zařízení". V tabulce zařízení označte příslušný řádek a stiskněte tlačítko "Test". Otevře se nové okno, do kterého se vypisují zprávy o průběhu, test můžete kdykoliv přerušit stiskutím tlačítka "Přerušit test". Zda zkouška proběhla v pořádku poznáte podle textu uvedeného v okně. Chcete-li test spustit znovu, stiskněte tlačítko "Spustit test", okno zavřete stisknutím tlačítka "Zavřít". (obr)

Chyba během testu nemusí vždy znamenat, že zařízení nekomunikuje. Například je-li zařízení typu "přímé propojení PC s ústřednou nebo jiný buffer" a je spuštěný program Tarwin, pak přenos má otevřený sériový port a žádný jiný program nemůže s portem pracovat a proto test hlásí chybu, že nemůže port otevřít i když vše pracuje správně. Stejná chyba se vypíše i v případě konfliktů mezi Tarwinem a programem Tarkonfig, například při testování zařízení, ze kterého právě probíhá přenos. Z tohoto důvodu je lepší program Tarwin před testováním vypnout.

Zrušení zařízení

V základním okně programu Tarkonfig přejděte na stránku "Zařízení". V tabulce zařízení označte řádek zařízení, které chcete zrušit a stiskněte tlačítko "Vymazat". Po potvrzení akce se pracovní adresář zařízení zruší.


Program Tarkonfig - editace parametrů zařízení

Program Tarkonfig

Editace parametrů zařízení

V základním okně programu Tarkonfig přejděte na stránku "Zařízení". V tabulce zařízení označte řádek podle toho, které zařízení chcete změnit a stiskněte tlačítko "Editovat". Otevře se editační okno, jehož plocha je rozdělena na dvě části. Horní část obsahuje volby společné pro všechny typy zařízení, jako cílový soubor nebo interval spouštění a v dolní části jsou umístěny volby specifické pro konkrétní komunikační protokol (typ zařízení). Následující přehled obsahuje stručný popis všech voleb tříděný podle typu zařízení:

Společné parametry (pro všechny typy):

  • Typ zařízení - typ zařízení, nelze měnit. Chcete-li změnit typ zařízení, je nutné jej nejprve smazat a pak vytvořit nové.

  • Cílový soubor - cesta a jméno souboru, kam se ukládají přijatá data. Cesta může být uveden absolutně, tj. včetně označení disku, může to být také adresář sdílený po síti nebo jej lze uvést relativně vůči pracovnímu adresáři zařízení.

    Příklady:

    • Absolutní cesta: C:\tardat\pbx.a\pa20.td
    • Síťová cesta: \\server\tardat\pbx.a\pa20.td
    • Relativní cesta: ..\pbx.a\pa20.td

  • Jméno zařízení - pojmenování zařízení není povinné, ale v případě, že plánujete připojení více zařízení, doporučujeme do tohoto pole uvést krátký text, který Vám usnadní orientaci v tabulkách, přehledech a chybových hlášeních programu TarWin.

  • Interval - časová prodleva mezi ukončením přenosu a zahájením následujícího přenosu. Tento parametr je vhodné zvolit podle typu zařízení, přenosové cesty, množství příchozích dat a dalších požadavků konkrétní aplikace. Vyberte si jednu z nabízených možností nebo přímo do editačního pole vložte vlastní hodnotu. Hodnoty se zapisují vždy číslem a následuje jednotka.

    Příklady:

    • 1h, 1 hod, 1 hodina, 2m, 1 min, 1 minuta, 2.5s, 2.5 sec, 2,5 sekundy, ...

Typ "TARFLEX na sériovém portu":

  • Parametry propojení PC-buffer:

    • Port - název sériového portu, ke kterému je buffer Tarflex připojen, například COM1, COM2, ...

    • Rychlost - komunikační rychlost mezi bufferem a PC. Musí být nastaveno shodně s rychlostí naprogramovanou v bufferu. Standardně 9600 Bd.

    • Max. počet pokusů - počet pokusů, kolikrát se zkouší přenos, než program hlásí chybu a přenos se ukončí, standardně 5.

    • Max. doba čekání na odpověď - maximální doba čekání na odezvu od zařízení, standardně 1 sekunda.

    • Max. délka datového paketu - největší délka přenášeného datového paketu, změnou tohoto parametru ovlivníte rychlost přenosu dat. U horší přenosové cesty můžete zkusit menší velikost paketů a naopak, hodnota 1024 bytů by měla vyhovovat ve většině případů.

  • Parametry propojení buffer-ústředna:

    • Rychlost - komunikační rychlost mezi bufferem a ústřednou. Musí být nastaveno shodně s rychlostí sériového kanálu z ústředny.

  • Parametry bufferu:

    • Filtr netiskntelných znaků - je-li tato volba zapnuta, pak buffer automaticky vypouští z přijatého textu netisknutelné znaky (ascii 0 až 31 mimo CR a LF) a u znaků s ascii hodnotou větší než 127 odřezává osmý bit.

    • Zvuk. signalizace při zaplnění - je-li tato volba zapnuta, pak buffer vydává při zaplnění nad 75% kapacity varovný akustický signál a při úplném zaplnění vydává havarijní akustický signál.

Typ "TARFLEX přes telefonní modem":

  • Parametry propojení PC-modem-buffer

    • Port - název sériového portu, ke kterému je připojen telefonní modem, například COM1, COM2, ...

    • Rychlost - komunikační rychlost mezi modemem a PC, standardně 9600 Bd

    • Vytáčené telefonní číslo - telefonní číslo, které musí modem na PC vytočit, aby se dostal k druhému modemu, ke kterému je připojen buffer Tarflex. Je-li to vyžadováno, je nutné uvést také přístupové číslo (například 0 nebo 9) pro přístup do veřejné telefonní sítě.

    • Příkaz pro inicializaci modemu - Příkazy modemu (AT příkazy), které se vysílají do modemu při zahájení přenosu. Seznam příkazů, které podporuje Váš modem najdete v dokumentaci k modemu. Doporučeno je ATX0 (tj. nečekat na oznamovací tón).

    • Max. počet pokusů - počet pokusů, kolikrát se zkouší přenos, než program hlásí chybu a přenos se ukončí, standardně 5.

    • Max. doba čekání na odpověď - maximální doba čekání na odezvu od zařízení, standardně 5 sekund.

    • Max. délka datového paketu - největší délka přenášeného datového paketu, změnou tohoto parametru ovlivníte rychlost přenosu dat. U modemového spojení by hodnota 4096 bytů měla vyhovovat ve většině případů.

  • Parametry propojení buffer-ústředna:

    • Rychlost - komunikační rychlost mezi bufferem a ústřednou. Musí být nastaveno shodně s rychlostí sériového kanálu z ústředny.

  • Parametry bufferu:

    • Filtr netiskntelných znaků - je-li tato volba zapnuta, pak buffer automaticky vypouští z přijatého textu netisknutelné znaky (ascii 0 až 31 mimo CR a LF) a u znaků s ascii hodnotou větší než 127 odřezává osmý bit.

    • Zvuk. signalizace při zaplnění - je-li tato volba zapnuta, pak buffer vydává při zaplnění nad 75% kapacity varovný akustický signál a při úplném zaplnění vydává havarijní akustický signál.

Typ "TARFLEX přes síť TCP/IP":

  • Parametry propojení PC-buffer:

    • IP adresa bufferu Tarflex - síťová IP adresa naprogramovaná v bufferu.

    • TCP Port - číslo síťového portu, které je naprogramované v bufferu, standardně 1110.

    • Max. počet pokusů - počet pokusů, kolikrát se zkouší přenos, než program hlásí chybu a přenos se ukončí, standardně 5.

    • Max. doba čekání na odpověď - maximální doba čekání na odezvu od zařízení, standardně 1 sekunda.

    • Max. délka datového paketu - největší délka přenášeného datového paketu, změnou tohoto parametru ovlivníte rychlost přenosu dat. Hodnota 1024 bytů by měla vyhovovat ve většině případů.

  • Parametry propojení buffer-ústředna:

    • Rychlost - komunikační rychlost mezi bufferem a ústřednou. Musí být nastaveno shodně s rychlostí sériového kanálu z ústředny.

  • Parametry bufferu:

    • Filtr netiskntelných znaků - je-li tato volba zapnuta, pak buffer automaticky vypouští z přijatého textu netisknutelné znaky (ascii 0 až 31 mimo CR a LF) a u znaků s ascii hodnotou větší než 127 odřezává osmý bit.

    • Zvuk. signalizace při zaplnění - je-li tato volba zapnuta, pak buffer vydává při zaplnění nad 75% kapacity varovný akustický signál a při úplném zaplnění vydává havarijní akustický signál.

Typ "TARFLEX-E":

  • Parametry propojení PC-buffer:

    • IP adresa bufferu Tarflex - síťová IP adresa naprogramovaná v bufferu (číslo síťového portu je vždy 110).

    • Max. počet pokusů - počet pokusů, kolikrát se zkouší přenos, než program hlásí chybu a přenos se ukončí, standardně 5.

    • Max. doba čekání na odpověď - maximální doba čekání na odezvu od zařízení, standardně 1 sekunda.

    • Max. délka datového paketu - největší délka přenášeného datového paketu, změnou tohoto parametru ovlivníte rychlost přenosu dat. Hodnota 32768 bytů by měla vyhovovat ve většině případů.

  • Parametry propojení buffer-ústředna:

    • Rychlost - komunikační rychlost mezi bufferem a ústřednou. Musí být nastaveno shodně s rychlostí sériového kanálu z ústředny.

    • HW řízení - řízení toku mezi bufferem a ústřednou. Ve většině případů vyhovuje volba Žádné.

  • Parametry bufferu:

    • Filtr netiskntelných znaků - je-li tato volba zapnuta, pak buffer automaticky vypouští z přijatého textu netisknutelné znaky (ascii 0 až 31 mimo CR a LF) a u znaků s ascii hodnotou větší než 127 odřezává osmý bit.

    • Zvuk. signalizace při zaplnění - je-li tato volba zapnuta, pak buffer vydává při zaplnění nad 75% kapacity varovný akustický signál a při úplném zaplnění vydává havarijní akustický signál.

Typ "Ústředna Alcatel 4400 přes TCP/IP"

  • IP adresa ústředny - síťová IP adresa naprogramovaná v ethernetovém rozhraní ústředny

  • Adresář s tarifními daty - adresář v ústředně, ve kterém se nachází soubory s tarifními daty, standardně /usr4/account

  • Max. počet registr. souborů - maximální počet souborů s tarifními údaji, které se mohou na disku ústředny vyskytnout (záleží na nastavení ústředny). Ve většině případů by měla vyhovovat hodnota 1000.

  • Odesílání žádosti o ukončení balíčku - je-li tato volba zapnuta, pak se před zahájení přenosu odešle do ústředny příkaz pro uzavření rozpracovaného balíčku tarifních dat.

  • Prompt ústředny - znak, kterým končí prompt (výzva k zadání příkazu) na ústředně. Standardně je to znak '>'.

Typ "Ústředna Alcatel OmniPCX přes TCP/IP"

  • IP adresa ústředny - síťová IP adresa naprogramovaná v ethernetovém rozhraní ústředny

  • Max. počet pokusů - maximální počet pokusů o navázání spojení, standardně 3.

Typ "Ústředna Alcatel 4400 přes SLIP"

  • Připojení - jméno vytáčeného připojení ze složky Telefonické a síťová připojení v Ovládacích panelech.

  • IP adresa ústředny - síťová IP adresa naprogramovaná v síťovém rozhraní ústředny

  • Adresář s tarifními daty - adresář v ústředně, ve kterém se nachází soubory s tarifními daty, standardně /usr4/account

  • Max. počet registr. souborů - maximální počet souborů s tarifními údaji, které se mohou na disku ústředny vyskytnout (záleží na nastavení ústředny). Ve většině případů by měla vyhovovat hodnota 1000.

  • Odesílání žádosti o ukončení balíčku - je-li tato volba zapnuta, pak se před zahájení přenosu odešle do ústředny příkaz pro uzavření rozpracovaného balíčku tarifních dat.

  • Prompt ústředny - znak, kterým končí prompt (výzva k zadání příkazu) na ústředně. Standardně je to znak '>'.

Typ "Ústředna Siemens 100,300 přes TCP/IP"

  • IP adresa ústředny - síťová IP adresa ústředny

  • Soubor s tarifními daty - jméno souboru, ve kterém se nachází tarifní data, viz dokumentace k ústředně, standardně gez.txt.

Typ "Přímé propojení PC s ústřednou nebo jiný buffer":

  • Port - název sériového portu, na který přicházejí data

  • Rychlost - komunikační rychlost mezi ústřednou nebo bufferem jiného výrobce a PC.

  • HW řízení - signály používané pro řízení toku dat (musí být obsaženy i propojovacím kabelu!).

  • Délka slova - počet bitů ve slově, standardně 8.

  • SW řízení - řízení toku dat vysíláním znaků Xon a Xoff

  • Parita - typ zabezpečení přenosu paritními bity, standarně Bez parity.

Typ "Zachytávání znaků na TCP portu":

  • Port - číslo síťového portu, na kterém má server čekat na spojení (pro ústředny Innovaphone je to 514).


Program Tarkonfig - konfigurace síťového rozhraní

Program Tarkonfig

Konfigurace síťového rozhraní

Program TarWin je vybaven síťovým rozhraním, které umožňuje pomocí běžného internetového prohlížeče sledovat stav programu nebo zahájit přenos dat. Standardně je tato funkce zapnuta a instaluje se na síťový port 1112. Toto rozhraní se používá ke spouštění přenosu dat při startu programu Tardat.

Parametry webového serveru se konfigurují na stánce "Rozhraní TCP/IP" v základním okně programu Tarkonfig. Zatržítkem "Povolit síťové rozhraní..." se funkce zapíná a vypíná, lze také změnit číslo síťového portu. V případě, že chcete, aby program vyžadoval autorizaci při vstupu do síťového rozhraní, zatrhněte volbu "Vyžadovat uživatelské jméno a heslo" a zadejte uživatelské jméno a heslo.

Provedené změny se projeví teprve po restartu programu Tarwin.


Program Tarkonfig - spouštění programu Tarwin

Program Tarkonfig

Spouštění programu Tarwin

Vhodné nastavení spouštění je závislé na konkrétních podmínkách, množství přicházejících dat a typech použitých zařízení. V zásadě jsou dva typy spouštění: a) ze složky po spuštění - aplikace se spouší minimalizovaná na liště u hodin a její běh je indikován ikonou modrého sluchátka, b) jako služba systému, které je dostupné pouze na operačních systémech Windows NT, 2000 a XP. V druhém případě aplikace nemůže mít uživatelské rozhraní (ke sledování doporučujeme použít síťové rozhraní, viz předchozí kapitola) a je aktivní i když na počítači není přihlášen žádný uživatel.

Instalace zástupce do složky "Po spuštění":

Zatrhněte volbu "Ze složky Po spuštění". Tím se vloží do složky "Nabídka Start -> Programy -> Po spuštění" nový zástupce a při dalším startu počítače se automaticky spustí program Tarwin.

Odstranění zástupce ze složky "Po spuštění":

Zrušte zatržítko u volby "Ze složky Po spuštění". Tím se ze složky "Nabídka Start -> Programy -> Po spuštění" odstraní zástupce ukazující na program Tarwin.

Instalace služby systému:

Zatrhněte volbu "Jako službu systému". Tím se nainstaluje do systému nová služba a bude se automaticky spouštět při startu počítače.

Odstranění služby systému:

Zrušte zatržítko u volby "Jako službu systému". Tím se služba odinstaluje ze systému.


Konfigurační soubory zařízení

Veškerá konfigurace přenosového programu Tarwin je uložena v textových souborech, takže změny konfigurace lze provádět mj. i běžně dostupnými jednoduchými textovými editory, například v "Poznámkovém bloku".

Následující kapitoly podrobně popisují formát souborů a význam jednotlivých voleb. Protože běžná nastavení programu lze provést pomocí uživatelského rozhraní, je tento text určen pro případy speciálních požadavků na chování programu nebo pro případy, kdy není možné konfigurační nástroj použít, např. přístup přes FTP apod.

Obsah

  1. Struktura konfiguračních souborů
  2. Hlavní konfigurační soubor
  3. Definice zařízení

Viz také:

  • Program Tarkonfig
  • Program Tarwin


Konfigurace zařízení - struktura konfiguračních souborů

Konfigurační soubory zařízení

Struktura konfiguračních souborů

Formát konfiguračních souborů vychází z formátu souborů .INI používaného v prostředí operačního systému Windows. Soubor se skládá z jedné nebo více sekcí. Každá sekce začíná hlavičkou a následuje tělo sekce. Přebytečné mezery, tabulátory na začátku, na konci nebo uprostřed řádku, prázdné řádky a řádky obsahující pouze poznámku se ignorují. U názvů sekcí a klíčů se nerozlišují velká a malá písmena.

Hlavička sekce obsahuje název sekce v hranatých závorkách. Za ní může být poznámka (viz dále).

Tělo může mít dva tvary: a) obsahuje dvojice klíč=hodnota na samostatných řádcích nebo b) obsahuje seznam řetězců, jednotlivé řetězce jsou na samostatných řádcích. Řádek může také obsahovat poznámku.

Poznámky začínají vždy mřížkou (#) a končí dvojicí znaků pro konec řádku.

Příklad:

[SEKCE1]
# Poznámka
klíč1 = hodnota1   # Poznámka
klíč2 = hodnota2

[SEZNAM1]          # Poznámka
položka1
položka2
Logické hodnoty se zapisují následovně (nerozlišují se velká a malá písmena):
  • ON, A, ANO, T, TRUE, 1 pro význam povoleno, zapnuto
  • OFF, N, NE, F, FALSE, 0 pro význam zakázáno, vypnuto
Číselné hodnoty se zapisují v desítkové soustavě.


Konfigurace zařízení - hlavní konfigurační soubor

Konfigurační soubory zařízení

Hlavní konfigurační soubor

Při spuštění přenosového modulu se nejprve čte hlavní konfigurační soubor tarwin.ini, který musí být umístěn ve stejném adresáři, jako program Tarwin a má následující části:

Sekce DEVICES obsahuje seznam obsluhovaných zařízení. Každé zařízení má svůj řádek. Na začátku řádku je uveden adresář, ve kterém se nachází konfigurační soubor zařízení (device.ini, viz dále) a který se také používá jako pracovní adresář pro ukládání různých souborů. V poznámce může být uvedeno jméno zařízení, které není povinné, ale při obsluze několika zařízení je užitečné si je pro přehlednost vhodně pojmenovat.

V sekci HTTP se konfiguruje monitorovací a řídící rozhraní. Tarwin obsahuje jednoduchý webový server, pomocí kterého lze na dálku sledovat činnost modulu nebo zahájit přenos. Sekce obsahuje tyto volby:

  • Server - logická hodnota, je-li ON, pak monitorovací rozhraní je zapnuto
  • TCPPort - číslo síťového portu, na který se instaluje webový server rozhraní
  • UserName - je-li tato položka vyplněna, pak server bude vyžadovat zadání uživatelského jména a hesla
  • Passwd - zakódované přístupové heslo
  • CSS - jméno souboru s absolutní nebo relativní cestou případně URL souboru s kaskádním stylem (CSS). Např. system\tarwin.css nebo http://server/styly/styl.css.
  • HEAD - jméno souboru s absolutní nebo relativní cestou (ne URL!) souboru se záhlavím. Obsah souboru bude vložen vždy na začátek stránky za značku <body>. Např. system\hlavicka.html.
  • FOOT - jméno souboru s absolutní nebo relativní cestou (ne URL!) souboru se zápatím. Obsah souboru bude vložen vždy na konec stránky před ukončující značku </body>. Např. system\paticka.html.

Příklad:

[DEVICES]
dev.a     # Buffer 1
dev.b     # Buffer 2

[HTTP]
Server = ON
TCPPort = 80
UserName =
Passwd =
CSS =
Head =
Foot =

Význam: Jsou definována dvě zařízení, první používá pracovní adresář dev.a a konfigurační soubor dev.a\device.ini, druhé má přidělen adresář dev.b. Protože jsou cesty uvedeny relativně, vztahují se vždy k adresáři, ve kterém je umístěn program Tarwin. První zařízení má jméno Buffer 1, druhé Buffer 2. Monitorovací a řídící rozhraní je zapnuto a je dostupné na síťovém portu 80, nebude vyžadována autorizace.


Konfigurace zařízení - definice zařízení

Konfigurační soubory zařízení

Definice zařízení

Jednotlivá zařízení mají své konfigurační soubory s nastavením a volbami. Tyto soubory jsou uloženy vždy v pracovním adresáři zařízení v souboru device.ini. Obsah souboru lze rozdělit na dvě části: část společnou pro všechny typy zařízení a část specifickou pro daný typ zařízení, se kterým se komunikuje. Společná část obsahuje jednu sekci s názvem CONFIGURATON. Volby specifické pro konkrétní typy zařízení a přenosové protokoly včetně příkladů jsou uvedeny v dalších kapitolách.

V následujícím přehledu je uveden popis jednotlivých voleb v části CONFIGURATION, příklady jsou u jednotlivých typů zařízení.

  • Protocol - typ zařízení, tj. komunikační protokol. Viz další odstavce popisující konfiguraci jednotlivých protokolů.
  • Device - prostředek používaný pro komunikaci se zařízením. Viz další odstavce popisující konfiguraci jednotlivých protokolů.
  • Interval - časový interval, ve kterém se provádí stahování nových dat. Je-li hodnota nula, pak se stažení dat provede pouze jednou při startu programu Tarwin (při spuštění počítače).
  • Delay - časové zpoždění od spuštění programu Tarwin nebo služby Tarwins do prvního spuštění přenosu z tohoto zařízení. Používá se v případě, že po startu počítače je nutné nějakou dobu počkat; standardně 0.
  • DataFile - cílový soubor, do kterého se ukládají přijatá data. Nová data se ukládají vždy na jeho konec, pokud soubor neexistuje, založí se nový. Cesta k cílovému souboru může být uvedna buď absolutně, tj. včetně názvu disku a plné cesty, nebo relativně vůči pracovnímu adresáři.
  • BckpFile - záložní soubor, do kterého se ukládá kopie přijatých data. Nová data se ukládají vždy na jeho konec, pokud soubor neexistuje, založí se nový.

Konfigurace připojení bufferu Tarflex přes sériový port

Tato kapitola popisuje konfiguraci zařízení, které získává data z bufferu Tarflex nebo Tarflex plus připojeného na sériový port počítače. Volba Protokol se nastaví na TARWIN a volba Device na RS232. Soubor dále obsahuje sekce:

Sekce RS232 nastavuje parametry sériového portu:

  • Port - název sériového portu, ke kterému je připojen buffer Tarflex - COM1, COM2, ... až COM8.
  • Baud - komunikační rychlost v baudech, na kterou je nastaven buffer Tarflex - standardně 9600
  • HShaking - jaké se má používat řízení toku dat - možné hodnoty: NONE, RTS/CTS, DTR/DSR, BOTH - standardně NONE.

Sekce BUFFER obsahuje parametry komunikačního protokolu

  • BufNr - výrobní číslo ovládaného bufferu, používá se v případě, že na jeden sériový port je připojeno více bufferů Tarflex. Je-li hodnota nastavena na 0, pak na výrobním čísle připojeného bufferu nezáleží. Standardně 0.
  • Serial - zapnutí této volby povoluje zapojování bufferů do kaskády pro zvýšení kapacity - standardně je vypnuto.
  • Fifo - povoluje přepisování nejstarších dat novými v případě, že se překročí paměťová kapacita bufferu - standardně je zapnuto.
  • Sound - povoluje zvukové signály, buffer vydává varovný signál při zaplnění nad 75% a havarijní signál při úplném zaplnění paměti - standardně zapnuto.
  • Datac - povoluje komprimaci dat v paměti bufferu. Tím lze dosáhnout úspory místa. Vhodné pouze pro tarifní data z ústředny - standardně zapnuto.
  • Text - buffer v tomto režimu uchovává pouze tisknutelné znaky a osmibitová slova upravuje na sedmibitová (ASCII). Standardně vypnuto.
  • PBXBaud - rychlost vstupního portu Tarflexu (propojení mezi bufferem a ústřednou). Tato volba musí být nastavena shodně s konfigurací ústředny!
  • PBXProt - řízení toku dat mezi bufferem a ústřednou. Možné hodnoty NONE, RTS/CTS, DTR/DSR, BOTH. Záleží ale také na propojovacím kabelu mezi bufferem a PBX.
  • MaxRet - počet pokusů, kolikrát se zkouší přenos, než program hlásí chybu a přenos se ukončí.
  • MaxDel - maximální doba čekání na odezvu od zařízení.
  • MaxLen - největší délka datového paketu

Do sekce COMMAND se zapisují mimořádné požadované akce, jako například

  • Allbuffer - je-li tato volba zapnuta, tak se při spuštění komunikace přenese do cílového souboru celý obsah paměti bufferu. Volba se po dokončení komunikace automaticky vypne. Pomocí této funkce lze v případě, že při havárii PC došlo ke ztrátě dat, získat alespoň část údajů, které se vešly do paměti bufferu (tj. posledních cca 2000 až 10000 hovorů podle typu bufferu).

Příklad:

Buffer Tarflex je zapojen na sériový port COM2. Jeho rozhraní pro komunikaci s PC je nastaveno na rychlost 9600 baudů a je připojen kabelem dodávaným výrobcem (třížilové vedení bez hardwarového řízení toku dat). Buffer je připojen k ústředně, která má tarifikační výstup nastaven na rychlost 1200 baudů a pro řízení toku dat používá signály DTR/DSR. Nová data se budou kontrolovat každou hodinu a ukládat do souboru pa20.td v adresáři ..\pbx.a.

[CONFIGURATION]
Protocol=Tarwin                # Komunikační protokol
Device=RS232                   # Používá se sériové rozhraní
Interval=3600                  # Kontrolovat data každých 3600 sekund = 1 hodina
DataFile=..\pbx.a\pa20.td      # Cílový soubor

[RS232]                        # Zde se konfiguruje vyse uvedene seriove rozhrani
Port=COM2                      # Buffer připojen na COM 2
Baud=9600                      # Rychlost Tarflex-PC je 9600
HShaking=None                  # Nepoužívá se hw řízení toku

[BUFFER]                       # Zde jsou nalezitosti bufferu Tarflex
BufNr=0                        # Ovládá se buffer s libovolným výr. č.
Serial=OFF                     # Vypnuto stohování
FIFO=ON                        # Zapnuto přepisování dat při zaplnění
Sound=ON                       # Zapnuté zvukové signály
DataC=ON                       # Zapnutá komprimace dat
Text=ON                        # Zapnutý textový režim
PBXBaud=1200                   # Rychlost PBX-Tarflex je 1200
MaxRet=5                       # Maximalne 5 opakovani pokusu o spojeni
MaxDel=1                       # Maximalne 1 sekundu cekat na odezvu bufferu
MaxLen=2048                    # Nejdelsi datove pakety budou 2048 bytů

[COMMAND]
AllBuffer=OFF                  # Normální provoz

Konfigurace připojení bufferu Tarflex přes síť TCP/IP

Tato kapitola popisuje konfiguraci zařízení, které získává data z bufferu Tarflex nebo Tarflex plus s rozhraním pro připojení do sítě Ethernet nebo z bufferu připojeného přes sériový port k jinému počítači zpřístupněný do sítě pomocí programu RSEth. Konfigurační soubor device.ini obsahuje společnou sekci, která je popsána na začátku této kapitoly. Volba Protokol se nastaví na TARWIN a volba Device na ETH. Soubor dále obsahuje sekce:

Sekce ETH nastavuje parametry síťového rozhraní bufferu:

  • IPBuf - IP adresa naprogramovaná v bufferu
  • TCPPort - číslo síťového portu naprogramované v bufferu, standardně 1110

Sekce BUFFER a COMMAND jsou popsány v předchozím odstavci.

Příklad:

Buffer Tarflex je připojen do sítě Ethernet a má IP adresu 192.168.1.110 a číslo portu 1110. Buffer je připojen k ústředně, která má tarifikační výstup nastaven na rychlost 1200 baudů a pro řízení toku dat používá signály DTR/DSR. Nová data se budou kontrolovat každou hodinu a ukládat do souboru pa20.td v adresáři ..\pbx.a.

[CONFIGURATION]
Protocol=Tarwin                # Komunikační protokol
Device=ETH                     # Používá se síťové rozhraní
Interval=3600                  # Kontrolovat data každých 3600 sekund = 1 hodina
DataFile=..\pbx.a\pa20.td      # Cílový soubor

[ETH]
IPBuf=192.168.1.110            # IP adresa bufferu Tarflex v síti
TCPPort=1110                   # TCP port pro přenos dat

[BUFFER]
Serial=OFF                     # Vypnuto stohování
FIFO=ON                        # Zapnuto přepisování dat při zaplnění
Sound=ON                       # Zapnuté zvukové signály
DataC=ON                       # Zapnutá komprimace dat
Text=OFF                       # Vypnutý textový režim
PBXBaud=9600                   # Rychlost PBX-Tarflex je 9600
MaxRet=5                       # Maximalne 5 opakovani pokusu o spojeni
MaxDel=1                       # Maximalne 1 sekundu cekat na odezvu bufferu
MaxLen=2048                    # Nejdelsi datove pakety 2048 bytů

[COMMAND]
AllBuffer=OFF                  # Normální provoz, nestahovat celý obsah paměti

Konfigurace připojení bufferu TARFLEX-E

Tato kapitola popisuje konfiguraci zařízení, které získává data z bufferu Tarflex-E. Konfigurační soubor device.ini obsahuje společnou sekci, která je popsána na začátku této kapitoly. Volba Protokol se nastaví na TARWIN a volba Device na ETH.

Sekce ETH, BUFFER a COMMAND jsou popsány v předchozím odstavci. Buffer používá standardně síťový port 110 (místo 1110) a v sekci BUFFER musí být navíc parametr Typ s hodnotou 2, která určje, že jde o Tarflex-E.

Příklad:

Buffer Tarflex je připojen do sítě Ethernet a má IP adresu 192.168.1.253. Buffer je připojen k ústředně, která má tarifikační výstup nastaven na rychlost 9600 baudů a pro řízení toku dat používá signály DTR/DSR. Nová data se budou kontrolovat každou hodinu a ukládat do souboru pa20.td v adresáři ..\pbx.a.

[CONFIGURATION]
Protocol=Tarwin                # Komunikační protokol
Device=ETH                     # Používá se síťové rozhraní
Interval=3600                  # Kontrolovat data každých 3600 sekund = 1 hodina
DataFile=..\pbx.a\pa20.td      # Cílový soubor

[ETH]
IPBuf=192.168.1.110            # IP adresa bufferu Tarflex v síti
TCPPort = 110                  # TCP port pro data, vzdy 110

[BUFFER]
Typ = 2                        # 1=Tarflex, 2=Tarflex-E
Serial=OFF                     # Vypnuto stohování
FIFO=ON                        # Zapnuto přepisování dat při zaplnění
Sound=ON                       # Zapnuté zvukové signály
DataC=ON                       # Zapnutá komprimace dat
Text=OFF                       # Vypnutý textový režim
PBXBaud=9600                   # Rychlost PBX-Tarflex je 9600
PBXProt=DTR/DSR                # Používají se hw signály DTR a DSR
MaxRet=5                       # Maximalne 5 opakovani pokusu o spojeni
MaxDel=1                       # Maximalne 1 sekundu cekat na odezvu bufferu
MaxLen=2048                    # Nejdelsi datove pakety 2048 bytů

[COMMAND]
AllBuffer=OFF                  # Normální provoz, nestahovat celý obsah paměti

Konfigurace připojení bufferu Tarflex přes telefonní modem

Tato kapitola popisuje konfiguraci zařízení, které získává data z bufferu Tarflex nebo Tarflex plus připojeného přes telefonnímu modem. Konfigurační soubor device.ini obsahuje společnou sekci, která je popsána na začátku této kapitoly. Volba Protokol se nastaví na TARWIN a volba Device na MODEM. Soubor dále obsahuje sekce:

Sekce MODEM nastavuje parametry telefonního modemu připojeného k tomuto počítači:

  • Port - číslo sériového portu na který je připojen telefonní modem - hodnoty COM1 až COM8.
  • Baud - komunikační rychlost v baudech mezi počítačem a modemem, například 57600
  • DialNum - číslo vytáčené do telefonní linky, včetně případné předvolby pro vstup na linku (viz. sada AT příkazů v dokumentaci použitého modemu).
  • DialType - pulzní nebo tónová volba čísla - hodnoty TONE, PULZE, standardně TONE.
  • CDC - zda čekat na signál CD od modemu, standardně zapnuto
  • ATCMDS - AT příkazy, které se posílají do modemu před zahájením vytáčení, stardardně ATX0, podle potřeby možno zadat jiné (viz. příručka použitého modemu)
  • Timeout - pokud se do této doby nenaváže spojení s bufferem, zavěsí se, standardně 40

Sekce BUFFER a COMMAND jsou popsány výše.

Příklad:

Buffer Tarflex je připojen k telefonnímu modemu. Druhý telefonní modem je v PC. Spojení se naváže vytočením čísla 0 pro přístup do telefonní sítě a dále se volí číslo 45454545. Buffer je připojen k ústředně, která má tarifikační výstup nastaven na rychlost 1200 baudů a pro řízení toku dat používá signály DTR/DSR. Nová data se budou kontrolovat každou hodinu a ukládat do souboru pa20.td v adresáři ..\pbx.a.

[CONFIGURATION]
Protocol=Tarwin                # Komunikační protokol
Device=MODEM                   # Používá se modem
Interval=3600                  # Kontrolovat data každých 3600 sekund = 1 hodina
DataFile=..\pbx.a\pa20.td      # Cílový soubor

[MODEM]
Port=COM3                      # Telefonní modem je na portu COM3
Baud=57600                     # a komunikuje rychlostí 57600 Bd
DialNum=0,45454545             # Vytáčené číslo
DialType=TONE                  # Tónová volba čísla
CDC=ON                         # Čekat na signál CD
ATCMDS=ATX0                    # AT příkaz modemu, aby nečekal na oznamovací tón.
Timeout=40                     # Pokud do 40s nezačne komunikace, zavěsit

[BUFFER]
BufNr=0                        # Ovládá se buffer s libovolným výr.č.
Serial=OFF                     # Vypnuto stohování
FIFO=ON                        # Zapnuto přepisování dat při zaplnění
Sound=ON                       # Zapnuté zvukové signály
DataC=ON                       # Zapnutá komprimace dat
Text=OFF                       # Vypnutý textový režim
PBXBaud=1200                   # Rychlost PBX-Tarflex je 1200
MaxRet=5                       # Maximalne 5 opakovat pokus o spojeni
MaxDel=1                       # Maximalne 1 sekundu cekat na odezvu bufferu
MaxLen=4096                    # Nejdelsi datove pakety 4096 bytů

[COMMAND]
AllBuffer=OFF                  # Normální provoz, nestahovat celý obsah paměti

Konfigurace připojení ústředny Alcatel 4400 přes síť TCP/IP

Tato kapitola popisuje konfiguraci zařízení, které získává data z přímo ústředny Alcatel 4400 po síti. Konfigurační soubor device.ini obsahuje společnou sekci, která je popsána na začátku této kapitoly. Volba Protokol se nastaví na ALC4400 a volba Device musí být nastavena na ETH. Soubor dále obsahuje sekci ALC4400 nastavuje parametry komunikace s ústřednou:

  • IPAlc - IP adresa ústředny Alcatel
  • Cwd - adresář, ve kterém se v ústředně nachází soubory s tarifikačními daty, standardně /usr4/account.
  • MaxCnt - maximální počet balíčků s tarifními daty v ústředně, ve většině případů by měla vyhovovat hodnota 1000.
  • Timeout - čas v sekundách, pokud se do té doby nenaváže spojení s ústřednou, přenos se ukončí, standardně 10
  • Cmd_Cmp - je-li tato volba nastavena, pak program Tarwin pošle na začátku přenosu ústředně příkaz pro uzavření rozpracovaného balíčku, standardně je tato funkce vypnutá.
  • Cmd_Prompt - znak, kterým končí prompt (výzva k zadání příkazu) na ústředně. Používá se pouze pro uzavírání rozpracovaného balíčku. Standardně končí prompt znakem '>'.

Příklad:

Ústředna Alcatel 4400 je připojena do sítě a má IP adresu 192.168.1.110. Nová data se budou kontrolovat každou hodinu a ukládat do souboru pa20.td v adresáři ..\pbx.a.

[CONFIGURATION]
Protocol=ALC4400               # Komunikační protokol
Device=Eth                     # Komunikace po síti
Interval=3600                  # Kontrolovat data každých 3600 sekund = 1 hodina
DataFile=..\pbx.a\pa20.td      # Cílový soubor

[ALC4400]
IPAlc=192.168.1.110            # IP adresa ústředny
Cwd=/usr4/account              # Adresář, kde jsou tarifní data
Timeout=10                     # Pokud do 10s nezačne komunikace, skončit
MaxCnt=2048                    # Maximalni počet souborů v ústředně

Konfigurace připojení ústředny Alcatel OmniPCX přes síť TCP/IP

Tato kapitola popisuje konfiguraci zařízení, které získává data z přímo ústředny Alcatel OmniPCX po síti. Konfigurační soubor device.ini obsahuje společnou sekci, která je popsána na začátku této kapitoly. Volba Protokol se nastaví na ALCOXO a volba Device musí být nastavena na ETH. Soubor dále obsahuje sekci ALCOXO nastavuje parametry komunikace s ústřednou:

  • IPAlc - IP adresa ústředny Alcatel
  • MaxRet - maximální počet pokusů o navázání spojení s ústřednou, standardně 3.
  • Timeout - čas v sekundách, pokud se do té doby nenaváže spojení s ústřednou, pokus o spojení se opakuje nebo se přenos ukončí, standardně 10.

Příklad:

Ústředna Alcatel OmniPCX je připojena do sítě a má IP adresu 192.168.1.110. Nová data se budou kontrolovat každou hodinu a ukládat do souboru pa20.td v adresáři ..\pbx.a.

[CONFIGURATION]
Protocol=ALCOXO                # Komunikační protokol
Device=Eth                     # Komunikace po síti
Interval=3600                  # Kontrolovat data každých 3600 sekund = 1 hodina
DataFile=..\pbx.a\pa20.td      # Cílový soubor

[ALCOXO]
IPAlc=192.168.1.110            # IP adresa ústředny
MaxRet = 3                     # Max. pocet pokusu o navazani spojeni
Timeout = 10                   # Jak dlouho cekat na spojeni (sekunkdy)

Konfigurace připojení ústředny Alcatel 4400 přes vytáčené připojení (SLIP)

Tato kapitola popisuje konfiguraci zařízení, které získává data z přímo ústředny Alcatel 4400 přes vytáčené připojení protokolem SLIP. Konfigurační soubor device.ini obsahuje společnou sekci, která je popsána na začátku této kapitoly. Volba Protokol se nastaví na ALC4400 a volba Device musí být nastavena na SLIP. Soubor dále obsahuje sekci ALC4400 nastavuje název vytáčeného připojení a parametry komunikace s ústřednou:

  • Dial - jméno vytáčeného připojení (viz systémová složka Síťová a telefonická připojení v Ovládacích panelech).
  • IPAlc - IP adresa ústředny Alcatel
  • Cwd - adresář, ve kterém se v ústředně nachází soubory s tarifikačními daty, standardně /usr4/account.
  • MaxCnt - maximální počet balíčků s tarifními daty v ústředně, ve většině případů by měla vyhovovat hodnota 1000.
  • Timeout - čas v sekundách, pokud se do té doby nenaváže spojení s ústřednou, přenos se ukončí, standardně 10
  • Cmd_Cmp - je-li tato volba nastavena, pak program Tarwin pošle na začátku přenosu ústředně příkaz pro uzavření rozpracovaného balíčku, standardně je tato funkce vypnutá.
  • Cmd_Prompt - znak, kterým končí prompt (výzva k zadání příkazu) na ústředně. Používá se pouze pro uzavírání rozpracovaného balíčku. Standardně končí prompt znakem '>'.

Příklad:

Ústředna Alcatel 4400 je dostupná přes vytáčené připojení sítě, které je ve složce "Telefonická a síťová připojení" pojmenováno "Ústředna - Praha". Ústředna má IP adresu 192.168.1.110. Nová data se budou kontrolovat každých 6 hodin (=21600 sekund) a ukládat do souboru pa20.td v adresáři ..\pbx.a.

[CONFIGURATION]
Protocol=ALC4400               # Komunikační protokol
Device = SLIP                  # Protokol SLIP
Interval=21600                 # Kontrolovat data každých 6 hodin
DataFile=..\pbx.a\pa20.td      # Cílový soubor

[ALC4400]
Dial = Ústředna - Praha        # Jméno připojení sítě
IPAlc=192.168.1.110            # IP adresa ústředny
Cwd=/usr4/account              # Adresář, kde jsou tarifní data
Timeout=10                     # Pokud do 10s nezačne komunikace, ukončit přenos
MaxCnt=2048                    # Maximalni počet souborů v ústředně

Konfigurace připojení ústředny Siemens přes síť TCP/IP

Tato kapitola popisuje konfiguraci zařízení, které získává data z ústředny Siemens HiCom 100/300 po síti. Ústředna musí být nakonfigurována tak, že se chová jako TFTP server. Konfigurační soubor device.ini obsahuje společnou sekci, která je popsána na začátku této kapitoly. Volba Protokol se nastaví na SIEIP. Soubor dále obsahuje sekci SIEIP nastavující parametry komunikace s ústřednou:

  • IPSie - IP adresa ústředny Siemens
  • FileName - jméno souboru, ve kterém se v ustředně nachází tarifikační data - standardně gez.txt.
  • Timeout - čas v sekundách, pokud se do té doby nenaváže spojení s ústřednou, přenos se ukončí, standardně 10

Příklad:

Ústředna Siemens je připojena do sítě a má IP adresu 192.168.1.110. Nová data se budou kontrolovat každou hodinu a ukládat do souboru pa20.td v adresáři ..\pbx.a.

[CONFIGURATION]
Protocol=SIEIP                 # Komunikační protokol
Interval=3600                  # Kontrolovat data každých 3600 sekund = 1 hodina
DataFile=..\pbx.a\pa20.td      # Cílový soubor

[SIEIP]
IPSie=192.168.1.110            # IP adresa ústředny
FileName=gez.txt               # Adresář, kde jsou tarifní data
Timeout=10                     # Pokud do 10s nezačne komunikace, skončit

Konfigurace připojení k jinému zařízení přes sériový port

Tato kapitola popisuje konfiguraci zařízení, které zachytává příchozí data ze sériového portu, ke kterému je přímo připojen tarifikační výstup pobočkové ústředny nebo jiný buffer. Konfigurační soubor device.ini obsahuje společnou sekci, která je popsána na začátku této kapitoly. Volba Protokol se nastaví na RAW a volba Device musí být nastavena na RS232. V tomto případě se ignoruje parametr Interval a data se přijímají nepřetžitě. Program Tarwin musí být v tomto případě spuštěný(!). Soubor dále obsahuje sekci RAW, kde se nastavují parametry sériového portu:

  • Port - název sériového portu, ze kterého přicházejí data, možné hodnoty: COM1, COM2, ... až COM8
  • Baud - komunikační rychlost v baudech, musí být shodná s nastavením ústředny nebo bufferu, například 9600
  • Parity - používané zabezpečení přenosu paritou, možné hodnoty jsou NONE, ODD, EVEN, MARK a SPACE, standardně NONE.
  • Len - počet bitů ve slově, možné hodnoty jsou 5, 6, 7, 8 a 16, standardně 8.
  • HShaking - hardwarové řízení toku dat - možné hodnoty NONE, DTR/DSR, RTS/CST, BOTH, standardně BOTH.
  • XOnXOff - zda používat řízení toku dat znaky XON a XOFF - standardně vypnuto

Příklad:

K počítači je přes sériový port COM1 připojena ústředna, jejíž sériové rozhraní je nastaveno na rychlost 9600 baudů a používá pro řízení toku dat harwarové signály DTR/DSR a RTS/CTS. Nová data se ukládají do souboru pa20.td v adresáři ..\pbx.a.

[CONFIGURATION]
Protocol=Raw                   # Komunikační protokol
Device=RS232                   # Používá se sériové rozhraní
DataFile=..\pbx.a\pa20.td      # Cílový soubor

[RAW]
Port=COM1                      # Ústředna je připojena na COM1
Baud=9600                      # Rychlost je 9600
HShaking=Both                  # Řízení toku signály DTR/DSR a RTS/CTS
Parity=NONE                    # Bez parity
Len=8                          # Osmibitová slova
XonXoff=OFF                    # Nepoužívat sw řízení toku

Konfigurace zachytávání znaků na TCP portu

Tato kapitola popisuje konfiguraci zařízení, které zachytává příchozí data ze síťového portu. Konfigurační soubor device.ini obsahuje společnou sekci, která je popsána na začátku této kapitoly. Volba Protokol se nastaví na RAW a volba Device musí být nastavena na Eth. V tomto případě se ignoruje parametr Interval a server je aktivní nepřetržitě. Program Tarwin musí být v tomto případě neustále spuštěný(!). Soubor dále obsahuje sekci RAW, kde se nastavuje jediný parametr:

  • Port - číslo síťového portu, na kterém je nainstalován TCP server.

Příklad:

Ústředna poskytuje data do počítačové sítě a je naprogramována tak, aby se chovala jako TCP klient, tzn. v určitém intervalu se spojí protokolem TCP/IP s protistranou a předá tam tarifní data. Server (v tomto případě program Tarwin) ukládá tato data do souboru pa20.td v adresáři ..\pbx.a.

[CONFIGURATION]
Protocol=Raw                   # Komunikační protokol
Device=Eth                     # Používá se síťové rozhraní
DataFile=..\pbx.a\pa20.td      # Cílový soubor

[RAW]
Port=514                       # Síťový port je 514


Konfigurace zařízení v programu Tardat

Dialogové okno pro nastavení konfigurace zařízení se spouští z hlavního okna programu Tardat v nabídce Konfigurace položka Zařízení. Toto dialogové okno má stejný vzhled a stejné ovládání jako hlavní okno programu TarKonfig, obsahuje navíc záložku Spouštění přenosů a chybí v něm záložka O programu. Tato kapitola se věnuje pouze těm funkcím, které chybí v programu Tarkonfig. Ostatní parametry a funkce jsou popsány v kapitole 1.2.

Obsah

  1. Spouštění přenosů

Viz také:

  • Program Tarwin


Konfigurace zařízení - spouštění přenosů

Konfigurace zařízení v programu Tardat

Spouštění přenosů

V případě, že buffer Tarflex nemáte připojený k PC, můžete využít funkci spouštění přenosového modulu Tarwin při spuštění programu Tardat. Při normálním (on-line) připojení bufferu tuto funkci nedoporučujeme.

Funkce Spouštění přenosů umožňuje iniciovat přenos dat ze všech zařízení při startu programu Tardat mimo časový plán. Seznam síťových rozhraní přenosových modulů, kterým se požadavek odesílá je uveden v konfigurační tabulce. Při spuštění programu Tardat se rozešlou modulům příkazy k přenesení dat. Přenosové moduly musí mít povolené síťové monitorovací a řídící rozhraní, viz kapitola 1.1.4 a 1.2.7.

Současný komunikační protokol neumožňuje zpětnou vazbu, která by kontrolovala, že přenos byl skutečně bezchybně zahájen a dokončen. Lze pouze zjistit, že požadavek nebylo možné odeslat, tj. program Tarwin není spuštěný, nemá povolené a správně nastavené síťové rozhraní. Komunikace může selhat také v případě, že počítačová síť neumožňuje TCP spojení mezi oběma počítači na příslušném síťovém portu.

Nastavení spouštění přenosů

Pro nastavení této funkce slouží záložka Spouštění přenosů v dialogovém okně pro konfiguraci zařízení. Zatržítkem Při spuštění Tardatu odeslat požadavek na přenos dat... lze funkci povolit nebo zakázat. Záložka obsahuje také tabulku se seznamem IP adres přenosových modulů, kterým se má odesílat příkaz na přenos dat. Používá-li se u některého modulu jiný než standardní síťový port (1112), je nutné uvést za IP adresou číslo síťového portu oddělené dvojtečkou (například 192.168.1.9:1222).

Vložení nového řádku do tabulky se provede tak, že IP adresa rozhraní vepíše do editačního pole pod tabulkou a stiskne se tlačítko Přidej řádek. Tlačítko Nahraď řádek nahradí vybraný řádek v tabulce textem uvedeným v editačním poli. Označený záznam v tabulce lze odstranit tlačítkem Vymaž řádek. Tlačítky se šipkou lze přesunovat označený řádek tabulky o jednu pozici nahoru nebo dolů.

Pomocí tlačítka Test lze otestovat nastavení funkce. Program rozešle všem modulům uvedeným v tabulce příkazy k přenesení dat. Jestliže odeslání proběhlo v pořádku, dialogové okno, do kterého se vypisuje průběh odesílání, se automaticky zavře. V případě, že došlo k chybě, dialogové okno zůstane otevřené a z protokolu lze zjistit, k jaké chybě došlo.

Příklad 1:

Program Tarwin běží na stejném počítači, na kterém se spouští program Tardat. Z žádného jiného počítače se s programem nepracuje. Konfigurační tabulka spouštění přenosů bude obsahovat jediný záznam:

127.0.0.1

Příklad 2:

Jeden program Tarwin běží na počítači s IP adresou 192.168.1.12, druhý na počítači 192.168.1.22. Protože síťový port 1112 se používá pro jinou službu, je v konfiguraci síťového rozhraní programů Tarwin zadán jiný síťový port číslo 1222. Program Tardat se spouští na několika počítačích v lokální síti. Konfigurační tabulka bude obsahovat dva záznamy:

192.168.1.12:1222
192.168.1.22:1222


Konfigurace ústředen

Konfigurace ústředen a související tabulky

Tato část konfigurace programu Tardat řídí proces zpracování hovorů a to od jeho načtení ze vstupního souboru až po jeho uložení do hlavní databáze a daších výstupů. Tabulky by měly popisovat logickou stavbu telefonní sítě zákazníka a to od poboček až k linkám, které vedou k poskytovatelům telefonních služeb.

V této kapitole je popsána struktura konfiguračních tabulek ústředen, skupin poboček, interního seznamu, průchodových a uživatelských sítí, definuje zavedené pojmy a význam jednotlivých parametrů.

Obsah

  1. Ústředny
  2. Průchodové sítě
  3. Uživatelské sítě
  4. Skupiny poboček a střediska
  5. Interní seznam

Viz také:

  • Popis databázových tabulek
  • Nástroje pro správu konfigurace
  • Zpracování hovorů


Konfigurace ústředen a související tabulky

Ústředny

Základní částí konfigurace je ústředna, která nejčastěji odpovídá jedné pobočkové ústředně uživatele. Z ústředen se v programu zpracovávají tarifní data. Program může zpracovávat tarifní data až od 47 nezávislých ústředen.

Ústředna je v programu Tardat definována záznamem v příslušné tabulce na serveru. V adresáři, ve kterém je nainstalována serverová verze programu Tardat, je vytvořen odpovídající adresář PBX.A pro první ústřednu, PBX.B pro druhou atd. V tomto adresáři se ukládají, vstupní a záložní data, která se týkají dané ústředny.

Aktivní ústředna

Během zpracování se vždy vybere jedna ústředna, která má ve vstupním souboru nová data určená ke zpracování. Taková ústředna se nazývá aktivní, při zpracování je vždy jedna ústředna aktivní - ta, ze které se právě zpracovávají data. Ke všem ostatním ústřednám přistupuje, jako by obsahovaly pouze tabulku přístupových kódů, ostatní tabulky a parametry se ignorují. Až se zpracují nová data jedné ústředny, pokračuje se další ústřednou, ta se prohlásí za aktivní.

Vytvoření a zrušení ústředny

Základní okno konfigurace ústředen obsahuje tabulku definovaných ústředen. V prvním sloupci je označení ústředny, které koresponduje s označením příslušného adresáře (Ústředna A má všechny soubory uloženy v adresáři PBX.A atd.). V druhém sloupci je její jméno a ve třetím sloupci je uveden maximální počet poboček povolený v hardwarovém klíči.

Nová ústředna se zřídí kliknutím na nový řádek a stiskem tlačítka Nová. Ústředna se vymaže tlačítkem Smazat, které po potvrzení uživatelem zruší konfigurační tabulky ústředny a vymaže také celý adresář ústředny. Dialog pro editaci nastavení ústředny se spustí tlačítkem Editovat nebo dvojklikem v příslušném řádku tabulky.

Vlastnosti ústředny

První záložka Vlastnosti obsahuje editační pole pro zadání jména ústředny, informace o formátu vstupních dat (výrobce + typ). Tlačítkem Nastavení formátu se otevře dialog pro změnu formátu. Vlastnosti, které se používají jen výjimečně a do kterých by uživatel neměl zasahovat jsou skyty v dialogu, který se spouští tlačítkem Pro odborníky.

V sekci Soubory jsou umístěny volby, které ovlivňují zacházení se soubory během procesu zpracování nových hovorů. Volba Zápis dat i do záložního souboru text.txt zapíná ukládání zpracovaných řádků také do záložního souboru patext.txt v adresáři ústředny; jeho velikost není nijak omezována.

Formát ústředny

Formát ústředny je soubor parametrů a procedur, které definují tvar vstupních dat a ovlivňují celý proces zpracování hovorů. Tyto volby se nastaví při změně formátu ústředny v editačním okně ústředny a mění se pouze ve výjimečných případech - proto jsou tyto volby umístěny v dialogu Pro odborníky. Každý formát ústředny má jednoznačně přiděleny dva řetězce - výrobce a typ ústředny s případným označení verze firmwaru (release), rozlišení různých variant apod., například Alcatel, 4400 (R1.4)

Při změně formátu lze také nastavit do výchozího stavu tabulky linek, svazků, poboček, zúčtovacích a odchozích kódů, případně lze z databáze odstranit všechny hovory této ústředny. Uživatelské rozhraní umožňuje zvolit, které hodnoty a tabulky budou inicializovány a zda odstranit hovory z databáze.

Nastavení formátu

Dialog pro změnu formátu vstupních řádků ústředny se otevře stiskem tlačítka Nastavení formátu na kartě Vlastnosti editačního okna ústředny. Tento dialog obsahuje výběrové pole se seznamem výrobců (nejprve je nutné zvolit výrobce) a v druhém výběrovém poli jsou zobrazeny všechny podporované formáty zvoleného výrobce.

Zatržítky v dolní části okna se volí, které tabulky se mají po potvrzení okna inicializovat. Volba Časování se týká časových odečtů a filtrů.

Při změně formátu lze také vymazat z hlavní databáze všechny hovory týkající se editované ústředny. Tato funkce se zapíná volbou Vymazat hovory....

Veškeré změny se provedou až po potvrzení okna tlačítkem OK.

Linky

Linky spojují ústřednu s veřejnou telefonní sítí (státní linky) nebo mohou vést do jiných ústředen (příčky) či privátních sítí. Jejich základní vlastností je proto příchozí a odchozí připojení. Ve většině případů se připojení nekonfiguruje přímo u linky, ale až u svazků, které sdružují několik linek se společným připojením.

Linka je identifikována pomocí čísla, které může obsahovat pouze čáslice a je maximálně devítimístné. Zpravidla odpovídá číslování linek ve výstupních řádcích z ústředny, v případech, kde to není možné, se v programu provádí pevně nastavené mapování.

Záložka Linky editačního dialogu ústředny obsahuje tabulku definovaných linek. V prvním sloupci je vždy uvedeno číslo linky a její jméno. Červený křížek u ikony znamená, že je linka utajená. Jména linek nemusí být jednoznačná, protože se k identifikaci používá pouze číslo. V dalších sloupcích jsou zobrazeny odchozí a připojení připojení a další parametry linky.

Nabídka všech funkcí, které lze provádět je dostupná v pop-up nabídce. Program umožňuje editovat několik linek najednou, lze celý seznam linek exportovat do souboru nebo kopírovat či přenášet linky přes zásobník.

V editačním dialogu linky se vždy vyplňuje číslo linky. Pojmenování není povinné a nemusí být ani jednoznačné. Vždy se vyplňuje také připojení, na výběr jsou dvě možnosti. Většinou se linka přiřadí do svazku a připojení se konfiguruje až v konfiguraci svazku nebo může mít linka samostatné připojení. V tom případě se v editačním dialogu zpřístupní další záložka Samostatné připojení pro jeho konfiguraci (je uvedeno dále).

Volba příjem tarifních informací určuje, zda po lince přichází informace, které jsou důležité pro ocenění hovoru. V případě, že je příjem informací zapnut a příjem informací není spolehlivý, je vhodné zapnout také korekci, která zajišťuje, aby hovor byl oceněn i v případě výpadků pulzů. Některé linky (např. ISDN) potřebují jen velmi malý čas na sestavení hovoru - v tomto případě se nastaví zatržítko nepoužívat odečty, které zakáže používání časových odečtů na této lince. Uživatel může nastavit, že konkrétní linka je utajená, v tomto případě veškeré hovory uskutečněné přes tuto linku se v přehledech nezobrazují. Další vlastností linky je příplatek, kterým lze navýšit nebo snížit cenu hovoru o zadaný počet procent (záporná hodnota znamená slevu, kladná příplatek). Vlastností linky je také typ volby (tónová, pulzní, žádná), která se na lince používá. Toto nastavení ovlivňuje u některých ústředen, které do trvání zahrnují i čas na vytáčení čísla, úpravu délky trvání (časový odečet).

Příchozí a odchozí přípojení

Příchozí připojení určuje, odkud po lince jdou příchozí a tranzitní hovory, odchozí připojení se týká odchozích a tranzitních hovorů. Nastavení odchozího směru se skládá z těchto parametrů (příchozí směr je symetrický):

  • Vstup do tarifní sítě - vyhledání umístění a ocenění hovoru podle tarifních tabulek - zadává se tarifní síť a vstupní bod. Tato volba může být zkombinována se vstupem do uživatelské sítě a zároveň se vstupem do některé tabulky odchozích kódů.
  • Vstup do uživatelské sítě - umožňuje zadat speciální uživatelskou sazbu na vybraná telefonní čísla (sady čísel). Zpravidla se kombinuje s připojením do tarifní sítě, která definuje cenu hovorů, jejichž volané číslo nesouhlasí ani s jednou položkou uživatelské sítě.
  • Vstup do tabulky odchozích kódů, ve které se na základě volaného čísla určuje další propojení hovoru v telefonní síti. Na výběr jsou tyto tři možnosti:
    • Přístupové kódy z této ústředny - vyhledává se shoda v tabulce přístupových kódů aktivní ústředny,
    • Přístupové kódy z jiné ústředny - vyhledává se shoda v tabulce přístupových kódů zvolené ústředny,
    • Průchodová síť - speciální konfigurační tabulka, která popisují chování směrovačů, privátních sítí apod.

Svazky

Svazek je konfigurační objekt, který definuje společné příchozí a odchozí připojení několika linek. Byl zaveden proto, že na ústředně která má mnoho linek, bývají linky rozděleny na jednu nebo dvě množiny, které vedou ke stejnému poskytovateli (např. pevné linky + jedna GSM brána) a bylo by nepraktické, aby se připojení muselo definovat u každé linky zvlášť.

Příklad:

Linky 1 až 6 jsou sdruženy do svazku Telecom Brno, který má připojení na odchozí i příchozí straně do Veřejné tel. sítě přes vstupní bod Český Telecom, Brno. Linky 6 a 7 mají samostatné připojení do Veřejné tel. sítě přes vstupní bod GSM Eurotel a GSM T-Mobile.

Linka 1    \
Linka 2    |
Linka 3    >  Svazek Telecom Brno   ( <- Veřejná tel. síť, Český telecom, Brno )
Linka 4    |                        ( -> Veřejná tel. síť, Český telecom, Brno )
Linka 5    /
Linka 6 --------------------------> ( -> Veřejná tel. síť, GSM Eurotel )
Linka 7 --------------------------> ( -> Veřejná tel. síť, GSM T-Mobile )

Každý svazek má své jméno, které musí být v rámci jedné ústředny jednoznačné, uživatel si může nastavit procentuální příplatek a nově také pseudotarifikační konstanty - časové odečty a filtry platné jen pro konkrétní svazek.

Záložka Svazky editačního dialogu ústředny obsahuje v levé části tabulku definovaných svazků linek. V prvním sloupci je uvedeno jméno svazku. V dalších sloupcích je zobrazeno odchozí a připojení připojení. Všechny funkce jsou dostupné v pop-up nabídce, seznam poboček lze exportovat do souboru. Pobočky je možné kopírovat nebo přenášet přes zásobník.

Editační dialog svazku obsahuje především nastavení odchozího a příchozího připojení a také jméno svazku, které musí být vyplněno a musí být jedinečné.

Další vlastnosti svazku se používají jen málo a jsou umístěny na kartě Vlastnosti. Sekce odečty a filtry slouží k nastavení speciálních časových odečtů a filtrů (používá se například u ISDN linek nebo GSM bran). Jestliže je aktivní volba Podle ústředny, pak pro hovory na tomto svazku platí časové konstanty uvedené v okně Pro odborníky (popsáno výše). Nastaví-li se jako aktivní volba Vlastní, pak se v okně objeví tabulka pro zadání odečtů a filtrů. Hodnoty jsou rozděleny podle tarifních oblastí a uvádí se vždy v sekundách. Tlačítko Standardní... nastaví všechny proměnné odečtů a filtrů na hodnoty přednastavené v programu.

Pobočky

Tabulka poboček definuje připojené účastníky (vnitřní linky) jejich očíslování a některé parametry ovlivňující zpracování a oceněnění hovoru. Maximální velikost tabulky je omezena kategorií uloženou v hardwarovém klíči. Pobočky jsou jednoznačně identifikovány pomocí čísel (nezávisle pro každou ústřednu), Tardat umožňuje zpracovat maximálně devítimístná čísla.

Pro každou pobočku je možné definovat také procentuální příplatek k ceně hovorů a způsob maskování telefonních čísel (viz dále). Pobočka může být utajená - hovory na této pobočce nebudou v přehledech zobrazovány.

Tabulka poboček se nastavuje na záložce pobočky v editačním okně ústředny. Tabulka obsahuje seznam všech definovaných poboček. V prvním sloupci je uvedeno vždy číslo pobočky a její jméno, v dalších sloupcích je přehled vlastností. U utajených poboček je v ikoně zobrazen červený křížek. Program umožňuje editovat několik poboček najednou. Všechny funkce jsou dostupné v pop-up nabídce, seznam poboček lze exportovat do souboru. Pobočky je možné kopírovat nebo přenášet přes zásobník.

Editační dialog pobočky obsahuje pole pro vložení čísla pobočky, které je povinné. Pole jméno nemusí být vyplněno.

Autorizační kódy

Některé typy ústředen umožňují použití tzv. autorizačních kódů. Je to maximálně 10 znaků dlouhá kombinace čísel a znaků (0123456789ABCD#*), která se vytáčí před vytáčením čísla volaného účastníka. Řeší se tím například osobní telefonní účty zaměstnanců pro soukromé hovory tak, aby bylo možné použít pro soukromý hovor libovolného telefonního přístroje. V tomto případě se každému zaměstnanci zřídí v programu Tardat tzv. virtuální pobočka a v její konfiguraci se vyplní položka autorizační kód. V přehledech se potom rozlišuje fyzický zdroj (identifikace konkrétního telefonního přístroje) a logický zdroj (identifikace zaměstnance). U hovorů bez a.k. je logický zdroj shodný s číslem fyzického zdroje.

Protože jsou virtuální pobočky umístěny v tabulce poboček ústředny, je nutné při výběru kategorie programu počítat i s dostatečnou rezervou pro autorizační kódy.

Zúčtovací kódy

Zúčtovací kód je maximálně 16 znaků dlouhá kombinace čísel a znaků (0123456789ABCD#*). Má podobnou funkci jako autorizační kódy, ale nemění číslo logické pobočky a navíc nespotřebovává zdroje v klíči, protože nezabírá místo v tabulce poboček.

Každý hovor se ve zpracování přiřadí právě jednomu zúčtovacímu kódu. Nemá-li hovor přiřazen žádný zúčtovací kód nebo se zadaný takový kód nenachází v tabulce a nelze jej autodetekovat, přiřadí se hovor k položce "Nezadán". To je speciální položka tabulky, která je vždy na prvním místě a nelze ji smazat.

Zúčtovací kódy slouží například k vyúčtování telefonních hovorů spojených s určitým zákazníkem nebo zakázkou. V přehledech lze zobrazit pouze hovory pro vybrané položky nebo vytvořit souhrnný nebo detailní přehled rozdělený po jednotlivých položkách.

Zúčtovací kód má vlastnosti podobné pobočce: procentuální příplatek k ceně hovoru a způsob maskování čísla. Nastavení zatržítka "Zobrazený jako 1. ZK" způsobí, že hovory pro tento zúčtovací kód budou v přehledu zařazeny pod položku "Nezadán".

Tabulka zúčtovacích kódů se nastavuje na záložce Zúčtovací kódy v editačním okně ústředny. Tato záložka je přístupná pouze u vybraných typů ústředen, které tuto funkci podporují. Je-li v ikoně zobrazen červený křížek, znamená to, že u daného kódu je zatržena volba Zobrazit jako 1. ZK (hovory budou v přehledu zobrazeny pod kódem "Nezadán"). Program umožňuje editovat vlastnosti nekolika řádků najednou. Veškeré funkce jsou dostupné v pop-up nabídce, je možné kopírovat nebo přenášet řádky přes zásobník.

V editačním okně kódu musí být vyplněno alespoň pole Kód. Zadání jména není povinné. Výjimkou je speciální kód Nezadán, který stojí v tabulce vždy na prvním místě, jeho kód je vždy prázdný a jméno Nezadán nelze měnit.

Uživatelské kódy

Uživatelský kód je maximálně 2 znaky dlouhá kombinace čísel a znaků (0123456789ABCD#*). Význam tohoto pole závisí na použitém formátu ústředny. Při importu hovorů ze souboru CSV rozlišují telefonní hovory a textové zprávy.

Každý hovor se ve zpracování přiřadí právě jednomu uživatelskému kódu. Nemá-li hovor přiřazen žádný uživatelský kód nebo se zadaný takový kód nenachází v tabulce a nelze jej autodetekovat, přiřadí se hovor k položce "Nezadán". To je speciální položka tabulky, která je vždy na prvním místě a nelze ji smazat.

Uživatelský kód má vlastnosti podobné zúčtovacímu kódu: procentuální příplatek k ceně hovoru a způsob maskování čísla. Nastavení zatržítka "Zobrazený jako 1. UK" způsobí, že hovory pro tento uživatelský kód budou v přehledu zařazeny pod položku "Nezadán".

Tabulka uživatelských kódů se nastavuje na záložce Uživatelské kódy v editačním okně ústředny. Je-li v ikoně zobrazen červený křížek, znamená to, že u daného kódu je zatržena volba Zobrazit jako 1. UK (hovory budou v přehledu zobrazeny pod kódem "Nezadán"). Program umožňuje editovat vlastnosti nekolika řádků najednou. Veškeré funkce jsou dostupné v pop-up nabídce, je možné kopírovat nebo přenášet řádky přes zásobník.

V editačním okně kódu musí být vyplněno alespoň pole Kód. Zadání jména není povinné. Výjimkou je speciální kód Nezadán, který stojí v tabulce vždy na prvním místě, jeho kód je vždy prázdný a jméno Nezadán nelze měnit.

Přístupové (odchozí) kódy z ústředny

Tabulka přístupových kódů se používá pro rozlišení směru u hovorů na základě telefonního čísla volajícího nebo volaného předané z ústředny nebo pro úpravu čísla před vstupem do tarifní sítě. Mohou také popisovat chování směrovače, který rozděluje hovory k provozovatelům na základě telefonního čísla.

Tabulka se používá zpravidla u ústředen Kapsch, které dávají před volaným číslem několikamístné předčíslí, které je nutné z čísla odstranit ještě před vstupem do tarifní sítě, aby mohl být hovor správně oceněn.

Pořadí jednotlivých záznamů v této tabulce nerozhoduje, vždy se hledá nejdelší shoda. Speciální znak otazník zastupuje libovolnou číslici. Do tabulky se zpravidla přidává jeden řádek, jehož kód je jen otazník. Tento řádek definuje připojení pro hovory, jejich telefonní číslo nesouhlasí s žádným jiným řádkem.

Vlastností přístupového kódu je na rozdíl od linek pouze jediný směr, který platí pro příchozí i odchozí hovory. U příchozích hovorů bývá číslo volajícího předáváno bez dalších předčíslí, takže se příchozí připojení u svazků definuje přímo do tarifní sítě pro zjištění umístění volajícího a až na výjimky se cena příchozích hovorů v přehledech vůbec nezobrazuje. Pro jednotlivé kódy lze také definovat procentuální příplatek nebo slevu, to umožňuje například definovat slevu pouze na mezinárodní hovory nebo příplatek na konkrétní telefonní čísla apod.

V editačním dialogu se vždy nastavuje přístupový kód, počet číslic, které se mají odebrat z telefonního čísla při průchodu, případně číslo, které se při průchodu vloží na začátek telefonního čísla (např. volba operátora). V dolní části okna se konfiguruje připojení, které platí v odchozím i příchozím směru.

Autodetekce

U větších ústředen by bylo značně nepraktické, kdyby uživatel musel nastavit ručně v konfiguraci Tardatu po instalaci kompletní tabulku poboček a linek. Proces autodetekce umožňuje tuto činnost automatizovat z dat dostupných ve vstupních řádcích z ústředny. Autodetekce je tedy proces samočinné změny konfigurace Tardatu bez zásahu uživatele, nejčastěji se provádí během zpracování.

Pro nastavení vlastností nově vzniklého objektu platí následující konvence: Je-li tabulka, kam má být nový objekt zařazen neprázdná, zkopírují se do nového objektu vlastnosti první položky. Má-li tabulka speciální prvek, který stojí na prvním místě (zúčtovací nebo uživatelský kód "Nezadán"), zkopírují se vlastnosti následující položky. V případě, že je tabulka prázdná, nastaví se vlastnosti podle parametrů přednastavených v programu od výrobce.

Doporučený postup je proto takový, že se vytvoří neexistující linka (např. číslo 0) jako vzor a zařadí se na první místo. Autodetekce potom kopíruje vlastnosti této pobočky. Protože na tuto pobočku nechodí žádné hovory, není v přehledech vidět.

V současné verzi se autodetekce týká těchto typů objektů: poboček, linek, zúčtovacích kódů, uživatelských kódů a skupin poboček.

V některých případech dává ústředna v řádcích i informace o jméně pobočky nebo zúčtovacího kódu. Je proto výhodné automaticky umožnit změnu konfigurace Tardatu podle těchto informací. Ve vlastnostech formátu lze tuto funkci nastavit ve třech úrovních:

  • Jména se z řádku přebírají vždy, je-li tato položka vyplněna,
  • Jména se přibírají jen při vytvoření objektu autodetekcí,
  • Jména se nepřebírají nikdy.

Některé velké ústředny (Alcatel 4400) umožňují také ve své vlastní konfiguraci rozdělení poboček do skupin (nákladových středisek) a dávají odpovídající informaci ve výstupním řádku. Tardat pak umožňuje automaticky přizpůsobit zařazení poboček do skupin podle konfigurace ústředny. V tomto případě je nutné zajistit, aby v případě, že dojde k přesunutí pobočky, byly hovory v přehledu správně vyúčtovány - hovory provedené před změnou konfigurace musí být uvedeny pod původní skupinou, ostatní hovory pod novou skupinou. V případě, že je pole se skupinou prázdné, přesune se pobočka i hovor do speciální skupiny "Ostatní pobočky".

Příplatky

Program Tardat umožňuje připočítat k hovorům na určité pobočce procentuální příplatek v rozsahu -100% (hovor je zdarma) až +1947% (hovor má více než dvacetinásobnou cenu). V současné verzi lze definovat příplatek pro většinu konfiguračních objektů. Jednotlivé procentuální příplatky se vždy sčítají.

Příklad:

Jestliže hovor byl veden z pobočky 100, která má definován příplatek 5% a která patří do skupiny Servis s příplatkem 10%, do linky 11, která má příplatek -7%, pak k ceně hovoru se po tarifikaci připočítá 5+10-7 = 8% z vypočtené ceny.

Maskování

V případech, kdy uživatel nechce, aby v přehledu bylo vidět celé telefonní číslo, například z důvodu možností zneužití osobních informací, je možné určitou část telefonního čísla zamaskovat. Tabulka, která rozhoduje o maskování telefonního čísla se nastavuje v dialogu Pro odborníky, může to být buď tabulka poboček, zúčtovacích, uživatelských nebo přístupových kódů. Na jedné ústředně lze maskovat telefonní čísla pouze na základě jedné tabulky.

Například, je-li nastaveno maskování podle zúčtovacích kódu, pak v editačním dialogu zúčtovacích kódů je povolena položka maskování, která určuje způsob maskování:

  • Nemaskovat nic
  • Maskovat vždy 1, 2, 3, ... 6 posledních čísel
  • Maskovat zbytek čísla - část telefonního čísla rozhodující pro nalezení cílového uzlu v síti se nechá, zbytek se zamaskuje.
  • Maskovat zbytek čísla, maximálně však 4 poslední místa.

Pro odborníky

Parametry ústředny, které až na výjimečné případy není nutné měnit jsou umístěny ve zvláštním dialogu, který je přístupný pod tlačítkem Pro odborníky na záložce Vlastnosti editačního okna ústředny. Tyto volby se nastaví podle konstant v programu automaticky při změně formátu ústředny. V následující tabulce je uveden přehled parametrů:

Volba | Význam
Příchozí hovory | Ústředna předává údaje o příchozích hovorech
Tranzitní hovory | Ústředna předává údaje o tranzitních hovorech
Vnitřní hovory | Ústředna předává údaje o vnitřních hovorech
Autodetekce linek, poboček, skupin, ... | Povolení automatické přidávání položek do tabulky linek, poboček, skupin, atd. podle předaných informací v tarifních datech.
Přesouvání poboček mezi skupinami | Povolení změny zařazení pobočky do skupiny podle předaného kódu
Přebírání jmen | Nastavuje režim funkce, která mění jména poboček a zúčtovacích kódů podle údajů předaných v řádku
Hlídání | Nastavuje funkci "Hlídání" - viz kapitola věnovaná zpracování
V trvání je volba čísla | Z trvání hovoru je nutné odečíst také čas pro volbu čísla - v tom případě je nutné u linek nastavit správný typ volby čísla (tónová, pulzní)
Čas je při zahájení hovoru | Zapnuto = ústředna předává čas zahájení hovoru, vypnuto = ústředna předává čas ukončení hovoru
Trvnání od 1. inf. jedn. | Ústředna nuluje počítadlo trvání hovoru při příchodu prvního pulzu
Odečty a filtry | Časové konstanty pro pseudotarifikaci, pro jednotlivé tarifní oblasti, globálně pro celou ústřednu.
Import záznamů | Na této záložce se konfigurují formáty pro import záznamů o hovorech ze souboru CSV.


Konfigurace ústředen a související tabulky

Průchodové sítě

Průchodové sítě jsou dalším ze sady prostředků, kterými uživatel popisuje logickou strukturu jeho telefonní sítě. Nemusí mít přesnou reálnou předlohu, mohou popisovat chování směrovačů, privátních sítí apod. Průchodová síť je vlastně pouze tabulka odchozích kódů, která rozhoduje o tarifikaci hovoru na základě volaného/volajícího čísla. Program umožňuje nadefinovat až 15 průchodových sítí.

Dialog pro konfiguraci průchodových sítí se vyvolá tlačítkem Průchodové sítě v okně Konfigurace ústředen. Jestliže zatím není definována žádná síť, okno obsahuje v horní části prázdnou plochu. Kliknutím na tlačítko Nová síť se vytvoří nová průchodová síť a v horní části okna se objeví editační prvky pro její nastavení. Každá síť má svoji záložku v záhlaví okna kliknutím na záložku se objeví nastavení sítě.

V konfiguraci sítě se vyplňuje jméno, které není povinné, ale pro lepší orientaci v programu doporučujeme síť vhodně pojmenovat. Tabulka obsahuje seznam definovaných odchozích kódů. Pořadí jednotlivých záznamů v této tabulce nerozhoduje, vždy se hledá nejdelší shoda. Speciální znak otazník zastupuje libovolnou číslici. Do tabulky se zpravidla přidává jeden řádek, jehož kód je jen otazník. Tento řádek definuje připojení pro hovory, jejich telefonní číslo nesouhlasí s žádným jiným řádkem.

V editačním dialogu se vždy nastavuje přístupový kód, počet číslic, které se mají odebrat z telefonního čísla při průchodu, případně číslo, které se při průchodu vloží na začátek telefonního čísla (např. volba operátora). V dolní části okna se konfiguruje připojení, které platí v odchozím i příchozím směru. Pro jednotlivé kódy lze také definovat procentuální příplatek nebo slevu, to umožňuje například definovat slevu pouze na mezinárodní hovory nebo příplatek na konkrétní telefonní čísla apod.

Příklad:

Kód     Význam
51      Místní hovory (Jihomoravský kraj)
53      Místní hovory (Jihomoravský kraj)
54      Místní hovory (Jihomoravský kraj)
00      Mezinárodní hovory
8       Barevné linky
9       Barevné linky, Internet
?       Všechna ostatní čísla


Konfigurace ústředen a související tabulky

Uživatelské sítě

Pomocí této konfigurační tabulky lze do programu vložit speciální ceny za připojení na vybraná čísla nebo skupiny čísel. Počet položek tabulky je omezen na 10, složitější případy se řeší placeným sazebníkem nebo použitím standardního sazebníku a definováním příplatků a slev na linkách nebo odchozích kódech.

Editor uživatelských sazeb se spouští z okna Konfigurace ústředen tlačítkem Uživatelská síť. Dialogové okno obsahuje tabulku definovaných uživatelských sazeb. Dvojklikem na řádek v tabulce se spustí editační okno.

Každá položka uživatelského sazebníku obsahuje specifikaci čísla nebo sady čísel, pro které daný řádek platí. Kód se zadává jako řetězec čísel 0-9 a znaků ABCD#*. Jednotlivá čísla lze oddělit čárkou s významem "NEBO". Speciální význam má znak otazník, který zastupuje libovolný znak a vykřičník, který se uvádí před číslo a znamená negaci. Pořadí položek v tabulce není rozhodující, hledá se vždy největší shoda. V případě, že před číslem představujícím největší shodu je uveden znak negace, vyhledávání skončí neúspěchem a hovor je oceněn podle tarifní sítě (viz postup při zpracování).

Příklad:

Maska 5,!52,!53 znamená, že cena platí pro všechna čísla začínající pětkou mimo čísla začínající 52 a 53.

Cena za hovor se specifikuje přímo u každého řádku. Uvádí se cena za minutu (s DPH nebo bez DPH), interval účtování v sekundách, nebo lze uvést paušální cenu za hovor bez ohledu na jeho trvání. Každá položka obsahuje také informaci o tom, jakým způsobem se mají interpretovat informace přijaté od provozovatele a oblast, do které má být hovor zařazen (oblasti slouží k roztřídění hovorů v přehledu na místní, dálkové, meziměsto, internet apod.) - tyto informace se v případě tarifních sítích nastavují v konfiguraci vstupního bodu. U každého řádku se uvádí také umístění, které se v přehledu zobrazí ve sloupci "Umístění" a "Detailní umístění".

Příklad:

Hovor byl dlouhý 5 minut a 10 sekund. V konfiguraci uživatelské sítě byla zadána cena 2 Kč/min bez 5% DPH a účtování po 60 sekundách. Délka hovoru se zaokrouhlí nahoru na celý násobek intervalu, účtované délka je tedy 6 minut. Cena bez daně je pak 2*6=12 Kč, připočte se daň 12+5%=12,60. Výsledná cena je 12,60 Kč včetně DPH.


Konfigurace ústředen a související tabulky

Skupiny poboček a střediska

Pobočky ústředen jsou rozděleny do skupin tak, že každá pobočka patří právě do jedné skupiny a do jedné skupiny mohou patřit i pobočky z několika ústředen. V reálném světě odpovídají například jednomu oddělení firmy, sdružují pobočky, které používá jeden nájemce, nebo mohou odpovídat nákladovému středisku v účetnictví. Se skupinami pracuje také nástroj Faktura. Podle skupin je možné v přehledu filtrovat hovory i rozdělovat řádky do bloků. Lze tedy vytvořit přehled obsahující hovory, které se mají vyfakturovat jednomu nájemci nebo vytisknout souhrnný přehled po pobočkách rozdělený na jednotlivé oddělení.

Dialog pro nastavení skupin se spouští v okně Konfigurace ústředen tlačítkem Skupiny poboček. Tabulka obsahuje seznam všech definovaných skupin. Dvojklikem na některou položku se spustí editační dialog. V tabulce skupin je vždy jedna skupina pojmenovaná "Ostatní pobočky", kterou nelze smazat. Patří do ní všechny pobočky, které nejsou zařazeny do žádné jiné skupiny.

Některé ustředny předávají kód skupiny v tarfiním řádku a program Tardat využívá této informace k autodetekci skupin a přesouvání poboček mezi skupinami. Pokud předává ústředna kód skupiny, uchovává se její identifikace v databázi hovorů a při vytváření přehledu se hovor zařazuje do skupiny podle tohoto kódu. Tím se zajistí, že dva hovory uložené v databázi s různým kódem skupiny se zobrazují pod různými skupinami. U hovorů bez kódu skupiny se do databáze neukládá žádná identifikace skupiny a ta se určuje teprve při tvorbě přehledu.

Pobočky je možné rozdělit také do středisek. Ty představují nezávislou strukturu dělení poboček. Využívá se u velkých organizací, které potřebují rozdělit pobočky do skupin na několika úrovních. Dialog pro konfiguraci středisek se spouští z okna Konfigurace ústředen tlačítkem Střediska poboček.

Editace skupin a středisek

Editační dialogy pro skupiny a střediska poboček jsou podobné. Ovládací prvky pro nastavení skupiny jsou rozděleny do dvou záložek: Na první záložce se nastavuje jméno skupiny, které musí být vyplněno a musí být jedinečné, a procentuální příplatek na hovory.

Druhá stránka obsahuje dvě tabulky, které slouží k zařazení poboček do skupin. V levé tabulce jsou pobočky zařazené do editované skupiny. V pravé tabulce jsou pobočky zařazené do skupiny Ostatní pobočky a jsou roztříděny na jednotlivé ústředny. Každá ústředna má svoji záložku nad tabulkou a kliknutím na záložku se zobrazí jen pobočky příslušné ústředny. Šipkami lze přesouvat vybrané pobočky mezi tabulkami. Výjimkou je pouze skupina Ostatní pobočky, která má na této straně pouze jedinou tabulku se zařazenými pobočkami roztříděnými podle ústředen.


Konfigurace ústředen a související tabulky

Interní seznam

Interní seznam se používá ze dvou důvodů: buď uživatel potřebuje v přehledu zobrazit u hovorů s určitými telefonními čísli přesnější údaj o volaném účastníkovi než jaký poskytuje tarifní síť nebo potřebuje nastavit v přehledu filtr podle telefonních čísel.

Editor interního seznamu se spouští z hlavního menu programu, v nabídce Konfigurace položka Interního seznamu. Editační okno obsahuje tabulku definovaných čísel. Seznam lze exportovat do souboru. Dvojklikem na řádek tabulky se spustí dialog pro nastavení položky. Pořadí jednotlivých záznamů nerozhoduje, hledá se vždy nejdelší shoda, přednost má konkrétní číslice před výčtem v hranatých závokách, ten má přednost před znakem otazník.

Každý řádek tabulky obsahuje telefonní číslo nebo sadu čísel (kód), který může obsahovat číslice 0-9, znaky ABCD#*. Speciální význam má znak čárka, která odděluje čísla s významem "NEBO". Znak otazník (?) zastupuje libovolnou číslici. V hranatých závorkách může být uveden výčet několika čísel na místě jedné číslice. Speciální položka pojmenovaná Ostatní čísla má vždy pevně zadanou masku (?) a neměnitelné jméno. Tuto položku nelze smazat a zařazují se k ní všechny hovory, které na základě telefonního čísla nelze přiřadit k žádné jiné položce tabulky.

Příklady:

51^53^54   - čísla začínající 51, 53 nebo 54
60[345]    - čísla začínající 603, 604 nebo 605
60344433   - všechna čísla 603444330 až 603444339

Každá položka interního seznamu má kromě kódu ještě jméno (libovolný řetězec) a vlajku, která určuje zda se jméno položky vypisuje v přehledech nebo slouží pouze pro filtrování hovorů. V případě, že je tato vlajka zapnutá, pak se jméno položky zobrazuje v přehledu ve sloupci "detailní umístění", je-li vlajka vypnutá, zobrazuje se v tomto sloupci název cílového místa určený ze struktury tarifní nebo uživatelské sítě. Sloupec "interní seznam" vždy obsahuje jméno položky bez ohledu na nastavení vlajky.


Zpracování hovorů

Modul zpracování hovorů načítá vstupní data v textovém formátu, jejichž tvar je závislý na typu ústředny, rozdělí je na jednotlivé hovory, které převede do jednotného formátu, vyhledá k nim umístění, cenu a další údaje. Výsledné záznamy ukládá do centrální databáze hovorů. Program také generuje další výstupy a přechodné soubory, které slouží pro servisní účely, zálohování nebo jako rozhraní pro jiné programy.

Proces zpracování je v současné verzi dodáván jako samostatný program, který se buďto spouští na pozadí nebo pracuje jako služba systému. Výhoda nezávislosti zpracování na Tardatu je v tom, že aktualizace databáze hovorů může probíhat trvale. Jednoduché uživatelské rozhraní programu Zpracuj nezabírá v paměti tolik místa jako celý program Tardat.

V této kapitole je popsán proces zpracování vstupních dat. Text také vysvětluje princip autodetekce poboček, linek, zúčtovacích kódů a skupin. Další část je věnována popisu ovládání programu Zpracuj a služby Zpracujs pomocí grafického a síťového rozhraní. Do závěrečné kapitoly Další funkce jsou zařazeny pomocné funkce programu.

Obsah

  1. Postup při zpracování tarifních dat
  2. Autodetekce během zpracování
  3. Program Zpracuj a služba Zpracujs
  4. Grafické uživatelské rozhraní
  5. Síťové rozhraní
  6. Další funkce

Viz také:

  • Konfigurace ústředen a související tabulky


Zpracování - postup při zpracování tarifních dat

Zpracování hovorů

Postup při zpracování tarifních dat

Proces zpracování předpokládá, že data z ústředny se ukládají do vstupního souboru, který má pevně dané umístění (soubor pa20.td v adresáři pbx.a pro ústřednu A, soubor pb20.td v adresáři pbx.b pro ústřednu B atd.). Odtud se textové řádky ve tvaru, v jakém je posílá ústředna, načítají postupně od začátku souboru a teprve po úspěšném uložení do databáze se ze vstupního souboru vymažou. Vstupní soubor funguje jako vyrovnávací paměť mezi přenosovým modulem Tarwin a modulem Zpracuj a představuje také důležitý diagnostický bod.

Zpracování vstupního souboru

Program Zpracuj periodicky hlídá velikost vstupního souboru a je-li delší než 4 byty, zahájí se zpracování nových dat. Ze vstupního souboru se načte balíček dat o pevné délce a postupně se v něm vyhledávají textové řádky. Textový řádek pak vstupuje do funkce, která z něj podle formátu ústředny nastaveného v konfiguraci ústředny získává informace důležité pro tarifikaci a kontroluje, zda odpovídá požadovanému tvaru.

V případě, že by se ve vstupním souboru nashromáždilo velké množství dat, trvalo by jejich zpracování velmi dlouho, protože program by musel neustále kopírovat velké množství dat na disku. Proto se využívá několika odkládacích souborů pa20.001, pa20.002 a pa20.003.

Zpracování hovoru

V okamžiku, kdy jsou k dispozici všechny údaje o hovoru (většina ústředen generuje pro jeden hovor více řádků), vyberou se z nich užitečné informace a na základě konfiguračních tabulek (poboček, linek, svazků, vstupních bodů aj.) se určí vlastnosti hovoru. Podle tarifních sítí a tabulek se určí také umístění volaného a volajícího. Dále se vypočítají odečty, filtry a nakonec se počítá výsledná cena hovoru.

Uložení hovorů do databáze

Po zpracování celého vstupního balíčku se hovory ukládájí do databáze hovorů. Teprve až se úspěšně dokončí ukládání na server, provede se vymazání zpracovaných dat ze vstupního souboru. Tímto postupem se zajišťuje, že se žádná data neztratí.

Průběžný soubor (paprubez.txt)

Průběžný soubor obsahuje posledních 30kB vstupních dat, které již byly zpracovány, včetně těch, které byly označeny jako chybné. Soubor je umístěn v adresáři ústředny a je pojmenován paprubez.txt pro ústřednu A, pbprubez.txt pro ústřednu B atd. Velikost průběžného souboru je pevná.

Textový soubor (patext.txt)

Ukládání dat do textového souboru je standardně vypnuto, funkci lze zapnout v konfiguraci ústředny na záložce Vlastnosti. Do textového souboru se ukládá kopie vstupních dat, které byly zpracovány, včetně těch, které byly označeny jako chybné. Soubor je umístěn v adresáři ústředny a je pojmenován patext.txt pro ústřednu A, pbtext.txt pro ústřednu B atd. Na rozdíl od průběžného souboru se jeho obsah neumazává, proto, pokud je zapnuto jeho vytváření, je nutné jeho velikost občas zkontrolovat, vytvořit jeho zálohu a soubor smazat. Použití této funkce se doporučuje v situaci, kdy se klade zvláštní důraz na spolehlivost programu, nebo při testování. Protože soubor obsahuje přesnou kopii dat posílanou z ústředny, je možné z něj v případě havárie kdykoliv obnovit obsah databáze hovorů.

Soubor s chybnými daty (pachybne.txt)

Řádky, které neodpovídají formátu ústředny a proces zpracování je odmítne, se ukládají do chybového souboru. Soubor je umístěn v adresáři ústředny a je pojmenován pachybne.txt pro ústřednu A, pbchybne.txt pro ústřednu B atd. Za normálního běhu programu by neměl moc narůstat. Pokud do tohoto souboru jdou veškerá vstupní data, pak tvar řádků neodpovídá definici formátu v programu Tardat. Buďto je špatně zvolen formát v konfiguraci ústředny nebo jde o novou verzi firmware ústředny. Data, která byla uložena do chybového souboru, lze znovu zařadit do zpracování pomocí nástroje Zpětné zpracování souboru chybny.txt.


Zpracování - autodetekce během zpracování

Zpracování hovorů

Autodetekce během zpracování

Program Tardat umí automaticky přizpůsobit některé konfigurační tabulky podle informací předaných v textových řádcích z ústředny. Jedná se o:

  • Čísla zapojených linek
  • Čísla zapojených poboček
  • Zúčtovací kódy
  • Jména poboček
  • Jména zúčtovacích kódů
  • Kódy skupin
  • Zařazení poboček do skupin

Čísla poboček a linek

Z řádku se přečte číslo zdroje a cíle. Ve většině formátů lze rozlišit, zda jde o pobočku nebo linku. V takovém případě je možné automaticky doplnit do konfigurace novou linku nebo pobočku. Její vlastnosti se automaticky nastaví podle první pobočky/linky v tabulce.

Zúčtovací kódy

Některé ústředny umožňují zadat k hovoru zúčtovací kód (virtuální účet k zákazníkovi či zakázce). Tyto kódy se zadávají přímo do ústředny a Tardat umožňuje automaticky doplňovat nové kódy do svých konfiguračních tabulek. Vlastnosti nové položky se vždy nastaví podle druhého řádku tabulky, protože na prvním místě stojí vždy speciální zúčtovací kód (nezadán).

Jména poboček a zúčtovacích kódů

Některé ústředny poskytují také informace o jménech poboček a zúčtovacích kódů, tak jak jsou uložené v nastavení ústředny. Je-li nastaveno v Tardatu přebírání jmen, proces zpracování automaticky aktualizuje informace v tabulkách. Je-li nastaveno Přebírat vždy, mění se podle informací z ústředny i pobočky/kódy, které již v tabulce existují. Je-li nastaveno Přebírat při autodetekci, nastaví se jméno pobočky/kódu jen u nových poboček/kódů, které byly právě vytvořeny autodetekcí. Poslední možnost Nepřebírat funkci vypne. Tato volba je umístěna v konfiguraci ústředny v okně Pro odborníky.

Kódy skupin a zařazení poboček do skupin

Tyto funkce se týkají zejména ústředen Alcatel, které umožňují rozdělit pobočky již v nastavení ústředny do skupin, které se identifikují čtyřmístným alfanumerickým kódem. Na žádost servisních techniků byla implementována funkce automatického přebírání skupin do konfigurace Tardatu, přičemž jméno skupiny se nastaví podle předaného kódu. Obě funkce lze povolit nebo zakázat pro každou ústřednu zvlášť v nastavení Pro odborníky.

Protože pro každý hovor je předáno jak číslo pobočky, tak kód skupiny, do které patří, program Tardat může automaticky přeřazovat pobočky ve skupinách synchronně podle nastavení ústředny. V tomto případě se kód skupiny ukládá také do databáze hovorů a při tvorbě přehledu se respektuje, viz následující příklad: Jestliže byla dne 14.6. pobočka 1112 přeřazena ze skupiny A do skupiny B, pak v přehledu hovorů za červen rozdělených podle skupin budou hovory uskutečněné do 14.6. pod skupinou A a hovory uskutečněné po 14.6. budou zařazeny do bloku skupiny B.


Zpracování - program Zpracuj a služba Zpracujs

Zpracování hovorů

Program Zpracuj a služba Zpracujs

Modul pro zpracování hovorů je dodáván ve dvou variantách: program Zpracuj spouštěný na pozadí a služba systému Zpracujs.

Program Zpracuj

Program Zpracuj.exe pracuje jako běžná aplikace, spouští se obvykle při startu počítače ze složky "Po spuštění". Nastavení spouštění programu se provádí pomocí dialogu Konfigurace zpracování v menu Konfigurace programu Tardat. Instalaci modulu lze provést také ručně podle následujícího návodu:

Instalace zástupce do složky Po spuštění:

Otevřete si Tento počítač a vyhledejte složku Po spuštění. Obvykle bývá v adresíři C:\Windows\Nabídka Start\Programy\Po spuštění. Pravým tlačítkem myši otevřete nabídku funkcí a zvolte Nový -> Zástupce. Spustí se průvodce pro vytváření zástupců. Stiskněte tlačítko Procházet a v navigačním okně vyhledejte program Zpracuj.exe (obvykle C:\tardat4\Zpracuj.exe), jako název zástupce vložte text Zpracuj.

Odstranění zástupce ze složky po spuštění:

Otevřete nabídku Start a vyhledejte v podnabídce Programy složku Po spuštění. V ní označte položku Zpracuj a pravým tlačítkem myši vyvolejte nabídku funkcí. Zvolte položku Odstranit a podvrďte odstranění zástupce.

Zpracování jako služba systému

Službu systému Zpracujs.exe lze použít pouze na operačních systémech Windows NT, 2000 a XP. Tento modul nemá žádné uživatelské rozhraní, pro sledování stavu lze využít pouze síťové rozhraní.

Instalace služby systému:

Spusťte program Zpracujs.exe s parametrem /INSTALL. Otevřete správce služeb a označte položku Tardat-Zpracovani a stiskněte tlačítko Spustit.

Odstranění služby systému:

Pomocí správce služeb nejprve službu Tardat-Zpracovani vypněte. Pak spusťte program Zpracujs.exe s parametrem /UNINSTALL.


Zpracování - grafické uživatelské rozhraní

Zpracování hovorů

Grafické uživatelské rozhraní

Ikona programu

Spuštění program je indikováno červeným sluchátkem s kolečkem vpravo dole u hodin. Probíhá-li právě zpracování hovorů, je u sluchátka zobrazena malá zelená šipka. V případě, že došlo k chybě, obsahuje ikona malý červený vykřičník.

Kliknutím pravým tlačítkem myši na ikonu programu se otevře základní nabídka funkcí:

  • Otevřít - otevře ovládací panel programu
  • Ukončit Zpracuj - ukončí činnost programu

Grafické rozhraní programu Zpracuj

Program Zpracuj je vybaven jednoduchým uživatelským rozhraním, které umožňuje sledovat stav zpracování hovorů a obsahuje také jednoduchou statistiku. Základní okno programu obsahuje několik záložek. První se jmenuje Stav a vypisují se do něj hlášení o průběhu zpracování hovorů na ústřednách. Poslední záložka O programu obsahuje stručnou informaci o modulu.

Tlačítka v dolní části dialogového okna slouží k řízení běhu procesu:

  • Start - spuštění procesu zpracování od začátku (reset)
  • Pozastavit - zastavení procesu zpracování (program Zpracuj se tím neukončí).
  • Minimalizovat - zavře ovládací panel a minimalizuje program zpět do ikony
  • Ukončit - ukončí proces zpracování a zavře program Zpracuj


Zpracování - síťové rozhraní

Zpracování hovorů

Síťové rozhraní

Modul zpracování hovorů (program i služba) obsahuje také jednoduchý webový server, který umožňuje sledování a řízení procesu zpracování. Tato funkce může být výhodná pro správce programu Tardat, který chce mít přehled o programu na své pracovní stanici, ačkoliv modul zpracování běží na jiném počítači.

Nastavení funkce

Monitorovací rozhraní se konfiguruje v programu Tardatu, menu Konfigrace, volba Zpracování.

  1. Na záložce Nastavení zatrhněte volbu Aktivovat monitorovací rozhraní

  2. Nastavte číslo TCP portu. Doporučujeme ponechat přednastavené číslo portu 1113.

  3. Stiskněte tlačítko Uložit.

  4. Restartujte proces zpracování: V případě, že používáte modul Zpracuj, otevřete jeho ovládací panel a stiskněte tlačítko Start. Používáte-li službu Zpracujs, vypněte ji a zase zapněte buďto pomocí tlačítek na záložce Spouštění nebo pomocí Správce služeb.

  5. Spusťte prohlížeč www stránek a do pole pro URL zadejte IP adresu počítače, na kterém je zpracování spuštěno. Například:

    http://192.168.1.1:1113/

    Po odeslání dotazu by se měla objevit úvodní stránka s nabídkou funkcí. (u služby Zpracujs trvá několik sekund, než se server aktivuje).

Obsah stránek

Úvodní stránka obsahuje seznam všech dostupných podstránek. Stránka Stav zpracování odpovídá záložce Monitor na ovládacím panelu a vypisují se zde hlášení o průběhu zpracování hovorů a také chybová hlášení. Počet řádků je omezen a po zaplnění kapacity se nejstarší řádky umazávají. Obsah okna se automaticky po 10 sekundách obnovuje (tuto funkci musí podporovat Váš prohlížeč).

Stránka Statistika zpracování odpovídá záložce Statistika na ovládacím panelu. Jsou zde uvedeny informace o velikosti zpracovaných vstupních dat, počtu hovorů uložených do databáze a do dalších výstupů a procentuální zastoupení odchozích, příchozích, tranzitních a vnitřních hovorů. V textu jsou také uvedena chybová hlášení. Všechna počítadla se nulují při spuštění programu (čas spuštění je uveden na začátku textu).

Stránku Monitor hovorů lze využít pro kontrolu funkčnosti přenosu dat (programu Tarwin) a procesu zpracování (programu Zpracuj). Tabulka obsahuje několik posledních zpracovaných hovorů. Hovory jsou v tabulce řazeny tak, že nejnovější záznam je na začátku tabulky. Velikost tabulky je omezena, po spuštění programu je tabulka prázdná. Jednotlivé typy hovorů jsou rolišeny grafickými ikonami, které jsou shodné s ikonami používanými v okně Monitor hovorů v programu Tardat. Obsah této stránky se automaticky po 10 sekundách obnovuje (tuto funkci musí podporovat Váš prohlížeč).


Zpracování - další funkce

Zpracování hovorů

Další funkce

Hlídání úsředny

Zasílání upozornění je užitečnou funkcí pro velké ústředny, v případě, že zpracování je spuštěno nepřetržitě. Program zobrazí hlášení v případě, že na ústředně nebyly po nastavenou dobu zpracovány žádné nové hovory. Ve verzi 4 je také možné nastavit, že se pomocí elektronické pošty zašle jednoduchá zpráva na několik adres.

Postup:

  1. Spusťte program Tardat, vyberte z nabídky Konfigurace volbu Ústředen. Stiskněte tlačítko Editovat.

  2. Na záložce Vlastnosti stiskněte tlačítko Pro odborníky.

  3. Na stránce Zpracování v sekci Hlídání zapnout zatržítko Upozornit, když více než... a do editačního okna vepište počet hodin, například 24.

  4. Nastavení v okně Pro odborníky uložte tlačítkem OK, zavřete také okno nastavení ústředny s uložením změn a vraťte se do hlavní nabídky programu.

  5. V menu Konfigurace vyberte volbu Zpracování a přejděte na záložku Hlídání.

  6. Pokud chcete, aby se při vydání upozornění zobrazilo dialogové okno s textem, zatrhněte volbu Zobrazit hlášení...

  7. V případě, že chcete zaslat zprávu elektronickou poštou prostřednictvím SMTP serveru, zatrhněte volbu Odeslat e-mail..., do editačního pole vepište adresu, na kterou se má zpráva odeslat (můžete zapsat několik příjemců oddělených čárkou), do editačního pole Odesílatel vyplňte adresu, která bude uvedena jako odesílatel zprávy, a zadejte také ip adresu poštovního serveru. V případě, že Váš server vyžaduje autorizaci, zadejte také uživatelské jméno a heslo. Tlačítkem Test odešlete jednoduchou zprávu a můžete tak ověřit, že parametry jsou nastaveny správně.

  8. Nastavení uložte tlačítkem Uložit.

  9. Restartujte proces zpracování: V případě, že používáte modul Zpracuj, otevřete jeho ovládací panel a stiskněte tlačítko Start. Používáte-li službu Zpracujs, vypněte ji a zase zapněte buďto pomocí tlačítek na záložce Spouštění nebo pomocí Správce služeb.


Popis databázových tabulek

Program Tardat 4 ukládá svoji konfiguraci i data na databázový server. V této příloze je uveden detailní popis všech tabulek, které jsou používány aktuální verzí programu. Tabulky jsou pro přehlednost rozděleny do několika skupin podle funkčních bloků.

Obecná nastavení

Tabulky denik, hwklice, hwzdroje, monitor, obecne, hotel a hotelpob.

Konfigurace ústředen

Tabulky importform, importpob, importlin, intseznam, linky, odefil, pobocky, pristupkody, pruchodkody, pruchodsite, skupiny, strediska, svazky, ustredny, uzivkody, uzivsit, vstupnibody a zuctkody.

Tarifní sítě

Tabulky oblastisite, provozovatele, sazebniky, staty, tarpasma, tarprogramy, tarprovozy, tarsite a uzlysite.

Konfigurace uživatelů

Tabulky role a uzivatele.

Databáze hovorů

Tabulka hovory.

Přehledy

Tabulky export, nazvysloupcu, odberatele, prehledy, dalsipol, sloupce a styly.

Poznámky:


Tabulky - obecná nastavení

Tabulky programu Tardat 4

Obecná nastavení

Tabulka Popis

obecne

Informace o nainstalovaném programu (verze), parametry z dialogu "Další možnosti", údaje o dodavateli, nastavení faktury a účtenky.

denik

Tabulka obsahuje záznamy o důležitých akcích, které provedli uživatelé v programu Tardat.

hotel

Tabulka aktivních i uzavřených účtů v nástroji Minihotelový provoz.

hotelpob

Rozdělení poboček k účtům hotelového provozu.

hwklice

Kopie informací z hardwarového nebo softwarového klíče.

hwzdroje

Přiřazení zdrojů v klíči k ústřednám.

Poznámky:


Tabulky - konfigurace ústředen

Tabulky programu Tardat 4

Konfigurace ústředen

Tabulka Popis

ustredny

Definované ústředny, nastavení formátu, parametry z dialogu "Pro odborníky". Odečty a filtry jsou uloženy odděleně v tabulce odefil.

odefil

Nastavení časových odečtů a filtrů používaných při pseudotarifikaci, pro každou ústředny i údaje definované v konfiguraci svazku.

linky

Definované linky z ústředen.

svazky

Definované svazky linek z ústředen. Odečty a filtry definované v dialogu "Svazky" jsou uloženy odděleně v tabulce odefil.

pobocky

Definované pobočky v ústřednách.

zuctkody

Definované zúčtovací kódy v ústřednách.

uzivkody

Definované uživatelské kódy v ústřednách.

pristupkody

Definované přístupové (odchozí) kódy z ústředen.

vstupnibody

Tabulka vstupních bodů.

skupiny

Definované skupiny poboček.

strediska

Definovaná střediska poboček.

uzivsit

Položky uživatelského sazebníku (sítě).

pruchodsite

Definované průchodové sítě.

pruchodkody

Definované kódy průchodových sítí.

intseznam

Položky interního telefonního seznamu.

importform

Nastavení formátů pro import hovorů ze souboru CSV.

importpob

Překladová tabulka (volající -> pobočka) pro import hovorů ze souboru CSV.

importlin

Překladová tabulka pro linky pro import hovorů ze souboru CSV.

Poznámky:


Tabulky - tarifní sítě

Tabulky programu Tardat 4

Tarifní sítě

Tabulky uložené na databázovém serveru obsahují pouze základní informace z tarifní sítě, které jsou potřebné pro tvorbu přehledů a nastavení programu. Neumožňují provádět tarifikaci, a proto je zpracování povoleno pouze v instalaci "server", která obsahuje kompletní tarifní síť (v souboru s00.td nebo s01.td v podadresáři system). Při instalaci, aktualizaci programu nebo aktualizaci tarifní sítě se vždy obnoví obsah těchto tabulek.

Tabulka Popis

tarsite

Tabulka s informacemi o druhu, verzi a aktualizaci tarifní sítě.

uzlysite

Pojmenovací tabulka pro sloupce "Stát", "Umístění" a "Detailní umístění" v přehledech.

oblastisite

Tabulka se používá v dialogu pro editaci vstupního bodu. Obsahuje předdefinovaná vlastní telefonní čísla pro jednotlivé kraje a operátory.

staty

Tabulka se používá v dialogu pro editaci vstupního bodu. Obsahuje předdefinovaná mezinárodní předčíslí pro vlastní telefonní čísla.

provozovatele

Tabulka definovaných provozovatelů. Každý provozovatel má definované své tarifní programy, ze kterých si vybírá uživatel v dialogu pro editaci vstupního bodu.

tarprogramy

Definované tarifní programy provozovatelů. Tarifní program se dále dělí na sazebníky, z nichž se dále automaticky vybírá platný sazebník podle období, v němž byl hovor uskutečněn.

sazebniky

Definované sazebníky včetně jejich platnosti.

tarpasma

Pojmenovací tabulka tarifních pásem v sazebnících. Tarifní pásmo rozlišuje cenu hovorů podle směru, kam byl hovor veden

tarprovozy

Pojmenovací tabulka tarifních provozů v sazebnících. Tarifní provoz rozlišuje cenu hovorů podle doby, kdy byl hovor uskutečněn

Poznámky:


Tabulky - databáze hovorů

Tabulky programu Tardat 4

Databáze hovorů

Tabulka Popis

hovory

Tabulka hovorů zařazených do databáze programu.

Poznámky:


Přehledy hovorů

Výstupem programu Tardat je přehled hovorů (zkráceně přehled), což je tabulka údajů, sestavená podle požadavků uživatele. Může to být například výpis všech hovorů na konkrétní pobočce za minulý měsíc nebo tabulka celkových cen hovorů za jednotlivé pobočky. Připravenou tabulku lze zobrazit na obrazovce ve formě mřížky, tisknout na tiskárně, exportovat do souboru nebo odeslat prostřednictvím elektronické pošty. V okně přehledů je k dispozici mimo jiné řada funkcí a nástrojů pro změnu nastavení přehledu, práci s hovory v databázi a další.

V této kapitole jsou popsány parametry, které ovlivňují obsah a formát přehledu hovorů. Druhá část textu je věnována popisu uživatelského rozhraní pro nastavení přehledů v programu Tardat. V poslední části kapitoly jsou popsány nástroje související s tvorbou přehledů.

Funkce uložení přehledu zapisuje do databáze pouze nastavení přehledu, nikoliv konkrétní data. Uložený záznam je tedy pouze předloha, která určuje jaká data a jak se mají zobrazit. V případě, že je potřeba zapsat do souboru hotový přehled včetně dat, je nutné použít funkci Export přehledu. Každý uživatel má svou vlastní sadu přehledů, která je uložena na databázovém serveru. Výjimku tvoří tzv. veřejně dostupné přehledy, které může prohlížet kterýkoliv uživatel programu Tardat.

Obsah

  1. Nastavení přehledu
  2. Okno přehledů
  3. Nastavení požadovaných vlastností přehledu
  4. Nastavení vzhledu
  5. Nástroje v okně přehledů
  6. Tisk přehledu
  7. Tisk faktury
  8. Tisk účtenky
  9. Export přehledu

Viz také:


Přehledy hovorů

Nastavení přehledu

Nastavení přehledu je souhrn parametrů, které určují obsah a vzhled výsledného přehledu. Tyto parametry lze rozdělit do čtyřech kategorí: první část parametrů je nezávislá na výstupním zařízení, ovlivňuje proces vytváření přehledu ve fázi čtení hovorů z databáze do paměti a určuje, jaká data se zobrazují. Druhá skupina voleb se používá během fáze převodu načtených dat do formátu vhodného pro zobrazení na konkrétním výstupním zařízení (obrazovka, tiskárna, soubor, ...). Do třetí skupiny patří tzv. pravidla, která určují, jaké změny v nastavení přehledu jsou povoleny. Poslední skupinou jsou volby společné pro všechny přehledy.

Typ přehledu (detailní nebo souhrnný)

V zásadě se rozlišují dva typy přehledů: V detailním přehledu reprezentuje každý řádek právě jeden hovor, zatímco v souhrnném přehledu odpovídá jeden řádek několika hovorům, které mají společnou určitou vlastnost - tabulka pak obsahuje mimo jiné také součtové a průměrové sloupce.

Sdružování do řádků

U souhrnného přehledu uživatel zadává vlastnosti, podle kterých se mají hovory přiřadit do jednotlivých řádků výsledné tabulky. Je-li například zvoleno jako kritérium pro sdružování hovorů do řádků číslo pobočky, pak každý řádek bude reprezentovat hovory, které byly volány z nebo na jednu pobočku. Program umožňuje zadat maximálně dvě vlastnosti. Není-li zadána žádná, pak výsledná tabulka bude obsahovat jeden řádek za všechny hovory. U detailního přehledu nemá tato volba žádný význam.

U vnitřních a tranzitních hovorů se v případě sdružování podle poboček, linek, svazků nebo skupin může stát, že jeden hovor patří ke dvěma řádkům (vnitřní hovor je volání z pobočky na pobočky a tranzitní hovor je volání z linky na linku). V takovém případě se hovor započítá do obou řádků, podle zdroje i podle cíle.

Současná verze programu umožňuje, aby výsledná tabulka obsahovala i řádky, ke kterým není přiřazen žádný hovor. Lze tak například vytvořit souhrnný přehled volání pro jednotlivé pobočky, který obsahuje i pobočky, ze kterých se ve sledovaném období nevolalo.

Filtr hovorů

Filtr hovorů specifikuje, které hovory z hlavní databáze mají být do přehledu zahrnuty. Celý filtr se skládá z několika položek, přičemž každá položka odpovídá nějaké vlastnosti hovorů (cena, typ hovoru, pobočky, datum a čas apod.). Hovor bude v přehledu zobrazen tehdy, pokud jeho vlastnosti vyhovují všem zadaným položkám filtru. Například, je-li ve filtru hovorů nastavena položka Datum a čas na hodnotu od 1.4.2003 do 30.4.2003 a položka Cena na hodnotu placené, pak v přehledu budou zobrazeny pouze hovory uskutečněné v dubnu 2003 s cenou vetší než 0.

Třídění do bloků

Řádky přehledu mohou být rozděleny do několika podtabulek (tzv. bloků). Každá podtabulka pak obsahuje jen hovory, které mají společné určité vlastnosti. Uživatel může zadat až dvě kritéria pro rozdělování do bloků. Není-li zadána žádná vlastnost, výsledný přehled bude obsahovat pouze jednu tabulku se všemi hovory. Tuto funkci lze využít u detailního i souhrnného přehledu.

U vnitřních a tranzitních hovorů se v případě rozdělování podle poboček, linek, svazků nebo skupin může stát, že jeden hovor patří ke dvěma blokům (vnitřní hovor je volání z pobočky na pobočky a tranzitní hovor je volání z linky na linku). V takovém případě se hovor objeví v přehledu v obou podtabulkách podle zdroje i podle cíle.

Současná verze programu umožňuje, aby výsledná tabulka obsahovala i bloky, ke kterým není přiřazen žádný hovor.

Řazení

Neméně důležité je také pořadí řádků v přehledu, které je dané implicitními pravidly: je-li přehled rozdělen do několika bloků (podtabulek), jsou tyto implicitně řazeny podle vlastností, které rozdělují řádky přehledu do bloků. U souhrnného přehledu jsou řádky řazeny také podle vlastností pro sdružování hovorů do řádků. Detailní přehled je řazen také podle startovního data a času hovoru. Uživatel může vždy změnit směr řazení (vzestupně/sestupně).

Funkce speciální řazení umožňuje seřadit hovory v přehledu podle jiné vlastnosti, například délky nebo ceny hovoru. Lze zadat maximálně dvě vlastnosti pro řazení přehledu. Směr řazení je volitelný. Není-li zadán žádný pořadavek na speciální řazení, hovory se řadí podle implicitních pravidel uvedených v předchozím odstavci.

Omezení počtu řádků

Pomocí funkce Počet řádků může uživatel vytvářet přehledy typu NEJ... (například deset nejdražších, pět nejdelších hovorů apod.). Hovory je vždy nejprve nutné seřadit tak, aby na začátku přehledu (případně bloků) byly hovory mají být ve výsledné sestavě zobrazeny (tj. nejdražší, nejdelší, apod.). Parametrem funkce je číslo, které udává maximální počet řádků, který bude v přehledu (v každém bloku) zobrazen.

Příklad: Přehled má obsahovat 10 nejdražších hovorů na každé pobočce. Hovory se rozdělí do bloků podle poboček. Zadá se speciální řazení řazení podle ceny, směr sestupný. Aktivuje se funkce omezení počtu řádků na hodnotu 10.

Zobrazené údaje

Zatímco předchozí odstavce se zabývají výběrem a upořádáním řádků, musí mít uživatel také možnost výběru zobrazených údajů, tj. výčtu sloupců, které chce mít v přehledu pro každý řádek zobrazeny. Výběr vlastností, které lze v přehledu zobrazit, se liší u detailního a souhrnného přehledu; například u souhrnného přehledu nabízí program součtové a průměrové sloupce, zatímco startovní datum a čas zde nemá smysl.

Každý zobrazený údaj se ve výsledném přehledu přiřadí k jednomu sloupci. V nastavení přehledu je uložen seznam údajů viditelných v přehledu, jejich pořadí, vodorovné zarovnání a šířka sloupce výsledné tabulky.

Styly

Každý řádek ve výsledném přehledu má přiřazen právě jeden styl, který je nositelem informace o výšce řádku, použitém písmu a svislém zarovnání textu. Styly, které se používají mimo tabulku (například nadpis), určují také vodorovné zarovnání, narozdíl od tabulkových stylů, u kterých se vodorovné zarovnání určuje podle zobrazeného údaje.

Pravidla práce s přehledem

Množina voleb, která určuje jaké změny v nastavení přehledu může uživatel provádět a ke kterým funkcím v okně přehledu má přístup, se nazývají souhrnně pravidla. Používají se tehdy, když správce programu Tardat potřebuje nastavit každému uživateli sadu přehledů s tím, že uživatelé nebudou moci měnit některá nastavení přehledu, nejčastěji filtr hovorů podle poboček. Podmínky, za kterých uživatel smí měnit pravidla jsou uvedeny na začátku kapitoly 3.1.

U pravidel práce s filtrem se nastavuje režim filtru - zda je povoleno měnit všechny položky filtru, jen vybrané položky a to buď formou tabulky nebo formou průvodce. Poslední možností je úplný zákaz změny filtru.

Stejným způsobem se zadávají také pravidla práce s přehledem. Program nabízí tři režimy práce - povolení všech funkcí, povolení jen vybraných funkcí nebo zákaz všech citlivých funkcí.

Společná nastavení přehledu

Volby v této kategorii jsou společné pro všechny přehledy jednoho uživatele, jsou proto uloženy v uživatelském nastavení. Do této skupiny patří povolení zvukové signalizace při dokončení přehledu, zapnutí ručního spouštění tvorby přehledu a uživatelské pojmenování údajů.

Funkce Uživatelské názvy údajů umožňuje přizpůsobit texty v záhlaví tabulce požadavkům na výstup z programu. Všechny údaje (datum, čas, cena, ...) mají své standardní názvy přednastavené od výrobce programu, které se používají není-li pro daný údaj zadáno žádné uživatelské pojmenování. Uživatelské jméno se může být libovolný neprázdný řetězec.


Přehledy hovorů

Okno přehledů

Okno přehledů slouží k zobrazování přehledů hovorů. Obsahuje pracovní plochu, nabídku funkcí, dolní stavový řádek, levý tlačítkový panel a horní ovládací panel.

Okno se může vždy nachází v jednom ze čtyř režimů:

  • Základní režim - přehled je zobrazen v mřížce
  • Tisk přehledu - zobrazeno je rozvržení textů a tabulek na stránky
  • Tisk faktury - zobrazen je náhled na fakturu
  • Tisk účtenky - zobrazen je náhled na účtenku

Pracovní plocha v základním režimu

V základním režimu je na pracovní ploše zobrazen přehled hovorů v mřížce. Během závěrečné fáze přípravy přehledu se každému řádku přidělí jeden styl, který určuje, jaký text bude v řádku zobrazen a také jeho vlastnosti - výšku, zarovnání a písmo. Každému slouci mřížky se přidělí jeden údaj, který určuje text zobrazený v buňkách uvnitř tabulek a také šířku sloupce a vodorovné zarovnání textu.

První řádek mřížky má šedý podklad a obsahuje názvy sloupců. Pomocí tohoto řádku lze myší tažením oddělovače mezi buňkami nastavit šířku sloupce, tažením buňky změnit pořadí sloupců nebo dvojklikem změnit nastavit způsob řazení hovorů v přehledu. První levý sloupec má také šedý podklad a slouží k nastavení výšky řádku (tažením oddělovače mezi řádky).

Uvnitř tabulky je zobrazen kurzor, (buňka s modrým podkladem), který lze přesunout myší kliknutím na jinou buňku v tabulce nebo šipkami na klávesnici případně dalšími klávesami, viz následující tabulka 3.1. K pohybu v přehledu lze využít také funkce z nabídky Jdi na.... Pro lepší orientaci v tabulce lze zapnout funkci Zvýrazňování kurzoru - program zvýrazní žlutým podkladem všechny buňky v řádku a ve sloupci, ve kterém se právě nachází kurzor.

Dvojklikem myší v mřížce se spouští funkce Informace o hovoru (viz dále), stiskem pravého tlačítka myši se otevře nabídka nejpoužívanějších funkcí.

Klávesa | význam
šipky | přesun kurzoru o 1 buňku vpravo, vlevo, nahoru resp. dolů
PageUp | přesun o 1 stránku nahoru
PageDown | přesun o 1 stránku dolů
Home | přesun kurzoru do prvního sloupce
End | přesun kurzoru do posledního sloupce
Ctrl+Home | přesun na první sloupec prvního řádku
Ctrl+End | přesun na poslední sloupec posledního řádku
Ctrl+PageUp | přesun na první řádek v zobrazené části přehledu
Ctrl+PageDown | přesun na poslední řádek v zobrazené části přehledu

Tabulka 3.1: Klávesy pro pohyb kurzoru v přehledu. Stránkou se zde myslí část přehledu, která se právě vejde na pracovní plochu

Pracovní plocha v režimu náhledu

Jestliže uživatel aktivuje funkci pro tisk přehledu, faktury nebo účtenky přepne se okno přehledu do režimu náhledu. Na pracovní ploše se místo mřížky zobrazuje jedna stránka s texty a tabulkami v takové podobě, v jaké budou odeslány do systémového tiskového ovladače.

Mezi stránkami se lze pohybovat myší pomocí tlačítek na horním ovládacím panelu nebo klávesami, jejichž přehled je uveden v tabulce 3.2. V editačním políčku se zobrazuje číslo zobrazené strany a celkový počet stran. Pro rychlý přesun na konkrétní stranu se vepíše číslo požadované stránky do editačního pole a stiskne se klávesa Enter.

Tlačítko | Klávesa | význam
 | PageUp | přesun o 1 stranu směrem k začátku
 | PageDown | přesun o 1 stranu směrem ke konci
 | Home | přesun na první stranu
 | End | přesun na poslední stranu

Tabulka 3.2: Klávesy pro pohyb mezi stránkami v náhledu

Levý tlačítkový panel

Panel u levého okraje okna přehledu obsahuje sadu tlačítek pro rychlé spouštění nejčastěji používaných funkcí. Přehled a význam tlačítek je uveden v tabulce 3.3. Tento panel je vypínatelný (položka Levý tlačítkový panel v nabídce Vzhled).

Tlačítko | význam
 | obnovení přehledu, přerušení přípravy přehledu, zahájení výpočtu přehledu (při ručním obnovování)
 | otevření přehledu
 | uložení přehledu
 | export přehledu
 | Přepne okno z náhledu zpět do základního režimu
 | Tisk přehledu
 | Funkce "Faktura"
 | Funkce "Účtenka"
 | Spustí průvodce nastavením přehledu
 | Otevře dialog pro nastavení pravidel práce
 | Zapíná a vypíná zvýrazňování kurzoru
 | Přepočítá šířky všech sloupců

Tabulka 3.3: Význam tlačítek na levém panelu

Horní ovládací panel

Panel u horního okraje okna přehledu slouží k rychlému nastavení přehledu. V základním režimu obsahuje tlačítka a ovládací prvky pro změnu nejčastěji používaných vlastností (filtr, třídění do bloků, řazení, apod.). Šipky za výběrovými poli indikují směr řazení hovorů, kliknutím na ikonu se obrátí směr řazení. Dvojklikem na logo programu Tardat se zobrazí dialog s informacemi o verzi programu.

Funkce panelu v ostatních režimech je vysvětlena v kapitolách 2.4.7, 2.4.8 a 2.4.9. Také ovládací panel lze skrýt (položka Horní ovládací panel v nabídce Vzhled).

Klávesové zkratky

Všechny častěji používané funkce mají své klávesové zkratky. Jejich přehled je uveden v tabulce 3.4.

Klávesa | význam
Ctrl+O | otevření přehledu
Ctrl+S | uložení přehledu
Ctrl+Alt+S | uložení přehledu pod jiným názvem
Ctrl+E | exportování přehledu
Ctrl+D | vymazání přehledu
Ctrl+P | tisk přehledu
Ctrl+K | funkce Faktura
Ctrl+U | funkce Účtenka
Ctrl+Z | nastavení zobrazených údajů
Ctrl+A | průvodce nastavením
Ctrl+W | nastavení vzhledu vybraného řádku
Ctrl+X | přepočítání šířky sloupců
Ctrl+R | obnovení přehledu
Ctrl+I | zobrazení informací o hovoru
Ctrl+Q | funkce Přepočet podle účtu
Ctrl+Q | vyhledání textu v přehledu
Ctrl+T | zahájení tisku (v režimu náhledu)

Tabulka 3.4: Klávesové zkratky


Přehledy hovorů

Nastavení požadovaných vlastností přehledu

Změnu vlastností otevřeného přehledu lze provést několika způsoby. Nejčastěji používané funkce jsou přístupné na horním panelu v okně přehledu. Ostatní volby se spouští položkami v nabídce Vlastnosti, které otevírají dialog pro nastavení přehledu. Volby v dialogu jsou přehledně rozděleny do několika záložek.

Přehled

Na této záložce se nastavují základní vlastnosti přehledu.

  • Druh přehledu:

    • Detailní přehled - v přehledu budou zobrazeny všechny hovory jednotlivě. Jeden hovor odpovídá vždy jednomu řádku.
    • Souhrnný přehled - zobrazuje v jednom řádku sumu hovorů v závislosti na nastaveném sdružování do řádků.

    Příklad:
    1. Detailní přehled - výpis všech hovorů na konkrétní pobočce za minulý měsíc
    2. Souhrnný přehled - přehled celkové délky a ceny hovorů za každou pobočku.

  • Sdružování do řádků - tato funkce je přístupná pouze pro souhrnné přehledy. Lze zadat až dvě vlastnosti, na základě kterých se hovory v přehledu sdružují do jednotlivých řádků. Zvolit můžete také vzestupné nebo sestupné řazení řádků.

    Příklad:
    Zvolíte-li např. "přehled po: Pobočky", výsledný přehled bude obsahovat řádek se sumou hovorů jdoucími např. přes pobočku Aleš, další řádek bude obsahovat hovory přes pobočku Dan, třetí řádek hovory přes pobočku Bohuslav atd.

Třídění a řazení

Na této záložce se nastavuje třídění hovorů do bloků a speciální řazení hovorů

  • Třídění do bloků (dílčích tabulek) - lze zadat maximálně dvě vlastnosti, na základě kterých se hovory v přehledu rozdělí do několika tabulek. Můžete také zvolit směr řazení tabulek.

    Příklad:
    Zvolíte-li např. "podle: Pobočky", rozdělí se přehled do několika tabulek, přičemž každá tabulka bude mít svoji vlastní hlavičku s názvem pobočky a bude obsahovat hovory příslušející k této pobočce.

  • Počet řádků - zatržítkem se tato funkce aktivuje a do editačního pole se zadá maximální počet řádků v tabulce.

    Příklad:
    10 nejdražších hovorů pro každou pobočku.
    Postup:

    1. V sekci Rozdělení do bloků zadejte třídění podle Pobočky a podle bez třídění;
    2. v sekci Počet řádků přidejte zatržítko a počet řádků vložte 10;
    3. v sekci Jiné řazení zvolte kriterium Cena případně Cena přepočtená, směr řazení nastavte na Sestupně (tj. nejdražší hovor bude na prvním místě);
    4. klikněte na záložku Přehled v horní části okna a na této kartě zvolte typ přehledu Detailní;
    5. na kartě Zobrazené údaje můžete nastavit sloupce, které mají být v přehledu zobrazeny;
    6. nastavení potvrďte tlačítkem OK.

  • Jiné řazení - v případě, že je potřeba změnit pořadí hovorů v tabulce, použije se tato funkce. Lze zadat až dvě úrovně řazení, změnit lze také směr řazení.

    Příklad:
    Vyberete-li z prvního políčka položku Skupiny a z druhého Pobočky, budou hovory seřazeny podle jména skupiny a ty hovory, které patří do stejné skupiny, pak budou následně seřazeny podle jména pobočky.

Filtr

Na této záložce je zobrazeno nastavení filtru v přehledné tabulce. Řádky tabulky odpovídají jednotlivým položkám filtru, mezi všemi položkami platí vždy logický součin (hovor musí splňovat všechny podmínky, aby byl v přehledu zobrazen). V pravém sloupci je uvedena vlastnost hovoru, které se položka filtru týká a v pravém sloupci je zobrazeno aktuální nastavení filtru. Je-li v pravém sloupci prázdé políčko, položka filtru není nastavena, tzn. podle této vlastnosti se nebude filtrovat. Políčka s šedým podkladem jsou nepřístupná (zakázaná v pravidlech práce s filtrem). Přejíždíte-li myší přes jednotlivé názvy, zobrazuje se k nim ve stavovém řádku okna Filtr krátký popis.

Editační dialog pro nastavení položky filtru spustíte dvojklikem myši na odpovídajícím řádku tabulky, klávesou Enter nebo tlačítkem Editovat. Obsah dialogu závisí na zvolené položce filtru, nahoře vlevo je vždy "hlavní" zatržítko, které aktivuje položku filtru. Otevřením dialogu se položka filtru vždy automaticky nastaví na aktivní.

Chcete-li některou z položek filtru zrušit, klikněte myší na odpovídající řádek v tabulce a stiskněte tlačítko Zrušit filtr nebo klávesu Delete. Můžete také zrušit všechny zadané filtry stiskem tlačítka Zrušit filtry.

  • Datum a čas

    Zadává se buď absolutně nebo relativně, vztaženo k okamžiku vytvoření přehledu. Nezadá-li se čas, doplňuje se automaticky 0:00 u "od" a 24:00 u "do". Datum je možné zadat přímo z klávesnice nebo si jej vybrat z kalendáře. Hranice se uvádějí vždy včetně. U relativního data se volí interval (rok, měsíc, týden, den, hodina, minuta) a čísla určující násobky intervalu pro horní a dolní mez. U jednotky měsíc lze navíc nastavit první den v měsíci (např. pro potřeby fakturace, kdy není fakturační období od prvního dne měsíce do posledního).

    Příklady:
    Absolutní datum a čas:

    • celý leden - od 1.1.2002 do 31.1.2002
    • prvního února - od 1.2.2002 do 1.2.2002
    Relativní datum a čas:
    • tento měsíc - měsíc, od 0 do 0
    • včera - den, od -1 do -1
    • tento a minulý týden - týden, od -1 do 0
    • minulý měsíc (fakt. obd. od 15. dne) - měsíc, od -1 do -1, první den: 15

Zobrazené údaje

Tato záložka slouží pro výběr sloupců, které mají být v přehledu zobrazeny (například den, čas, telefonní číslo, cena, ...). Tabulka obsahuje seznam všech dostupných údajů, které mohou být v daném typu přehledu zobrazeny, jiné sloupce se nabízí pro detailní a pro souhrnné přehledy. Sloupce, které budou v přehledu zobrazeny, mají políčko zaškrtnuté; stav zatržítka lze měnit kliknutím myši nebo Mezerníkem. Tlačítkem Standardní výběr se nastaví nejběžnější výběr položek podle přednastavených hodnot v programu, tlačítkem Zrušit výběr se zruší všechna zatržítka v tabulce.

Vybranou položku je navíc možno přejmenovat (zadat nebo změnit uživatelský název sloupce) - editační dialog pro zadání nového jména se vyvolá dvojklikem na příslušné položce nebo klávesou Enter. Tento nový název pak bude zobrazen v záhlaví tabulek v přehledu.

Texty, mřížka

Volby na této záložce ovlivňují vzhled přehledu. Tlačítko Standardní nastaví všechny volby na výchozí hodnoty přednastavené od výrobce programu.

  • Každý blok do samostatného sloupce - pokud máte přehled tříděn po blocích, tisknete do několika tiskových sloupců a chcete, aby každý z nich byl vytištěn v samostatném sloupci, zatrhněte tuto volbu.

  • Každý blok na samostatnou stránku - pokud máte přehled tříděn po blocích a chcete, aby každý z nich byl vytištěn na samostatné stránce, zatrhněte tuto volbu. Vhodné třeba pro případ, kdy chcete každému pracovníkovi předložit jeho výpis hovorů.

  • Každý blok na samostatnou dvojstránku - je-li tato volba zatržena, bude každý blok (tj. podtabulka) začínat na samostatné liché stránce. To znamená, že při oboustranném tisku na tiskárně vybavené duplexorem bude každý blok na samostatném listě papíru.

  • Zobrazit úvodní řádek - zapíná zobrazovnání úvodního řádku v přehledu ("Přehled vytvořil program Tardat...")

  • Zobrazit způsob řazení - zapíná zobrazování řádku s informací o způsobu řazení hovorů (např. "Seřazeno podle začátku hovoru").

  • Zobrazit výběrové podmínky - zapíná zobrazování řádku s popisem použitého filtru (např. "Datum od 1.8.2003 do 31.8.2003"). Popis filtru může být stručný (např. "pobočky 3/15" - vybrané jsou 3 pobočky z 15) nebo plný (např. "pobočky 13, 14, 15" - uvádí se výčet vybraných poboček).

  • Zobrazit závěrečný řádek - zapíná zobrazování závěrečného řádku v přehledu ("Počet hovorů: ...").

  • V nadpisu přehledu - nastavení textu v nadpisu přehledu:

    • Zobrazit druh přehledu - automaticky generovaný text podle druhu přehledu a rozdělení do bloku (standardně).
    • Zobrazit název přehledu - jméno, pod kterým byl přehled uložen (v hlavním menu Přehledy).
    • Zobrazit jiný text - je-li vybrána tato volba, objeví se editační pole, do kterého je možné vložit libovolný text.

  • Plná mřížka v tabulce - Při zaškrtnutí bude mít každá z buněk přehledu okraj ze všech stran.

  • Barva mřížky - Tlačítkem Změnit barvu se vyvolá dialog pro výběr barvy.

Pravidla

Pravidla práce s filtrem určují, které položky filtru je povoleno měnit, zatímco pravidla práce s přehledem definují oprávnění ke změně nastavení přehledu. Přístup k důležitým funkcím v přehledu se nastavuje v oprávnění v konfiguraci uživalele. Tlačítkem Standardní nastavíte pravidla na "plný přístup".

  • Možnosti úprav filtru - nastavuje režim práce s filtrem:

    • Celý - uživatel může měnit všechny položky filtru
    • Jen vybrané části - uživatel může měnit nastavení jen těch položek filtru, které jsou vybrány v sekci Vybrané části filtru
    • Jen vybrané části formou průvodce - totéž co předchozí bod, ale stiskem tlačítka Filtr v okně přehledu se zobrazí přímo dialogové okno pro nastavení první položky filtru
    • Žádné - filtr nelze změnit

  • Vybrané části filtru - v této sekci se zatrhnou části filtru, které mají být přístupné. Ve většině případů odpovídá jedno zatržítko několika podobným položkám filtru.

  • Možnosti úprav přehledu - nastavuje režim práce s přehledem (filtr se konfiguruje zvlášť):

    • Vše - uživatel má povolené všechny funkce v nastavení přehledu
    • Jen vybrané části - uživatel má povolené jen funkce, které jsou zatržené v sekci Vybrané části přehledu.
    • Žádné - uživatel nemůže měnit nastavení přehledu.

  • Vybrané části přehledu - v této sekci se zatrhnou části nastavení přehledu, které mají být přístupné.

Další možnosti

Na této záložce se nastavují další málo používané volby. Tlačítkem Standardní je nastavíte na hodnoty přednastavené v programu od výrobce.

  • Zobrazovat cenu příchozích hovorů - standardně se zobrazují ceny pouze u hovorů odchozích a tranzitních hovorů, protože příchozí hovory obvykle neplatíte. Chcete-li však přesto sledovat cenu i u nich, zaškrtnete toto políčko.

  • Zobrazit filtr před otevřením přehledu - při otevření tohoto přehledu z nabídky Přehledy v hlavní nabídce programu Tardat se automaticky nabídne dialog pro zadání filtru ve formě tabulky nebo průvodce (podle nastavení pravidel práce s filtrem).

  • Nabídnout tisk po otevření přehledu - při otevření přehledu se okno automaticky přepne do režimu náhledu a nabídne se dialog pro tisk přehledu.

  • Zobrazit i pobočky/linky/svazky/skupiny/čísla ze kterých se nevolalo - je-li tato volba zapnuta, pak se v přehledu zobrazují i řádky a bloky za pobočky, linky, svazky, skupiny poboček nebo položky interního seznamu, pro které nejsou v databázi hovoru žádné záznamy. Pomocí této funkce lze vytvořit např. souhrnný přehled po linkách, ve kterém jsou zobrazeny všechny linky z konfigurace ústředen i když přes ně nebyly uskutečněny žádné hovory. Nebo lze vytisknout detailní přehled rozdělený do bloků po pobočkách, ve kterém mají svoji tabulku (prázdnou) i ty pobočky, ze kterých se nevolalo.

    Pozor!
    Je-li tato funkce zapnuta, pak některé kombinace parametrů přehledu nemusejí dávat očekávaný výsledek.

Společná nastavení přehledů

Volby v tomto okně jsou uloženy v uživatelském profilu a proto jsou společné pro všechny přehledy.

  • Přehled vytvořit až na povel Start - při zaškrtnutí volby přehled není automaticky aktualizován při každé změně, ale až kliknutí na ikonu Obnovení přehledu. Tato funkce může zrychlí práci s přehledy na pomalejších počítačích, protože program neobnovuje přehled po každé změně nastavení, ale tabulka se přepočítá teprve po nastavení všech parametrů přehledu.

  • Zvukové oznámení dokončení přehledu - po dokončení aktualizace přehledu se ozve pípnutí.

  • Zobrazovat uživatelské názvy sloupců - přepíná zobrazování uživatelských a standardních názvu sloupců.

  • Změnit uživatelské názvy - otevírá dialogové okno, ve kterém se definují uživatelské názvy (viz následující odstavec).

Uživatelské názvy sloupců

Toto samostatné dialogové okno je určeno pro zadavání uživatelského pojmenování sloupců v přehledech. Tabulka obsahuje tři sloupce: v prvním sloupci je zobrazen standardní název (pevný přednastavený od výrobce). Ve druhém je uveden typ přehledu a pro který řádek platí (Pozor: sloupec Cena v detailním přehledu a v souhrnném přehledu jsou v programu dva různé údaje!). Třetí sloupec je vyhrazen pro uživatelské názvy. Je-li v něm prázdný řetězec, pak se v přehledu zobrazuje vždy standardní název.

Změna uživatelského názvu se provede kliknutím myši na příslušné políčko a na klávesnici se napíše nový název sloupce. Text lze vymazat klávesou Delete. Tlačítko Standardní pod tabulkou vymaže všechny zadané uživatelské názvy.


Přehledy hovorů

Nastavení vzhledu

Písmo a způsob zarovnání textů v přehledu se nastavuje samostatným dialogovým oknem, které se spouští volbou Vzhled vybraného řádku z nabídky Vzhled, případně z kontextové nabídky, která se otevírá pravým tlačítkem myši nebo klávesovou zkratkou Ctrl+W. Kurzor je nutné nejprve umístit na řádek, jehož vlastnosti mají být nastaveny.

Dialogové okno pro nastavení vzhledu vybraného řádku je rozděleno do tří částí. V horní sekci je zobrazena ukázka písma, tlačítkem Změnit písmo se spustí standardní dialog pro nastavení vlastností písma. Dolní dvě sekce slouží pro nastavení zarovnání textu.

Změníte-li vlastnosti písma, svislé zarovnání nebo výšku řádku, platí toto nastavení pro všechny řádky patřící ke stejnému stylu jako řádek, na kterém při spuštění dialogu stál kurzor. Například označíte-li řádek s nadpisem a v dialogu změníte jeho písmo, změní se automaticky písmo u všech nadpisů v přehledu. U vodorovného zarovnání je situace složitější, protože u textů v tabulce je toto zarovnání dáno nastavením zobrazeného údaje, nikoliv nastavením stylu. Změna vodorovného zarovnání uvnitř tabulky se projeví ve všech řádcích tabulky včetně hlavičky a patičky. U textů mimo tabulku je vodorovné zarovnání dáno nastavením stylu, a provedené změny platí proto pro všechny řádky jednoho stylu.

V nabídce Vzhled program nabízí další funkce:

  • Přepočítat šířku sloupců - v šířka každého sloupce se upraví podle nejdelšího textu.

  • Přepočítat výšku řádků - nastaví optimální výšku řádků, podle použitého písma.

  • Standardní vzhled všech řádků - automaticky upraví nastavení vzhledu tabulky podle konstant nastavených v programu od výrobce.

Další funkce v nabídce Vzhled mění vzhled okna s přehledem:

  • Zvýrazněný kurzor - zapíná a vypíná zvýrazňování řádku a sloupce, ve kterém stojí kurzor.

  • Horní ovládací panel - zapíná a vypíná panel s ovládacími prvky u horního okraje okna.

  • Levý tlačítkový panel - zapíná a vypíná panel s tlačítky při levém okraji okna.


Přehledy hovorů

Nástroje v okně přehledů

Otevření přehledu

Tato funkce umožňuje načíst uložený přehled aniž by bylo nutné zavírat okno přehledu. Lze také načíst přehled ze složky podřízených uživatelů. Tabulka obsahuje seznam přehledů ve složce vybraného uživatele pod čarou jsou uvedeny veřejně dostupné přehledy. Přepnutí do složky jiného uživatele se provádí pomocí výběrového pole Uživatel.

Uložení přehledu

Funkce Uložit přepíše aktuální nastavení otevřeného přehledu (do stejné složky a pod stejným názvem), pro tuto funkci musí mít uživatel oprávnění Ukládání vlastních přehledů. K uložení přehledu do jiné složky nebo pod jiným názvem je určena funkce Uložit jako - otevře se dialogové okno s polem pro výběr uživatele a editačním polem pro zadání nového jména přehledu. Přehled můžete také uložit do zvláštní složky tzv. veřejně dostupných přehledů. Takové přehledy mohou otevírat všichni uživatelé. Pozor -- přepsaný není možné obnovit zpět.

V případě, že uložíte přehled do složky jiného uživatele, ten nebude moci změnit nastavení Pravidel.

Smazání přehledu

Pro tuto funkci musí mít uživatel nastaveno oprávnění Ukládání vlastních přehledů. Dialog Smazání přehledu umožňuje smazání dříve uloženého uživatelského přehledu. V tabulce jsou přehledy příslušející do aktuální složky, pod čarou jsou uvedeny veřejně dostupné přehledy. Pozor -- Vymazané přehledy není možné obnovit!

Přehled určený ke smazání se označí a stiskne se tlačítko Smazat. Dialog se zavře až stiskem tlačítka Storno. Přepnutí do složky jiného uživatele se provádí pomocí výběrového pole Uživatel.

Průvodce nastavením programu

Cílem této části programu je nabídnout uživateli co nejjednodušší nástroj pro nastavení vlastností přehledu; byla vybrána pouze omezená množina nejčastěji používaných voleb, které lze pomocí tohoto nástroje nastavit. Uživatelské rozhraní je řešeno formou několika dialogů. U každé otázky je nabídnuto několik odpovědí nebo je uživatel požádán o zatrhnutí ze seznamu položek apod. Na každé straně je v levé části okna stručná nápověda.

Funkce se spouští z tlačítkového panelu nebo položkou Průvodce nastavením v nabídce Vlastnosti. V současné době je možné pomocí průvodce nastavit tyto parametry:

  • Typ přehledu
  • U souhrnného přehledu kritérium sdružování do řádků
  • Dělení do bloků
  • Celá databáze nebo výběr podle filtru
  • Filtr "datum a čas" relativně nebo absolutně
  • Filtr "pobočky" nebo "skupiny poboček"
  • Filtr "linky" nebo "svazky"
  • Filtr "zúčtovací kódy"
  • Filtr "interní seznam"
  • Zobrazené údaje

Informace o hovoru

Tento nástroj umožňuje zobrazit v textové podobě kompletní údaje o vybraném hovoru (u detailního přehledu) nebo o skupině hovorů (u souhrnného přehledu). Informace jsou v okně rozděleny do několika odstavců.

Postup:

  1. V okně přehledu v základním režimu nastavte kurzor na řádek, o kterém chcete získat detailní informace,
  2. Dvojklikem nebo z nabídky Funkce otevřete nástroj Informace o hovoru.
  3. Obsah okna můžete zkopírovat do schránky (clipboardu) pro přenesení do jiného programu stiskem tlačítka Zkopírovat nebo klávesou Ctrl+C.
  4. Dialogové okno zavřete tlačítkem Zavřít.

Vložení hovoru

Tento nástroj umožňuje vložit nový hovor do databáze. Spouští se položkou Vložit hovor z nabídky Funkce. V dialogovém okně uživatel zadá parametry hovoru, které jsou přehledně rozděleny do několika stránek, které se přepínají tlačítky Pokračovat a Zpět. Na poslední stránce program zobrazí okno s detailními informacemi o vkládaném hovoru včetně umístění a ceny. Po potvrzení tlačítkem Uložit se nový hovor vloží do databáze.

POZOR!

  • Doporučujeme, aby byl tento nástroj přístupný jen správci programu Tardat.
  • Vložený hovor se v tabulce objeví teprve po jeho obnovení přehledu.

Editace hovoru

Tento nástroj umožňuje změnit parametry vybraného hovoru. Spouští se položkou Editovat hovor z nabídky Funkce. V dialogovém okně uživatel změní parametry hovoru, které jsou přehledně rozděleny do několika stránek, které se přepínají tlačítky Pokračovat a Zpět. Na poslední stránce program zobrazí okno s detailními informacemi o hovoru. Uživatel může tlačítkem Uložit potvrdit změny a zapsat hovor do databáze nebo tlačítkem Storno ukončit editační dialog bez uložení změn.

POZOR!

  • Doporučujeme, aby byl tento nástroj přístupný jen správci programu Tardat.
  • Program neumožňuje u editace hovorů funkci "O krok zpět" - tj. vrátit se k původním parametrům.
  • Po zavření dialogu se změní hodnoty v tabulce přehledu na řádku, na kterém se nachází editovaný hovor, ale celkové ceny, délky apod. se přepočítají teprve po obnovení celého přehledu.

Vymazání hovoru

Pomocí funkce Vymazání hovoru můžete vymazat vybraný hovor z databáze. Tento nástroj se spouští z nabídky Funkce, v dialogovém okně se zobrazí informace o vybraném hovoru, stiskem tlačítka Vymazat se hovor v databázi označí jako vymazaný (skutečné zrušení hovoru se provádí při manipulacích z databází - přepracování, archivace, výmaz duplicit). Dokud se neprovede obnovení přehledu, u vymazaného hovoru se vypisuje ve všech řádcích tabulky text "vymazán".

POZOR!

  • Doporučujeme, aby byl tento nástroj přístupný jen správci programu Tardat.
  • Vymazané hovory nelze obnovit zpět
  • Po vymazání hovoru se na řádku, na kterém se nacházel smazaný hovor objeví ve všech sloupcích text "vymazán". Tento řádek zmizí a celkové ceny, délky apod. se přepočítají teprve po obnovení celého přehledu.

Postup:

  1. V okně přehledu v základním režimu vytvořte detailní přehled
  2. Nastavte kurzor na hovor, který chcete vymazat.
  3. Z nabídky Funkce vyberte položku Vymazat hovor.
  4. V dialogovém okně zkontrolujte, že zobrazené údaje odpovídají hovoru, který chcete vymazat (v případě že neodpovídají, proveďte obnovení přehledu a postup opakujte).
  5. Akci potvrďte tlačítkem Vymazat.
  6. Potřebujete-li vymazat více hovorů, opakujte body 2-5.
  7. Obnovte přehled (Ctrl+R).

Přepočet podle účtu

Při tarifikaci mohou vzniknout nepřesnosti při výpočtu cen hovorů. Tato funkce umožňuje upravit ceny hovorů tak, aby celková provolaná částka, kterou ukazuje program Tardat byla shodná s částkou, kterou za stejné období naúčtoval provozovatel.

Každý hovor má v databázi uloženy dvě ceny (přepočítaná a nepřepočítaná). Po zpracování nebo přepracování hovoru jsou obě ceny shodné, provedením přepočtu se vždy změní pouze cena přepočtená, jako výchozí částka při výpočtu se používá vždy cena nepřepočítaná. V přehledu se ve sloupcích Cena, Cena bez DPH, atd. zobrazuje vždy přepočítaná cena, původní nepřepočítaná částka se zobrazuje ve speciálním sloupci Cena nepřepočítaná. Protože obě ceny jsou součástí parametrů hovoru, ukládají se přepočtené ceny také do archívu. Zrušení přepočtu (tj. nastavení cen hovorů na nepřepočítané ceny) se provede přepočítaním s koeficientem 1,0.

Do přepočtu se zahrnují vždy pouze hovory, které jsou zobrazeny v aktuálním přehledu. Proto je nutné nejprve správně nastavit filtr hovorů tak, aby přehled obsahoval jen hovory v příslušném účetním období na odpovídající lince atd.

Protože se ceny hovorů zaokrouhlují vždy na haléře, po navýšení nebo snížení cen hovorů a zaokrouhlení, nemusí výsledná částka přesně souhlasit se zadanou požadovanou cenou. Program proto volitelně provede přesné vyrovnání - pokud se po provedení přepočtu zjistí rozdíl oproti požadované částce, vybere se náhodně několik hovorů, kterým se sníží nebo zvýší cena o 1 haléř. Vyrovnání lze provést pouze na cenu s DPH.

Postup - přepočítání hovorů za období od 10.7.2003 do 9.8.2003 včetně, které byly vedeny přes linku 1. Výsledná částka má být 321.00 Kč včetně DPH přesně:

  1. Otevřete si detailní nerozdělený přehled.

  2. V ovládacím panelu klikněte na tlačítko filtr. Nastavte filtr tak, aby v přehledu byly zobrazeny jen hovory, které mají být do přepočtu zahrnuty, v tomto případě Datum a čas: 10.7.2003 až 9.8.2003, Linky: 1, Typ hovoru: odchozí a tranzitní.

  3. Tlačítkem OK zavřete okno, a pokud se přehled neobnovuje automaticky, spusťte vytvoření přehledu tlačítkem Obnov (nebo Start).

  4. Z nabídky funkce vyberte položku Přepočítat podle účtu. Otevře se dialogové okno nástroje, v jeho horní části okna je zobrazena celková cena hovorů vypočítaná podle sazebníků v programu.

  5. V dolní části editačního políčka zadejte požadovanou částku s DPH - 321.00. Můžete také přímo zadat požadovaný koeficient (např.: 2,0 = dvojnásobné ceny). Jednotky (Kč) nemusíte uvádět. Volba Vyrovnat přesně... by měla zůstat zatržená.

  6. Stiskněte tlačítko Přepočítat. Nyní se zahájí přepočet hovorů. Po jeho skončení se v dialogovém okně zobrazí zpráva o počtu změněných hovorů.

  7. Dialog zavřete tlačítkem Zavřít.


Přehledy hovorů

Tisk přehledu

Tento nástroj umožňuje vytisknout aktuální přehled na tiskárně. V současné verzi byly rozšířeny možnosti nastavení formátu papíru, záhlaví a zápatí. Lze též vytisknout pouze určitý rozsah stran. Program nekomunikuje s tiskárnou přímo, ale prostřednictvím systémového tiskového ovladače, které jsou buď součástí operačního systému nebo jsou dodávány zvlášť výrobcem tiskárny. Z tohoto důvodu je nutné mít v systému vpořádku nainstalovaný správný ovladač k tiskárně.

Tisk přehledu se zahájí vybráním položky Vytisknout přehled z nabídky Přehled. Totéž lze provést také stiskem kláves Ctrl+P nebo stiskem tlačítka na liště u levého okraje okna. Program nejprve musí přehled zformátovat (rozmístit texty a tabulky na papír) a poté se okno přehledu přepne do režimu náhledu. Náhled se zobrazuje ve stejném okně, jako tabulka hovoru, jen se změní horní nabídka příkazů a horní ovládací lišta, která v náhledu obsahuje ovládací prvky pro nastavení tisku.

  • Tisk - otevře standardní tiskový dialog, ve kterém můžete zvolit tiskárnu, nastavit její vlastnosti nebo zadat rozsah stran, které mají byt vytisknuty, tlačítkem OK zahájíte tisk přehledu.

  • Zpět - zavře náhled a přepne pracovní plochu zpět do základního režimu

  • Nastavení - spouští dialog pro nastavení tisku (viz následující odstavec)

Nastavení tisku

Tlačítko Nastavení na horním ovládacím panelu se otevírá konfigurační okno, ve kterém lze změnit parametry tisku. Volby jsou přehledně rozděleny do čtyř záložek. Na každé kartě je k dispozici tlačítko Standardní, které volby na otevřené záložce nastaví na hodnoty podle přednastavení výrobce programu.

Papír

Na teto kartě lze nastavit velikost a orientaci papíru a šířku okrajů:

  • Velikost papíru - nastaví se velikost papíru (A3, A4 nebo A5)

  • Orientace - volba orientace papíru (na výšku nebo na šířku)

  • Okraje - lze nastavit velikost okrajů na horním, dolním, pravém resp. levém okraji papíru. Šířka se uvádí v milimetrech (např. 20 mm) nebo v centimetrech (např. 2 cm).

  • Sloupce - v případě, že přehled obsahuje malý počet údajů a tabulka se vejde proto několikrát na šířku papíru, lze program nastavit tak, aby zformátoval výstup do několika tiskových sloupců. Nastavuje se počet sloupců a šířka mezery mezi sloupci. (Pozn.: V Dalších možnostech lze zapnout ukončování sloupců mezi bloky - každá tabulka pak bude začínat na začátku sloupce.

Hlavička a patička

Zde se nastavuje hlavička přehledu, tzn. texty zobrazené u horního okraje na všech stranách. Vkládání hlavičky se povoluje zatržítkem Zobrazit hlavičku. Do třech editačních polí se vloží text, který má byt zobrazen v záhlaví vlevo, uprostřed a vpravo. Do editačního pole lze vložit libovolný text (např. Vytiskl: Novák), a je možné využít několik automatických textů, které začínají vždy mřížkou (např. dne #D #C), přehled kódů je uveden v následující tabulce 3.3.

  • Výška hlavičky - výška oblasti, která je vyhrazena pro tisk hlavičky, udává se v milimetrech (např. 20 mm) nebo v centimetrech (např. 2 cm).

  • Mezera za hlavičkou určuje výšku mezery mezi hlavičkou a oblastí, do které se tiskne přehled.

  • Písmo - v poli se zobrazuje název a velikost písma, které bude použito pro tisk hlavičky. Tlačítkem Změnit písmo se otevře dialog pro změnu parametrů písma.

  • Legenda - přehled automatických textů, stiskem tlačítka se do editačního pole vloží na místo kurzoru odpovídající kód.

Stejným způsobem se nastavuje také patička, tj. text vytisknutý na všech stranách u dolního okraje.

Další možnosti

Na této záložce jsou umístěny málo používané volby, které logicky nepatří do některé z předcházejících záložek.

  • Černobílý tisk - je-li tato volba zatržena, ignoruje se při tisku nastavení barev a veškeré texty se tisknou černou barvou na bílém podkladu.

Automatické texty

Pokud se v textech, které mají být vysázeny v hlavičce nebo patičce (viz předcházející odstavce), uvede některý z kódů uvedených v tabulce 3.5, bude při formátování přehledu nahrazen odpovídajícím řetězcem podle svého významu. Často používaným kódem je například Strana ##/#*, který se používá pro číslování stran - na první stránce bude vysázen text "Strana 1/10", na druhé stránce "Strana 2/10" atd. Pomocí automatických textů lze také zajistit, že u přehledu rozděleného po pobočkách bude v záhlaví každého papíru uvedeno jméno pobočky (kód #B).

Kód | význam
## | číslo strany
#* | celkový počet stran
#D | aktuální datum ve formátu den. měsíc. rok
#C | aktuální čas ve formátu hodiny:minuty
#B | název bloku (podtabulky)
#P | název, pod kterým je přehled uložen (např. Účetní odd. minulý měsíc)
#Q | nadpis přehledu, který je uveden v přehledu (např. Detailní po pobočkách)

Tabulka 3.5: Význam automatických textů v hlavičce a patičce přehledu


Přehledy hovorů

Tisk faktury

Tento nástroj umožňuje vytisknout fakturu za telefonní provoz (např. firmě v nájmu). Než spustíte tuto funkci, musíte mít přehled řádně filtrován, tak aby obsahoval jen hovory za příslušné fakturační období a pouze hovory na pobočkách případně skupinách poboček, které mají být do výsledné částky na faktuře započítány.

Výběrem položky Tisk faktury z nabídky Přehled se pracovní plocha okna přehledu přepne do režimu náhledu na fakturu a změní se také obsah horního ovládacího panelu, který bude obsahovat tlačítka pro tisk a vstup do dialogového okna pro nastavení faktury.

  • Tisk - otevře standardní tiskový dialog, ve kterém můžete zvolit tiskárnu a nastavit její vlastnosti. Tlačítkem OK zahájíte tisk faktury.

  • Zpět - zavře náhled a přepne pracovní plochu zpět do základního režimu

  • Nastavení - spouští dialog pro nastavení faktury (viz následující odstavec)

Nastavení faktury

Tlačítko Nastavení na horním ovládacím panelu se otevírá konfigurační okno, ve kterém lze změnit parametry faktury, které jsou přehledně rozděleny do tří záložek.

Vlastnosti

  • Číslo faktury - do tohoto pole je možné napsat jakékoli číslo tak, aby korespondovalo s používaným účetním programem či účetní knihou. Po vytisknutí se číslo automaticky zvyšuje o 1.

  • Dny vystavení, zdanitelného plnění a splatnosti - standardně je nastaveno pro položky Den vystavení a Den zd. plnění aktuální datum a pro Den splatnosti se k aktuálnímu datu přičte lhůta 14 dnů. Tato data lze libovolně měnit.

  • Vystavil - jméno pracovníka, který přehled vystavil - bude vytisknuto na faktuře.

Dodavatel

Do editačních polích se vyplňují údaje o dodavateli (tj. osobě, která fakturu vystavuje).

Poznámka:
Pole Ostatní údaje je určeno pro údaj o tom, kde je osoba zapsána v obchodím rejstříku (zapsán u ...).

Odběratelé

V horním výběrovém poli se vybere odběratel, v seznam jsou nabízeny všechny skupiny poboček definované v konfiguraci programu (viz konfigurace skupin poboček). V níže zobrazených polích se zadají příslušné fakturační údaje pro vybraného odběratele (skupinu).

Okno Další položky slouží k zadání např. paušálních položek, které mají být kromě vyhodnoceného hovorného zahruty do faktury. V tabulce se nachází na konci vždy jeden prázdný řádek, do kterého je možno přidat další položku. Údaje se do tabulky vpisují z klávesnice přímo do tabulky. Políčka se potvrzují klávesou Enter. Opravu políčka lze provést kliknutím myši na pole a napsáním nové hodnoty. Opět potvrdit Enterem. Při editaci tabulky lze využít také funkční tlačítka umístěná vlevo u tabulky, jejich význam je uveden v tabulce 3.6.

  • Položka - název položky (například Pronájem telefonního přístroje).

  • Cena nebo Cena s DPH - částka v Kč (není nutné uvádět jednotku Kč, desetinná místa lze oddělit tečkou nebo čárkou).

  • Sazba DPH - procentuální sazba DPH (není nutné uvádět znak procento).

Tlačítko | význam
 | vloží nový řádek do tabulky na pozici kurzoru
 | odstraní vybraný řádek z tabulky
 | přesune označený řádek o jednu pozici nahoru
 | přesune označený řádek o jednu pozici dolů
 | zkopíruje celý obsah tabulky do schránky (pro přenesení do tabulky jiného odběratele)
 | vymaže celý obsah tabulky a nahradí jej obsahem schránky

Tabulka 3.6: Tlačítka v dialogu pro nastavení odběratele faktury


Přehledy hovorů

Tisk účtenky

Tento nástroj umožňuje vytisknout účtenku za telefonní provoz (např. firmě v nájmu). Účtenka může obsahovat také detailní výpis hovorů. Než spustíte tuto funkci, musíte mít přehled řádně filtrován, tak aby obsahoval jen hovory za účtované období a pouze hovory na pobočkách případně skupinách poboček, které mají být do účtenky započítány.

Výběrem funkce Tisk účtenky v nabídce Přehled se pracovní plocha okna přehledu přepne do režimu náhledu na účtenku a změní se také obsah horního ovládacího panelu, který bude obsahovat tlačítka pro tisk a vstup do dialogového okna pro nastavení účtenky. Tlačítkem Tisk otevřete standardní dialog pro výběr tiskárny a zahájení tisku, stiskem tlačítka Zpět se okno přepne zpět do základního režimu.

Nastavení účtenky

Tlačítko Nastavení na horním ovládacím panelu se otevírá konfigurační okno, ve kterém lze změnit parametry účtenky, které jsou přehledně rozděleny do tří záložek.

Vlastnosti

  • Dodavatel je plátcem DPH - zatrhnout, pokud je pronajímatel plátcem DPH.

  • Vytisknout také přehled hovorů - při zatržení se vytiskne i přehled hovorů podle aktuálního nastavení přehledu. Pokud není zatrženo, vytiskne se jen celková částka.

  • Černobílý tisk - ignoruje se nastavení barev v přehledu - např. pro ušetření barevných tonerů při tisku na barevné tiskárně.

  • Číslo účtenky - pořadové číslo, nastavitelné, automaticky se po tisku zvyšuje o 1.

  • Den vystavení - datum vystavení účtenky.

  • Zaokrouhlovat - volba metody zaokrouhlení celkové částky.

  • Formát data - v tomto editačním poli lze nastavit požadovaný formát data na účtenkce (netýká se data hovorů v přehledu).

Papír

Na teto kartě lze nastavit velikost a orientaci papíru a šířku okrajů. Hodnoty se uvádí v milimetrech (např. 20 mm) nebo v centimetrech (např. 2 cm).

  • Velikost papíru - nastaví se velikost papíru (A3, A4 nebo A5)

  • Orientace - volba orientace papíru (na výšku nebo na šířku)

  • Okraje - lze nastavit velikost okrajů na horním, dolním, pravém resp. levém okraji papíru. Šířka se uvádí v milimetrech (např. 20 mm) nebo v centimetrech (např. 2 cm).

Úvodní a závěrečné řádky

Na této záložce lze do třech textových polích vepsat texty, které mají vysázeny v úvodu a závěru účtenky.

  • Zvýrazněné řádky - řádky v úvodu tisknuté tučným větším písmem, nejčastěji jméno firmy - například Tartek - Ing. Václav Opletal.

  • Další řádky - řádky tisknuté standardním písmem a umístěné bezprostředně pod zvýrazněnými řádky, toto pole je určeno pro vložení adresy a IČ firmy - například Lužická 9, 616 00 Brno, IČ....

  • Závěrečné řádky - řádky tisknuté standardním písmem na konci účtenky, například Děkujeme Vám za návštěvu.

  • Změnit písmo - otevře dialog pro nastavení písma (pro každé pole zvlášť)


Přehledy hovorů

Export přehledu

Pomocí tohoto nástroje můžete exportovat zobrazený přehled do souboru. Na výběr je několik výstupních formátů, které mají ještě řadu uživatelských nastavení, takže výstup je možné vložit do většiny existujících textových a tabulkových procesorů nebo odeslat na databázový server. Uživatelské rozhraní nástroje je řešeno formou průvodce.

Postup při vytváření výstupního souboru:

  1. Z nabídky Nástroje vyberte volbu Exportovat.

  2. Na první stránce se volí formát, v jakém mají být data do souboru uložena. Současná verze programu Tardat obsahuje tyto výstupní filtry:

    • Prostý text - neformátovaný textový soubor s pevnou šířkou sloupců,

    • Formátovaný text (RTF) - export do standardního souboru formátovaného textu čitelného textovými editory (např. Microsoft Word).

    • CSV - textový soubor, jednotlivá pole jsou oddělena středníkem, každý záznam je na samostatném řádku. Filtr má velké množství nastavení, takže lze formát přizpůsobit konkrétním požadavkům,

    • stránka HTML - vytvoří jednoduchou stránku v jazyce HTML, která je zobrazitelná běžnými internetovými prohlížeči,

    • dBase III - formát používaný některými relačními databázovými systémy. Lze vložit do většiny tabulkových procesorů (přípona dbf),

    • příkazy SQL - soubor se sadou SQL příkazů. Pomocí konzoly lze tabulku nahrát na databázový server.

Další postup závisí na zvolném formátu:

Export do prostého textu

  4. Vyberte si požadováné kódování českých znaků.

  5. V dalším dialogu můžete nastavit, které informace bude výstupní soubor obsahovat.

    • Uložit popisky sloupců - bude exportováno i záhlaví tabulky s popisky sloupců.

    • Uložit textové řádky - export informačních řádků hlavičky (výběrové podmínky, způsob řazení, úvodní a závěrečný řádek).

    • Uložit součtové řádky - export řádků se součtem, popř. s mezisoučty.

    • Uložit nadpisy přehledů a bloků - do exportu budou zahrnuty i název (nadpis) přehledů a nadpisy bloků.

    • Svislé oddělovací čáry mezi sloupci - jednotlivé sloupce budou odděleny znakem "|". Je-li volba vypnuta, odděluje se mezerou.

    • Vodorovné oddělovací čáry - popisy sloupců a součtový řádek budou v tabulce odděleny znaky "-".

    • Vkládat znaky pro odstránkování - do souboru budou ukládány znaky pro přechod na novou stránku (ASCII 12), a to:
      1. na začátku každého bloku, je-li v přehledu nastaveno Každý blok na samostatnou stránku,
      2. a vždy, když počet řádek na stránce přesáhne zadanou hodnotu:

    • Počet řádků na stránku - po kolika řádcích vložit odstránkování (viz. výše).

  6. Program Vás požádá o vyhledání adresáře, do kterého chcete soubor uložit, a o zadání jména souboru. Po stisknutí tlačítka Uložit se provede export tabulky a výsledek se uloží do zvoleného souboru.

  7. Pokud proběhlo vše v pořádku, program vypíše počet uložených záznamů. V opačném případě se zobrazí chybové hlášení.

Export do formátovaného textu

  4. V dialogu můžete nastavit, které informace bude výstupní soubor obsahovat.

    • Uložit popisky sloupců - bude exportováno i záhlaví tabulky s popisky sloupců.

    • Uložit textové řádky - export informačních řádků hlavičky (výběrové podmínky, způsob řazení, úvodní a závěrečný řádek).

    • Uložit součtové řádky - export řádků se součtem, popř. s mezisoučty.

    • Uložit nadpisy přehledů a bloků - do exportu budou zahrnuty i název (nadpis) přehledů a nadpisy bloků.

  5. Program Vás požádá o vyhledání adresáře, do kterého chcete soubor uložit, a o zadání jména souboru. Po stisknutí tlačítka Uložit se provede export tabulky a výsledek se uloží do zvoleného souboru.

  6. Pokud proběhlo vše v pořádku, program vypíše počet uložených záznamů. V opačném případě se zobrazí chybové hlášení.

Export do formátu CSV

  4. Vyberte si požadováné kódování českých znaků.

  5. V dalším dialogu můžete změnit parametry filtru. Stisknutím tlačítka Nastavit standardní volby se nastaví hodnoty parametrů přednastavené od výrobce.

    • Uložit nadpisy přehledů a bloků - do exportu budou zahrnuty i název (nadpis) přehledů a nadpisy bloků. Uloženy budou jako poznámky.

    • Uložit textové řádky - export informačních řádků hlavičky (výběrové podmínky, způsob řazení, úvodní a závěrečný řádek). Budou uloženy jako poznámky.

    • Uložit popisky sloupců - bude exportováno i záhlaví tabulky s popisky sloupců.

    • Pole jsou uzavřená do - znak nebo několik znaků, kterými začíná a končí každé pole,

    • Jen řetězce - je-li tato volba zatržena, pak se uzavírají pouze textová pole,

    • Řídící znak "escape" - pokud se v poli vyskytuje znak uzavírající pole, ukončující pole, ukončující řádek nebo řídící znak, pak se před takový znak vloží uvedený řídící znak,

    • Pole jsou oddělená - znak nebo několik znaků oddělující jednotlivá pole,

    • Řádky jsou oddělené - znak nebo několik znaků oddělující jednotlivé záznamy,

    • Poznámky začínají - znak nebo několik znaků, kterými začínají řádky s poznámkou.

    • Des. místa se oddělují - znak pro oddělení desetinných míst (tečka nebo čárka).

    POZOR!

    Do všech uvedených polí lze vkládat také netisknutelné znaky, jako je tabulátor nebo nový řádek. Tyto znaky se uvozují vždy zpětným lomítkem bez ohledu na nastavení řídícího znaku. Tabulka 3.7 ukazuje přehled řídících sekvencí:

  6. Program Vás požádá o vyhledání adresáře, do kterého chcete soubor uložit, a o zadání jména souboru. Po stisknutí tlačítka Uložit se provede export tabulky a výsledek se uloží do zvoleného souboru.

  7. Pokud proběhlo vše v pořádku, program vypíše počet uložených záznamů. V opačném případě se zobrazí chybové hlášení.

Znaky | Význam
\n | nový řádek (dvojice CR+LF)
\t | tabulátor
\\ | zpětné lomítko (!)

Tabulka 3.7: Speciální znaky v nastavení exportu do formátu CSV

Příklad:
Jednotlivá pole mají být oddělená čárkou, uzavírají se do apostrofů. Pokud se někde v řetězci vyskytuje apostrof, vloží se před něj druhý apostrof. Záznamy mají být na samostatných řádcích. Poznámky začínají mřížkou.

Nastavení:
Pole jsou uzavřená do: '
Jen řetězce: ne
Řícící znak "escape": '
Pole jsou oddělená: ,
Řádky jsou oddělené: \n
Poznámky začínají: #

Ukázka výstupu (export poboček):

CISLO,JMENO,SKUPINA,JMEN_SKUP,PRIPL,MASK_TYP,AUTH_KOD,UTAJENI,POZNAMKA
'47','Dita','2','Obchodní oddělení','0','Nemaskovat','','N',''
'48','Dana','2','Obchodní oddělení','0','Nemaskovat','','N',''
'99','Test ''apostrofů''','0','Ostatní pobočky','0','Nemaskovat','','N',''

Export do jazyka HTML

  4. Vyberte si požadováné kódování českých znaků.

  5. V dalším dialogu můžete nastavit, které informace bude výstupní soubor obsahovat:

    • Uložit popisky sloupců - bude exportováno i záhlaví tabulky s popisky sloupců.

    • Uložit textové řádky - export informačních řádků hlavičky (výběrové podmínky, způsob řazení, úvodní a závěrečný řádek).

    • Uložit součtové řádky - export řádků se součtem, popř. s mezisoučty.

    • Uložit nadpisy přehledů a bloků - do exportu budou zahrnuty i název (nadpis) přehledů a nadpisy bloků.

  6. Program Vás požádá o vyhledání adresáře, do kterého chcete soubor uložit, a o zadání jména souboru. Po stisknutí tlačítka Uložit se provede export tabulky a výsledek se uloží do zvoleného souboru.

  7. Pokud proběhlo vše v pořádku, program vypíše počet uložených záznamů. V opačném případě se zobrazí chybové hlášení.

Export do formátu dBase III (dbf)

  4. Vyberte si požadováné kódování českých znaků.

  5. Program Vás požádá o vyhledání adresáře, do kterého chcete soubor uložit, a o zadání jména souboru. Po stisknutí tlačítka Uložit se provede export tabulky a výsledek se uloží do zvoleného souboru.

  6. Pokud proběhlo vše v pořádku, program vypíše počet uložených záznamů. V opačném případě se zobrazí chybové hlášení.

Příkazy SQL

  4. Vyberte si požadováné kódování českých znaků.

  5. V dalším dialogu můžete nastavit, které informace bude výstupní soubor obsahovat:

    • poznámky - všechny texty v přehledu mimo tabulky se ukládají jako poznámky,

    • struktura tabulky - vloží příkaz CREATE TABLE s definicí tabulky.

    • příkaz DROP TABLE - příkaz vymaže existující tabulku, pokud existuje,

    • příkaz USE - příkaz nastaví aktívní databázi - musí být vyplněno jméno databáze,

    • jméno tabulky - jméno tabulky (povinné),

    • jméno databáze - jméno databáze (povinné, pokud se vkládá příkaz USE).

  6. Program Vás požádá o vyhledání adresáře, do kterého chcete soubor uložit, a o zadání jména souboru. Po stisknutí tlačítka Uložit se provede export tabulky a výsledek se uloží do zvoleného souboru.

  7. Pokud proběhlo vše v pořádku, program vypíše počet uložených záznamů. V opačném případě se zobrazí chybové hlášení.


Konfigurace uživatelů

Databáze hovorů je ve většině firem citlivou záležitostí, proto je nutné omezit přístup do programu na vybranou množinu osob, které mají v programu zadané své heslo. Program také vede podrobný deník provedených akcí. K programu Tardat může zároveň přistupovat několik uživatelů, každý uživatel má kromě vlastní sady přehledů také své osobní nastavení uživatelského prostředí (profil). Konfigurace uživatelů programu Tardat je zcela nezávislá na systému uživatelů používaném pro přihlašování do sítě a do databáze. Systém uživatelů se používá také v případě, kdy se k přehledům programu Tardat přistupuje pomocí webového serveru.

Během první instalace programu je automaticky zřízen první uživatel, který se nazývá správce. Tento uživatel má přístup ke všem funkcím programu. Správce systému může vytvořit další uživatelské účty a přidělit každému uživateli oprávnění provádět určité úkony. Pokud se vytváří větší množství uživatelů, není nutné nastavovat oprávnění každému zvlášť. Ke hromadné definici oprávnění je určena tabulka rolí. Role je skupina uživatelů se stejným oprávněním.

V této kapitole je popsána konfigurace uživatelů v programu Tardat, druhá část je věnována uživatelskému rozhraní pro nastavení uživatelských účtů.

Obsah

  1. Vlastnosti uživatelů
  2. Editace uživatelů v programu Tardat
  3. Editace rolí v programu Tardat
  4. Postup při přihlašování do programu Tardat

Viz také:


Konfigurace uživatelů

Vlastnosti uživatelů

V nastavení programu Tardat se definuje tabulka uživatelů programu Tardat. Každý uživatel má v systému přiděleno své jméno a heslo používané při přihlašování do systému, a také sadu oprávnění, které omezují přístup k funkcím programu. Tyto vlastnosti lze editovat pomocí dialogu Konfigurace uživatelů v programu Tardat.

Během instalace programu se automaticky zřídí první uživatel (má označení Uživatel A), který se nazývá správce a má plný přístup ke všem funkcím systému. Má také oprávnění zřizovat a rušit další uživatele.

Počet uživatelů

V základní verzi programu je maximální počet uživatelů 64, ale tento počet může být zvýšen placenými moduly Uživ+256 a Uživ+512 až na 832 uživatelů.

Jméno uživatele

Je vhodné, aby každý uživatel měl v systému zadané své jméno. Tento řetězec se zobrazuje v přihlašovacím okně a v dalších dialozích programu, používá se také při přihlašování přes webový server. Pokud budou uživatelé přistupovat přes webový server, nedoporučujeme používat u jmen uživatelů znaky s diakritikou. Není-li v konfiguraci přiřazeno žádné jméno, systém používá pro identifikaci uživatele řetězec "Uživatel XX", kde XX se nahrazuje jedním nebo dvěma přidělenými identifikačními písmeny.

Přístupové heslo

Neautorizovanému přístupu do programu brání přístupové heslo. Heslem může být libovolně dlouhý řetězec znaků, číslic apod., velká a malá písmena se nerozlišují. Je-li jako heslo zadán prázdný řetězec (tuto funkci je nutné povolit v nastavení programu), systém jeho zadání při startu programu Tardat nevyžaduje.

Do programu je také možné vstupit pomocí zvláštního hesla, které lze použít v případě, že uživatel zapomene své přihlašovací heslo. Toto heslo Vám sdělí na požádání servisní technik firmy Tartek. Po vstupu do programu bude Tardat ihned vyžadovat změnu stávajícího hesla.

Oprávnění

Oprávnění uživatele je množina logických proměnných, které umožňují nebo zakazují uživateli používat určité funkce programu. Vždy platí, že libovolný uživatel nesmí mít větší oprávnění než jeho nadřízený, oprávnění správce je omezeno pouze hardwarovým klíčem. Uživatel si nemůže svoji množinu oprávnění měnit.

Uživatelské role

Tabulka rolí umožňuje jednoduchým způsobem definovat oprávnění pro celou skupinu uživatelů. Role obsahuje nastavení oprávnění pro všechny zařazené uživatele. Změna oprávnění u role se automaticky projeví u zařazených uživatelů. Role lze vytvářet, editovat a rušit pomocí dialogu Konfigurace uživatelů v programu Tardat.

Deník provedených akcí

U každého uživatele program Tardat eviduje důležité akce, které pomocí programu Tardat provedl jako například přihlášení a odhlášení, změna konfigurace, použítí vybraných nástrojů apod. Akce jsou pro přehlednost rozděleny do čtyřech kategorií: uživatel, přehledy, konfigurace a nástroje. Záznamy starší než jeden rok se z deníku automaticky průběžně vymazávají.


Konfigurace uživatelů

Editace uživatelů v programu Tardat

Dialog pro editaci uživatelů se spouští z hlavní nabídky programu Tardat v nabídce Konfigurace položka Uživatelů. Otevře se dialogové okno, které obsahuje dvě záložky; na jedné se edituje tabulka uživatelů, druhá je určena pro editaci rolí.

Záložka Uživatelé obsahuje tabulku se seznamem všech uživatelů definovaných v systému Tardat. Ikonami (viz tabulka 3.6) jsou rozlišeny tři základní typy uživatelů: správce (Uživatel A), technik (má oprávnění vytvářet a editovat další uživatele) a běžný uživatel (ostatní). V pravé části okna pod tlačítky je uveden počet definovaných uživatelů / maximální povolený počet. Tlačítkem Editovat se spustí editační dialog pro nastavení parametrů vybraného uživatele, ovládací prvky jsou v okně tématicky rozděleny do tří stránek:

Symbol | význam
 | správce (Uživatel A, stojí vždy nejvýše)
 | technik (má oprávnění vytvářet a editovat další uživatele)
 | běžný uživatel (ostatní)

Tabulka 3.6: Symboly pro rozlišení kategorií uživatelů

Vlastnosti

  • Označení - identifikační písmeno (písmena) uživatele pro vnitřní potřebu programu. Toto pole není možné měnit.

  • Jméno uživatele - uživatelské jméno, které se používá pro přihlášení do programu Tardat a také při vstupu přes webový server.

  • Oprávnění - můžete uživatele zařit buď do některé z připravených rolí nebo zvolit Samostatné oprávnění (konfiguruje se na další záložce).

  • Tlačítko Změnit heslo spouští dialog pro zadání nového hesla. Program vyžaduje zadání vlastního hesla (tj. hesla uživatele, který změnu provádí), do dalšího editačního pole se zadává nové heslo a do posledního políčka se opíše nové heslo pro kontrolu. Pokud je to povoleno v nastavení programu, přístupové heslo může být prázdné - program se pak při startu nebude na heslo ptát (nedoporučujeme).

Samostatné oprávnění

Pokud není uživatel zařazen do role, konfiguruje se na další stránce oprávnění editovaného uživatele. Jednotlivé volby jsou uspořádany přehledně do stromu, který odpovídá položkám v hlavním menu programu. Před každou volbou je ikona, která znázorňuje její stav, viz tabulka 3.7 Změna oprávnění se provádí tlačítky Povolit nebo Zakázat. Povolení nebo zakázání uzlu, který má pod sebou další podvolby, změní stav také všech podvoleb.

Tlačítkem Oprávnění podle se spouští dialog umožňující zkopírovat nastavení oprávnění od jiného uživatele nebo role.

Symbol | význam
 | funkce je povolena a jsou-li pod touto volbou zařazeny ještě další volby, jsou všechny také povoleny
 | funkce je zakázána a jsou-li pod touto volbou zařazeny ještě další možnosti, jsou všechny také zakázány
 | tato ikona znamená, že pro touto volbou jsou zařazeny ještě další volby a některé z nich jsou povoleny a některé zákázány
 | indikuje, že tato funkce je zakázána a nelze ji povolit.

Tabulka 3.7: Symboly v okně pro nastavení oprávnění uživatele

Kniha přístupů

Na poslední stránce konfiguračního okna uživatele je zobrazen výpis z deníku provedených akcí. Tlačítky v horní části okna lze zapnout nebo vypnout zobrazování událostí z určité kategorie. Záznamy ve výpisu jsou vždy seřazeny podle data tak, že nejčerstvější záznamy jsou vždy nahoře. Ikony v tabulce indikují kategorii, do které událost patří, viz tabulka 3.8

Symbol | význam
 | Uživatelé (např. přihlášení a odhlášení)
 | Přehledy (uložení a mazání přehledů apod.)
 | Nástroje (archivace, zpětné zpracování, ...)
 | Konfigrace (změny v konfiguraci programu Tardat)

Tabulka 3.8: Symboly pro rozlišení katerorií v deníku uživatele


Konfigurace uživatelů

Editace rolí v programu Tardat

Dialog pro nastavení uživatelských účtů se spouští z hlavní nabídky programu Tardat v nabídce Konfigurace položka Uživatelů. Otevře se dialogové okno, které obsahuje dvě záložky; na jedné se edituje tabulka uživatelů, druhá je určena pro editaci rolí.

Záložka Role obsahuje tabulku se seznamem všech rolí definovaných v systému Tardat. Ikonami (viz tabulka 3.9) jsou rozlišeny dva základní typy uživatelů: technici, kteří mají oprávnění vytvářet a editovat další uživatele a běžní uživatelé. V pravé části okna pod tlačítky je uveden počet definovaných rolí / maximální povolený počet. Tlačítkem Editovat se spustí editační dialog pro nastavení parametrů vybrané role, ovládací prvky jsou v okně tématicky rozděleny do dvou stránek:

Symbol | Význam
 | technik (má oprávnění vytvářet a editovat další uživatele)
 | běžný uživatel (ostatní)

Tabulka 3.9: Symboly pro rozlišení základních typů rolí

Vlastnosti

  • Jméno role - Pojmenování role (např. technici, účetní, ...)

Oprávnění

V sekci Oprávnění se nastavují zatržítka povolující a zakazující přístup k funkcím programu. Jednotlivé volby jsou uspořádany přehledně do stromu, který odpovídá položkám v hlavním menu programu. Před každou volbou je ikona, která znázorňuje její stav, viz tabulka 3.10 Změna oprávnění se provádí tlačítky Povolit nebo Zakázat. Povolení nebo zakázání uzlu, který má pod sebou další podvolby, změní stav také všech podvoleb.

Tlačítkem Oprávnění podle se spouští dialog umožňující zkopírovat nastavení oprávnění od jiného uživatele nebo role.

Symbol | Význam
 | funkce je povolena a jsou-li pod touto volbou zařazeny ještě další volby, jsou všechny také povoleny
 | funkce je zakázána a jsou-li pod touto volbou zařazeny ještě další možnosti, jsou všechny také zakázány
 | tato ikona znamená, že pro touto volbou jsou zařazeny ještě další volby a některé z nich jsou povoleny a některé zákázány
 | indikuje, že tato funkce je zakázána a nelze ji povolit.

Tabulka 3.10: Symboly v okně pro nastavení oprávnění uživatele

Přiřazení uživatelé

Pomocí této sekce lze jednoduchým způsobem přiřadit uživatele do editované role nebo jej naopak vyřadit. Záložka obsahuje dvě tabulky. V levé tabulce je zobrazen seznam přiřazených uživatelů zatímco v pravé tabulce se nachází uživatelé, kteří mají momentálně nastaveno samostatné oprávnění.

Tlačítky se šipkou můžete přemístit vybrané položky z jedné tabulky do druhé. Pomocí tlačítka s ikonou [image] můžete přesunout vybrané uživatele z levé tabulky přímo do jiné role.


Konfigurace uživatelů

Postup při přihlašování do programu Tardat

Přihlašovací dialog programu Tardat

  1. Není-li v konfigurační tabulce definován žádný uživatel, program vypíše chybové hlášení a skončí. V takovém případě je nutné program přeinstalovat, instalační program automaticky vytvoří prvního uživatele, tzv. správce.

  2. Je-li v Tardatu definováno více uživatelů a identifikace uživatele není zadána parametrem v příkazovém řádku, zobrazí se seznam uživatelů, uživatel klikne na položku s jeho přihlašovacím jménem a stiskne tlačítko Pokračovat.

  3. V případě, že uživatel má v konfiguraci nastavené neprázdné heslo, požádá program o jeho zadání. Při zadání špatného hesla 3x po sobě se program Tardat ukončí. Také přihlašovací heslo lze předat v příkazové řádce.

  4. V případě ztráty hesla je možné použít pro vstup do programu speciální nadheslo, kontaktujte prosím výrobce programu.

Příkazová řádka

Uživatelské jméno a heslo se přes příkazovou řádku předává následujícím způsobem:

tardat [jméno[:heslo]]
kde jméno je uživatelské jméno nebo identifikační písmeno případně dvojice písmen, a heslo je jeho přihlašovací heslo. Pokud některý z parametrů obsahuje mezeru, musí být celý parametr uzavřen do úvozovek.

Příklady:

tardat a
tardat a:mojeheslo
tardat Novák:mojeheslo
tardat "P. Novák:moje heslo"


Tabulky - konfigurace uživatelů

Tabulky programu Tardat 4

Konfigurace uživatelů

Tabulky definující oprávnění pro přístup do programu Tardat.

Tabulka Popis

uzivatele

Tabulka definovaných uživatelů, přístupová hesla a oprávnění.

role

Role definují společná oprávnění pro skupiny uživatelů.

Poznámky:


Tabulky - přehledy

Tabulky programu Tardat 4

Přehledy

Tabulka Popis

prehledy

Nastavení všech definovaných přehledů s výjimkou přehledu "Naposled vytvořený", který je uložen v uživatelském profilu na disku.

sloupce

Nastavení sloupců pro jednotlivé přehledy, tj. zobrazované sloupce, jejich šířku a pořadí.

styly

Nastavení stylů (písma, barvy, ...) pro definované přehledy.

nazvysloupcu

Uživatelské názvy sloupců používaných v přehledech.

export

Nastavení exportních filtrů pro funkci "Export přehledu" a "Export konfigurace".

odberatele

Obsahuje fakturační údaje o odběratelích (jméno, adresa, IČO, ...)

dalsipol

Tabulka paušálních položek uváděných na faktuře.

Poznámky:


Malý webový server

V současné době obsahuje program Tardat v základní instalaci server pro přístup do programu Tardat po síti (tvz. malý webový server). Uživatel využívá pro přístup svůj internetový prohlížeč, který odesílá požadavky do serveru, ten vytvoří přehled a odešle jej prohlížeči zpět v jazyce HTML. Přístup je chráněn jednoduchou autorizací, každý uživatel má přístup pouze k přehledům ve své složce. Malý webový server neumožňuje měnit nastavení přehledů - ty musí každému uživateli nejprve nastavit správce pomocí uživatelského rozhraní programu Tardat. Server podporuje také kaskádní styly (CSS) pro začlenění stránek do intranetového přostředí uživatele.

Tato kapitola se zabývá konfigurací a instalací malého webového serveru programu Tardat.

Obsah

  1. Konfigurace serveru
  2. Instalace a ovládání modulů
  3. Ovládání webového rozhraní

Viz také:

  • Konfigurace uživatelů


Malý webový server

Konfigurace webového serveru

Server se konfiguruje pomocí programu Tardat. Z hlavní nabídky zvolte v nabídce Konfigurace položku WWW serveru... Aby se provedené změny v konfiguraci projevily, je nutné je nejprve uložit tlačítkem Uložit a potom ovládacími tlačítky na záložce Spouštění server vypnout a zapnout!

Nastavení síťového portu (PORT)

Klikněte na záložku server. Nastavte číslo síťového portu (standardně 80). Zadané číslo portu nesmí být obsazeno jinou síťovou službou. Pokud již na Vašem počítači běží jiný webový server (např. Apache), použijte jiné číslo portu. Doporučujeme využít čísla z rozsahu 1024 - 65535, které jsou vyhrazeny pro uživatelské služby.

Poznámka:
V malých intranetových sítích se obvykle nepoužívá DNS ani nebývá všude správně nastavený soubor hosts.sam (C:\windows\hosts.sam), který obsahuje překladovou tabulku jméno počítače -> IP adresa, v těchto případech je nutné do editačního pole prohlížeče uvádět přímo IP adresu počítače, na kterém je server spuštěný.

POZOR!
Je-li číslo portu nastaveno jinak než na 80, potom je nutné ve webových prohlížečích uvádět adresu včetně protokolu, viz následující příklad, například: http://192.168.1.15:1080/

Navázání serveru (BINDING)

Má-li Váš počítač více než jedno síťové rozhraní, můžete server navázat na všechna rozhraní - bude potom přístupný ze všech sítí. Chcete-li aby byl dostupný pouze přes jedno rozhraní, zvolte v sekci Navázat server na položku Zadané a do editačního pole vepište IP adresu nebo hostitelskou adresu vybraného rozhraní. Jinak ponechte vybranou volbu Všechna síťová rozhraní (standardně).

Kniha přístupů

Server může vytvářet deník přístupů. V konfiguračním dialogu se nastavuje, zda se do deníku zapisují pouze chybová hlášení, všechny přístupy nebo zda je vytváření deníku zakázáno. Záznamy se ukládají do souboru tardatd.txt (při použití programu Tardatd) nebo tardats.txt (pokud používáte službu Tardats) v podadresáři log.

Volba "KeepAlive"

Tato volba řídí chování webového serveru po odeslání odpovědi webovému prohlížeči. Je-li zapnuta, pak server neukončuje spojení a čeká na další žádost, v opačeném případě se ihned po odeslání odpovědi spojení ukončuje. Standardně je tato volba zapnuta.

Povolení a zákaz přístupu na základě IP adresy

Na druhé záložce (přístup) se konfigurují IP adresy nebo série adres, pro které je přístup do serveru povolen nebo zakázán. Správná konfigurace zamezuje nepovolenému přístupu např. z vnější sítě. Uvádí se seznam IP adres nebo jejich částí oddělené čárkou, středníkem nebo novým řádkem. Do horního editačního pole se uvádí povolené adresy, do dolní části zakázané adresy. Neodpovídá-li adresa ani jedné položce, není přístup povolen!

Příklad:
Přístup je povolen jen pro adresy začínající 192.168.*.*, zakázán pro 192.168.2.* a povolen pro 192.168.2.20. Povolen je také přístup z počítače, na kterém je Tardat spuštěn (127.0.0.1).

Konfigurace serveru se nastaví takto:
Povolit přístup pro IP adresy:
    127.0.0.1
    192.168
    192.168.2.20

Zakázat přístup pro IP adresy:
    192.168.2

Spouštění

Nastavení spouštění malého webového serveru. Viz následující kapitola.

Volby

Na této záložce se nastavují další možnosti webového serveru:

  • jméno souboru s absolutní nebo relativní cestou případně URL souboru s kaskádním stylem (CSS). Např. tardat.css nebo http://server/styly/styl.css.
  • jméno souboru s absolutní nebo relativní cestou (ne URL!) souboru se záhlavím. Obsah souboru bude vložen vždy na začátek stránky za značku <body>. Např. hlavicka.html.
  • jméno souboru s absolutní nebo relativní cestou (ne URL!) souboru se zápatím. Obsah souboru bude vložen vždy na konec stránky před ukončující značku </body>. Např. paticka.html.

Poznámka:
Pokud není uvedena absolutní cesta k souboru, program se vždy odkazuje do podadresáře system v adresáři programu Tardat.


Malý webový server

Instalace a ovládání modulů

Server je k dispozici jako samostatný modul ve dvou variantách: Na operačních systémem Windows 98 SE a novějších funguje modul tardatd.exe, který se spouští jako běžný program. Automatické spuštění se zajistí umístěním zástupce do složky "Po spuštění". Běh programu je indikován malou ikonou v pravé dolní části okna a uživatel si může kdykoliv otevřít dialogové okno, ve kterém vidí záznam o několika posledních přístupech. Ovládacími tlačítky může server zastavit nebo spustit.

Druhá varianta, modul tardats.exe je určena POUZE pro platformu Windows NT, t.j. operační systémy Windows NT, 2000 a XP. Modul se instaluje jako služba systému; výhodou je to, že server je aktivní i když na počítači není příhlášen žádný uživatel.

Server lze nainstalovat pomocí dialogového okna pro konfiguraci webového serveru programu Tardat, záložka Spouštění.

Instalace do složky "Po spuštění"

Chcete-li spouštět modul ze složky "Po spuštění", t.j. vždy po startu počítače a po přihlášení uživatele do systému, přidejte zatržítko k volbě "ze složky Po spuštění". Program vytvoří zástupce do složky "Po spuštění" a informuje o tom uživatele. Zástupce je možné opět zrušit odebráním zatržítka.

Instalace jako službu systému

K instalaci služby systému tardats slouží druhá volba Jako službu systému. Přidáním zatržítka modul nainstalujete, jeho odebráním opět odinstalujete.

Ruční instalace modulu tardatd

Přidání zástupce do složky "Po spuštění":
Otevřete "Tento počítač" a najděte složku "Po spuštění" (Ve Windows 98 je to adresář C:\Windows\Nabídka Start\Programy\Po spuštění). Pravým tlačítkem myši klikněte na prázdné místo v okně a vyberte si volbu "Nový" -> "Zástupce". Stiskněte tlačítko "Procházet" a ve struktuře adresářů najděte adresář, kde máte nainstalovaný program Tardat a v něm označte soubor tardatd.exe. Stiskněte OK -> Další -> Dokončit.

Odebrání zástupce ze složky "Po spuštění"
Klikněte na tlačítko "Start" -> "Programy" -> "Po spuštění". klikněte pravým tlačítkem myši na položce tardatd.exe a z menu vyberte volbu "Odstranit".

Spuštění serveru na tomto PC
Z adresáře, ve kterém máte nainstalovaný program Tardat, spustťe program tardatd.exe

Ukončení programu
Klikněte levým tlačítkem myši v pravém dolním rohu na ikonu (obr). V okně serveru klikněte na tlačítko "Ukončit".

Ruční ovládání modulu tardats

Instalace služby
Z adresáře, ve kterém máte nainstalovaný program Tardat, spustťe program tardats.exe s parametrem /INSTALL

Odinstalování služby
Z adresáře, ve kterém máte nainstalovaný program Tardat, spustťe program tardats.exe s parametrem /UNINSTALL

Spuštění služby
Klikněte na "Start" -> "Nastavení" -> "Ovládací panely" -> "Nástroje pro správu" -> "Služby". V seznamu služeb najděte a označte položku "Malý webový server (TARDAT)". Na horní liště klikněte na ikonu "Spustit službu".

Zastavení služby
Klikněte na "Start" -> "Nastavení" -> "Ovládací panely" -> "Nástroje pro správu" -> "Služby". V seznamu služeb najděte a označte položku "Malý webový server (TARDAT)". Na horní liště klikněte na ikonu "Zastavit službu".


Malý webový server

Ovládání webového rozhraní

Ovládání internetového prohlížeče při přístupu k webového serveru ukazuje následující postup:

  1. Spustťe webový prohlížeč (MS IE, Netscape, Mozilla apod.)
  2. Do editačního políčka pro zadání URL (adresy požadované stránky) zadejte jméno nebo adresu počítače, ne kterém běží Tardat se spuštěným www serverem případně uveďte i název protokolu (http:) a číslo portu (:xxx). Uvedené informace musí souhlasit s konfigurací počítače a Tardatu.

    Příklady:

    192.168.1.15
    http://192.168.1.20:1080/

  3. Otevřete zadanou stánku (Enter).
  4. Jsou-li zadané informace správné, měl by se zobrazit dialog pro autorizaci uživatele do "sféry" Tardat. Do editačních políček zapište své uživatelské jméno, pod kterým se přihlašujete do Tardatu (ne síťové uživatelské jméno) a heslo do Tardatu. Místo celého jména můžete zadat jen písmeno odpovídající identifikačnímu číslo uživatele - to je uvedeno v editačním okně v konfiguraci uživatelů Tardatu.

    Příklad (MS IE 5):

    Server               localhost
Sféra                Tardat
Uživatelské jméno    B
Heslo                mojeheslo
  5. Hlavní stránka obsahuje seznam všech dostupných přehledů. Vyberte si jeden z nich a klikněte na něj myší (t.j. otevřete odkaz spojený s názvem přehledu).
  6. Zobrazí se zvolený přehled ve formě HTML stránky. Obsahuje-li datábáze příliš mnoho hovorů může příprava výstupu trvat dlouhou dobu.
  7. Tlačítkem Zpět nebo kliknutím na odkaz Zpět na hlavní stránku se vrátíte zpět na seznam přehledů.


Program Tardat

Nástroje pro správu konfigurace

Program Tardat obsahuje užitečné nástroje, které umožňují exportovat nebo importovat konfigurační tabulky do souboru a propojit tak tarifikační software s dalšími programy. Program umí zpracovat několik vstupních a výstupních formátů souborů, které lze dále modifikovat pomocí nastavitelných parametrů.

V tomto dokumentu jsou popsány nástroje, které pracují s celou konfigurací programu Tardat - provádí export nebo import tabulek a nástroj pro zálohování konfigurace. V textu jsou uvedeny také specifikace podporovaných formátů vstupních a výstupních souborů. U každé podkapitoly je uveden také popis ovládání nástrojů.

Obsah

  1. Import konfiguračních tabulek
  2. Formáty vstupních souborů
  3. Export konfiguračních tabulek
  4. Formáty výstupních souborů
  5. Záloha konfigurace
  6. Obnova konfigurace

Viz také:


Konfigurace - import konfigurace

Program Tardat

Import konfiguračních tabulek

Tento nástroj by měl řešit propojení programu Tardat v rovině konfigurace s jinými produkty, například podnikovým informačním systémem zákazníka. Pomocí této funkce je možné změnit vybrané části konfigurace podle vstupního souboru. Data mohou být uložena v několika formátech. V současné době je ve verzi 4.2 implementován vstupní filtr pro soubory dBase III (DBF) a textové soubory se středníkem jako oddělovačem (CSV).

Uživatelské rozhraní nástroje

Uživatelské prostředí nástroje má formu průvodce. Výběr otázek se liší podle zvoleného vstupního filtru. V levé části okna se zobrazuje stručný návod.

  1. V první řadě program zobrazí standardní dialogové okno pro otevření souboru a očekává zadání vstupního souboru. Výběr potvrďte tlačítkem Otevřít.

  2. Program se pokusí automaticky určit typ souboru a nabídne dialog pro zadání formátu vstupního souboru. Zadejte odpovídajcí formát vstupního souboru a stiskněte tlačítko Pokračovat.

  3. Program se dále ptá na použité kódování českých znaků.

  4. Zadejte, jaká data soubor obsahuje, tj. která konfigurační tabulka se má změnit

  5. Nastavují-li se pobočky nebo zúčtovací kódy a v programu je definována více než jedna ústředna, program umožní uživateli vybrat si ústřednu, která se bude modifikovat.

  6. V posledním kroku zadejte, co se má provést se stávajícími položkami v tabulce. Na výběr jsou tyto možnosti:

    • Stávající položky ponechat, podle souboru jen opravit jejich vlastnosti a přidat položky nové (vyhledává se podle klíče, tj. prvního sloupce ve vstupním souboru)
    • Všechny stávající položky nejdříve vymazat
    • Před zahájením importu se vymazat položky, jejichž identifikační čísla leží v zadaném rozsahu.


Konfigurace - vstupní formáty

Program Tardat

Formáty vstupních souborů

Každý formát souboru má svou hlavičku, ve které se specifikují názvy sloupců. Ty určují, do které proměnné data v daném sloupci patří. Vždy je nutné dodržet pojmenování sloupců, které je specifikováno v tabulce 3. Důležité je také pořadí sloupců.

Klíč

V každém formátu je určena jedna položka, která slouží jako klíč (bývá to první sloupec). Musí být vždy vyplněná. Při importu se podle klíče vyhledává mezi stávajícími položkami ta, jejíž hodnota klíče se shoduje s hodnotou uvedenou v souboru. Pokud taková položka existuje, opraví se podle dat ze souboru její vlastnosti. V opačném případě se vytvoří položka nová.

Příklad:

Jestliže v interním seznamu existují tyto položky:
   MASKA          JMÉNO
   0541414141     Petr Novák
   0223232323     Libor Novotný

a vstupní soubor má tvar (JMÉNO je klíč):
   JMÉNO          MASKA
   Libor Novotný  666
   Fax            999

pak po importu konfigurace se tabulka změní na:
   0541414141     Petr Novák
   666            Libor Novotný
   999            Fax

Má-li vstupní soubor tvar (MASKA je klíč):
   MASKA          JMÉNO
   0541414141     Libor Novotný
   999            Fax

pak výsledná tabulka bude vypadat takto:
   0541414141     Libor Novotný
   0223232323     Libor Novotný
   999            Fax

Formát DBF

Většina programů, které pracují s tabulkami dat, umožňuje zapsat nebo načíst data v tomto formátu. Z tohoto důvodu toto rozhraní umožňuje propojení s celou řadou programových produktů. Filtr je upraven tak, aby zpracoval i soubory neodpovídající přesně specifikaci formátu.

Protože soubor neobsahuje žádné informace o tom, jaký druh dat se v něm nachází, při importu se program zeptá, kam je mají data ze souboru uložit.

V uživatelském rozhraní je také možné nastavit použité kódovaní českých znaků, výběrem ze tří možností: kódová stránka 1250 (Windows), 859 (DOS) nebo kódování bří. Kamenických.

Formát CSV

Toto je jednoduché textové rozhraní. Výhodou tohoto formátu je, že je editovatelný běžným textovým editorem a snadno se programuje.

Jednotlivé věty databáze tvoří textové řádky, oddělené dvojicí znaků CR (13) a LF (10) nebo jen jedním znakem LF (10). Sloupce jsou navzájem odděleny středníkem. Je-li potřeba uložit do buňky znak středník, celý řetězec se uzavře do úvozovek nebo apostrofů. V případě, že je řetězec uzavřen v úvozovkách, pak znak úvozovky se zapisuje jako dvě bezprostředně následující úvozovky. Stejné pravidlo platí v případě apostrofů.

Reálná čísla zapisují se s desetinnou tečkou, logické hodnoty se zapisují ANO, A, TRUE, T pro "ano" a NE, N, FALSE, F pro "ne". Na velikosti písmen nezáleží.

Příklad:

tvar souboru ve formátu CSV pro import interního seznamu:

JMENO;MASKA;ZOBRAZIT;POZNAMKA
Tartek;43240402;T;Tartek pevná
"Libor Novotný";1234567;F;Libor pevná
"""Petr"" Novák";7654321;T;mobil

Program Tardat vyžaduje, aby v prvním řádku byla hlavička s názvy sloupců. Jejich pojmenování musí odpovídat specifikaci uvedené v následující tabulce.

Specifikace sloupců tabulek

Tabulka položek interního seznamu
Jméno | Význam | Poznámky
MASKA | Maska telefonního čísla. Zapisuje se stejně jako v editačním okně uživatelského prostředí programu Tardat. | povinná, klíč
JMENO | Jméno položky, které je možné uvádět v přehledu jako Detailní umístění. | klíč
ZOBRAZIT | Logická hodnota. Je-li nastavena na Ano, zobrazuje se jméno položky v přehledu. |
POZNAMKA | Libovolný text |
CISLO | Identifikační číslo - libovolné číslo od 0 do 65535, musí být jedinečné. Číslo 0 je vyhraženo pro položku "Ostatní čísla" (speciální položka, do které patří všechna telefonní čísla nevyhovující maskám ostatních položek). | klíč
Tabulka skupin poboček
Jméno | Význam | Poznámky
JMENO | Jméno skupiny | klíč, povinná
JMENO_FIRMY nebo FIRMA | Jméno firmy uváděné na faktuře | klíč
ADRESA | Adresa firmy (ulice + orient. číslo) |
MESTO | Město |
PSC | Poštovní směrovací číslo |
ICO | IČO |
DIC | DIČ |
BANK_SPOJ | Bankovní spojení |
POZNAMKA | Libovolný text |
CISLO | Identifikační číslo - libovolné číslo od 0 do 65535, musí být jedinečné. Číslo 0 je vyhraženo pro položku "Ostatní pobočky" (speciální položka, do které patří všechny pobočky nezařazené do jiné skupiny). | klíč
Tabulka poboček ústředny
Jméno | Význam | Poznámky
CISLO | Číslo pobočky v rozsahu 0 až 999999, musí být jedinečné. | klíč, povinná
JMENO | Jméno pobočky, libovolný text | klíč
SKUPINA | Identifikační číslo skupiny, do které pobočka patří | Uvádí se buď SKUPINA nebo JMEN_SKUP
JMEN_SKUP | Jméno skupiny, do které pobočka patří. | Uvádí se buď SKUPINA nebo JMEN_SKUP
UTAJENI | Logická hodnota. Je-li Ano, pak hovory na této pobočce se v přehledech neuvádějí. |
PRIPL_PODLE | Logická hodnota. Je-li Ano, pak příplatek pro hovory na této pobočce se počítá podle tabulky zúčtovacích kódů. |
PRIPL_PROC | Výše příplatku v procentech. Rozsah hodnot od -100 do +1023 %. |
MASK_PODLE | Logická hodnota. Je-li Ano, pak maskování tel. č. pro hovory na této pobočce se určuje podle tabulky zúčtovacích kódů. |
MASK_PROC | Typ maskování telefonních čísel. 0=Nemaskovat, 1=Zbytek; 2=Zbytek, max. 4; 3=vždy 1 místo; 4=vždy 2 místa; ... 8=vždy 6 míst |
AUTH_KOD | Autorizační kód - řetězec znaků 0-9ABCD max. délky 10 znaků |
POZNAMKA | Libovolný text |
Tabulka zúčtovacích kódů ústředny
Jméno | Význam | Poznámky
KOD | Zúčtovací kód, řetězec znaků 0-9ABCD*#, maximálně 16 znaků, musí být jedinečný. | klíč, povinná
JMENO | Jméno zúčtovacího kódu, libovolný text | klíč
PRIPL_PROC | Výše příplatku v procentech. Rozsah hodnot od -100 do +1023 %. |
MASK_PROC | Typ maskování telefonních čísel. 0=Nemaskovat, 1=Zbytek; 2=Zbytek, max. 4; 3=vždy 1 místo; 4=vždy 2 místa; ... 8=vždy 6 míst |
POZNAMKA | Libovolný text |


Konfigurace - export konfigurace

Program Tardat

Export konfigurace

Pomocí tohoto nástroje můžete exportovat vybrané konfigurační tabulky do souboru. Na výběr je několik výstupních formátů, které mají ještě řadu uživatelských nastavení, takže výstup je možné vložit do většiny existujících textových a tabulkových procesorů nebo uložit na databázový server, například MySQL.

Postup při vytváření výstupního souboru

  1. V programu Tardat vyberte z hlavní nabídky Nástroje volbu Export konfigurace.

  2. Na první stránce je zobrazen seznam všech dostupných konfiguračních tabulek. Označte tabulku, kterou chcete exportovat a stiskněte tlačítko Pokračovat.

  3. V dalším dialogu zvolte formát, v jakém mají být data do souboru uložena.

  4. Vyberte si požadováné kódování českých znaků.

  5. V dalším dialogu nastavte, které údaje bude výstupní soubor obsahovat. Obsah okna se liší podle zvoleného formátu výstupu, jednotlivé volby jsou pospsány v předchozí kapitole.

  6. Program Vás požádá o vyhledání adresáře, do kterého chcete soubor uložit, a o zadání jména souboru. Stisknutím tlačítka Uložit zahájíte exportování tabulky.

  7. Pokud proběhlo vše v pořádku, program vypíše počet uložených záznamů. V opačném případě se zobrazí chybové hlášení.


Konfigurace - výstupní formáty

Program Tardat

Specifikace formátů výstupních souborů

Současná verze programu Tardat obsahuje tyto výstupní filtry:

  • Prostý text - neformátovaný textový soubor s pevnou šířkou sloupců

  • CSV - textový soubor, jednotlivá pole jsou oddělena středníkem nebo jiným oddělovačem, každý záznam je na samostatném řádku. Filtr má velké množství nastavení, takže lze formát přizpůsobit konkrétním požadavkům.

  • stránka HTML - vytvoří jednoduchou stránku v jazyce HTML, která je zobrazitelná běžnými internetovými prohlížeči.

  • formát DBF - formát používaný některými relačními databázovými systémy (dBase, FoxPro). Lze jej otevřít také ve většině tabulkových procesorů.

  • příkazy SQL - soubor se sadou SQL příkazů. Pomocí konzoly lze tabulku nahrát na databázový server.

Export do prostého textu

Výstupní soubor obsahuje řádky, které jsou odděleny dvojicí znaků CR (13) a LF (10). Kódovaní českých znaků je volitelné, program podporuje kódovou stránku 1250 (Windows), 859 (DOS), ISO 8859-2 (Linux), kód bří Kamenických a výstup bez diakritiky.

Výstup může obsahovat záhlaví s názvem tabulky případně s popisy sloupců. Sloupce tabulky mají pevnou šířku. Soubor může být zakončen informačním řádkem, který obsahuje údaj o počtu záznamů, verzi programu s datem a časem vytvoření tabulky.

Soubor v tomto formátu můžete načíst do běžného textového editoru a vytisknout. Použijte písmo, které má pevnou šířku znaku, například Courier, aby bylo zachováno rozdělení sloupců.

Příklad:

Pobočky ústředny A

Číslo  Jméno pobočky     Skupina Jméno skupiny      Příplatek Maska
    15 Martin                  2 Obchodní oddělení          0 Nemaskovat
    16 Jitka                   3 Sekretariát                0 Nemaskovat
    17 Sekretářka              3 Sekretariát                0 Nemaskovat

Počet řádků: 3. Přehled vytvořil program TARDAT 3.6.3 dne: 31. 3. 2003 11:53.

Export do formátu CSV

Výstupní soubor obsahuje řádky, které jsou odděleny dvojicí znaků CR (13) a LF (10). Kódovaní českých znaků je volitelné, program podporuje kódovou stránku 1250 (Windows), 859 (DOS), ISO 8859-2 (Linux), kód bří Kamenických a výstup bez diakritiky. Narozdíl od předchozího případu nejsou šířky sloupců pevné, ale mezi jednotlivými sloupci je oddělovač, nejčastěji středník.

Výstup může obsahovat záhlaví s názvem tabulky případně s popisy sloupců. Soubor může být zakončen informačním řádkem, který obsahuje údaj o počtu záznamů, verzi programu s datem a časem vytvoření tabulky. Tyto údaje se uvádějí vždy do poznámky.

Filtr má velké množství parametrů uvedených v následujícím přehledu, které umožňují přizpůsobit výstup podle přání uživatele. Do všech uvedených polí lze vkládat také netisknutelné znaky, jako je tabulátor nebo nový řádek. Tyto znaky se uvozují vždy zpětným lomítkem bez ohledu na nastavení řídícího znaku. Přehled řídících sekvencí je v tabulce 4 .

  • pole jsou uzavřená do - znak nebo několik znaků, kterými začíná a končí každé pole, například úvozovky: "25";"Jan Novák"

  • jen řetězce - je-li tato volba zatržena, pak se uzavírají pouze textová pole, například 25;"Jan Novák"

  • řídící znak "escape" - pokud se v poli vyskytuje znak uzavírající pole, oddělující pole, ukončující řádek nebo řídící znak, pak se před takový znak vloží uvedený řídící znak, například zpětné lomítko: "Jan \"Honza\" Novák".

  • pole jsou oddělená - znak nebo několik znaků oddělující jednotlivá pole, například čárka: 25,Jan Novák

  • řádky jsou oddělené - znak nebo několik znaků oddělující jednotlivé záznamy,

  • poznámky začínají - znak nebo několik znaků, kterými začínají řádky s poznámkou (název tabulky, informační řádek, ...), například mřížka:
    # Pobočky ústředny A

Znaky | Význam
\n | nový řádek (dvojice CR+LF)
\t | tabulátor
\\ | zpětné lomítko (!)

Tabulka 4: Řídící sekvence formátu CSV

Příklad:

Jednotlivá pole mají být oddělená čárkou, uzavírají se vždy do apostrofů. Pokud se někde v řetězci vyskytuje apostrof, vloží se před něj druhý apostrof. Záznamy mají být na samostatných řádcích. Poznámky začínají mřížkou.

Výstupní filtr se nastaví takto:

Pole jsou uzavřená do: '
Jen řetězce          : ne
Řícící znak "escape" : '
Pole jsou oddělená   : ,
Řádky jsou oddělené  : \n
Poznámky začínají    : #

Ukázka výstupu (export poboček):

# Pobočky ústředny A
#
CISLO,JMENO,SKUPINA,JMEN_SKUP,PRIPL,MASK_TYP,AUTH_KOD,UTAJENI,POZNAMKA
'15','Martin','2','Obchodní oddělení','0','Nemaskovat','','N',''
'16','Jitka','3','Sekretariát','0','Nemaskovat','','N',''
'17','Sekretářka','3','Sekretariát','0','Nemaskovat','','N',''
# Počet řádků: 3. Přehled vytvořil program TARDAT 3.6.3 dne: 31. 3. 2003 11:56.

Export do jazyka HTML

Výstupní soubor obsahuje jednoduchou webovou stránku, na které je jednoduchá tabulka s daty, záhlavím a informačním řádkem. Kódovaní českých znaků je volitelné, program podporuje kódovou stránku 1250 (Windows), 859 (DOS), ISO 8859-2 (Linux), kód bří Kamenických a výstup bez diakritiky.

Výsledná stránka může obsahovat záhlaví s názvem tabulky. Také hlavička tabulky s popisy sloupců je volitelná. Soubor může být zakončen informačním řádkem, který obsahuje údaj o počtu záznamů, verzi programu s datem a časem vytvoření tabulky.

Příklad:

Pobočky ústředny Siemens 100E

Číslo | Jméno pobočky | Skupina | Jméno skupiny | Příplatek | Maska | Autor. kód | Utajení | Poznámka
15 | Martin | 2 | Obchodní oddělení | 0 | Nemaskovat |  | N |
16 | Jitka | 3 | Sekretariát | 0 | Nemaskovat |  | N |
17 | Sekretářka | 3 | Sekretariát | 0 | Nemaskovat |  | N |

Počet řádků: 3. Přehled vytvořil program TARDAT 3.6.3 dne: 31. 3. 2003 11:58.

Export do formátu dBase III (dbf)

U tohoto formátu se nastavuje pouze kódovaní českých znaků, program podporuje kódovou stránku 1250 (Windows), 859 (DOS), ISO 8859-2 (Linux), kód bří Kamenických a výstup bez diakritiky.

Výsledný soubor lze vložit do většiny tabulkových editorů a databázových systémů.

Příkazy SQL

Výstupní soubor obsahuje příkazy jazyka SQL, který podporuje většina databázových serverů. Kódovaní českých znaků je volitelné, program podporuje kódovou stránku 1250 (Windows), 859 (DOS), ISO 8859-2 (Linux), kód bří Kamenických a výstup bez diakritiky.

Výstup může obsahovat na začátku příkaz USE pro změnu databáze, příkaz DROP TABLE pro vymazání stávající tabulky a příkaz CREATE TABLE pro vytvoření nové tabulky a definici její struktury. Soubor může také v poznámce obsahovat název tabulky a informační řádek, který obsahuje údaj o počtu záznamů, verzi programu s datem a časem vytvoření tabulky.

Příklad:

USE `tardat`;

# Pobočky ústředny Siemens 100E
#

# Struktura tabulky pobockyA
DROP TABLE IF EXISTS `pobockyA`;
CREATE TABLE `pobockyA` (
  `CISLO` INT(6) NOT NULL,
  `JMENO` CHAR(64),
  `SKUPINA` INT(5),
  `JMEN_SKUP` CHAR(64),
  `PRIPL` INT(4),
  `MASK_TYP` CHAR(16),
  `AUTH_KOD` CHAR(10),
  `UTAJENI` CHAR(1),
  `POZNAMKA` CHAR(64));

# Data tabulky pobockyA
INSERT INTO `pobockyA` VALUES ("15","Martin","2","Obchodní oddělení","0","Nemaskovat","","N","");
INSERT INTO `pobockyA` VALUES ("16","Jitka","3","Sekretariát","0","Nemaskovat","","N","");
INSERT INTO `pobockyA` VALUES ("17","Sekretářka","3","Sekretariát","0","Nemaskovat","","N","");

#
# Počet řádků: 3. Přehled vytvořil program TARDAT 3.6.3 dne: 31. 3. 2003 11:59.


Nástroje - záloha konfigurace

Program Tardat

Záloha konfigurace

Pomocí tohoto nástroje lze jednoduše vytvořit zálohu konfiguračních souborů a tabulek programu Tardat. Konfigurační tabulky lze potom obnovit pomocí funkce Obnovení konfigurace.

Z nabídky Nástroje vyberte volbu Záloha konfigurace. Zobrazí se standardní dialog pro výběr souboru. Přejděte do adresáře, do kterého chcete vytvořit zálohu. Můžete také změnit jméno souboru. Potvrďte tlačítkem Uložit.


Nástroje - obnova konfigurace

Program Tardat

Obnova konfigurace

POZOR! Tato funkce provádí kopírování souborů z vybrané složky do adresáře, ve kterém máte nainstalovaný program Tardat. V případě, že záloha obsahuje konfiguraci jiné verze programu nebo je obsah souborů poškozen, může program Tardat přestat fungovat. Stávající soubory s konfigurací budou uloženy v souborech s příponou .tdz, ale jejich obnovení zpět může být pracné.

Následující postup ukazuje, jak obnovit konfiguraci ze zálohy programu Tardat, která je uložena v souboru C:\zalohy\td20052008.zip.

  1. Z nabídky Nástroje vyberte volbu Obnova konfigurace.

  2. Ve standardním dialogu pro výběr souboru vyberte adresář, který obsahuje zálohu souborů programu Tardat, v tomto případě adresář C:\Zálohy. Označte soubor se zálohou a potvrďte tlačítkem Otevřít.

  3. Zatrhněte části konfigurace, které chcete obnovit, a stiskněte tlačítko Pokračovat.

  4. Program Vás upozorní, že měníte konfiguraci programu a vyžaduje potvrzení. Do editačního pole napište text "OK" (bez úvozovek) a stiskněte tlačítko Obnovit. Tím zahájíte kopírování souborů.


Program Tardat

Nástroje pro správu databáze

V programu Tardat je implementována řada nástrojů umožňující správu databáze hovorů v programu Tardat. Nástroje jsou k dispozici v hlavní nabídce programu Tardat. Většina z nich je k dispozici pouze správci.

Obsah

  1. Archivace hovorů
  2. Zpětné zpracování databáze
  3. Zpětné zpracování souborů 'chybne'
  4. Zpracování dat ze souboru
  5. Vymazání duplicit
  6. Import hovorů ze souboru CSV

Viz také:


Nástroje - archivace hovorů

Program Tardat

Archivace hovorů

Tato funkce přesouvá bloky hovorů z databáze do souborů a zpět. Lze ji použít pro odstranění již nepotřebných záznamů, pro zálohování dat apod. Jeden blok je sada hovorů pořízených na jedné ústředně za jeden měsíc. Každému bloku dat odpovídá soubor v adresáři pro ukládání archívů. Jméno souboru je vytvořeno z identifikačního písmene ústředny, za kterým následuje rok a měsíc. Přípona souborů je .arc. Při přenosu záznamů se vždy kontrolují duplicity.


Nástroje - zpětné zpracování

Program Tardat

Zpětné zpracování

Po změně nastavení tarifikace je nutné přepočítat hovory v tabulce, tak aby cena hovorů odpovídala novému nastavení. K tomu slouží funkce "zpětné zpracování". Funkce pracuje se záznamy již uloženými v databázi, znovu provede jejich ocenění podle aktuálních konfiguračních a tarifních tabulek a výsledné záznamy opět uloží do databáze. Přepracovat lze kompletní obsah databáze nebo pouze hovory za vybrané období.


Nástroje - zpracování souboru 'chybne.txt'

Program Tardat

Zpracování souboru 'chybne.txt'

Pokud je v konfiguraci ústředny chybně nastaven formát tarifního řádku (tj. výrobce a typ ústředny), modul zpracování tarifním datům nerozumí a ukládá je do zvláštního souboru. Pro první ústřednu je to soubor pachybne.txt v podadresáři PBX.A, pro druhou ústřednu je to soubor pbchybne.txt v podadresáři PBX.B atd.

Otevřete konfiguraci ústředny, stiskněte tlačítko Změna formátu, vyberte výrobce ústředny a její typ. U některých typů se ještě dále rozlišují formáty podle verze firmware apod. Nové nastavení uložte, v nabídce Nástroje vyberte položku Zpětné zpracování a v podnabídce klikněte na ... souboru "chybné.txt". V průvodci...


Nástroje - zpracování dat ze souboru

Program Tardat

Zpracování dat ze souboru

Máte-li tarifní data z ústředny uložena v souboru, můžete použít tuto funkci pro jejich zpracování. V konfiguraci ústředny musí být nastaven správný formát tarifního řádku (tj. výrobce a typ ústředny). Pro zpracování elektronických výpisů hovorů ve formátu CSV použijte funkci "Import hovorů ze souboru CSV".


Nástroje - vymazání duplicit

Program Tardat

Vymazání duplicit

Tento nástroj slouží k vymazání duplicitních záznamů z databáze. Dva záznamy se považují za duplicitní, pokud pochází ze stejné ústředny, mají shodný datum a čas zahájení, stejný typ a číslo zdroje a cíle (pobočka + linka), délku trvání, počet jednotek, a shoduje se také volané číslo předané z ústředny, zúčtovací a uživatelský kód.


Nástroje - import dat ze souboru CSV

Program Tardat

Import dat ze souboru CSV

Pomocí tohoto nástroje může uživatel vložit do databáze programu elektronický výpis od provozovatele. Tarifní data musí být uložena v textovém souboru v jednom z podporovaných formátů. Záznamy se do databáze vloží jako běžné hovory, neprovádí se dohledávání odpovídajících záznamů v tarifních datech získaných z pobočkové ústředny, taková funkce by byla velice složitá.

Ze vstupního souboru se převádí datum a čas zahájení hovoru, délka trvání, volané číslo, cena hovoru. U některých formátů lze také použít telefonní číslo volajícího, které se obvykle převádí na číslo pobočky.

Zpracování vstupního souboru

  1. Spusťte program Tardat, otevřete nabídku Nástroje a vyberte volbu Import dat ze souboru CSV.

  2. V dialogu stiskněte tlačítko Vyhledat a ve standardním dialogu vyhledejte soubor s elektronickým výpisem od provozovatele. Soubor označte a dialog potvrďte tlačítkem Otevřít.

  3. Ve výběrovém poli vyberte formát souboru (rozlišeno podle názvu provozovatele).

  4. Je-li v konfiguraci programu nastaveno více pobočkových ústředen, zkontrolujte, že ve výběrovém poli je označena ústředna, ke které mají být data přiřazena. U některých formátů je nutné zadat také číslo pobočky, ke které budou hovory přiřazeny.

  5. Tlačítkem Provést zahájíte zpracování dat. Po dokončení procesu program informuje o počtu nalezených hovorů. Řádky, které neodpovídají nastavenému formátu se uloží s příslušným chybovým hlášením do souboru, který má stejné jméno jako vstupní souboru, ale přípona má .err.

Nastavení formátu

Nastavení formátu pro import ze souboru CSV je zcela nezávislé na aktuálním nastavení formátu tarifního řádku pro modul zpracování. Konfigurační tabulky jsou společné pro všechny ústředny. Pro nastavení formátu můžete použít dialog Pro odborníky v dialogu pro konfiguraci ústředny, záložka Import hovorů.

Tato záložka je dále rozdělena na tři sekce, každá z nich slouží pro nastavení jedné konfigurační tabulky. První tabulka, Formáty záznamů, slouží k definici formátů řádků v souborech CSV. Každý záznam v tabulce obsahuje několik parametrů:

  • Jméno operátora (formátu) - jméno formátu, které se zobrazuje v dialogovém okně nástroje pro import hovorů, obvykle odpovídá jménu operátora.

  • Počet polí - počet polí v řádku. Počet řádků musí být dodržen, jinak je řádek prohlášen za neplatný.

  • Oddělovač polí - znak, který odděluje jednotlivá pole, obvykle středník.

  • Určení volajícího - způsob, jakým se určuje číslo pobočky, ke které se mají hovory ze souboru přiřadit. Maskou - telefonní číslo volajícího nebo jeho část, tabulkou - pobočka se určí zvláštní tabulkou (viz přiřazení volajícího) nebo ručně - při importu se program zeptá na číslo pobočky.

  • Pozice id. volajícího - pořadí pole, ve kterém se nachází identifikace volajícího, počítáno od 1. Nepoužívá se v případě, že způsob určení volajícího je nastaven na ručně.

  • Počet číslic volajícího - používá se v případě, že způsob určení volajícího je nastaven na maskou. Program přečte řetězec ze souboru, který je v řádku uveden na pozici dané předchozím parametrem a zkrátí jej na zadaný počet míst zprava. Výsledek se použije jako číslo pobočky.

  • Určení linky - způsob, jakým se určuje číslo linky, ke které se mají hovory přiřadit. Maskou - telefonní číslo volajícího nebo jeho část nebo tabulkou - pobočka se určí zvláštní tabulkou (viz přiřazení linek).

  • Pozice id. linky - pořadí pole, ve kterém se nachází identifikace linky, počítáno od 1.

  • Počet číslic linky - používá se v případě, že způsob určení linky je nastaven na maskou. Program přečte řetězec ze souboru, který je v řádku uveden na pozici dané předchozím parametrem a zkrátí jej na zadaný počet míst zprava. Výsledek se použije jako číslo linky.

  • Pozice data volání - pořadí pole, ve kterém se nachází datum zahájení hovoru.

  • Pozice času volání - pořadí pole, ve kterém se nachází čas zahájení hovoru, u některých formátů je totožné s pořadím pole datum.

  • Pozice volaného čísla - pořadí pole, ve kterém se nachází volané telefonní číslo.

  • Pozice délky trvání - pořadí pole, ve kterém je zapsána informace o délce trvání hovoru.

  • Pozice ceny - pořadí pole, ve kterém je zapsána cena hovoru.

  • Pozice uživatelského kódu - pořadí pole s doplňkovou informací o hovoru. U formátu Eurotel se používá pro rozlišení hovorů (TEL) a krátkých textových zpráv (TEXT).

Na druhé záložce lze nastavit překladovou tabulku, která převádí identifikaci volajícího, obvykle telefonním číslem, na číslo pobočky. Chcete-li používat tuto tabulku, je nutné nastavit způsob určení volajícího na tabulkou. Konfigurační tabulka obsahuje dva parametry: maska telefonního čísla, která se skládá z číslic a dalších znaků povolených v telefonním čísle (0123456789ABCD#*). Řídícími znaky jsou: Čárka oddělující dva výrazy s významem NEBO, otazník nahrazuje libovolný znak a znaky uzavřené v hranaté závorce nahrazují jeden ze znaků uvedených v závorce. Druhým parametrem je výsledné číslo pobočky. Tabulka se prochází bez ohledu na pořadí, hledá se vždy největší shoda. Pravidla jsou podobná jako u tabulky přístupových kódů.

Na třetí záložce se nastavuje překladová tabulka, která přiřazuje k hovoru číslo linky. Má stejný formát jako předchozí tabulka. Obvykle obsahuje jediný řádek s maskou "?", což znamená, že všechny hovory budou přiřazeny k jedné odchozí lince (hovory z jednotlivých mobilů se rozlišují pomocí pobočky).


Nástroje pro správu databáze

Program Tardat

Rozšiřující moduly

V této kapitole jsou soustředěny popisy nástrojů, které nelze logicky přiřadit k jedné z předchozích kapitol.

Obsah

  1. Minihotelový provoz

Viz také:


Nástroje - archivace hovorů

Program Tardat

Minihotelový provoz

Tento modul umožňuje účtování telefonních hovorů v malých hotelích a penzionech, pacientům v nemocnicích apod. Pomocí programu Tardat se při příchodu hosta zapíše do systému datum a čas příchodu a jeho iniciály. V okamžiku, kdy host odchází, program vypočítá na základě aktuálního obsahu databáze hovorů celkovou provolanou částku na všech pronajatých pobočkách a vytiskne jednoduchou účtenku, která může obsahovat detailní výpis hovorů.

Nastavení

Před použitím funkce je nutné v konfiguraci ústředen nastavit, které pobočky jsou k dispozici na hotelových pokojích. V editačním dialogu pobočky se zatrhne volba Pobočka hotelového provozu. U ikony v tabulce poboček jsou tyto položky označeny zeleným písmenem "H".

Dále je potřeba nastavit údaje uvedené na účtence. To lze provést v programu Tardat buď pomocí okna přehled (funkce Tisk účtenky, tlačítko Nastavení) nebo při tisku první účtenky z hotelového systému (tlačítko Nastavení v náhledu před tiskem). Nastavení je pro obě funkce společné.

Pozn.: Konfigurace hotelového provozu v programu Tardat 4 se liší od programu Tardat 3, ve kterém byl pro nastavení provozu zvláštní dialog v okně nástroje.

Příchod hosta

Při příchodu hosta se zapíše jeho příchod do systému. K tomu slouží jednoduchý dialog spouštěný z dialogového okna nástroje.

  1. V hlavní nabídce programu Tardat otevřete nabídku Nástroje a klikněte na položku Minihotelový provoz.

  2. Stiskněte tlačítko Příchod hosta.

  3. Na první stránce průvodce je zobrazen aktuální datum a čas v počítači. Pokud je host zapsán dodatečně, je možné v tomto kroku změnit datum a čas jeho příchodu, které je rozhodující pro to, které hovory jsou započítány na výsledné účtence. Potvrďte tlačítkem Pokračovat.

  4. Na další stránce jsou umístěny editační pole pro vložení základních údajů o hostovi, tyto údaje budou vytisknuty na účtence. Povinné pole je pouze jméno, ostatní položky není nutné vyplňovat. Stiskněte tlačítko Pokračovat.

  5. V tabulce zatrhněte pokoje, které si host pronajal. Určíte tím pobočky, které budou zahrnuty do hotelového účtu. V tabulce jsou zobrazeny pouze pobočky, které mají ve své konfiguraci nastavenu volbu Pobočka hotelového provozu a zároveň nejsou přiřazeny k jinému hotelovému účtu.

  6. Tlačítkem Uložit vytvoříte nový hotelový účet. Stiskněte tlačítko Zavřít pro ukončení dialogu a návrat zpět do hlavního okna nástroje.

Aktuální stav hotelového provozu

V tabulce Otevřené účty jsou zobrazeny jména hostů pro všechny aktivní (tj. neuzavřené) účty. Druhá tabulka, Obsazenost pokojů, zobrazuje přehledně, které pobočky jsou přiřazeny k hotelovým účtům. Šedou barvou písma jsou vyznačeny neobsazené pobočky.

Aktuální provolanou částku lze zobrazit výběrem odpovídající položce v tabulce účtů nebo pokojů a stiskem tlačítka Zjistit stav. Pro změnu nastavení účtu je k dispozici editační dialog (tlačítko Editovat).

Odchod hosta

  1. V hlavní nabídce programu Tardat otevřete nabídku Nástroje a klikněte na položku Minihotelový provoz.

  2. Stiskněte tlačítko Odchod hosta.

  3. Na první stránce průvodce je zobrazen aktuální datum a čas v počítači. Zkontrolujte datum a čas odchodu a nastavení potvrďte tlačítkem Pokračovat. Datum a čas příchodu a odchodu je rozhodující pro výběr hovorů, které budou zahrnuty do výpočtu provolané částky.

  4. Podle jména hosta klikněte na hotelový účet, který chcete vyúčtovat a uzavřít. V tabulce jsou zobrazeny pouze aktivní (tj. neuzavřené) účty.

  5. Po potvrzení program provede výpočet celkové provolané částky a připraví účtenku. Celková provolaná částka, zaokrouhlená podle pravidla zadaného v nastavení účtenky, je uvedena v dialogovém okně. Stiskněte odpovídající tlačítko podle toho, zda chcete nebo nechcete vytisknout účtenku.

  6. Program se dále uživatele ptá, zda si přeje označit hovory za vyúčtované. Pokud stisknete odpověď Ano, pak program změní u všech hovorů, které byly zahrnuty k tomuto účtu, příznak vyúčtován. Tento příznak lze zobrazit v detailních přehledech.

  7. Stiskněte tlačítko Zavřít pro ukončení dialogu a návrat zpět do hlavního okna nástroje.

Deník hotelového provozu

Záznamy o aktivních i uzavřených účtech se ukládají v databázi do dvou tabulek, hotel a hotelpob. První tabulka obsahuje údaje o hostech, datum a čas příchodu, jména osob, která provedli zápis hosta a jeho vyúčtování a také výslednou provolanou a zaplacenou částku. Aktivní účty mají v poli odchod hodnotu NULL. Druhá tabulka určuje přidělení poboček k hotelovým účtům. Tyto údaje zůstávají v tabulce pro uživatelské použití (výpisy, statisktiky apod.)


Přístroj Tarflex-E

Tarflex-E je univerzální inteligentní zálohovaná paměť se síťovým rozhraním sloužící k nepřetržitému a spolehlivému zaznamenávání dat. Po více než deseti letech zkušeností s vývojem a výrobou zálohovacích zařízení přicházíme s moderním přístrojem, který je oproti předchozímu typu výrazně menší, lehčí a především obsahuje zcela nový, moderní způsob komunikace.

Tato příručka je návodem k instalaci a použití přístoje Tarflex-E, její obsah je systematicky rozdělen do několika kapitol. V této úvodní části jsou popsány všechny vlastnosti přístroje a jeho rozhraní, záruční a licenční podmínky. V druhé kapitole najdete stručný návod na uvedení bufferu do provozu a instalaci obslužných programů. Podrobný popis všech funkcí přístroje a také podrobný návod na ovládání obslužných programů najdete v elektronickém manuálu, který je součástí přiloženého CD.

Těší nás, že jste dali důvěru našemu produktu a věříme, že budete s jeho užíváním maximálně spokojeni.

Obsah

  1. Úvod
  2. Instalace přístroje a programů
  3. Techická specifikace
  4. Konfigurace bufferu pomocí programu Telnet

Viz také:

  • Program Tarflex
  • Konektory a kabely


Přístroj Tarflex-E - úvod

Přístroj Tarflex-E

Úvod

Vlastnosti přístroje

Přístroj Tarflex-E je vybaven sériovým rozhraním RS-232 pro příjem vstupních dat z pobočkové ústředny, měřícího přístroje apod. Vstupní port má volitelnou rychlost v rozmezí od 300 Bd až do 38400 Bd. Přicházející data jsou indikována žlutou LED diodou (DTA) na předním panelu. Sériové rozhraní je obousměrné, lze tedy do připojeného zařízení znaky i vysílat. Přijatá data přístroj nepřetržitě ukládá do vnitřní paměti v binární podobě. Na výstupu je tedy přesný obraz dat ze vstupu a to zajišťuje naprostou univerzálnost nasazení tohoto přístroje.

Vnitřní paměť přístroje má kapacitu 1 MB, která je zálohována lithiovým článkem. Stav zaplnění paměti je indikován osmi barevnými LED diodami na předním panelu přístroje (0 % až 100 %). Po naplnění 75 % celkové kapacity paměti přístroj vydává krátké pípnutí jednou za 2 s a může také odeslat varovnou zprávu pomocí elektronické pošty. Po zaplnění celé paměti přístroj vydává krátké pípnutí v intervalu 1 s. Přístroj umožňuje obnovit celý obsah vnitřní paměti, v případě potřeby je tedy možné znovu přečíst i data, která již byla označena ke smazání.

Tarflex-E lze jednoduše zapojit do počítačové sítě a plně s ním po této síti komunikovat. Přes toto rozhraní je možné stahovat data a konfigurovat přístroj nejen po lokální síti, ale také po internetu odkudkoliv na světě. K přenosu dat lze použít standardní protokol POP3 pro elektronickou poštu, případně protokol TarWin, navržený speciálně pro náš buffer. K uloženým záznamům v přístroji je tedy možné přistupovat pomocí programu pro příjem elektronické pošty - buffer umí pracovat jako poštovní server (POP3), tzn. dokáže data připravit a odeslat jako přílohu v elektronické poště.

Tarflex-E může pracovat také jako poštovní klient - buffer dokáže při zaplnění vnitřní paměti, výskytu sledovaného textu v přijatých datech nebo změně signálu na vstupním konektoru odeslat zprávu elektronickou poštou protokolem SMTP.

Tarflex-E je napájen pomocí externího síťového napáječe, který je součástí dodávky. Při výpadku napájení je zajištěno interními akumulátory přijímání a ukládání dat do paměti po dobu nejméně 24 hodin. Data v paměti jsou navíc zajištěna pomocí lithiových článků minimálně po dobu 3 let. Po opětovném připojení napájení se přístroj uvede automaticky do provozu. Přístroj je konstruován pro nepřetržitý provoz a má nízkou spotřebu elektrické energie, což zajišťuje minimální provozní výdaje.

Obslužné programy

Zakoupením přístroje jste získali také licenci k programu Tarflex, což je jednoduchý grafický nástroj určený pro nastavení a otestování parametrů bufferu v prostředí MS Windows, a také licenci k programu Tarwin, který slouží k bezpečnému přenosu dat z paměti bufferu do počítače.

Instalační balíčky obou programů najdete na přiloženém CD; aktuální verze obou programů jsou k dispozici na internetových stránkách výrobce. V kapitole Instalace této příručky je uveden stručný návod na instalaci a ovládání programů. Detailní popis všech funkcí najdete v podrobném elektronickém manuálu na CD.

Záruční podmínky

  1. Na kompletní dodávku poskytuje výrobce záruku 24 měsíců. Podmínkou vzniku nároku na záruku je řádné vyplnění záručního listu.

  2. Záruka se vztahuje na bezvadný chod přístroje a programů, přičemž bezvadným chodem se rozumí chod v souhlasu s touto dokumentací.

  3. V době záruky se výrobce zavazuje bezplatně odstranit poruchy přístroje nebo programů způsobené výrobní závadou nebo vadným materiálem. Záruční doba se prodlužuje o dobu, po kterou byl výrobek v opravě.

  4. Oprávnění na záruční opravu zaniká v případě, že výrobek je obsluhován v rozporu s obsahem tohoto návodu, nebo byl na přístroji proveden zákrok uživatelem, případně jinou neoprávněnou osobou. Oprávnění na záruční opravu se také nevztahuje na vady, které uživatel způsobil nevhodnou dopravou či umístěním nebo skladováním ve vlhkém, prašném, chemicky agresívním nebo jinak nevhodném prostředí. Dále se oprávnění na záruční opravy nevztahuje na závady vzniklé vniknutím cizích látek do výrobku (voda apod.) a také na závady vzniklé výjimečnou událostí (např. poškození bleskem).

  5. Výrobce neručí za bezvadný chod přístroje v případě, že nejsou dodrženy technické podmínky uvedené v této dokumentaci, nebo je přístroj připojen k zařízení, které není kompatibilní se standardy rozhraní uvedenými v části "Technická specifikace".

  6. Výrobce neručí za bezvadný chod obslužných programů v případě, že jsou provozovány na technice, která není kompatibilní se standardem IBM PC nebo jsou provozovány na jiných operačních systémem než je uvedeno v této dokumentaci.

  7. Prodejce je povinnen řádně vyplnit záruční list v době prodeje výrobku. Neúplný nebo měněný záruční list je neplatný.

  8. Pokud bude zjištěno, že poškození neodpovídá záručním podmínkám, hradí náklady na takovou opravu majitel výrobku.

  9. Výrobce neručí za jakékoliv škody způsobené použitím přístroje nebo programů, pokud byly použity v rozporu s touto dokumentací nebo vznikly následkem předem nedefinované události.

Licenční podmínky

  1. Zakoupením přístroje Tarflex-E získává kupující licenci na použití programů (programového díla) Tarflex a Tarwin. Uživatel se stává majitelem licence dnem zakoupení přístroje. Uživatel přestává být majitelem licence v případě, že o to písemně požádá výrobce.

  2. Instalací programů uživatel vyjadřuje svůj souhlas s plným zněním licenčních a záručních podmínek tak, jak jsou uvedeny v této dokumentaci.

  3. Uživatel je oprávněn používat programy pouze k nastavení a obsluze přístroje Tarflex-E. Použití programů k obsluze jiného zařízení je porušením licenčních podmínek.

  4. Uživatel se zavazuje používat programy tak, aby nedošlo k porušení či ohrožení autorských práv výrobce.

  5. Uživatel smí pořizovat archívní kopie programů a instalačního CD pouze pro potřeby archivace a vytvoření záložních kopií.

  6. Uživatel nesmí poskytnout programy osobě, která není majitelem licence, bezplatně ani za úplatu.

  7. Uživatel nesmí provádět žádné změny do programů ani provádět zpětný překlad programů.

Obsah dodávky

  • Přístroj Tarflex-E

  • Napájecí adaptér

  • CD s programy a elektronickým manuálem

  • Návod k obsluze

  • Kabel pro připojení vstupního zařízení. (Pokud nebylo při objedání dohodnuto jinak, dodáváme standardně kabel s konektory RJ-10 a CAN DB-9V.)

Technické podmínky pro provoz přístroje

  • Přístroj je určen pouze pro vnitřní prostředí.

  • K napájení přístroje musí být použit síťový adaptér, který je součástí dodávky.

  • Nevystavujte přístroj teplotám nižším než 10 °C nebo vyšším než 40 °C. Nevystavujte přístroj příliš prašnému, vlhkému nebo chemicky agresívnímu prostředí.

Neprovádějte demontáž síťového napáječe. Po jeho otevření by mohlo dojít k dotyku životně nebezpečného napětí!

Přístroj obsahuje vestavěný lithiový článek a NiMH akumulátory. Pro výměnu článků nebo akumulátorů se obraťte na výrobce.

Požadavky na vybavení počítače pro provoz programů

Programy Tarwin a Tarflex vyžadují pro provoz minimálně:

  • osobní počítač s procesorem Pentium 150 MHz

  • operační systém počítače či stanice sítě Microsoft Windows 98 SE, 2000, NT, ME

  • operační paměť 64 MB

  • volné místo na pevném disku 10 MB

  • myš nebo jiné kompatibilní polohovací zařízení

  • připojení do počítačové sítě

  • podpora protokolu TCP/IP


Přístroj Tarflex-E - instalace přístroje a programů

Přístroj Tarflex-E

Instalace přístroje a programů

V této kapitole je popsáno, jak uvést přístroj do provozu a jak nainstalovat obslužné programy.

Uvedení přístroje do provozu

Přední panel přístroje Tarflex-E

Přední panel přístroje Tarflex-E

Zadní panel přístroje Tarflex-E

Zadní panel přístroje Tarflex-E

  1. Zapojte adaptér do konektoru na zadní straně přístroje. Adaptér zapojte do elektrovodné sítě 220 V. Na přední straně přístroje se krátce rozsvítí celý displej a ozve se krátké pípnutí. Pokud se místo krátkého pípnutí ozve pípání morseovkou "CERR", byla při startu zjištěna závada v harwarovém nebo programovém vybavení a přístroj je nutné opravit.

  2. Na displeji zůstane trvale svítit zelená kontrolka napájení. Pokud by došlo k odpojení napájecího adaptéru, bude tato kontrolka blikat a přístroj bude vydávat varovný akustický signál v intervalu asi 2 s. Po odpojení adaptéru je možné přístroj úplně vypnout zasunutím tenkého předmětu do úzkého otvoru na spodní straně přístroje.

  3. Pokud je připojen napájecí adaptér a na přední straně přístroje svítí zelená kontrolka napájení, připojte buffer do počítačové sítě. Konektor pro připojení je na zadní straně přístroje a pokud je vše v pořádku, rozsvítí se na tomto konektoru levá oranžová kontrolka (při 10Mb síti) nebo levá i pravá kontrolka (při zapojení do 100Mb sítě).

  4. V případě, že nebylo při objedání přístroje dohodnuto jinak, je buffer z výroby nastaven takto:

    5. Síťové rozhraní:
IP adresa | 192.168.1.253
Adresa brány | není
Maska sítě | 255.255.255.0
Sériové rozhraní:
Rychlost | 9600 Bd
Délka slova | 7 b
Řízení toku dat | žádné

    Sledovaný řetězec v přijímaných datech a e-mailové adresy pro odesílání hlášení nejsou definovány.

    Výše uvedené parametry lze změnit pomocí programu Tarflex. Způsob prvotního nastavení přístroje je uveden dále.

Instalace programu Tarflex

Program Tarflex je jednoduché grafické rozhraní pro nastavení síťových parametrů a parametrů vstupního portu bufferu. V případě, že jste se s výrobcem dohodli na přednastavení parametrů a nastavení nepotřebujete měnit, není nutné, abyste tento program instalovali.

Máte-li připojení k internetu, doporučujeme stáhnout a nainstalovat nejnovější verzi programu, která je dostupná na www stránkách výrobce.

Instalace z CD:

  1. Do CD mechaniky Vašeho počítače vložte přiložené instalační CD. Automaticky se zobrazí úvodní stránka. Klikněte na ikonu TARFLEX-E v levé části okna. V seznamu akcí označte položku Nainstalovat program Tarflex a stiskněte tlačítko Provést. V případě, že se úvodní stránka nezobrazí, spusťte ručně instalační program Tarflex-instal.exe z adresáře Tarflex na CD.

  2. Postupujte podle pokynů uvedených v průvodci instalací programu.

Instalace z internetu:

  1. Z internetových stránek výrobce (www.tartek.cz) ze sekce Ke stažení stáhněte instalaci programu Tarflex.

  2. Spusťte instalační program Tarflex-instal.exe

  3. Postupujte podle pokynů uvedených v průvodci instalací programu.

Konfigurace přístroje pomocí programu Tarflex

  1. Spusťte program Tarflex (Nabídka Start -> Programy -> Tarflex -> Tarflex). Zobrazí se úvodní formulář, do kterého uveďte IP adresu ovládaného bufferu. Potvrďte tlačítkem Připojit.

    Pokud není IP adresa známa nebo nesouhlasí s nastavením sítě, stiskněte nejprve tlačítko Vyhledat a program vyhledá všechny dostupné přístroje ve Vaší síti. Podle MAC adresy (uvedena na štítku na spodku přístroje) vyberte zařízení, které chcete nastavit a stiskněte tlačítko Připojit.

  2. Program se pokusí navázat spojení s bufferem. V případě, že buffer není v síti dostupný (jeho síťová adresa nesouhlasí s nastavením sítě), program upozorní uživatele hlášením Nepodařilo se připojit buffer s adresou "xx-xx-xx-xx-xx" a nabídne uživateli možnost změnit síťové parametry bufferu.

  3. Po navázání komunikace s přístrojem Vás program požádá o autorizaci. Zadejte uživatelské jméno a přístupové heslo, které jsou zapsány v konfigurační tabulce bufferu a potvrďte tlačítkem OK. Pokud nebylo při objednávce dohodnuto jinak, je přístroj z výroby nastaveno takto:

    Uživatelské jméno: admin
    Heslo: výrobní číslo bufferu

  4. Otevře se formulář s nabídkou funkcí. Při prvotní konfiguraci přístroje postupujte následujícím způsobem:

  5. Pokud jste nenastavili síťové parametry v bodě 2, stiskněte tlačítko Změnit IP adresu a parametry sítě. Ve formuláři vyplňte požadovanou IP adresu, masku sítě, případně adresu brány síťového rozhraní bufferu. Nastavení potvrďte tlačítkem Uložit.
    Příklad:
    Nová IP adresa | 192.168.1.20
    Síťová maska | 255.255.255.0
    IP adresa brány | (žádná)

  6. V nabídce funkcí dále stiskněte tlačítko Změnit konfiguraci bufferu. V dialogu nastavte požadované parametry vstupního portu, které musí odpovídat parametrům připojeného zařízení, které bude připojeno na vstup bufferu, zejména rychlost komunikace.

  7. Tlačítkem Další přejdete na další stránku dialogu. Nastavení elektronické pošty zatím neměňte a nastavení uložte tlačítkem Uložit.

Bližší popis všech položek nastavení najdete v elektronickém manuálu, který je součástí přiloženého CD. V případě pochybností se podívejte také do dokumentace k připojenému zařízení.

  • Obnovení dat v paměti bufferu - tato funkce umožňuje obnovit celý obsah vnitřní paměti bufferu, takže při dalším přenosu se přečte celý obsah vnitřní paměti, včetně dat, která již byla přenesena. Funkce se používá v případě, kdy při havárii počítače došlo ke ztrátě dat - uživatel pak může znovu přečíst poslední 1 MB dat (což při průměrné délce záznamu 100 B představuje přibližně 10.000 záznamů).

  • Přenos data z bufferu - pomocí této funkce můžete přenést data z paměti bufferu a uložit je do souboru na disk počítače.

Připojení přístroje k zařízení

Připojte ke vstupnímu portu bufferu zařízení, ze kterého se mají přijímat data. Vyvolejte funkci zařízení, která pošle do bufferu nějaká data. Na pobočkové ústředně zahájením a ukončením nějakého hovoru.

Pokud je zachycen alespoň jeden znak, rozsvítí se na předním panelu bufferu zelená LED dioda u zaplnění 1 %. V okamžiku, kdy přicházejí data na vstupní port, navíc poblikává žlutá kontrolka DTA.

Vyzkoušení funkčnosti pomocí programu Tarflex

  1. Z libovolného PC připojeného do sítě zkuste pomocí příkazu Ping na IP adresu bufferu, zda je buffer správně přihlášen do sítě.

  2. Na připojeném zařízení vyvolejte funkci, která způsobí odeslání dat do bufferu. Například na pobočkové ústředně zahájením a ukončením hovoru. Během přenosu dat do bufferu by měla poblikávat žlutá LED dioda (DTA) na předním panelu přístroje. Pokud byl přenesen a uložen alespoň jeden byte, rozsvítí se zelená LED dioda (1 % zaplnění).

  3. Spusťte program Tarflex, připojte se k bufferu stejným způsobem jako při konfiguraci a v hlavní nabídce stiskněte tlačítko Stáhnout data z bufferu. V dialogovém okně zadejte jméno cílového souboru, například test.txt. Potvrďte tlačítkem Uložit. Program naváže komunikaci s bufferem a stáhne nová data z jeho paměti a uloží je do zadaného souboru.

  4. Po skončení přenosu zhasne zelená LED dioda (1 % zaplnění), což znamená, že paměť přístroje je prázdná.

  5. Otevřete soubor test.txt v libovolném textovém editoru (např. Poznámkový blok) a zkontrolujte, že soubor obsahuje očekávaný text, například u pobočkové ústředny záznam o uskutečněném hovoru).

Instalace programu Tarwin

Program Tarwin je určen pro bezpečné stahování dat z paměti bufferu do souboru. V případě, že budete přenášet data z bufferu jiným způsobem, není nutné abyste tento program instalovali.

Máte-li připojení k internetu, doporučujeme stáhnout a nainstalovat nejnovější verzi programu, která je dostupná na www stránkách výrobce.

Instalace z CD:

  1. Do CD mechaniky Vašeho počítače vložte přiložené instalační CD. Automaticky se zobrazí úvodní stránka. Klikněte na ikonu TARFLEX-E v levé části okna. V seznamu akcí označte položku Nainstalovat program Tarwin a stiskněte tlačítko Tarwin-instal.exe z adresáře Tarwin na CD.

  2. Postupujte podle pokynů uvedených v průvodci instalací programu.

Instalace z internetu:

  1. Z internetových stránek výrobce (www.tartek.cz) ze sekce Ke stažení stáhněte instalaci programu Tarwin.

  2. Spusťte instalační program Tarwin-instal.exe

  3. Postupujte podle pokynů uvedených v průvodci instalací programu.

Stahování dat pomocí programu Tarwin

Program Tarwin periodicky stahuje data z paměti bufferu a ukládá je do souboru na disk. Pro přenos používá bezpečený protokol, který byl navržený speciálně pro buffery Tarflex.

Celý program se sestává ze tří modulů: Aplikace Tarwin, která se nejčastěji spouští při startu počítače ze složky Po spuštění a pracuje jako běžná aplikace na pozadí (běh je indikován ikonou na systémové liště). Pro operační systémy Windows NT4, 2000 a XP je k dispozici také modul Tarwins, který pracuje jako služba systému a je spuštěný i tehdy, pokud na počítači není nikdo přihlášen. Aplikace Tarkonfig je grafický uživatelský nástroj, který slouží pro nastavení programu.

Následující postup ukazuje, jak nastavit periodické stahování dat z paměti bufferu pomocí programu Tarkonfig.

Konfigurace programu Tarwin

  1. Spusťte program Tarkonfig (Nabídka Start -> Programy -> Tarwin -> Tarkonfig).

  2. V tabulce zařízení klikněte do prázdného řádku a stiskněte tlačítko Přidat, tím se spustí průvodce přidáním nového zařízení.

  3. Zvolte typ připojeného zařízení Tarflex-E a stiskněte tlačítko Pokračovat.

  4. Zadejte IP adresu bufferu Tarflex-E a také rychlost a typ řízení toku dat na vstupu bufferu. Pro správnou funkci bufferu je nutné, aby se parametry vstupního portu shodovaly s nastavením připojeného zařízení. Stiskněte tlačítko Pokračovat.

  5. V posledním dialogu můžete změnit jméno souboru, do kterého se zapisují přijatá data a také interval stahování. Stisknutím tlačítka Uložit se vytvoří nový adresář zařízení a uloží se jeho konfigurační soubor. Průvodce se zavře a nové zařízení je připraveno.

  6. Nyní můžete konfiguraci otestovat. V tabulce zařízení klikněte na řádek zařízení a stiskněte tlačítko Test. Program se pokusí navázat komunikaci s bufferem a pokud je vše v pořádku vypíše se v okně následující text:

    7. Připojeno na IP adresu 192.168.1.253 : 110
    Připojen TARFLEX-E výr.č. 1234 s kapacitou paměti 1048512 B
    Zaplnění paměti :10656 B, tj. 1 %
    Síťové spojení bylo řádně ukončeno

    V případě, že síťový buffer není dostupný, vypíše se chybové následující hlášení. Zkontrolujte zadanou IP adresu a nastavení bufferu Tarflex. Komunikaci také můžete vyzkoušet programem Ping.

    Síťové připojení na IP adresu 192.168.1.253 : 110 se nezdařilo.
    Connect timed out.

    Pokud je spojení s bufferem v pořádku, pokračujte dále.

  7. Přejděte na záložku Spouštění modulů.

    • V případě, že chcete spouštět program Tarwin při spuštění počítače jako aplikaci na pozadí, zatrhněte volbu Ze složky Po spuštění. Tím se vloží do složky Nabídka Start -> Programy -> Po spuštění nový zástupce a při dalším startu počítače se automaticky spustí program Tarwin.

      Tlačítkem Spustit na tomto PC zahájíte přenos dat.

    • Chcete-li používat pro přenos dat službu Tarwins, zatrhněte volbu Jako službu systému. Tím se nainstaluje do systému nová služba a bude se automaticky spouštět při startu počítače.

      Tlačítkem Spustit službu zahájíte přenos dat.

Stahování dat pomocí poštovního klienta

Data uložená v paměti bufferu můžete také přečíst pomocí programu pro čtení pošty -- poštovního klienta. Vhodný poštovní klient musí používat pro čtení pošty standardní protokol POP3. Buffer Tarflex-E připraví data do přílohy dopisu, který odešle klientovi.

Následující postup vyvětluje, jak nastavit poštovního klienta pro příjem dat z bufferu Tarflex. Postup byl vyzkoušen s programem Outlook Express, který je součástí instalace operačního systému MS Windows. Pravděpodobně bude nutné postup přizpůsobit ovládání konkrétního poštovního programu, který používáte. V případě pochybností se podívejte do jeho manuálu.

  1. Spusťte program Outlook Express.

  2. Vytvořte nový účet pro příjem pošty (Nástroje -> Účty... -> tlačítko Přidat -> volba Pošty...).

  3. Zobrazované jméno nechte, stiskněte tlačítko Pokračovat. V následujícím dialogu zatrhněte volbu Již mám elektronickou adresu... a zadejte libovolnou adresu. Protože přes tento účet budete poštu pouze číst, nezáleží na tom, co do těchto polí vyplníte.

  4. Do pole IP adresa serveru příchozí pošty zadejte adresu nastavenou v konfiguraci bufferu Tarflex-E, komunikační protokol (typ serveru) zvolte POP3. V případě, že program po Vás vyžaduje vyplnění také serveru odchozí pošty, zadejte stejnou IP adresu jako u příchozí pošty. Potvrďte tlačítkem Další.

  5. Název účtu (uživatelské jméno) a heslo se musí shodovat s údaji zadanými při konfiguraci bufferu.

  6. Zkontrolujte, že v bufferu máte připravená data ke stažení, tj. svítí zelená LED (1 % zaplnění).

  7. Vyvolejte funkci pro čtení pošty z vloženého účtu (Odeslat a přijmout vše). Ve složce Doručená pošta by se měla objevit nová zpráva. Data v bufferu se nacházejí v příloze dopisu.


Přístroj Tarflex-E - techická specifikace

Přístroj Tarflex-E

Techická specifikace

Sériové rozhraní: | RS-232C
- rychlost: | 300 Bd - 38400 Bd 1)
- řízení toku dat: | hardwarové, softwarové nebo žádné
- délka slova: | 7 nebo 8 b
- konektor: | RJ-10
Síťové rozhraní: | Ethernet 10BASE-T/100BASE-TX
- standard: | Ethernet Version 2.0/IEEE 802.3
- podporované protokoly: | ARP, TCP/IP, ICMP, POP3, SMTP, TarWin
Kapacita paměti:
1 MB
Napájení:
- Ze sítě: | síťovým adaptérem 9 V/300 mA.
- Z vestavěných akumulátorů: | provoz bez síťového napájení minimálně 24 hodin. 2) 3)
Spotřeba:
typicky 2 W
Rozměry (š x h x v):
95 x 160 x 37 mm
Hmotnost:
295 g
Rozsah pracovních a skladovacích teplot:
+10 °C až +40 °C
Rozsah pracovních vlhkostí:
0 až 60 %
Přístroj je určen pouze pro vnitřní prostředí.

Poznámky:

  1. Při rychlosti 38400 Bd není možné použít funkci odeslání zprávy při výskytu řetězce.
  2. V tomto případě není aktivní síťové rozhraní, provádí se pouze příjem a ukládání dat.
  3. Za předpokladu předchozího napájení ze sítě po dobu alespoň 3 dny.


Přístroj Tarflex-E - konfigurace bufferu pomocí programu Telnet

Přístroj Tarflex-E

Konfigurace bufferu pomocí programu Telnet

Buffer lze naprogramovat mimo jiné programem Telnet, který je dostupný na většině operačních systému. Tímto způsobem nelze změnit síťové parametry bufferu (IP adresa, síťová maska a adresa brány).

Buffer odpovídá na příkazy buďto "+OK", pokud byl příkaz proveden nebo "-ERR" v případě chyby. Víceřádkové odpovědi končí řádkem, který obsahuje pouze tečku na začátku řádku.

Postup

  1. Spusťte program Telnet a připojte se na IP adresu bufferu a síťový port 110.

    telnet 192.168.1.253 110 (Enter)

  2. Zadejte příkaz USER (jméno), kde jméno je uživatelské jméno nastavené v konfigurační tabulce bufferu, z výroby je nastavené na A.

    USER A (Enter)

  3. Zadejte příkaz PASS (heslo), kde heslo je uživatelské jméno nastavené v konfigurační tabulce bufferu, z výroby je nastavené na A.

    PASS A (Enter)

  4. Příkaz INFO vypíše aktuální nastavení bufferu.

    INFO (Enter)

  5. Příkaz HELP vypíše seznam dostupných příkazů a stručnou nápovědu ke každému příkazu.

    HELP (Enter)


Přístroj Tarflex-S

Tarflex-S je univerzální inteligentní zálohovaná paměť se sériovým rozhraním RS-232 sloužící k nepřetržitému a spolehlivému zaznamenávání dat. Po více než deseti letech zkušeností s vývojem a výrobou zálohovacích zařízení přicházíme s moderním přístrojem, který je oproti předchozímu typu výrazně menší, lehčí a především obsahuje zcela nový, moderní způsob komunikace.

Tato příručka je návodem k instalaci a použití přístoje Tarflex-S, její obsah je systematicky rozdělen do několika kapitol. V této úvodní části jsou popsány všechny vlastnosti přístroje a jeho rozhraní, záruční a licenční podmínky. V druhé kapitole najdete stručný návod na uvedení bufferu do provozu a instalaci obslužných programů. Podrobný popis všech funkcí přístroje a také podrobný návod na ovládání obslužných programů najdete v elektronickém manuálu, který je součástí přiloženého CD.

Těší nás, že jste dali důvěru našemu produktu a věříme, že budete s jeho užíváním maximálně spokojeni.

Obsah

  1. Úvod
  2. Instalace přístroje a programů
  3. Techická specifikace

Viz také:

  • Program Tarflex
  • Konektory a kabely


Přístroj Tarflex-S - úvod

Přístroj Tarflex-S

Úvod

Vlastnosti přístroje

Přístroj Tarflex-S je vybaven sériovým rozhraním RS-232 pro příjem vstupních dat z pobočkové ústředny, měřícího přístroje apod. Vstupní port má volitelnou rychlost v rozmezí od 300 Bd až do 38400 Bd. Přicházející data jsou indikována žlutou LED diodou (DTA) na předním panelu. Sériové rozhraní je obousměrné, lze tedy do připojeného zařízení znaky i vysílat. Přijatá data přístroj nepřetržitě ukládá do vnitřní paměti v binární podobě. Na výstupu je tedy přesný obraz dat ze vstupu a to zajišťuje naprostou univerzálnost nasazení tohoto přístroje.

Vnitřní paměť přístroje má kapacitu 1 MB, která je zálohována lithiovým článkem. Stav zaplnění paměti je indikován osmi barevnými LED diodami na předním panelu přístroje (0 % až 100 %). Po naplnění 75 % celkové kapacity paměti přístroj vydává krátké pípnutí jednou za 2 s. Po zaplnění celé paměti přístroj vydává krátké pípnutí v intervalu 1 s. Přístroj umožňuje obnovit celý obsah vnitřní paměti, v případě potřeby je tedy možné znovu přečíst i data, která již byla označena ke smazání.

Tarflex-S lze jednoduše zapojit do sériového portu počítače (COM). Přes toto rozhraní je možné nejen stahovat data, ale také nastavit parametry přístroje. K tomu lze použít textový protokol podobný protokolu POP3 pro elektronickou poštu, případně protokol TarWin, navržený speciálně pro náš buffer.

Přístroj Tarflex-S je napájen pomocí externího síťového napáječe, který je součástí dodávky. Při výpadku napájení je zajištěno interními akumulátory přijímání a ukládání dat do paměti po dobu nejméně 24 hodin. Data v paměti jsou navíc zajištěna pomocí lithiových článků minimálně po dobu 3 let. Po opětovném připojení napájení se přístroj uvede automaticky do provozu. Přístroj je konstruován pro nepřetržitý provoz a má nízkou spotřebu elektrické energie, což zajišťuje minimální provozní výdaje.

Obslužné programy

Zakoupením přístroje jste získali také licenci k programu Tarflex, což je jednoduchý grafický nástroj určený pro nastavení a otestování parametrů bufferu v prostředí MS Windows, a také licenci k programu Tarwin, který slouží k bezpečnému přenosu dat z paměti bufferu do počítače.

Instalační balíčky obou programů najdete na přiloženém CD; aktuální verze obou programů jsou k dispozici na internetových stránkách výrobce. V kapitole Instalace této příručky je uveden stručný návod na instalaci a ovládání programů. Detailní popis všech funkcí najdete v podrobném elektronickém manuálu na CD.

Záruční podmínky

  1. Na kompletní dodávku poskytuje výrobce záruku 24 měsíců. Podmínkou vzniku nároku na záruku je řádné vyplnění záručního listu.

  2. Záruka se vztahuje na bezvadný chod přístroje a programů, přičemž bezvadným chodem se rozumí chod v souhlasu s touto dokumentací.

  3. V době záruky se výrobce zavazuje bezplatně odstranit poruchy přístroje nebo programů způsobené výrobní závadou nebo vadným materiálem. Záruční doba se prodlužuje o dobu, po kterou byl výrobek v opravě.

  4. Oprávnění na záruční opravu zaniká v případě, že výrobek je obsluhován v rozporu s obsahem tohoto návodu, nebo byl na přístroji proveden zákrok uživatelem, případně jinou neoprávněnou osobou. Oprávnění na záruční opravu se také nevztahuje na vady, které uživatel způsobil nevhodnou dopravou či umístěním nebo skladováním ve vlhkém, prašném, chemicky agresívním nebo jinak nevhodném prostředí. Dále se oprávnění na záruční opravy nevztahuje na závady vzniklé vniknutím cizích látek do výrobku (voda apod.) a také na závady vzniklé výjimečnou událostí (např. poškození bleskem).

  5. Výrobce neručí za bezvadný chod přístroje v případě, že nejsou dodrženy technické podmínky uvedené v této dokumentaci, nebo je přístroj připojen k zařízení, které není kompatibilní se standardy rozhraní uvedenými v části "Technická specifikace".

  6. Výrobce neručí za bezvadný chod obslužných programů v případě, že jsou provozovány na technice, která není kompatibilní se standardem IBM PC nebo jsou provozovány na jiných operačních systémem než je uvedeno v této dokumentaci.

  7. Prodejce je povinnen řádně vyplnit záruční list v době prodeje výrobku. Neúplný nebo měněný záruční list je neplatný.

  8. Pokud bude zjištěno, že poškození neodpovídá záručním podmínkám, hradí náklady na takovou opravu majitel výrobku.

  9. Výrobce neručí za jakékoliv škody způsobené použitím přístroje nebo programů, pokud byly použity v rozporu s touto dokumentací nebo vznikly následkem předem nedefinované události.

Licenční podmínky

  1. Zakoupením přístroje Tarflex-S získává kupující licenci na použití programů (programového díla) Tarflex a Tarwin. Uživatel se stává majitelem licence dnem zakoupení přístroje. Uživatel přestává být majitelem licence v případě, že o to písemně požádá výrobce.

  2. Instalací programů uživatel vyjadřuje svůj souhlas s plným zněním licenčních a záručních podmínek tak, jak jsou uvedeny v této dokumentaci.

  3. Uživatel je oprávněn používat programy pouze k nastavení a obsluze přístroje Tarflex-E. Použití programů k obsluze jiného zařízení je porušením licenčních podmínek.

  4. Uživatel se zavazuje používat programy tak, aby nedošlo k porušení či ohrožení autorských práv výrobce.

  5. Uživatel smí pořizovat archívní kopie programů a instalačního CD pouze pro potřeby archivace a vytvoření záložních kopií.

  6. Uživatel nesmí poskytnout programy osobě, která není majitelem licence, bezplatně ani za úplatu.

  7. Uživatel nesmí provádět žádné změny do programů ani provádět zpětný překlad programů.

Obsah dodávky

  • Přístroj Tarflex-S

  • Napájecí adaptér

  • CD s programy a elektronickým manuálem

  • Návod k obsluze

  • Kabel pro připojení vstupního zařízení. (Pokud nebylo při objedání dohodnuto jinak, dodáváme standardně kabel s konektory RJ-10 a CAN DB-9V.)

Technické podmínky pro provoz přístroje

  • Přístroj je určen pouze pro vnitřní prostředí.

  • K napájení přístroje musí být použit síťový adaptér, který je součástí dodávky.

  • Nevystavujte přístroj teplotám nižším než 10 °C nebo vyšším než 40 °C. Nevystavujte přístroj příliš prašnému, vlhkému nebo chemicky agresívnímu prostředí.

Neprovádějte demontáž síťového napáječe. Po jeho otevření by mohlo dojít k dotyku životně nebezpečného napětí!

Přístroj obsahuje vestavěný lithiový článek a NiMH akumulátory. Pro výměnu článků nebo akumulátorů se obraťte na výrobce.

Požadavky na vybavení počítače pro provoz programů

Programy Tarwin a Tarflex vyžadují pro provoz minimálně:

  • osobní počítač s procesorem Pentium 150 MHz

  • operační systém počítače či stanice sítě Microsoft Windows 98 SE, 2000, NT, ME

  • operační paměť 64 MB

  • volné místo na pevném disku 10 MB

  • myš nebo jiné kompatibilní polohovací zařízení

  • připojení do počítačové sítě

  • podpora protokolu TCP/IP


Přístroj Tarflex-S - instalace přístroje a programů

Přístroj Tarflex-S

Instalace přístroje a programů

V této kapitole je popsáno, jak uvést přístroj do provozu a jak nainstalovat obslužné programy.

Uvedení přístroje do provozu

Přední panel přístroje Tarflex-S

Přední panel přístroje Tarflex-S

Zadní panel přístroje Tarflex-S

Zadní panel přístroje Tarflex-S

  1. Zapojte adaptér do konektoru na zadní straně přístroje. Adaptér zapojte do elektrovodné sítě 220 V. Na přední straně přístroje se krátce rozsvítí celý displej a ozve se krátké pípnutí. Pokud se místo krátkého pípnutí ozve pípání morseovkou "CERR", byla při startu zjištěna závada v harwarovém nebo programovém vybavení a přístroj je nutné opravit.

  2. Na displeji zůstane trvale svítit zelená kontrolka napájení. Pokud by došlo k odpojení napájecího adaptéru, bude tato kontrolka blikat a přístroj bude vydávat varovný akustický signál v intervalu asi 2 s. Po odpojení adaptéru je možné přístroj úplně vypnout zasunutím tenkého předmětu do úzkého otvoru na spodní straně přístroje.

  3. Pokud je připojen napájecí adaptér a na přední straně přístroje svítí zelená kontrolka napájení, připojte buffer do počítačové sítě. Konektor pro připojení je na zadní straně přístroje a pokud je vše v pořádku, rozsvítí se na tomto konektoru levá oranžová kontrolka (při 10Mb síti) nebo levá i pravá kontrolka (při zapojení do 100Mb sítě).

  4. V případě, že nebylo při objedání přístroje dohodnuto jinak, je buffer z výroby nastaven takto:

    5. Vstupní rozhraní (do ústředny, měřícího přístroje, apod.):
Rychlost | 9600 Bd
Délka slova | 7 b
Řízení toku dat | žádné
Výstupní rozhraní (do počítače):
Rychlost | 9600 Bd
Délka slova | 8 b
Řízení toku dat | žádné

    Rychlost komunikace s počítačem se nastavuje miniaturními DIP přepínači, které jsou umístěny pod otvorem na spodní straně přístroje, viz následující tabulka. Přednastavená rychlost 9600 Bd by měla vyhovovat u většiny instalací. Pokud je mezi bufferem a počítačem velmi dlouhá linka (řádově stovky metrů), použijte rychlost 1200 Bd. Je-li spojení krátké a sériový port počítače takovou rychlost dovoluje, přepněte přepínače do polohy odpovídající rychlosti 115200 Bd.

    DIP 1 | DIP 2 | Rychlost [Bd]
ON | ON | 1200
OFF | ON | 9600
ON | OFF | 38400
OFF | OFF | 115200

  5. Pokud je připojen napájecí adaptér a na přední straně přístroje svítí zelená kontrolka napájení, připojte buffer na sériový port počítače (COM).

  6. Parametry výstupního rozhraní lze změnit pomocí programu Tarflex.

Instalace programu Tarflex

Program Tarflex je jednoduché grafické rozhraní pro nastavení síťových parametrů a parametrů vstupního portu bufferu. V případě, že jste se s výrobcem dohodli na přednastavení parametrů a nastavení nepotřebujete měnit, není nutné, abyste tento program instalovali.

Máte-li připojení k internetu, doporučujeme stáhnout a nainstalovat nejnovější verzi programu, která je dostupná na www stránkách výrobce.

Instalace z CD:

  1. Do CD mechaniky Vašeho počítače vložte přiložené instalační CD. Automaticky se zobrazí úvodní stránka. Klikněte na ikonu TARFLEX-S v levé části okna. V seznamu akcí označte položku Nainstalovat program Tarflex a stiskněte tlačítko Provést. V případě, že se úvodní stránka nezobrazí, spusťte ručně instalační program Tarflex-instal.exe z adresáře Tarflex na CD.

  2. Postupujte podle pokynů uvedených v průvodci instalací programu.

Instalace z internetu:

  1. Z internetových stránek výrobce (www.tartek.cz) ze sekce Ke stažení stáhněte instalaci programu Tarflex.

  2. Spusťte instalační program Tarflex-instal.exe

  3. Postupujte podle pokynů uvedených v průvodci instalací programu.

Konfigurace přístroje pomocí programu Tarflex

  1. Spusťte program Tarflex (Nabídka Start -> Programy -> Tarflex -> Tarflex). Zobrazí se úvodní formulář, na kterém klikněte na záložku Tarflex-S, v tabulce označte sériový port, ke kterému je buffer připojen a stiskněte tlačítko Připojit.

  2. Po navázání komunikace s přístrojem Vás program požádá o autorizaci. Zadejte uživatelské jméno a přístupové heslo, které jsou zapsány v konfigurační tabulce bufferu a potvrďte tlačítkem OK. Pokud nebylo při objednávce dohodnuto jinak, je přístroj z výroby nastaveno takto:

    Uživatelské jméno: admin
    Heslo: výrobní číslo bufferu

  3. Otevře se formulář s nabídkou funkcí. Při prvotní konfiguraci přístroje postupujte následujícím způsobem:

  4. V nabídce funkcí stiskněte tlačítko Změnit konfiguraci bufferu. V dialogu nastavte požadované parametry vstupního portu, které musí odpovídat parametrům připojeného zařízení, které bude připojeno na vstup bufferu, zejména rychlost komunikace.

  5. Tlačítkem Uložit zapíšete nastavení do konfigurační tabulky bufferu.

Bližší popis všech položek nastavení najdete v elektronickém manuálu, který je součástí přiloženého CD. V případě pochybností se podívejte také do dokumentace k připojenému zařízení.

  • Obnovení dat v paměti bufferu - tato funkce umožňuje obnovit celý obsah vnitřní paměti bufferu, takže při dalším přenosu se přečte celý obsah vnitřní paměti, včetně dat, která již byla přenesena. Funkce se používá v případě, kdy při havárii počítače došlo ke ztrátě dat - uživatel pak může znovu přečíst poslední 1 MB dat (což při průměrné délce záznamu 100 B představuje přibližně 10.000 záznamů).

  • Přenos data z bufferu - pomocí této funkce můžete přenést data z paměti bufferu a uložit je do souboru na disk počítače.

Připojení přístroje k zařízení

Připojte ke vstupnímu portu bufferu zařízení, ze kterého se mají přijímat data. Vyvolejte funkci zařízení, která pošle do bufferu nějaká data. Na pobočkové ústředně zahájením a ukončením nějakého hovoru.

Pokud je zachycen alespoň jeden znak, rozsvítí se na předním panelu bufferu zelená LED dioda u zaplnění 1 %. V okamžiku, kdy přicházejí data na vstupní port, navíc poblikává žlutá kontrolka DTA.

Vyzkoušení funkčnosti pomocí programu Tarflex

  1. Na připojeném zařízení vyvolejte funkci, která způsobí odeslání dat do bufferu. Například na pobočkové ústředně zahájením a ukončením hovoru. Během přenosu dat do bufferu by měla poblikávat žlutá LED dioda (DTA) na předním panelu přístroje. Pokud byl přenesen a uložen alespoň jeden byte, rozsvítí se zelená LED dioda (1 % zaplnění).

  2. Spusťte program Tarflex, připojte se k bufferu stejným způsobem jako při konfiguraci a v hlavní nabídce stiskněte tlačítko Stáhnout data z bufferu. V dialogovém okně zadejte jméno cílového souboru, například test.txt. Potvrďte tlačítkem Uložit. Program naváže komunikaci s bufferem a stáhne nová data z jeho paměti a uloží je do zadaného souboru.

  3. Po skončení přenosu zhasne zelená LED dioda (1 % zaplnění), což znamená, že paměť přístroje je prázdná.

  4. Otevřete soubor test.txt v libovolném textovém editoru (např. Poznámkový blok) a zkontrolujte, že soubor obsahuje očekávaný text, například u pobočkové ústředny záznam o uskutečněném hovoru).

Instalace programu Tarwin

Program Tarwin je určen pro bezpečné stahování dat z paměti bufferu do souboru. V případě, že budete přenášet data z bufferu jiným způsobem, není nutné abyste tento program instalovali.

Máte-li připojení k internetu, doporučujeme stáhnout a nainstalovat nejnovější verzi programu, která je dostupná na www stránkách výrobce.

Instalace z CD:

  1. Do CD mechaniky Vašeho počítače vložte přiložené instalační CD. Automaticky se zobrazí úvodní stránka. Klikněte na ikonu TARFLEX-S v levé části okna. V seznamu akcí označte položku Nainstalovat program Tarwin a stiskněte tlačítko Tarwin-instal.exe z adresáře Tarwin na CD.

  2. Postupujte podle pokynů uvedených v průvodci instalací programu.

Instalace z internetu:

  1. Z internetových stránek výrobce (www.tartek.cz) ze sekce Ke stažení stáhněte instalaci programu Tarwin.

  2. Spusťte instalační program Tarwin-instal.exe

  3. Postupujte podle pokynů uvedených v průvodci instalací programu.

Stahování dat pomocí programu Tarwin

Program Tarwin periodicky stahuje data z paměti bufferu a ukládá je do souboru na disk. Pro přenos používá bezpečený protokol, který byl navržený speciálně pro buffery Tarflex.

Celý program se sestává ze tří modulů: Aplikace Tarwin, která se nejčastěji spouští při startu počítače ze složky Po spuštění a pracuje jako běžná aplikace na pozadí (běh je indikován ikonou na systémové liště). Pro operační systémy Windows NT4, 2000 a XP je k dispozici také modul Tarwins, který pracuje jako služba systému a je spuštěný i tehdy, pokud na počítači není nikdo přihlášen. Aplikace Tarkonfig je grafický uživatelský nástroj, který slouží pro nastavení programu.

Následující postup ukazuje, jak nastavit periodické stahování dat z paměti bufferu pomocí programu Tarkonfig.

Konfigurace programu Tarwin

  1. Spusťte program Tarkonfig (Nabídka Start -> Programy -> Tarwin -> Tarkonfig).

  2. V tabulce zařízení klikněte do prázdného řádku a stiskněte tlačítko Přidat, tím se spustí průvodce přidáním nového zařízení.

  3. Zvolte typ připojeného zařízení Tarflex-S a stiskněte tlačítko Pokračovat.

  4. Zadejte sériový port počítače, ke kterému je připojen bufferu Tarflex-S a také rychlost na výstupu bufferu podle polohy DIP přepínačů (viz tabulka). Zadejte také rychlost a typ řízení toku dat na vstupu bufferu. Pro správnou funkci bufferu je nutné, aby se parametry vstupního portu shodovaly s nastavením připojeného zařízení. Stiskněte tlačítko Pokračovat.

  5. V posledním dialogu můžete změnit jméno souboru, do kterého se zapisují přijatá data a také interval stahování. Stisknutím tlačítka Uložit se vytvoří nový adresář zařízení a uloží se jeho konfigurační soubor. Průvodce se zavře a nové zařízení je připraveno.

  6. Nyní můžete konfiguraci otestovat. V tabulce zařízení klikněte na řádek zařízení a stiskněte tlačítko Test. Program se pokusí navázat komunikaci s bufferem a pokud je vše v pořádku vypíše se v okně následující text:

    7. Port COM1 úspěšně otevřen s rychlostí 9600Bd
    Připojen TARFLEX-E výr.č. 0 s kapacitou paměti 1048512 B
    Zaplnění paměti :10656 B, tj. 1 %
    Port COM1 úspěšně uzavřen

    V případě, že sériový buffer není dostupný, vypíše se chybové následující hlášení. Zkontrolujte, zda byl zadán správný port a rychlost komunikace.

    Port COM1 úspěšně otevřen s rychlostí 9600Bd
    Buffer nekomunikuje
    Chyba během komunikace
    Port COM1 úspěšně uzavřen

    Pokud je spojení s bufferem v pořádku, pokračujte dále.

  7. Přejděte na záložku Spouštění modulů.

    • V případě, že chcete spouštět program Tarwin při spuštění počítače jako aplikaci na pozadí, zatrhněte volbu Ze složky Po spuštění. Tím se vloží do složky Nabídka Start -> Programy -> Po spuštění nový zástupce a při dalším startu počítače se automaticky spustí program Tarwin.

      Tlačítkem Spustit na tomto PC zahájíte přenos dat.

    • Chcete-li používat pro přenos dat službu Tarwins, zatrhněte volbu Jako službu systému. Tím se nainstaluje do systému nová služba a bude se automaticky spouštět při startu počítače.

      Tlačítkem Spustit službu zahájíte přenos dat.


Přístroj Tarflex-S - techická specifikace

Přístroj Tarflex-S

Techická specifikace

Sériové rozhraní (vstup): | RS-232C
- rychlost: | 300 Bd - 38400 Bd
- řízení toku dat: | hardwarové, softwarové nebo žádné
- délka slova: | 7 nebo 8 b
- konektor: | RJ-10
Sériové rozhraní (výstup) | RS-232C
- rychlost: | 1200, 9600, 38400 nebo 115200 Bd
- podporované protokoly: | Tarwin
- délka slova: | 8 b
- konektor: | CAN-9Z
Kapacita paměti:
1 MB
Napájení:
- Ze sítě: | síťovým adaptérem 9 V/300 mA.
- Z vestavěných akumulátorů: | provoz bez síťového napájení minimálně 24 hodin. 1) 2)
Spotřeba:
typicky 2 W
Rozměry (š x h x v):
95 x 160 x 37 mm
Hmotnost:
295 g
Rozsah pracovních a skladovacích teplot:
+10 °C až +40 °C
Rozsah pracovních vlhkostí:
0 až 60 %
Přístroj je určen pouze pro vnitřní prostředí.

Poznámky:

  1. V tomto případě není aktivní výstupní rozhraní, provádí se pouze příjem a ukládání dat.
  2. Za předpokladu předchozího napájení ze sítě po dobu alespoň 3 dny.


Program Tarflex

Program Tarflex slouží k nastavení parametrů bufferů Tarflex-E a Tarflex-S.

V této kapitole najdete návod na instalaci a použití programu a také detailní popis všech parametrů bufferu.

Obsah

  1. Instalace programu
  2. Spuštění programu a připojení bufferu
  3. Nastavení síťových parametrů bufferu
  4. Nastavení ostatních parametrů bufferu
  5. Další funkce
  6. Servisní menu
  7. Licenční podmínky

Viz také:

  • Buffer Tarflex-E
  • Buffer Tarflex-S


Program Tarflex - instalace programu

Program Tarflex

Instalace programu

Máte-li připojení k internetu, doporučujeme stáhnout a nainstalovat nejnovější verzi programu, která je dostupná na www stránkách výrobce. V opačném případě nainstalujte program z instalačního CD, který jste obdrželi s přístrojem Tarflex.

Instalace z CD:

  1. Do CD mechaniky Vašeho počítače vložte přiložené instalační CD. Automaticky se zobrazí úvodní program. V levém sloupci klikněte na tlačítko Tarflex, v seznamu akcí označte položku Nainstalovat program Tarflex a stiskněte tlačítko Provést.

    V případě, že se úvodní stránka nezobrazí, spusťte ručně program Tarflex-instal.exe z adresáře Tarflex na CD.

  2. Postupujte podle pokynů uvedených v průvodci instalací programu.

Instalace z internetu:

  1. Z internetových stránek výrobce (www.tartek.cz) ze sekce Soubory ke stažení stáhněte instalaci programu Tarflex.

  2. Spusťte instalační program Tarflex-instal.exe

  3. Postupujte podle pokynů uvedených v průvodci instalací programu.

Instalátor rozbalí do cílového adresáře program Tarflex.exe a vytvoří na něj odkaz do Nabídky Start --> Programy, kde se vytvoří nová složka Tarflex s odkazem na program.

Pokud budete chtít program odinstalovat, smažte cílový adresář a z nabídky Start zrušte příslušný odkaz.


Program Tarflex - spuštění programu a připojení bufferu

Program Tarflex

Spuštění programu a připojení bufferu

Program lze nejjednodušším způsobem spustit z nabídky Start --> Programy --> Tarflex --> položka Tarflex. Po spuštění se zobrazí úvodní dialog, ve kterém program požaduje zadání IP adresy bufferu, který se bude nastavovat a ovládat.

Obrázek 3.1: Úvodní dialog programu Tarflex

Postup 1: Připojení na základě IP adresy

Buffer je připojen do počítačové sítě, má v sobě nastavené správné parametry sítě (IP adresu, síťovou masku a adresu brány) a je z počítače dostupný protokolem TCP/IP. V tomto případě je možné nakonfigurovat buffer kdekoliv na síti, do programu se bude zadávat jeho IP adresa.

  1. Spusťte program Tarflex.

  2. V úvodním dialogu vepište IP adresu bufferu, který chcete nastavit.

  3. Stiskněte tlačítko Připojit. Program naváže komunikaci s bufferem a přečte jeho nastavení. Pokud proběhlo vše v pořádku, program se přepne do hlavní nabídky funkcí. V případě, že se nepodařilo nastavení přečíst, program vypíše hlášení "Buffer nekomunikuje".

Obrázek 3.2: Připojení bufferu na základě síťové adresy

Postup 2: Připojení na základě MAC adresy

Buffer je připojen do stejné ethernetové sítě jako počítač. V takovém případě není nutné znát předem jeho síťovou adresu nebo buffer není pod stávající adresou dostupný). Buffer se bude v programu připojovat na základě hardwarové (MAC) adresy. Tato adresa je uvedena na štítku na spodku přístroje.

  1. Spusťte program Tarflex.

  2. V úvodním dialogu stiskněte tlačítko Vyhledat. Program zjistí, které buffery jsou dostupné a zobrazí seznam jejich hardwarových adres.

  3. V tabulce označte adresu odpovídající bufferu, který chcete nastavit.

  4. Stiskněte tlačítko Připojit. Program naváže komunikaci s bufferem a přečte jeho nastavení. Pokud proběhlo vše v pořádku, program se přepne do hlavní nabídky funkcí. V případě, že buffer má naprogramovanou IP adresu, která není v síti platná, program zobrazí hlášení a zeptá se uživatele, zda chce nejprve nastavit síťové parametry bufferu. Aby bylo možné buffer naprogramovat, musí mít nejprve správnou síťovou adresu.

Obrázek 3.3: Připojení bufferu na základě hardwarové adresy


Program Tarflex - nastavení síťových parametrů bufferu

Program Tarflex

Nastavení síťových parametrů bufferu

Síťovými parametry bufferu se rozumí síťová (IP) adresa, maska sítě a IP adresa brány. Tyto parametry jsou dány konfigurací počítačové sítě a měl by je sdělit správce sítě. Pokud není při objednávce dohodnuto jinak, nastavuje výrobce parametry takto: IP adresa 192.168.1.253, maska sítě 255.255.255.0 a adresa brány žádná. Pomocí následujícího postupu můžete tyto parametry změnit.

POZOR!
Jestliže nastavujete buffer mimo Vaši lokální síť, používejte tuto funkci opatrně. Pokud změníte nastavení sítě tak, že buffer nebude s novým nastavením dostupný, nebude možné změnu vrátit jednoduše zpět. V takovém případě je jediným řešením připojit buffer na základě hw adresy na počítači v síti, do které je buffer připojen, a parametry sítě opravit.

  1. V hlavní nabídce funkcí programu Tarflex stiskněte tlačítko Změnit IP adresu a parametry sítě. Otevře se dialogové okno, ve kterém je zobrazena stávající síťová adresa bufferu a tři editační boxy pro zadání nové adresy, masky a brány.

  2. Zadejte nové nastavení sítě a stiskněte tlačítko Uložit. Program provede uložení změn a vrátí se do hlavní nabídky. V případě, že nevyplníte pole Síťová maska, program automaticky doplní standardní masku podle třídy zadané adresy. Pokud se pro spojení mezi počítačem nepoužívá brána, nechte pole IP adresa brány prázdné.

Obrázek 3.4: Dialog pro zadání síťových parametrů bufferu Tarflex-E


Program Tarflex - nastavení ostatních parametrů bufferu

Program Tarflex

Nastavení ostatních parametrů bufferu

V následujícím kroku se provede konfigurace dalších parametrů bufferu, zejména nastavení vstupního portu bufferu. Pro správný příjem dat je nutné, aby parametry vstupního portu (rychlost a způsob řízení) odpovídaly parametrům připojeného zařízení (pobočkové ústředny, měřícího přístroje apod.). V případě pochybností se podívejte do jeho dokumentace.

Postup

  1. V hlavní nabídce funkcí programu Tarflex stiskněte tlačíko Změnit konfiguraci bufferu. Program přečte aktuální nastavení bufferu a zobrazí konfigurační okno, ve kterém jsou vyplněny aktuální hodnoty parametrů. Přehled všech parametrů je uveden dále.

    Obrázek 3.5: Dialog pro změnu parametrů bufferu Tarflex-E

  2. Nastavte požadované hodnoty parametrů a stiskněte tlačíko Další.

  3. Na druhé stránce lze změnit nastavení parametry pro odesílání elektronické pošty. Bližší popis jednotlivých parametrů je uveden dále.

    Obrázek 3.6: Dialog pro změnu parametrů elektronické pošty

  4. Nastavte požadované hodnoty parametrů a stiskněte tlačítko Uložit. Program uloží změny do bufferu a vrátí se do hlavní nabídky funkcí.

Přehled parametrů bufferu Tarflex-E

  • Síťové parametry - parametry síťového rozhraní bufferu:

    • Hardwarová (MAC) adresa - adresa jednoznačně identifikující buffer. Je uvedena na štítku na spodku přístroje a nelze ji změnit.
    • Síťová (IP) adresa - adresa identifikující buffer v počítačové síti, nastavitelná.
    • Maska sítě - rozděluje IP adresu bufferu na síťovou část (net part) a číslo zařízení v síti (host part).
    • Adresa brány - IP adresa počítače nebo jiného zařízení, které zajišťuje přenos dat mezi sítěmi.

  • Vstup dat - parametry vstupního sériového portu:

    • Rychlost - bitová rychlost v Bd, musí souhlasit s rychlostí výstupního portu připojeného zařízení.
    • Řízení toku dat - žádné, DTR/DSR - hardwarovými signály, Xon/Xoff - vysíláním znaků Xon a Xoff nebo softwarové - port je v obousměrném režimu, posílání dat řídí aplikace.
    • Režim - délka slova - v 7bitovém režimu je automaticky odřezáván z přijímaných dat nejvyšší bit.

  • Přístup protokolem POP3 - autorizační parametry pro čtení dat pomocí poštovního protokolu POP3:

    • Uživatelské jméno - max. 8 znaků, rozlišuje velikost písmen

    • Heslo - max. 8 znaků, rozlišuje velikost písmen

  • Zvuková signalizace - akustické signály, které vydává buffer:

    • Při zaplnění paměti - je-li funkce zapnuta, vydává buffer při zaplnění paměti nad 75% kapacity akustický signál.

  • Elektronická pošta - parametry pro odesílání zpráv z bufferu:

    • SMTP server - IP adresa poštovního serveru.

    • Odesílatel - elektronická adresa, která bude ve zprávách uvedena v poli "odesílatel".

    • Příjemce 1, 2 - max. dvě elektronické adresy příjemců zpráv.

  • Kontrola zaplnění - odesílání zprávy při zaplnění paměti bufferu:

    • Text zprávy - Text, který má být uveden v předmětu zprávy, max. 23 znaků

  • Kontrola hw signálu - odesílání zprávy při změně hw signálu na vstupním portu bufferu:

    • Text zprávy - Text, který má být uveden v předmětu zprávy, max. 23 znaků

  • Kontrola výskytu řetězce - odesílání zprávy při výskytu určitého řetězce v přijímaných datech:

    • Sledovaný řetězec - max. délka 16 znaků

    • Text zprávy - Text, který má být uveden v předmětu zprávy, max. 23 znaků


Program Tarflex - další funkce

Program Tarflex

Další funkce

V hlavním menu programu Tarflex jsou kromě tlačítek pro nastavení parametrů bufferu ještě další funkce, které jsou určeny pro otestování zapojení a konfigurace po uvedení přístroje do provozu.

Obnovení dat v paměti bufferu

Tato funkce umožňuje obnovit celý obsah vnitřní paměti bufferu, takže při dalším přenosu se přečte celý obsah vnitřní paměti, včetně dat, která již byla přenesena. Funkce se používá v případě, kdy při havárii počítače došlo ke ztrátě dat - uživatel pak může znovu přečíst poslední 1 megabyte dat (což při průměrné délce záznamu 100 bytů představuje přibližně 10.000 záznamů).

Postup:

  1. V hlavní nabídce funkcí programu Tarflex stiskněte tlačíko Obnovit data v paměti bufferu.

  2. Potvrďte akci tlačítkem Ano.

Přenos data z bufferu

Pomocí této funkce můžete přenést data z paměti bufferu a uložit je do souboru na disk počítače.

Postup:

  1. V hlavní nabídce funkcí programu Tarflex stiskněte tlačíko Stáhnout data z bufferu.

  2. Zadejte jméno cílového souboru. Potvrďte tlačítkem Uložit.


Program Tarflex - servisní menu

Program Tarflex

Servisní menu

V servisním menu programu Tarflex se nacházejí speciální funkce pro prvotní nastavení a testování bufferu. POZOR! Některé funkce v servisním menu přepisují obsah celé paměti bufferu. Můžete tím přepsat obsah celé paměti bufferu bez možnosti jejich obnovení. Nabídka servisních funkcí se otevírá stiskem kláves Ctrl+Shift+S v hlavní nabídce a stiskem tlačítka Otevřít servisní menu.

Nastavit výchozí konfiguraci X-Portu

Nastavuje výchozí konfiguraci síťového rozhraní bufferu. Nemění síťové parametry (IP adresu, masku sítě a bránu), ale změní nastavení elektronické pošty a parametrů potřebných pro komunikaci mezi procesorem a síťovým rozhraním v bufferu.

Test paměti bufferu

Prověří funkčnost vnitřní paměti bufferu. Pozor - při testu se přepíše celý obsah vnitřní paměti zkušebními daty!

Test datového okruhu

Prověří činnost sériového rozhraní bufferu - vysílání a příjem dat. Na sériový port bufferu je nutné připojit testovací propojku. Pozor - při testu se do vnitřní paměti ukládají zkušební data.

Test řídících signálů

Prověří činnost řídících signálů na sériovém rozhraní bufferu. Na sériový port bufferu je nutné připojit testovací propojku.

Nastavit výchozí konfiguraci bufferu

Nastaví konfigurační tabulky bufferu na výchozí hodnoty, nemění nastavení síťových parametrů. Pozor - vymaže z paměti přijatá data.

Zapsat výrobní číslo

Tato funkce je určena jen k nastavení bufferu při výrobě. Nepoužívejte ji!!!

Uložit výsledky testů do souboru

Uloží výsledky předchozích testů do souboru v podadresáři sešit. Soubor je pojmenován podle výrobního čísla bufferu.

Vyslat data na vstupní port bufferu přes síť

Umožňuje vyslat data ze zadaného souboru přes sériový port bufferu do připojeného zařízení.

Vyslat data do bufferu přes sériový port

Funkce odešle data ze zadaného souboru na vybraný sériový port počítače. Funkci lze použít k ověření, že buffer správně přijímá a ukládá data.

Vyslat data do bufferu přes sériový port

Funkce odešle data ze zadaného souboru na vybraný sériový port počítače. Funkci lze použít k ověření, že buffer správně přijímá a ukládá data.


Program Tarflex - licence

Program Tarflex

Licenční podmínky

  1. Zakoupením přístroje Tarflex-E nebo Tarflex-S získává kupující licenci na použití programů (programového díla) Tarflex. Uživatel se stává majitelem licence dnem zakoupení přístroje. Uživatel přestává být majitelem licence v případě, že o to písemně požádá výrobce.

  2. Instalací programů uživatel vyjadřuje svůj souhlas s plným zněním licenčních a záručních podmínek tak, jak jsou uvedeny v návodu k obsluze přístroje.

  3. Uživatel je oprávněn používat programy pouze k nastavení a obsluze přístrojů Tarflex-E a Tarflex-S. Použití programů k obsluze jiného zařízení je porušením licenčních podmínek.

  4. Uživatel se zavazuje používat programy tak, aby nedošlo k porušení či ohrožení autorských práv výrobce.

  5. Uživatel smí pořizovat archívní kopie programů a instalačního CD pouze pro potřeby archivace a vytvoření záložních kopií.

  6. Uživatel nesmí poskytnout programy osobě, která není majitelem licence, bezplatně ani za úplatu.

  7. Uživatel nesmí provádět žádné změny do programů ani provádět zpětný překlad programů.


Tardat 4 - licence

Program Tardat 4

Licenční podmínky

  1. Zakoupením jedné instalace programu Tardat získává uživatel právo na instalaci a použití programu (programového díla) Tardat. Uživatel se stává majitelem licence dnem zakoupení licence. Uživatel přestává být majitelem licence v případě, že o to písemně požádá výrobce.

  2. Instalací programu Tardat jako demonstrační verze se uživatel stává majitelem bezplatné licence, která umožňuje uživateli používat vybrané funkce a moduly. V demonstrační verzi programu není možné zpracovávat vstupní data.

  3. Placená licence umožňuje uživateli nainstalovat jednu instalaci programu na jednom počítači. Použití (spouštění) této instalace je dovoleno na libovolném množství počítačů. Zpracování vstupních dat je povoleno jen na počítači, ke kterému je připojen platný hardwarový klíč, nebo na počítači, na kterém je uložen platný softwarový klíč. Uživatel je oprávněn nainstalovat a používat novější verze programu, nejvýše však do verze, která je povolena v hardwarovém nebo softwarovém klíči.

  4. Majitel bezplatné nebo placené licence je oprávněn nainstalovat a používat neomezený počet klientských instalací programu pro přístup do databáze programu.

  5. Instalací programu uživatel vyjadřuje svůj souhlas s plným zněním uvedených licenčních podmínek.

  6. Uživatel se zavazuje používat program tak, aby nedošlo k porušení či ohrožení autorských práv výrobce.

  7. Uživatel nesmí provádět žádné změny programů ani provádět zpětný překlad programů.


ZIP - Licence

ZIP a UNZIP

Některé funkce programu Tardat používají pro kompresi dat dynamické knihovny zip32.dll a unzip32.dll od Info-ZIPu. Knihovny by měly být umístěny v hlavním adresáři, ve kterém je nainstalovaný program Tardat. Software Info-ZIPu je zdarma a jeho zdrojové i binární kódy můžete získat na různých ftp serverech. Domovská stránka projektu je:

http://www.info-zip.org/pub/infozip/

Licence

This is version 1999-Oct-05 of the Info-ZIP copyright and license.
The definitive version of this document should be available at
ftp://ftp.cdrom.com/pub/infozip/license.html indefinitely.

Copyright (c) 1990-1999 Info-ZIP.  All rights reserved.

For the purposes of this copyright and license, "Info-ZIP" is defined as
the following set of individuals:

   Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois,
   Jean-loup Gailly, Hunter Goatley, Ian Gorman, Chris Herborth, Dirk Haase,
   Greg Hartwig, Robert Heath, Jonathan Hudson, Paul Kienitz, David Kirschbaum,
   Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. Miller,
   Sergio Monesi, Keith Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel,
   Steve Salisbury, Dave Smith, Christian Spieler, Antoine Verheijen,
   Paul von Behren, Rich Wales, Mike White

This software is provided "as is," without warranty of any kind, express
or implied.  In no event shall Info-ZIP or its contributors be held liable
for any direct, indirect, incidental, special or consequential damages
arising out of the use of or inability to use this software.

Permission is granted to anyone to use this software for any purpose,
including commercial applications, and to alter it and redistribute it
freely, subject to the following restrictions:

    1. Redistributions of source code must retain the above copyright notice,
       definition, disclaimer, and this list of conditions.

    2. Redistributions in binary form must reproduce the above copyright
       notice, definition, disclaimer, and this list of conditions in
       documentation and/or other materials provided with the distribution.

    3. Altered versions--including, but not limited to, ports to new operating
       systems, existing ports with new graphical interfaces, and dynamic,
       shared, or static library versions--must be plainly marked as such
       and must not be misrepresented as being the original source.  Such
       altered versions also must not be misrepresented as being Info-ZIP
       releases--including, but not limited to, labeling of the altered
       versions with the names "Info-ZIP" (or any variation thereof, including,
       but not limited to, different capitalizations), "Pocket UnZip," "WiZ"
       or "MacZip" without the explicit permission of Info-ZIP.  Such altered
       versions are further prohibited from misrepresentative use of the
       Zip-Bugs or Info-ZIP e-mail addresses or of the Info-ZIP URL(s).

    4. Info-ZIP retains the right to use the names "Info-ZIP," "Zip," "UnZip,"
       "WiZ," "Pocket UnZip," "Pocket Zip," and "MacZip" for its own source and
       binary releases.


Zapojení konektorů a kabelů

V tomto dokumentu jsou uvedena různá zapojení konektorů a kabelů, které se používají na tarifikačních výstupech pobočkových ústředen, počítačových sítích a také na bufferech Tarflex a Tartek. K dispozici je také verze pro tisk

POZOR! Zapojení konektorů ústředen vycházejí ze zkušeností z terénu nikoliv z oficiálních materiálů výrobců. Pokud je budete používat, dbejte zvýšené opatrnosti a pokud je to možné, zapojení nejprve ověřte podle manuálu k ústředně. Budeme rádi, pokud nám případné nesrovnalosti sdělíte.

Obsah:

  1. Ústředny: Alcatel, Alphatel, Asconn, Atlas, DeTeWe, Ericsson, GoldStar, Hymax, Interconnect, Kapsch, Lucent Technologies, Macrotel, Matra, Panasonic, Philips, Samsung, Siemens, Tesla, Tie, TTC.

  2. Buffery: Tarflex, Tartek.

  3. Rozhraní: RS-232 (COM), Ethernet.

Ústředny (bez záruky!)
  • obecné zapojení Buffer Tarflex - ústředna - zapojení č. 01

Alcatel
  • 4100 - zapojení č. 08
  • 4200 - zapojení č. 09
  • 4200D - zapojení č. 22
  • 4400 - zapojení č. 02
  • 4520 (BCN) - zapojení č. 10
  • OXO - zapojení č. 21
  • TELIC 2600E - zapojení č. 11

Alphatel
  • T LINE, M LINE - zapojení č. 12

Asconn
  • ALFA OFFICE - zapojení č. 05
  • CONNEX BX-8 - zapojení č. 12
  • CONNEX AX-32, RS-02 PLUS - zapojení č. 15

Atlas
  • KSX 32,128 - zapojení č. 20
  • V - zapojení č. 05

DeTeWe
  • VARIX 12/32 - zapojení č. 02
  • VARIX 200 - zapojení č. 12
  • VARIX CONTENT - zapojení č. 02

Ericsson
  • BP 24 - zapojení č. 05
  • BP 50, 250 - zapojení č. 03
  • BP 150 - zapojení č. 04

GoldStar
  • GHX, GSX - zapojení č. 03

Hymax
  • KSX 32i - zapojení č. 02

Interconnect
  • 200 - zapojení č. 13

Kapsch
  • DKS-200 - zapojení č. 05
  • MERIDIAN - zapojení č. 17 (Cannon DB-25 zásuvka)
  • MERIDIAN - zapojení č. 03 (Cannon DB-25 vidlice)
  • MERIDIAN - zapojení č. 23 (Cannon DB-25 vidlice, FNM)
  • MIDISTAR - zapojení č. 05

Lucent Technologies
  • DEFINITY - zapojení č. 03
  • EUROGENERIS - zapojení č. 14
  • MERLIN LEGEND - zapojení č. 07
  • PARTNER - zapojení č. 07

Macrotel
  • MT-16H - zapojení č. 02

Matra
  • MC 4500 - zapojení č. 16

Panasonic
  • DBS - zapojení č. 02
  • KX-T - zapojení č. 02
  • KX-TA - zapojení č. 12
  • KX-TD - zapojení č. 02

Philips
  • SOPHO iS3000 - zapojení č. 05

Samsung
  • SKP - zapojení č. 03

Siemens
  • Hicom 100 - zapojení č. 02
  • Hicom 100E - zapojení č. 06
  • Hicom 150E - zapojení č. 02
  • Hicom 150E OfficePro - zapojení č. 02
  • Hicom 150H V1_2 (HIPATH) - zapojení č. 02
  • Hicom 300 - zapojení č. 03

Tesla
  • UE-5, 10, 20 - zapojení č. 04
  • UE-101,200,201,210 - zapojení č. 04

Tie
  • TCX - zapojení č. 02
  • ONYX VS - zapojení č. 18

TTC
  • 2000 - zapojení č. 12

Buffer Tarflex
  • Tarflex-E - konektor RJ-10
  • Ústředna - Tarflex (obecné zapojení)
  • Tarflex - Tarflex (zapojení za sebou)
  • Tarflex - PC RS 232 C (standardní zapojení)
  • Tarflex - PC RS 232 C (dvoudrátové vedení)
  • Připojení dvou bufferů Tarflex na jeden port PC
  • Přemostění bufferu Tarflex
  • Tarflex - telefonní modem

Buffer Tartek (starý buffer)
  • Propojení Buffer Tartek - PC
  • Volba rychlosti bufferu Tartek

Sériové rozhraní RS 232
  • Cannon DB-9
  • Cannon DB-25
  • Redukce Cannon DB-9/DB-25
  • Nulový modem

Síťové rozhraní Ethernet
  • TP - přímý kabel
  • TP - křížený kabel

Poznámky:


Přílohy - konektory a kabely

Zapojení konektorů a kabelů

(verze pro tisk)

V tomto dokumentu jsou uvedena různá zapojení konektorů a kabelů, které se používají na tarifikačních výstupech pobočkových ústředen, počítačových sítích a také na bufferech Tarflex a Tartek.

POZOR! Zapojení konektorů ústředen vycházejí ze zkušeností z terénu nikoliv z oficiálních materiálů výrobců. Pokud je budete používat, dbejte zvýšené opatrnosti a pokud je to možné, zapojení nejprve ověřte podle manuálu k ústředně. Budeme rádi, pokud nám případné nesrovnalosti sdělíte.

Ústředny (bez záruky!)

  • obecné zapojení Buffer Tarflex - ústředna - zapojení č. 01

Alcatel

  • 4100 - zapojení č. 08
  • 4200 - zapojení č. 09
  • 4200D - zapojení č. 22
  • 4400 - zapojení č. 02
  • 4520 (BCN) - zapojení č. 10
  • OXO - zapojení č. 21
  • TELIC 2600E - zapojení č. 11

Alphatel

  • T LINE, M LINE - zapojení č. 12

Asconn

  • ALFA OFFICE - zapojení č. 05
  • CONNEX BX-8 - zapojení č. 12
  • CONNEX AX-32, RS-02 PLUS - zapojení č. 15

Atlas

  • KSX 32,128 - zapojení č. 20
  • V - zapojení č. 05

DeTeWe

  • VARIX 12/32 - zapojení č. 02
  • VARIX 200 - zapojení č. 12
  • VARIX CONTENT - zapojení č. 02

Ericsson

  • BP 24 - zapojení č. 05
  • BP 50, 250 - zapojení č. 03
  • BP 150 - zapojení č. 04

GoldStar

  • GHX, GSX - zapojení č. 03

Hymax

  • KSX 32i - zapojení č. 02

Interconnect

  • 200 - zapojení č. 13

Kapsch

  • DKS-200 - zapojení č. 05
  • MERIDIAN - zapojení č. 17 (Cannon DB-25 zásuvka)
  • MERIDIAN - zapojení č. 03 (Cannon DB-25 vidlice)
  • MERIDIAN - zapojení č. 23 (Cannon DB-25 vidlice, FNM)
  • MIDISTAR - zapojení č. 05

Lucent Technologies

  • DEFINITY - zapojení č. 03
  • EUROGENERIS - zapojení č. 14
  • MERLIN LEGEND - zapojení č. 07
  • PARTNER - zapojení č. 07

Macrotel

  • MT-16H - zapojení č. 02

Matra

  • MC 4500 - zapojení č. 16

Panasonic

  • DBS - zapojení č. 02
  • KX-T - zapojení č. 02
  • KX-TA - zapojení č. 12
  • KX-TD - zapojení č. 02

Philips

  • SOPHO iS3000 - zapojení č. 05

Samsung

  • SKP - zapojení č. 03

Siemens

  • Hicom 100 - zapojení č. 02
  • Hicom 100E - zapojení č. 06
  • Hicom 150E - zapojení č. 02
  • Hicom 150E OfficePro - zapojení č. 02
  • Hicom 150H V1_2 (HIPATH) - zapojení č. 02
  • Hicom 300 - zapojení č. 03

Tesla

  • UE-5, 10, 20 - zapojení č. 04
  • UE-101,200,201,210 - zapojení č. 04

Tie

  • TCX - zapojení č. 02
  • ONYX VS - zapojení č. 18

TTC

  • 2000 - zapojení č. 12

Buffer Tarflex

  • Ústředna - Tarflex (obecné zapojení) - zapojení č. 01
  • Tarflex - Tarflex (zapojení za sebou) - zapojení č. 50
  • Tarflex - PC RS 232 C (standardní zapojení) - zapojení č. 51
  • Tarflex - PC RS 232 C (dvoudrátové vedení) - zapojení č. 52
  • Připojení dvou bufferů Tarflex na jeden port PC - zapojení č. 53
  • Přemostění bufferu Tarflex - zapojení č. 54
  • Tarflex - telefonní modem - zapojení č. 55
  • Tarflex-E - konektor RJ-10 - zapojení č. 56

Buffer Tartek (starý buffer)

  • Propojení Buffer Tartek - PC - zapojení č. 60
  • Volba rychlosti bufferu Tartek - zapojení č. 61

Sériové rozhraní RS 232

  • Cannon DB-9 - zapojení č. 70
  • Cannon DB-25 - zapojení č. 71
  • Redukce Cannon DB-9/DB-25 - zapojení č. 72
  • Nulový modem - zapojení č. 73

Síťové rozhraní Ethernet

  • TP - přímý kabel - zapojení č. 80
  • TP - křížený kabel - zapojení č. 81

Ústředny
01 | 02
03 | 04
05 | 06
07 | 08
09 | 10
11 | 12
13 | 14
15 | 16
17 | 18
19 | 20
21 | 22
23

Tarflex
50 | 51
52 | 53
54 | 55
56

Tartek
60 | 61

RS-232
70 | 71
72 | 73

Ethernet
80 | 81


Soubory tarifkačního systému Tardat

Podadresáře: SYSTEM, DEV.X, PBX.X, LOG, ARCHIV.
Legenda: Programy, Konfigurace, Data (hovory), Pracovní soubory (vlajky), Deníky, Ostatní.

C:\Tardat4\
Soubor | Formát | Popis
Iangel32.dll | knihovna | Funkce pro instalaci ovladače hw klíče
Tardat.exe | aplikace | Program Tardat
Tardat.chm | nápověda | Elektronická nápověda
Tardat.ini | textový | Hlavní konfigurační souboru programu Tardat
Tardatd.exe | aplikace | Malý webový server (aplikace)
Tardats.exe | služba systému | Malý webový server (služba)
Http.ini | textový | Konfigurační soubor pro webový server
Tarkonfig.exe | aplikace | Nástroj pro konfiguraci zařízení
Tarwin.ini | textový | Hlavní konfigurační souboru programu Tarwin
Tarwin.exe | aplikace | Přenos dat ze zařízení (aplikace)
Tarwins.exe | služba systému | Přenos dat ze zařízení (služba)
Update.exe | aplikace | Aktualizace Tardatu
Zip32.dll | knihovna | Funkce pro kompresi souborů
Zpracuj.exe | aplikace | Zpracování hovorů (aplikace)
Zpracujs.exe | služba | Zpracování hovorů (služba)
Zpracuj.ini | textový | Konfigurační soubor pro zpracování hovorů
C:\Tardat4\system
Soubor | Formát | Popis
S00.td | binární | Tarifní síť a sazebníky (veřejná)
S01.td | binární | Zákaznická tarifní síť
xxxx.td | binární | Softwarový klíč číslo xxxx
C:\Tardat4\dev.x (x = A, B, C, ... Z, AA, AB, ...)
Soubor | Formát | Popis
Device.ini | textový | Konfigurace zařízení
Done.txt | textový | Seznam přenesených souborů (protokol Alc4400)
Pbx.txt | textový | Seznam souborů na ústředně (protokol Alc4400)
New.txt | textový | Seznam nových souborů k přenesení (protokol Alc4400)
C:\Tardat4\pbx.x (x = A, B, C, ... Z, AA, AB, ...)
Soubor | Formát | Popis
Px2y.td | textový | y=0..3 Vstupní soubor řádků z ústředny a další pomocné soubory zpracování
Px30.td | binární | Datum - meziblokový sklad
Px31.td | binární | ukládání volaných čísel, přepojení - mezihovorový sklad
Px32.td | binární | ukládání autorizačních kódů - mezihovorový sklad
Px33.td | binární | aktuální pořadí zpracováného hovoru
Pxchybne.txt | textový | Textový soubor s chybnými řádky
Pxprubez.txt | textový | Textový soubor s posledním 30 kilobyty řádků
Pxtext.txt | textový | Záložní textový soubor
C:\Tardat4\log
Soubor | Formát | Popis
zpracuj.log | textový | Deník modulu Zpracování
http.log | textový | Deník modulu Malý webový server
tarwins.log | textový | Deník služby Tarwin
C:\Tardat4\archiv
Soubor | Formát | Popis
xrrrr-mm.arc | binární | Archív hovorů (x=ústředna, rrrr=rok, mm=měsíc)


Použitá literatura a užitečné odkazy

  • Cascading Style Sheets (CSS) language, http://www.w3.org/Style/CSS

  • Extensible Markup Language (XML), http://www.w3.org/XML/

  • HyperText Markup Language (HTML), http://www.w3.org/MarkUp/

  • Info-Zip, Licence, http://www.info-zip.org/license.html

Dokumenty RFC

  • Character Mnemonics & Character Sets (RFC 1345), http://www.rfc-editor.org/rfc/rfc1345.txt, 1992

  • Assigned Numbers (RFC 1700), http://www.rfc-editor.org/rfc/rfc1700.txt, 1994

  • Post Office Protocol - Version 3 (RFC 1939), http://www.rfc-editor.org/rfc/rfc1939.txt, 1996

  • Hypertext Transfer Protocol -- HTTP/1.1 (RFC 2068), http://www.rfc-editor.org/rfc/rfc2068.txt, 1997


Kabely - Tartek

Konektory a kabely

Propojení pobočkové ústředny a bufferu Tarflex (obecné zapojení)


Kabely - Tarflex

Konektory a kabely

Propojení dvou bufferů Tarflex v zapojení za sebou


Kabely - Tarflex

Konektory a kabely

Propojení Buffer Tarflex - PC (standardní zapojení)


Kabely - Tarflex

Konektory a kabely

Propojení Buffer Tarflex - PC (dvoudrátové zapojení)


Kabely - Tarflex

Konektory a kabely

Připojení dvou bufferů Tarflex na jeden sériový port PC


Kabely - Tarflex

Konektory a kabely

Přemostění bufferu Tarflex


Kabely - Tarflex

Konektory a kabely

Propojovací kabel Buffer Tarflex - telefonní modem


Kabely - RS232

Konektory a kabely

RS 232 C - Cannon DB-9

Cannon DB-9
KZD (PC): vidlice
UZD (modem): zásuvka

vývod | signál
1 | DCD
2 | RD
3 | TD
4 | DTR
5 | SG
6 | DSR
7 | RTS
8 | CTS
9 | RI


Kabely - RS232

Konektory a kabely

RS 232 C - Cannon DB-25

Cannon DB-25

vývod | signál
FG | 1
SG | 7
TD | 2
RD | 3
RTS | 4
CTS | 5
DSR | 6
DTR | 20
DCD | 8

vývod | signál
TC | 15
RC | 17
STD | 14
SRD | 16
SRTS | 19
SCTS | 13
SDCD | 12
RI | 22


Kabely - RS232

Konektory a kabely

RS 232 C - Redukce Cannon DB-25/DB-9

vývod DB-9 | signál | vývod DB-25
1 | DCD | 8
2 | RD | 3
3 | TD | 2
4 | DTR | 20
5 | SG | 7
6 | DSR | 6
7 | RTS | 4
8 | CTS | 5
9 | RI | 22


Kabely - RS232

Konektory a kabely

RS 232 - nulový modem

signál | vývod | vývod | signál
SG | 5 | 5 | SG
RD | 2 | 3 | TD
TD | 3 | 2 | RD
DTR | 4 | 6 | DSR
DSR | 6 | 4 | DTR
Na obou stranách propojit 7 (RTS) a 8 (CTS)


Kabely - ethernet

Konektory a kabely

Ethernet - Kabel mezi PC a datovou zásuvkou


Kabely - ethernet

Konektory a kabely

Ethernet - křížený kabel na propojení dvou PC bez použití HUBu


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 01


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 02


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 03


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 04


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 05


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 06


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 07


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 08


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 09


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 10


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 11


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 12


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 13


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 14


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 15


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 16


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 17


Modul

Vzorky

Zapojení ústředen do bufferu

Číslo zapojení: 18


Modul

Konektory a kabely

Zapojení ústředen do bufferu

Číslo zapojení: 20


Modul

Konektory a kabely

Zapojení ústředen do bufferu

Číslo zapojení: 21


Modul

Konektory a kabely

Zapojení ústředen do bufferu

Číslo zapojení: 22


Modul

Konektory a kabely

Zapojení ústředen do bufferu

Číslo zapojení: 23


Kabely - Tarflex

Konektory a kabely

Zapojení vývodů konektoru RJ-10 na bufferu Tarflex-E


Kabely - Tartek

Konektory a kabely

Propojení Buffer Tartek - PC (starý buffer)


Kabely - Tartek

Konektory a kabely

Volba komunikační rychlosti u bufferu Tartek (starý buffer)


Tardat 4 - tabulka 'dalsipol'

Tabulky programu Tardat 4

Tabulka 'dalsipol'

Tabulka obsahuje nastavení dalších položek na faktuře individuálně pro každého odběratele.

Pole Popis

gid

Identifikační číslo skupiny = odběratele

id

Identifikační číslo položky

text

Popis položky (např. "pronájem tel. přístroje")

castka

Částka v haléřích

jesdph

Je-li 0, pak je částka uvedená v poli 'castka' bez daně, je-li 1 je uvedena s daní

procdph

Sazba daně z přidané hodnoty, v desetinách procenta

Poznámky:


Tardat 4 - tabulka 'denik'

Tabulky programu Tardat 4

Tabulka 'denik'

Tabulka obsahuje záznamy o provedených akcích v programu Tardat. Záznamy z deníku jsou v programu Tardat přístupné v editačním okně uživatele (Konfigurace uživatelů).

Pole Popis

dt

Datum a čas

evnt

Kód provedené akce, viz zdrojový kód programu

uid

Identifikační číslo uživatele, který akci provedl

data

Doplňující informace, význam pole závisí na kódu akce.

Poznámky:


Tardat 4 - tabulka 'export'

Tabulky programu Tardat 4

Tabulka 'export'

Tabulka obsahuje nastavení exportních filtrů. Každému uživateli se ukládá jeho individuální nastavení, v poli "uid" je uloženo číslo uživatele. Součástí primárního klíče je také pole "typ", které rozlišuje, zda řádek obsahuje nastavení nástroje "Export přehledu" nebo "Export konfigurace".

Pole Popis

uid

Identifikační číslo uživatele

typ

Rozlišuje nastavení nástroje (0 = Export přehledu, 1 = Export konfigurace)

cesta

Adresář, do kterého byl uložen naposled vytvořený soubor

soubor

Jméno naposled vytvořeného souboru

form

Formát výstupního souboru ('TEXT', 'RTF', 'HTML', 'CSV', 'SQL', 'DBF')

detail

Je-li 1, pak se zobrazují v průvodci detailní nastavení výstupního filtru

textnazev

Filtr TEXT: Je-li 1, pak se do výstupního souboru uloží název tabulky

textinfo

Filtr TEXT: Je-li 1, pak se do výstupního souboru uloží informační řádky

textpopis

Filtr TEXT: Je-li 1, pak se do výstupního souboru uloží popisy sloupcu

textsoucty

Filtr TEXT: Je-li 1, pak se do výstupního souboru uloží součtové řádky

textstranky

Filtr TEXT: Je-li 1, pak se do výstupního souboru ukládají znaky pro odstránkování. Počet řádků na stránce se nastavuje v poli 'textradku'.

textradku

Filtr TEXT: Počet řádků na stránce, používá se pouze pokud je zapnuto stránkování.

texth_cary

Filtr TEXT: Je-li 1, pak se do souboru uloží vodorovné čáry oddělující záčátek a konec tabulky.

textv_cary

Filtr TEXT: Je-li 1, pak se v tabulce oddělují jednotlivé sloupce svislými čarami.

textdvip

Filtr TEXT: Je-li 1, pak se jednotlivé bloky přehledu rozdělí do samostatných souborů.

textcp

Filtr TEXT: Způsob kódování českých znaků ('WIN' = Windows-1250, 'ISO' = ISO 8859-2, 'DOS' = Latin 2, 'KAM' = Kamenických, '7bit' = bez diakritiky)

rtfnazev

Filtr RTF: Je-li 1, pak se do výstupního souboru uloží název tabulky

rtfinfo

Filtr RTF: Je-li 1, pak se do výstupního souboru uloží informační řádky

rtfpopis

Filtr RTF: Je-li 1, pak se do výstupního souboru uloží popisy sloupcu

rtfsoucty

Filtr RTF: Je-li 1, pak se do výstupního souboru uloží součtové řádky

rtfdvip

Filtr RTF: Je-li 1, pak se jednotlivé bloky přehledu rozdělí do samostatných souborů.

csvnazev

Filtr CSV: Je-li 1, pak se do výstupního souboru uloží jako poznámka také název tabulky

csvinfo

Filtr CSV: Je-li 1, pak se do výstupního souboru uloží jako poznámky také informační řádky

csvpopis

Filtr CSV: Je-li 1, pak se do výstupního souboru uloží popisy sloupcu

csvdvip

Filtr CSV: Je-li 1, pak se jednotlivé bloky přehledu rozdělí do samostatných souborů.

csvcp

Filtr CSV: Způsob kódování českých znaků ('WIN' = Windows-1250, 'ISO' = ISO 8859-2, 'DOS' = Latin 2, 'KAM' = Kamenických, '7bit' = bez diakritiky)

csvenc

Filtr CSV: Znak, který se používá pro uzavření řetězcových polí.

csvencopt

Filtr CSV: Je-li 1, pak se uzavírají řetězcová pole pouze v případě, že je to nutné.

csvesc

Filtr CSV: Znak, který se používá pro uvození řídících znaků

csvfterm

Filtr CSV: Znak, který se používá pro oddělení polí v řádku (Pozn.: '\t' = tabulátor)

csvlterm

Filtr CSV: Znak, který se používá pro oddělení polí řádků (Pozn.: '\n' = CR+LF)

csvrem

Filtr CSV: Znak, kterým se uvozují řádky s poznámkami

csvdec

Filtr CSV: Znak, který se používá pro oddělení desetinných míst

htmlnazev

Filtr HTML: Je-li 1, pak se do výstupního souboru uloží název tabulky

htmlinfo

Filtr HTML: Je-li 1, pak se do výstupního souboru uloží informační řádky

htmlpopis

Filtr HTML: Je-li 1, pak se do výstupního souboru uloží popisy sloupcu

htmlsoucty

Filtr HTML: Je-li 1, pak se do výstupního souboru uloží součtové řádky

htmldvip

Filtr HTML: Je-li 1, pak se jednotlivé bloky přehledu rozdělí do samostatných souborů.

htmlcp

Filtr HTML: Způsob kódování českých znaků ('WIN' = Windows-1250, 'ISO' = ISO 8859-2, 'DOS' = Latin 2, 'KAM' = Kamenických, '7bit' = bez diakritiky)

sqlpozn

Filtr SQL: Je-li 1, pak se do výstupního souboru uloží jako poznámky název tabulky a informační řádky

sqlcreate

Filtr SQL: Je-li 1, pak se do výstupního souboru uloží příkazy CREATE TABLE pro vytvoření tabulky

sqldrop

Filtr SQL: Je-li 1, pak se do výstupního souboru uloží příkazy DROP TABLE pro zrušení stávající tabulky

sqluse

Filtr SQL: Je-li 1, pak se do výstupního souboru uloží příkaz USE pro výběr databáze. Jméno databáze musí být uloženo v poli 'sqldb'.

sqldb

Filtr SQL: Jméno databáze. Používá se pouze u příkazu USE.

sqltable

Filtr SQL: Jméno tabulky

sqlcp

Filtr SQL: Způsob kódování českých znaků ('WIN' = Windows-1250, 'ISO' = ISO 8859-2, 'DOS' = Latin 2, 'KAM' = Kamenických, '7bit' = bez diakritiky)

dbfdivp

Filtr DBF: Je-li 1, pak se jednotlivé bloky přehledu rozdělí do samostatných souborů.

dbfcp

Filtr DBF: Způsob kódování českých znaků ('WIN' = Windows-1250, 'ISO' = ISO 8859-2, 'DOS' = Latin 2, 'KAM' = Kamenických, '7bit' = bez diakritiky)

Poznámky:


Tardat 4 - tabulka 'hotel'

Tabulky programu Tardat 4

Tabulka 'hotel'

Tabulka účtů v nástroji minihotelový provoz. Tabulka obsahuje informace o aktivních i uzavřených účtech. Přiřazení poboček k účtům definuje tabulka 'hotelpob'.

Pole Popis

id_hotel

Identifikační číslo účtu. Interní informace, která se nikde nevypisuje.

jmeno

Jméno a příjmení hosta

ulice

Bydliště hosta, ulice + č.p., nepovinné

mesto

Bydliště hosta, město, nepovinné

psc

Bydliště hosta, PSČ, nepovinné

dalsi

Další údaje o hostovi, tento text bude vytištěn na účtence

pozn

Poznámky pro interní potřebu hotelu, tento text nebude vytištěn na účtence.

prichod

Datum a čas příchodu hosta.

odchod

Pokud je NULL, pak je tento účet aktivní. Pokud je vyplněno, účet byl uzavřen a pole obsahuje datum a čas odchodu hosta.

doklad

Pokud je účet aktivní nebo k tomuto účtu nebyl vystaven doklad, obsahuje pole prázdný řetězec. Jinak obsahuje číslo dokladu.

provolano

Pole se vyplní až při uzavření účtu, neobsahuje tedy aktuální stav účtu. Provolaná částka v haléřích před zaokrouhlením včetně DPH.

zaplaceno

Částka, která byla zaplacena při vyúčtování telefonního účtu. Částka je uvedena v haléřích, po zaokrouhlení a včetně DPH.

vlozil

Název uživatele, který provedl zapsání hosta do hotelového provozu.

vyuctoval

Název uživatele, který provedl vyúčtování hosta a uzavření jeho účtu.


Tardat 4 - tabulka 'hotelpob'

Tabulky programu Tardat 4

Tabulka 'hotelpob'

Tabulka určuje přiřazení poboček k účtům v minihotelovém provozu. Záznamy v tabulce zůstávají i po uzavření účtu.

Pole Popis

ucet

Identifikační číslo účtu. Viz pole id_hotel v tabulce hotel.

pobid

Identifikační číslo pobočky.

pbxid

Identifikační číslo ústředny, do které pobočka patří.


Tardat 4 - tabulka 'hovory'

Nahoru

Tabulky programu Tardat 4

Tabulka 'hovory'

Tabulka obsahuje údaje o hovorech v databázi programu. Primárním klíčem je pole "id_hovor", což je automaticky generované identifikační číslo hovoru.

Pole Popis

Start

Datum a čas zahájení hovoru

id_hovor

Identifikační číslo hovoru, automaticky generované, primární klíč tabulky.

HovorHotelu

Je-li 1, hovor je zařazen v zákanickém modulu "hotelový provoz"

Uskutecnen

Příznak určovaný ve zpracování, zda byl hovoru uskutečněn (0 = neuskutečněn, 1 = uskutečněn)

Vyzvednut

Příznak předávaný ústřednou, zda byl hovor vyzvednut (0 = nevyzvednut, 1 = vyzvednut)

Vyuctovan

Příznak vyúčtování hovoru (0 = ne, 1 = ano)

Jednotek

Počet jednotek předávaných ústředou jako informace o ceně, délce nebo uskutečnění hovoru

Trvani

Délka trvání hovoru změřená ústřednou v sekundách

Odecet10

Časový odečet od trvání hovoru v desetinách sekundy

Filtr

Časový filtr použitý při pseudotarifikaci v sekundách

KVyzva

Délka vyzvánění změřená ústřednou v sekundách

CisloPBX

Identifikační číslo ústředny, ze které hovor pochází

TypVolby

Způsob volby telefonního čísla (0 = žádná nebo neurčeno, 1 = pulzní, 2 = tónová), určuje zpracování

SRF

Číslo fyzického zdroje (max. 9 míst), předává ústředna

SRFTYPU

Typ fyzického zdroje, které předává ústředna (0 = neurčeno, 1 = pobočka, 2 = linka)

SRFTYPZ

Typ fyzického zdroje, které bylo určeno ve zpracování (0 = neurčeno, 1 = pobočka, 2 = linka)

SRL

Číslo logického zdroje (max. 9 míst)

SRLTYP

Typ logického zdroje (0 = neurčeno, 1 = pobočka, 2 = linka)

SRV

Virtuální zdroj: pokud šel hovor příčkou z jiné ústředny, obsahuje toto pole číslo ústředny, ze které hovor přišel

SRVTYP

Typ virtuálního zdroje (0 = žádný, 1 = ústředna)

PREPSR

Informace o přepojení hovoru na zdrojové straně, bitová maska ($01 = přijal, $02 = předal)

DTF

Číslo fyzického cíle (max. 9 míst), předává ústředna

DTFTYPU

Typ fyzického cíle, které předává ústředna (0 = neurčeno, 1 = pobočka, 2 = linka)

DTFTYPZ

Typ fyzického cíle, které bylo určeno ve zpracování (0 = neurčeno, 1 = pobočka, 2 = linka)

DTL

Číslo logického cíle (max. 9 míst)

DTLTYP

Typ logického cíle (0 = neurčeno, 1 = pobočka, 2 = linka)

DTV

Virtuální cíl: pokud šel hovor příčkou do jiné ústředny, obsahuje toto pole číslo ústředny, do které hovor odešel

DTVTYP

Typ virtuálního cíle (0 = žádný, 1 = ústředna)

PREPDT

Informace o přepojení hovoru na cílové straně, bitová maska ($01 = přijal, $02 = předal)

VOLCISF

Telefonní číslo ve tvaru, v jakém ho předala ústředna

VOLCISL

Telefonní číslo bez přístupových kódů z ústředny

VOLCISS

Telefonní číslo, které bylo použito pro tarifikaci v tarifní síti

MASKPOCET

Doporučený počet číslic, které mají být v telefonním čísle zamaskovány. Skutečný počet zamaskovaných číslic je určen až při tvorbě přehledu na základě aktuální konfigurace. Je-li typ masky určen jako zbytek případně zbytek max. 4, použije se hodnota v tomto poli.

ACCESTRF

Odchozí kód předaný z ústředny, pokud není součástí telefonního čísla.

ACCESTRL

Odchozí kód určený ve zpracování z polí ACCESTRF a VOLCISF

ACCE

Identifikační číslo položky v tabulce přístupových kódů z ústředny (pro filtrování)

AUTHSTR

Autorizační kód předaný z ústředny

AUTHTYP

Příznak, který určuje jakým způsobem zpracování naložilo s autorizačním kódem. (0 = Nezadán, 1 = vadný, 2 = Použit beze změny pob., 4 = Použit se změnou pob.)

ACCOSTR

Zúčtovací kód předaný z ústředny

ACCOTYP

Příznak, který určuje jakým způsobem zpracování naložilo se zúčtovacím kódem. (0 = Nezadán, 1 = vadný, 2 = Použit)

USERSTR

Uživatelský kód předaný z ústředny

SKUPSTR

Kód nákladové střediska předaný z ústředny

SKUPTYP

Příznak, který určuje jakým způsobem zpracování naložilo s kódem nákladového střediska. (0 = Vadný, 1 = Použit, 2 = Nezadán, 3 = Nepoužit)

SITTYP

Typ sítě použitý pro tarifikaci (0 = Žádná síť, 1 = Vlastní tarifní síť ve zdroji, 2 = Vlastní tarifní síť v cíli, 3 = Nevlastní tarifní síť ve zdroji, 4 = Nevlastní tarifní síť v cíli, 5 = Vlastní uživatelská síť ve zdroji, 6 = Vlastní uživatelská síť v cíli, 7 = Nevlastní uživatelská síť ve zdroji, 8 = Nevlastní uživaelská síť v cíli)

BOD

Je-li použita tarifní síť, určuje identifikační číslo vstupního bodu použitého pro tarifikaci, je-li použita uživatelská síť, určuje identifikační číslo položky v uživatelské sítě.

STAT

Identifikační číslo státu, do kterého je zařazen provozovatel (pouze tarifní sítě)

PROVOZOVATEL

Identifikační číslo provozovatele (pouze tarifní sítě)

TARPROGRAM

Identifikační číslo použitého tarifního programu (pouze tarifní sítě)

SAZEBNIK

Identifikační číslo sazebníku použitého pro tarifikaci (pouze tarifní sítě)

PROVOZ

Identifikační číslo tarifního provozu, do kterého byl hovor zařazen (pouze tarifní sítě)

PASMOPRO

Identifikační číslo tarifního pásma, do kterého byl hovor zařazen (pouze tarifní sítě)

PASMOSITE

Identifikační číslo síťového pásma (nezobrazuje se)

OBLASTMMM

Číslo tarifního oblasti, do které byl hovor zařazen, hodnoty jsou určeny výčtem ve zdrojovém kódu, nesouvisí s tabulkou 'oblastisite'

TYPINFORMACE

Příznak určující způsob, jakým byl ve zpracování použit počet jednotek předaných z ústředny (0 = informace o ceně hovoru, 1 = informace o délce hovoru, 2 = informace o uskutečnění hovoru, 3 = nepoužito)

JETARIFPR

Je-li nastaven na 1, byla použita přesná tarifikace

JETARIFPS

Je-li nastaven na 1, byla použita pseudotarifikace

JETARIFKOR

Je-li nastaven na 1, byla použita korekce

JETARIFKOR

Je nastaven na 1, pokud dává ústředna trvání hovoru až od 1. pulzu

UMISSTA

Identifikační číslo uzlu v tarifní síti, který odpovídá státu volaného. Zobrazuje se v poli "stát"

UMISTTO

Identifikační číslo uzlu v tarifní síti, který odpovídá umístění volaného. Zobrazuje se v poli "umístění"

UMISMTO

Identifikační číslo uzlu v tarifní síti, který odpovídá detailnímu umístění volaného. Zobrazuje se v poli "detailní umístění"

PULZU

Nepřepočtená cena hovoru (tj. tak jak byla vypočtena ve zpracování), bez příplatku, včetně DPH, v haléřích

TYPPULZU

Nepoužito

CENAPUL

Nepoužito

PRIPLATEK

Příplatek k hovoru, v 0.1 %

PROCDPH

Sazba daně z přidané hodnoty, v 0.1 %

CENAPREPOC

Přepočtená cena hovoru (tj. upravená nástrojem Přepočet podle účtu), včetně příplatku a DPH, v haléřích

Poznámky:


Tardat 4 - tabulka 'hwklice'

Tabulky programu Tardat 4

Tabulka 'hwklice'

Tabulka obsahuje kopii informací z klíče. Obsah tabulky se nesmí editovat, jinak program přestane zpracovávat hovory!

Poznámky:


Tardat 4 - tabulka 'hwzdroje'

Tabulky programu Tardat 4

Tabulka 'hwzdroje'

Tabulka obsahuje kopii informací z klíče. Obsah tabulky se nesmí editovat, jinak program přestane zpracovávat hovory!

Poznámky:


Tardat 4 - tabulka 'importform'

Tabulky programu Tardat 4

Tabulka 'importform'

Tabulka obsahuje položky nastavení formátů řádků v souborech CSV. Formáty se nastavují v konfiguraci ústředny v dialog "Pro odborníky". Používají se v nástroji "Import hovorů ze souboru CSV". Nastavení je společné pro všechny ústředny.

Pole Popis

id

Identifikační číslo položky

jmeno

Uživatelské jméno položky, obvykle jméno operátora

pocetpoli

Počet polí v souboru

separ

Znak oddělující jednotlivá pole, obvykle středník

voltyp

Způsob určení volajícího (= pobočky). (0 = maskou z položky, 1 = tabulkou 'importpob', 2 = výběrem při importu)

volpoz

Pořadí položky určující volajícího. Používá se pouze je-li 'voltyp' = 0 nebo 1.

volmaska

Počet číslic zprava, které se použijí z pole určující volajícího k vytvoření čísla pobočky.

lintyp

Způsob přiřazení hovory k lince. (0 = maskou z položky, 1 = tabulkou 'importlin')

linpoz

Pořadí položky určující linku.

linmaska

Počet číslic zprava, které se použijí z pole určující linku k vytvoření čísla linky.

datum

Pořadí položky určující datum.

cas

Pořadí položky určující čas.

telcislo

Pořadí položky určující volané telefonní číslo.

trvání

Pořadí položky určující trvání hovoru.

cena

Pořadí položky určující cenu hovory.

uzivkod

Pořadí položky určující další doplňující informace (uživatelský kód). U formátu Eurotel rozlišuje volání (TEL) a textové zprávy (TEXT).

Poznámky:

Barva písma a podkladu se ukládá jako celé číslo, které po převedení do šestnáctkového zápisu lze rozdělit po osmi bitech na hodnoty barevných kanálů R, G a B.


Tardat 4 - tabulka 'importlin'

Tabulky programu Tardat 4

Tabulka 'importlin'

Překladová tabulka používaná v nástroji "Import hovorů ze souboru CSV". Převádí telefonní číslo volajícího na identifikační číslo linky. Používá se pouze v případě, že je tato funkce povolena ve formátu - viz tabulka 'importform', pole 'lintyp'.

Pole Popis

id

Identifikační číslo položky.

maska

Maska telefonních čísel, pravidla pro rozlišení hovorů podle telefonního čísla.

linka

Identifikační číslo linky, ke které se hovor přiřadí.

Poznámky:


Tardat 4 - tabulka 'importpob'

Tabulky programu Tardat 4

Tabulka 'importpob'

Překladová tabulka používaná v nástroji "Import hovorů ze souboru CSV". Převádí telefonní číslo volajícího na identifikační číslo pobočky. Používá se pouze v případě, že je tato funkce povolena ve formátu - viz tabulka 'importform', pole 'voltyp'.

Pole Popis

id

Identifikační číslo položky.

maska

Maska telefonních čísel, pravidla pro rozlišení hovorů podle telefonního čísla.

pobocka

Identifikační číslo pobočky, ke které se hovor přiřadí.

Poznámky:


Tardat 4 - tabulka 'intseznam'

Tabulky programu Tardat 4

Tabulka 'intseznam'

Tabulka obsahuje položky interního telefonního seznamu.

Pole Popis

id

Identifikační číslo položky

maska

Maska telefonních čísel, pravidla pro rozlišení hovorů podle telefonního čísla

jmeno

Uživatelské jméno položky. Pokud je pole 'zobr'=1, pak se v přehledu zobrazuje jméno v polích "Detailní umístění" a "Interní seznam".

pozn

Poznámka, libovolný text

zobr

Je-li 1, pak se jméno položky zobrazuje v přehledu v polích "Detailní umístění" a "Interní seznam".

jepismo

Je-li 1, pak se hovory přiřazené k této položce zvýrazní v přehledu odlišnou barvou písma, nastavenou v poli 'pismo'

pismo

Barva písma použitá pro hovory přiřazené k této položce (funkce musí být povolena v poli 'jepismo'), viz poznámky

jepozadi

Je-li 1, pak se hovory přiřazené k této položce zvýrazní v přehledu odlišnou barvou podkladu, nastavenou v poli 'pozadi'

pozadi

Barva podkladu použitá pro hovory přiřazené k této položce (funkce musí být povolena v poli 'jepozadi'), viz poznámky

Poznámky:

Barva písma a podkladu se ukládá jako celé číslo, které po převedení do šestnáctkového zápisu lze rozdělit po osmi bitech na hodnoty barevných kanálů R, G a B.


Tardat 4 - tabulka 'linky'

Tabulky programu Tardat 4

Tabulka 'linky'

Tabulka obsahuje nastavení linek na ústřednách. Primárním klíčem tabulky je dvojice polí "pbxid" - číslo ústředny do které linka patří, a "id" - identifikační číslo linky. Odchozí a příchozí připojení, uložené v této tabulce se používá pouze pro linky s tzv. samostatným připojením, což jsou linky nepřiřazené do nějakého svazku. U takových linek je pole 'dosvazku' nastaveno na 0.

Pole Popis

id

Identifikační číslo linky (max. 9 míst)

pbxid

Identifikační číslo ústředny

jmeno

Uživatelské jméno linky, které se zobrazuje v přehledech, např. přiřazené telefonní číslo nebo text "GSM brána" apod.

pozn

Poznámka, libovolný text, lze zobrazit v přehledu

vis

Je-li 0, pak hovory z této linky se nezobrazují v přehledech

jetarifpr

Je-li 1, pak pro hovory na této lince předává ústředna tarifní informace

jetarifkor

Je-li 1, pak je povolena funkce korekce,

ignode

Je-li 1, pak se na této lince ignorují nastavené časové odečty (pro ISDN linky)

ignfil

Je-li 1, pak se na této lince ignorují nastavené časové filtry

typvolby

Typ volby telefonního čísla (0 = žádná, 1 = pulzní, 2 = tónová)

pripl

Příplatek k ceně hovoru v procentech

jepismo

Je-li 1, pak se hovory na této lince zvýrazní v přehledu odlišnou barvou písma, nastavenou v poli 'pismo'

pismo

Barva písma použitá pro hovory na této lince (funkce musí být povolena v poli 'jepismo'), viz poznámky

jepozadi

Je-li 1, pak se hovory na této lince zvýrazní v přehledu odlišnou barvou podkladu, nastavenou v poli 'pozadi'

pozadi

Barva podkladu použitá pro hovory na této lince (funkce musí být povolena v poli 'jepozadi'), viz poznámky

dosvazku

Je-li 1, pak je linka zařazena do svazku, ze kterého se také přebírá nastavení odchozího a příchozího směru.

svazek

Identifikační číslo svazku. Pole 'pbxid', číslo ústředny, musí být u linky a svazku shodné.

ToPtr_DoSite

Odchozí připojení: Je-li 1, je linka zapojena do tarifní sítě. Číslo vstupního bodu musí být nastaveno v poli 'ToPtr_Bod'.

ToPtr_Bod

Odchozí připojení: Identifikační číslo vstupního bodu pro vstup do tarifní sítě. Pole 'ToPtr_DoSite' musí být 1.

ToPtr_DoUSite

Odchozí připojení: Je-li 1, je linka zapojena do uživatelské sítě.

ToPtr_DoTab

Odchozí připojení: Je-li 1, hovory se tarifikují podle tabulky přístupových kódů v této ústředně

ToPtr_DoPSite

Odchozí připojení: Je-li 1, je linka zapojena do průchodové sítě. Číslo sítě musí být nastaveno v poli 'ToPtr_PSit'.

ToPtr_PSit

Odchozí připojení: Identifikační číslo průchodové sítě. Pole 'ToPtr_DoPSite' musí být 1.

ToPtr_DoPbx

Odchozí připojení: Je-li 1, hovory se tarifikují podle tabulky přístupových kódů jiné ústředny. Číslo ústředny musí být nastaveno v poli 'ToPtr_Pbx'.

ToPtr_Pbx

Odchozí připojení: Identifikační číslo ústředny, do které je linka připojena. Pole 'ToPtr_DoPbx' musí být 1.

FmPtr_DoSite

Příchozí připojení: Je-li 1, je linka zapojena do tarifní sítě. Číslo vstupního bodu musí být nastaveno v poli 'FmPtr_Bod'.

FmPtr_Bod

Příchozí připojení: Identifikační číslo vstupního bodu pro vstup do tarifní sítě. Pole 'FmPtr_DoSite' musí být 1.

FmPtr_DoUSite

Příchozí připojení: Je-li 1, je linka zapojena do uživatelské sítě.

FmPtr_DoTab

Příchozí připojení: Je-li 1, hovory se tarifikují podle tabulky přístupových kódů v této ústředně

FmPtr_DoPSite

Příchozí připojení: Je-li 1, je linka zapojena do průchodové sítě. Číslo sítě musí být nastaveno v poli 'FmPtr_PSit'.

FmPtr_PSit

Příchozí připojení: Identifikační číslo průchodové sítě. Pole 'FmPtr_DoPSite' musí být 1.

FmPtr_DoPbx

Příchozí připojení: Je-li 1, hovory se tarifikují podle tabulky přístupových kódů jiné ústředny. Číslo ústředny musí být nastaveno v poli 'FmPtr_Pbx'.

FmPtr_Pbx

Příchozí připojení: Identifikační číslo ústředny, do které je linka připojena. Pole 'FmPtr_DoPbx' musí být 1.

Poznámky:

Barva písma a podkladu se ukládá jako celé číslo, které po převedení do šestnáctkového zápisu lze rozdělit po osmi bitech na hodnoty barevných kanálů R, G a B.


Tardat 4 - tabulka 'monitor'

Tabulky programu Tardat 4

Tabulka 'monitor'

Tabulka obsahuje nastavení nástroje "Monitor hovorů". Každý uživatel má své vlastní nastavení.

Pole Popis

uid

Identifikační číslo uživatele, ke kterému záznam patří

sekund

Interval obnovování okna monitoru v sekundách

pocet

Maximální počet řádků, který se zobrazuje v monitoru

sloupce

Seznam identifikačních čísel zobrazených sloupců

cenap

Je-li 1, zobrazuje se cena také u příchozích hovorů

CelaDb

Globální povolení filtrování hovorů (0 = filtrovat, 1 = celá databáze)

FUziv

Je-li 1, hovory se filtrují podle uživatelských kódů

Uziv

Seznam zobrazovaných uživatelských kódů, viz poznámky

FPbx

Je-li 1, hovory se filtrují podle identifikačního čísla ústředny

Pbx

Seznam identifikačních čísel zobrazovaných ústředen, viz poznámky

FTyp

Je-li 1, hovory se filtrují podle typu hovoru

Typ

Filtr podle typu hovoru, bitová maska ($01 = odchozí, $02 = příchozí, $04 = vnitřní, $08 = tranzitní, $10 = neurčeno)

FPob

Je-li 1, hovory se filtrují podle poboček

Pob

Seznam zobrazovaných poboček, viz poznámky

FLin

Je-li 1, hovory se filtrují podle linek

Lin

Seznam zobrazovaných linek, viz poznámky

Poznámky:

Seznam poboček, linek apod. se zapisuje jako text, jednotlivé položky se oddělují čárkou. Každá položka se skládá ze dvou komponent, které se nazývají prefix a suffix; u tabulky poboček je prefixem číslo ústředny a suffixem číslo pobočky. V textovém zápisu se položka uvádí ve tvaru prefix:suffix, přičemž prefix s dvojtečkou lze vynechat, pokud je shodný s prefixem předchozí položky. Prefix se vynechá u první položky, je-li roven 0.


Tardat 4 - tabulka 'nazvysloupcu'

Tabulky programu Tardat 4

Tabulka 'nazvysloupcu'

Tabulka obsahuje uživatelské názvy sloupců. Sloupce, pro které se používají standardní názvy, se v tabulce neuvádějí. Je-li uživatelský název vlnovka, pak je sloupec skrytý a není ani nabízen v tabulce zobrazených údajů. Uživatelské názvy jsou společné pro všechny uživatele. Primárním klíčem je pole "id", což je identifikační číslo sloupce, které je definováno výčtem uvedeným ve zdrojovém kódu programu.

Pole Popis

id

Identifikační číslo sloupce

nazev

Uživatelský název sloupce (~ = skrytý sloupec)

Poznámky:


Tardat 4 - tabulka 'tarsite'

Tabulky programu Tardat 4

Tabulka 'obecne'

Tabulka obsahuje základní informacemi o nainstalovaném programu a řadu dalších nastavení společných pro všechny uživatele. Tabulka má vždy pouze jeden řádek.

Pole Popis

layout

Typ uživatelského rozhraní programu Tardat (0 = telefonní ústředny, 1 = zabezpečovací ústředny)

kadmin

Je-li 1, je povoleno přihlášení správce pomocí klientské instalace programu Tardat

phesla

Je-li 1, je povoleno uložení prázdného přístupového hesla

verstr

Kompletní řetězec s nainstalovanou verzí programu. Needitovat!

vernum

Číslo verze programu. Needitovat!

vernum

Nejvyšší číslo verze povolené v klíči. Needitovat!

modkey

Rozšiřující moduly povolené v klíči. Needitovat!

cna

Počítadlo, používané pro komunikaci s klíčem. Needitovat!

cna

Počítadlo, které se zvýši po změně konfigurace ústředen. Zajistí, že si modul Zpracování automaticky načte novou konfiguraci.

cna2

Počítadlo, které se zvýši po změně konfigurace ústředen. Zajistí, že si modul Zpracování automaticky načte novou konfiguraci.

crc

Kontrolní součet informací v klíči. Needitovat!

softkeys

Typ klíče (0 = hadrwarový, 1 = softwarový). Needitovat!

ico

Identifikační číslo organizace (IČO). Musí souhlasit s hodnotou v softwarovém klíči. Needitovat!

jmeno

Jméno organizace. Musí souhlasit s hodnotou v softwarovém klíči. Needitovat!

fakcislo

Pořadové číslo následující faktury. Po vytisknutí faktury se automaticky zvyšuje o 1.

fakprilohy

Je-li 1, tiskne se k faktuře výpis hovorů jako příloha

dodjmeno1

Informace na faktuře o dodavateli - jméno, 1. řádek

dodjmeno2

Informace na faktuře o dodavateli - jméno, 2. řádek

dodulice

Informace na faktuře o dodavateli - ulice + číslo

dodmesto

Informace na faktuře o dodavateli - město

dodpsc

Informace na faktuře o dodavateli - poštovní směrovací číslo (PSČ)

dodico

Informace na faktuře o dodavateli - identifikační číslo organizace (IČO)

doddic

Informace na faktuře o dodavateli - daňové identifikační číslo (DIČ)

dodbanka

Informace na faktuře o dodavateli - bankovní spojení

dodostatni

Informace na faktuře o dodavateli - údaje o zápisu do živnostenského nebo obchodího rejstříku

dodplatce

Nastavit na 1, pokud je dodavatel plátcem daně z přidané hodnoty

uctcislo

Pořadové číslo následující účtenky. Po vytisknutí účtenky se automaticky zvyšuje o 1.

UctPapir

Formát papíru při tisku účtenky (0 = A3, 1 = A4, 2 = A5)

UctOrient

Orientace papíru nastavená v tisku účtenky (0 = na šířku, 1 = na výšku)

UctNadpis

Text uvedený v záhlaví účtenky velkým písmem, obvykle jméno firmy

UctPodnadpis

Text uvedený v záhlaví účtenky menším písmem, obvykle adresa firmy, IČO, ...

UctZaver

Text uvedený v závěru účtenky, obvykle poděkování apod.

UctZaokr

Způsob zaokrouhlení výsledné částky (0 = na haléře, 1 = na 10hal nahoru, 2 = na 50hal nahoru, 3 = na 1Kc nahoru, 4 = na 10hal, 5 = na 50hal, 6 = na 1Kc)

UctVypis

Je-li 1, tiskne se na účtence podrobný výpis hovorů

UctBw

Je-li 1, účtenka se tiskne bez barevného rozlišování řádků.

UctDatum

Formát data na účtence (0 = 26/8/2004, 1 = 26. 8. 2004, 2 = 26. srp. 2005, 3 = 26. srpna 2004, 4 = Pá 26. srpna 2004, 5 = 2004-08-26)

UctTMargin

Horní okraj při tisku účtenky v setinách milimetru

UctBMargin

Dolní okraj při tisku účtenky v setinách milimetru

UctRMargin

Pravý okraj při tisku účtenky v setinách milimetru

UctLMargin

Levý okraj při tisku účtenky v setinách milimetru

UctFont1

Definice písma používaného pro nadpis, viz poznámky

UctFont2

Definice písma používaného pro podnadpis, viz poznámky

UctFont3

Definice písma používaného pro závěrečné řádky, viz poznámky

UctVyuct

Je-li 1, pak se na účtence zobrazují i vyúčtované hovory (jen hotelový provoz).

UctNeplac

Je-li 1, pak se na účtence zobrazují i neplacené hovory (jen hotelový provoz).

FontName

Předdefinované písmo používaný pro standardní nastavení stylů v přehledech

FontSize

Předdefinovaná velikost fontu používaná pro standardní nastavení stylů v přehledech

FontStyle

Předdefinovaný styl fontu používaný pro standardní nastavení stylů v přehledech. Styl je řetězec 0-4 znaků: (B = tučné, I = kurzíva, U = podtržené, S = přeškrtnuté).

FontCharset

Předdefinované identifikační číslo znakové sady, která se používaná pro standardní nastavení stylů v přehledech (obvykle 238 = Středoevropské jazyky)

Poznámky:

Nastavení písma se ukládá jako text, jednotlivé položky jsou odděleny středníkem: Jméno;Velikost;Styl;Číslo znakové sady;Barva. Styl je řetězec 0-4 znaků: (B = tučné, I = kurzíva, U = podtržené, S = přeškrtnuté).


Tardat 4 - tabulka 'oblastisite'

Tabulky programu Tardat 4

Tabulka 'oblastisite'

Tabulka předdefinovaných vlastních telefonních čísel pro jednotlivé oblasti a operátory. Položky jsou rozděleny do států. Informace z tabulky se používají v dialogu 'Editace vstupního bodu'. Obsahuje kopii dat ze souboru s tarifní sítí.

Pole Popis

id

Identifikační číslo položky

jmeno

Jméno kraje nebo operátora

predvolba

Mezinárodní předvolba (např. 00420). Musí odpovídat nějakému záznamu v tabulce státy.

cislo

Telefonní číslo v národním formátu bez mezer.

Poznámky:


Tardat 4 - tabulka 'odberatele'

Tabulky programu Tardat 4

Tabulka 'odberatele'

Tabulka obsahuje nastavení faktur v sekci odběratele. Každý odběratel odpovídá jedné skupině poboček (mají stejná identifikační čísla).

Pole Popis

gid

Identifikační číslo skupiny = odběratele

jmeno1

Jméno odběratele, 1. řádek

jmeno2

Jméno odběratele, 2. řádek

ulice

Adresa odběratele, ulice + číslo

mesto

Adresa odběratele, město

psc

Poštovní směrovací číslo

ico

Identifikační číslo organizace (IČO)

dic

Daňové indentifikační číslo (DIČ)

banka

Bankovní spojení

objedn

Číslo objednávky

ks

Konstantní symbol (KS)

uhrada

Způsob úhrady (0 = převodem, 1 = v hotovosti)

zaokr

Způsob zaokrouhlení částek (0 = na haléře, 1 = na 10hal nahoru, 2 = na 50hal nahoru, 3 = na 1Kc nahoru, 4 = na 10hal, 5 = na 50hal, 6 = na 1Kc)

Poznámky:


Tardat 4 - tabulka 'odefil'

Tabulky programu Tardat 4

Tabulka 'odefil'

Tabulka obsahuje nastavení časových odečtů a filtrů. Tyto konstanty se používají při pseudotarifikaci. Každá ústředna má svoji vlastní sadu konstant. Uživatel také může nastavit speciální sadu odečtů a filtrů pro linky zařazené do svazku. Primární klíč tabulky tvoří tři pole: 1) pole 'pbxid' - číslo ústředny, 2) pole 'busid', které obsahuje buď hodnotu -1 pro hodnoty platné v rámci jedné ústředny nebo identifikační číslo svazku v případě, že řádek definuje hodnoty platné pouze pro linky zařazené do tohoto svazku a 3) číslo oblasti, kterým se rozlišují hovory místní, dálkové, mezinárodní, atd.

Pole Popis

pbxid

Identifikační číslo ústředny

busid

Identifikační číslo svazku nebo -1, pokud platí pro všechny linky ústředny

oblast

Identifikační číslo oblasti, definované výčtem ve zdrojovém kódu

ode

Časový odečet v desetinách sekundy

fil

Časový filtr v sekundách

Poznámky:


Tardat 4 - tabulka 'pobocky'

Tabulky programu Tardat 4

Tabulka 'pobocky'

Tabulka obsahuje nastavení poboček (vnitřních linek) na ústřednách. Primárním klíčem tabulky je dvojice polí "pbxid" - číslo ústředny do které pobočka patří, a "id" - identifikační číslo pobočky.

Pole Popis

id

Identifikační číslo pobočky (max. 9 míst)

pbxid

Identifikační číslo ústředny

jmeno

Uživatelské jméno pobočky, které se zobrazuje v přehledech, např. jméno zaměstnance apod.

pozn

Poznámka, libovolný text, lze zobrazit v přehledech.

pripl

Příplatek k ceně hovoru v procentech

jepismo

Je-li 1, pak se hovory na této pobočce zvýrazní v přehledu odlišnou barvou písma, nastavenou v poli 'pismo'

pismo

Barva písma použitá pro hovory na této pobočce (funkce musí být povolena v poli 'jepismo'), viz poznámky

jepozadi

Je-li 1, pak se hovory na této pobočce zvýrazní v přehledu odlišnou barvou podkladu, nastavenou v poli 'pozadi'

pozadi

Barva podkladu použitá pro hovory na této pobočce (funkce musí být povolena v poli 'jepozadi'), viz poznámky

vis

Je-li 0, pak hovory z této pobočky se nezobrazují v přehledech

hotel

Je-li 1, pak tato pobočka je zařazena do hotelového provozu.

auth

Autorizační kód. Je-li uveden v tarifním řádku stejný kód, pak se hovory přiřadí k této pobočce bez ohledu na číslo pobočky předané v tarifním řádku z ústředny.

skup

Identifikační číslo skupiny, do které je pobočka zařazena (viz tabulka 'skupiny')

stred

Identifikační číslo střediska, do kterého je pobočka zařazena (viz tabulka 'strediska')

masktyp

Způsob maskování telefonního čísla, funkce musí být povolena v nastavení ústředny - pole 'maskpodle' (0 = Nemaskovat, 1 = Zbytek, 2 = Zbytek max. 4, 3 = 1 místo, 4 = 2 místa, 5 = 3 místa, 6 = 4 místa, 7 = 5 míst, 8 = 6 míst)

Poznámky:

Barva písma a podkladu se ukládá jako celé číslo, které po převedení do šestnáctkového zápisu lze rozdělit po osmi bitech na hodnoty barevných kanálů R, G a B.


Tardat 4 - tabulka 'prehledy'

Tabulky programu Tardat 4

Tabulka 'prehledy'

Tabulka obsahuje nastavení všech definovaných přehledů s výjimkou přehledu "Naposled vytvořený", který je uložen v uživatelském profilu na disku. Primárním klíčem je pole "id_prehled", které je automaticky generováno. Přehledy jsou rozděleny do uživatelských složek hodnotou v poli "userid".

Pole Popis

id_prehled

Identifikační číslo přehledu, automaticky generované, primární klíč tabulky.

userid

Identifikační číslo uživatele, do jehož složky přehled patří. Je-li v tomto poli hodnota -1, jedná se o "Obecně dostupný přehled".

nazev

Jméno přehledu zobrazované v nabídce přehledy apod.

vlast

Identifikační číslo uživatele, který naposledy uložil tento přehled.

druh

Druh přehledu (0 = detailní, 1 = souhrnný)

ZobrCenuPrich

Je-li 1, pak se zobrazuje cena i u příchozích hovorů.

StartFiltr

Je-li 1, pak se po otevření přehledu automaticky nabízí dialog pro editaci filtru.

StartTisk

Je-li 1, pak se po otevření přehledu automaticky nabízí tisk přehledu.

StartFakt

Je-li 1, pak se po otevření přehledu automaticky nabízí tisk faktury.

ZobrazNevol

Je-li 1, pak je povoleno zobrazování řádků s počtem hovorů 0 v souhrnném přehledu.

IgnorBarvy

Je-li 1, pak je ignorováno nastavení barev písma a pozadí.

FormDelky

Formát zobrazování trvání hovory (0 = 99h 99m 99s, 1 = 99:99:99)

FormDatCas

Formát zobrazování data a času (0 = 99:99, 1 = 99:99:99)

Odberatel

Identifikační číslo naposledy vybraného uživatele v dialogu "Nastavení faktury"

RezimFiltr

Způsob zadávání podmínek filtru (0 = celý, 1 = jen vybrané části, 2 = jen vybrané části formou průvodce, 3 = zakázán)

CastiFiltr

Vybrané části filtru, bitová maska

RezimPrehl

Povolení/zákaz nastavení přehledu (0 = povoleno vše, 1 = jen vybrané části, 2 = nelze editovat)

CastiPrehl

Vybraná nastavení přehledu, bitová maska

KurzorKriz

Povoluje zvýrazňování řádek a sloupec, ve kterém stojí kurzor

ZobrazPanel

Povoluje zobrazení horního ovládacího panelu v okně přehledů

ZobrazTlac

Povoluje zobrazení levého tlačítkového panelu v okně přehledů

PlnaMrizka

Přepíná typ mřížky v tabulce (0 = jen obrysy, 1 = plná mřížka)

BarvaMrizky

Barva mřížky v tabulce

BlokNaSloupec

Zalomit bloky na samostatné sloupce

BlokNaStranku

Zalomit bloky na samostatné strany

BlokNaList

Zalomit bloky na samostatné listy (dvojstránky)

ZobrazFiltr

Zobrazit nastavení filtru v záhlaví přehledu

PodrobFiltr

Je-li 1, pak se zobrazuje podrobný filtr (např. plný seznam vybraných poboček) v záhlaví přehledu

ZobrazRazeni

Povoluje zobrazování způsobu řazení v záhlaví přehledu

ZobrazUvod

Povoluje zobrazování úvodního řádku. Pokud je program nainstalován se softwarovým klíčem, nelze vypnout.

ZobrazZaver

Povoluje zobrazování závěrečného řádku s počtem bloků a řádků

ZobrazNazev

Vybírá text zobrazený v nadpisu přehledu (1 = automaticky generovaný popis přehledu, 2 = název přehledu, 3 = uživatelský text)

NazevText

Uživatelský text zobrazovaný v nadpisu přehledu místo automaticky generovaného textu. Pole "ZobrazNazev" musí být nastaveno na hodnotu 3)

SortCol1

První sloupec pro řazení, identifikační číslo sloupce

SortDir1

Směr řazení pro první kritérium (0 = vzestupně, 1 = sestupně)

SortCol2

Druhý sloupec pro řazení, identifikační číslo sloupce

SortDir2

Směr řazení pro druhé kritérium (0 = vzestupně, 1 = sestupně)

GroupCol1

První sloupec pro sdružování hovorů do řádku, identifikační číslo sloupce

GroupDir1

Směr řazení řádků pro první kritérium (0 = vzestupně, 1 = sestupně)

GroupCol2

Druhý sloupec pro sdružování hovorů do řádku, identifikační číslo sloupce

GroupDir2

Směr řazení řádků pro druhé kritérium (0 = vzestupně, 1 = sestupně)

BlokCol1

První sloupec pro rozdělení řádků do bloků, identifikační číslo sloupce

BlokDir1

Směr řazení bloků pro první kritérium (0 = vzestupně, 1 = sestupně)

BlokCol2

Druhý sloupec pro rozdělení řádků do bloků, identifikační číslo sloupce

BlokDir2

Směr řazení bloků pro druhé kritérium (0 = vzestupně, 1 = sestupně)

UseLimit

Omezení počtu řádků (0 = vypnuto, 1 = zapnuto)

ValLimit

Max. počet řádků, funkce musí být povolena (UseLimit = 1)

CelaDB

Globální povolení filtrování hovorů (0 = filtrovat, 1 = celá databáze)

FDatumCas

Je-li 1, hovory se filtrují podle data a času

DatumCas

Způsob filtrování podle data a času (0 = absolutně, 1 = relativně)

CasOd

Počáteční datum a čas intervalu pro filtrování

CasDo

Koncové datum a čas intervalu pro filtrování

RelInt

Interval pro relativní filtrování podle data a času (0 = rok, 1 = měsíc, 2 = týden, 3 = den, 4 = hodina, 5 = minuta)

RelOd

Počáteční násobek intervalu pro relativní filtrování

RelDo

Koncový násobek intervalu pro relativní filtrování

RelPrv

Číslo prvního dne v měsíci, kterým začíná účetní období. Používá se pouze u relativního filtrování s intervalem 'měsíc'.

FDny

Je-li 1, hovory se filtrují podle dne v týdnu

Dny

Vybrané dny v týdnu pro filtrování, bitová maska ($001 = Pracovní dny, $002 = Pondělí, $004 = Úterý, $008 = Středa, $010 = Čtvrtek, $020 = Pátek, $040 = Volné dny, $080 = Sobota, $100 = Neděle, $200 = Státní svátky)

FDoba

Je-li 1, hovory se filtrují podle denní doby

DobaOd

Začátek intervalu pro filtrování podle denní doby v minutách

DobaDo

Konec intervalu pro filtrování podle denní doby v minutách

FTrvani

Je-li 1, hovory se filtrují podle trvání

TrvaniOd

Začátek intervalu pro filtrování podle trvání v sekundách. Je-li menší než 0, hranice se nekontroluje

TrvaniDo

Konec intervalu pro filtrování podle trvání v sekundách. Je-li menší než 0, hranice se nekontroluje

FVyzva

Je-li 1, hovory se filtrují podle délky vyzvánění

VyzvaOd

Začátek intervalu pro filtrování podle délky vyzvánění v sekundách. Je-li menší než 0, hranice se nekontroluje

VyzvaDo

Konec intervalu pro filtrování podle délky vyzvánění v sekundách. Je-li menší než 0, hranice se nekontroluje

FOdecet

Je-li 1, hovory se filtrují podle časového odečtu

OdecetOd

Začátek intervalu pro filtrování podle časového odečtu v sekundách. Je-li menší než 0, hranice se nekontroluje

OdecetDo

Konec intervalu pro filtrování podle časového odečtu v sekundách. Je-li menší než 0, hranice se nekontroluje

FJedn

Je-li 1, hovory se filtrují podle počtu jednotek

JednOd

Začátek intervalu pro filtrování podle počtu jednotek. Je-li menší než 0, hranice se nekontroluje

JednDo

Konec intervalu pro filtrování podle počtu jednotek. Je-li menší než 0, hranice se nekontroluje

FPoradi

Je-li 1, hovory se filtrují podle identifikačního čísla hovoru

PoradiOd

Začátek intervalu pro filtrování podle identifikačního čísla hovoru. Je-li menší než 0, hranice se nekontroluje

PoradiDo

Konec intervalu pro filtrování podle identifikačního čísla hovoru. Je-li menší než 0, hranice se nekontroluje

FPripl

Je-li 1, hovory se filtrují podle příplatku

PriplOd

Začátek intervalu pro filtrování podle příplatku v procentech +100. Je-li menší než 0, hranice se nekontroluje

PriplDo

Konec intervalu pro filtrování podle příplatku v procentech +100. Je-li menší než 0, hranice se nekontroluje

FVyzved

Je-li 1, hovory se filtrují podle příznaku vyzvednutí

Vyzved

Filtr podle příznaku vyzvednutí, bitová maska ($01 = Vyzvednuté, $02 = Nevyzvednuté)

FVyucto

Je-li 1, hovory se filtrují podle příznaku vyúčtování

Vyucto

Filtr podle příznaku vyúčtování, bitová maska ($01 = Vyúčtované, $02 = Nevyúčtované)

FAutor

Je-li 1, hovory se filtrují podle příznaku autorizace

Autor

Filtr podle příznaku autorizace, bitová maska ($01 = Bez autorizace, $02 = Autorizace bez změny pobočky, $04 = Autorizace se změnou pobočky, $08 = Neznámý autorizační kód)

FOblast

Je-li 1, hovory se filtrují podle oblasti

Oblast

Filtr podle oblasti, bitová maska

FTyp

Je-li 1, hovory se filtrují podle typu hovoru

Typ

Filtr podle typu hovoru, bitová maska ($01 = odchozí, $02 = příchozí, $04 = vnitřní, $08 = tranzitní, $10 = neurčeno)

FCena

Je-li 1, hovory se filtrují podle ceny

Cena

Filtr podle ceny hovoru, bitová maska ($01 = placené, $02 = neplacené, $04 = cena v zadaném intervalu, $08 = přepočtená cena v zadaném intervalu)

CenaOd

Začátek intervalu pro filtrování podle ceny v haléřích. Je-li menší než 0, hranice se nekontroluje

CenaDo

Konec intervalu pro filtrování podle ceny v haléřích. Je-li menší než 0, hranice se nekontroluje

PrepOd

Začátek intervalu pro filtrování podle přepočtené ceny v haléřích. Je-li menší než 0, hranice se nekontroluje

PrepDo

Konec intervalu pro filtrování podle přepočtené ceny v haléřích. Je-li menší než 0, hranice se nekontroluje

FUzivKody

Je-li 1, hovory se filtrují podle uživatelských kódů

UzivKody

Seznam zobrazovaných uživatelských kódů, viz poznámky

FSkupiny

Je-li 1, hovory se filtrují podle skupin poboček

Skupiny

Seznam zobrazovaných skupin poboček, viz poznámky

FStrediska

Je-li 1, hovory se filtrují podle středisek poboček

Strediska

Seznam zobrazovaných středisek poboček, viz poznámky

FPobocky

Je-li 1, hovory se filtrují podle poboček

Pobocky

Seznam zobrazovaných poboček, viz poznámky

FLinky

Je-li 1, hovory se filtrují podle linek

Linky

Seznam zobrazovaných linek, viz poznámky

FSvazky

Je-li 1, hovory se filtrují podle svazků linek

Svazky

Seznam zobrazovaných svazků linek, viz poznámky

FCisla

Je-li 1, hovory se filtrují podle položky v interním seznamu

Cisla

Seznam identifikačních čísel zobrazovaných položek v interním seznamu, viz poznámky

FKody

Je-li 1, hovory se filtrují podle zúčtovacích kódů

Kody

Seznam zobrazovaných zúčtovacích kódů, viz poznámky

FOdchod

Je-li 1, hovory se filtrují podle přístupových (odchozích) kódů

Odchod

Seznam identifikačních čísel zobrazovaných přístupových (odchozích) kódů, viz poznámky

FUstredny

Je-li 1, hovory se filtrují podle identifikačního čísla ústředny

Ustredny

Seznam identifikačních čísel zobrazovaných ústředen, viz poznámky

FProvoz

Je-li 1, hovory se filtrují podle identifikačního čísla provozovatele

Provoz

Seznam identifikačních čísel zobrazovaných provozovatelů, viz poznámky

FVolCis

Je-li 1, hovory se filtrují podle telefonního čísla

Provoz

Seznam zobrazovaných telefonních čísel, viz poznámky

Papir

Formát papíru nastavený v tisku přehledu (0 = A3, 1 = A4, 2 = A5, 3 = uživatelský)

Sirka

Uživatelská šířka papíru nastavená v tisku přehledu v setinách milimetru

Vyska

Uživatelská výška papíru nastavená v tisku přehledu v setinách milimetru

NaVysku

Orientace papíru nastavená v tisku přehledu (0 = na šířku, 1 = na výšku)

OkrHor

Horní okraj při tisku přehledu v setinách milimetru

OkrDol

Dolní okraj při tisku přehledu v setinách milimetru

OkrPra

Pravý okraj při tisku přehledu v setinách milimetru

OkrLev

Levý okraj při tisku přehledu v setinách milimetru

Sloupcu

Počet sloupců na stránce

SlMezera

Mezera mezi sloupci v setinách milimetru

Hlavicka

Je-li 1, na začátku každé stránky je uvedena hlavička, specifikovaná dále

HlaVys

Výška oblasti, do které se tiskne hlavička v setinách milimetru

HlaMez

Mezera oddělující hlavičku a oblast, do které se tiskne přehled, v setinách milimetru

HlaLev

Text tisknutý v hlavičce u jejího levého okraje

HlaStr

Text tiskuntý v hlavičce na středu

HlaPra

Text tisknutý v hlavičce u jejího pravého okraje

HlaPis

Definice písma používaného v hlavičce, viz poznámky

Paticka

Je-li 1, na konci každé stránky je uvedena patička, specifikovaná dále

PatVys

Výška oblasti, do které se tiskne patička v setinách milimetru

PatMez

Mezera oddělující oblast, do které se tiskne přehled, a patičku v setinách milimetru

PatLev

Text tisknutý v patičce u jejího levého okraje

PatStr

Text tiskuntý v patičce na středu

PatPra

Text tisknutý v patičce u jejího pravého okraje

PatPis

Definice písma používaného v patičce, viz poznámky

cb

Je-li 1, přehled se tiskne bez barevného rozlišování řádků

Poznámky:

Seznam poboček, linek apod. se zapisuje jako text, jednotlivé položky se oddělují čárkou. Každá položka se skládá ze dvou komponent, které se nazývají prefix a suffix; u tabulky poboček je prefixem číslo ústředny a suffixem číslo pobočky. V textovém zápisu se položka uvádí ve tvaru prefix:suffix, přičemž prefix s dvojtečkou lze vynechat, pokud je shodný s prefixem předchozí položky. Prefix se vynechá u první položky, je-li roven 0.

Nastavení písma se ukládá jako text, jednotlivé položky jsou odděleny středníkem: Jméno;Velikost;Styl;Číslo znakové sady;Barva. Styl je řetězec 0-4 znaků: (B = tučné, I = kurzíva, U = podtržené, S = přeškrtnuté).


Tardat 4 - tabulka 'pristupkody'

Tabulky programu Tardat 4

Tabulka 'pristupkody'

Tabulka obsahuje nastavení přístupových kódů na ústřednách. Primárním klíčem tabulky je dvojice polí "pbxid" - číslo ústředny do které linka patří, a "id" - identifikační číslo položky.

Pole Popis

id

Identifikační číslo položky

pbxid

Identifikační číslo ústředny

maska

Maska telefonních čísel, pravidla pro rozlišení hovorů podle telefonního čísla

pozn

Poznámka, libovolný text

ubrat

Počet číslic, které se uberou z telefonního čísla zleva, pokud se použije tento řádek. Odstraňuje před tarifikací z čísla nežádoucí znaky, jako např. a-kódy na ústřednách Kapsch nebo 0 či 9 vytáčená na začátku čísla.

pridat

Číslice, které se přidají zleva k telefonnímu číslu před tarifikací, pokud se použije tento řádek.

maskatyp

Způsob maskování telefonního čísla, funkce musí být povolena v nastavení ústředny - pole 'maskpodle' (0 = Nemaskovat, 1 = Zbytek, 2 = Zbytek max. 4, 3 = 1 místo, 4 = 2 místa, 5 = 3 místa, 6 = 4 místa, 7 = 5 míst, 8 = 6 míst)

pripl

Příplatek k ceně hovoru v procentech

jepismo

Je-li 1, pak se hovory na této lince zvýrazní v přehledu odlišnou barvou písma, nastavenou v poli 'pismo'

pismo

Barva písma použitá pro hovory na této lince (funkce musí být povolena v poli 'jepismo'), viz poznámky

jepozadi

Je-li 1, pak se hovory na této lince zvýrazní v přehledu odlišnou barvou podkladu, nastavenou v poli 'pozadi'

pozadi

Barva podkladu použitá pro hovory na této lince (funkce musí být povolena v poli 'jepozadi'), viz poznámky

dosite

Je-li 1, tarifikují se hovory podle tarifní sítě. Číslo vstupního bodu musí být nastaveno v poli 'Bod'.

bod

Identifikační číslo vstupního bodu pro vstup do tarifní sítě. Pole 'DoSite' musí být 1.

dousite

Je-li 1, tarifikují se hovory podle uživatelské sítě.

dopsite

Je-li 1, tarifikují se hovory podle průchodové sítě. Číslo sítě musí být nastaveno v poli 'PSit'.

pst

Identifikační číslo průchodové sítě. Pole 'DoPSite' musí být 1.

dopbx

Je-li 1, tarifikují se hovory podle tabulky přístupových kódů jiné ústředny. Číslo ústředny musí být nastaveno v poli 'Pbx'.

pbx

Identifikační číslo ústředny. Pole 'DoPbx' musí být 1.

Poznámky:

Barva písma a podkladu se ukládá jako celé číslo, které po převedení do šestnáctkového zápisu lze rozdělit po osmi bitech na hodnoty barevných kanálů R, G a B.


Tardat 4 - tabulka 'provozovatele'

Tabulky programu Tardat 4

Tabulka 'provozovatele'

Pojmenovací tabulka provozovatelů. Obsahuje zjednodušenou kopii dat ze souboru s tarifní sítí.

Pole Popis

cid

Identifikační číslo státu

id

Identifikační číslo položky

jmeno

Jméno provozovatele

Poznámky:


Tardat 4 - tabulka 'pruchodkody'

Tabulky programu Tardat 4

Tabulka 'pruchodkody'

Tabulka obsahuje nastavení kódů v průchodových sítích. Primárním klíčem tabulky je dvojice polí "netid" - číslo sítě, do které položka patří, a "id" - identifikační číslo položky.

Pole Popis

id

Identifikační číslo položky

netid

Identifikační číslo průchodové sítě

maska

Maska telefonních čísel, pravidla pro rozlišení hovorů podle telefonního čísla

pozn

Poznámka, libovolný text

ubrat

Počet číslic, které se uberou z telefonního čísla zleva, pokud se použije tento řádek. Odstraňuje před tarifikací z čísla nežádoucí znaky, jako např. a-kódy na ústřednách Kapsch nebo 0 či 9 vytáčená na začátku čísla.

pridat

Číslice, které se přidají zleva k telefonnímu číslu před tarifikací, pokud se použije tento řádek.

pripl

Příplatek k ceně hovoru v procentech

dosite

Je-li 1, tarifikují se hovory podle tarifní sítě. Číslo vstupního bodu musí být nastaveno v poli 'Bod'.

bod

Identifikační číslo vstupního bodu pro vstup do tarifní sítě. Pole 'DoSite' musí být 1.

dousite

Je-li 1, tarifikují se hovory podle uživatelské sítě.

dopsite

Je-li 1, tarifikují se hovory podle průchodové sítě. Číslo sítě musí být nastaveno v poli 'PSit'.

pst

Identifikační číslo průchodové sítě. Pole 'DoPSite' musí být 1.

dopbx

Je-li 1, tarifikují se hovory podle tabulky přístupových kódů jiné ústředny. Číslo ústředny musí být nastaveno v poli 'Pbx'.

pbx

Identifikační číslo ústředny. Pole 'DoPbx' musí být 1.

Poznámky:


Tardat 4 - tabulka 'pruchodsite'

Tabulky programu Tardat 4

Tabulka 'pruchodsite'

Tabulka obsahuje pojmenování průchodových sítí. Položky sítí jsou uloženy v tabulce 'pruchodkody'.

Pole Popis

id

Identifikační číslo průchodové sítě

jmeno

Uživatelské jméno sítě

Poznámky:


Tardat 4 - tabulka 'role'

Tabulky programu Tardat 4

Tabulka 'role'

Tabulka obsahuje nastavení skupin uživatelů (tzv. rolí).

Pole Popis

id

Identifikační číslo role

jmeno

Jméno role

pozn

Poznámka, libovolný text

oprav

Oprávnění uživatelů zařazených do této skupiny. Obsah tohoto pole je zakódován a chráněn kontrolním součtem.

Poznámky:


Tardat 4 - tabulka 'sazebniky'

Tabulky programu Tardat 4

Tabulka 'sazebniky'

Pojmenovací tabulka sazebníků. Každý tarifní program je rozdělen do sazebníků, sazebníky jsou rozlišeny podle data platnosti. Tím je zajištěno, že program správně ocení i hovory při úpravě cen v rámci jednoho programu. Tabulka obsahuje zjednodušenou kopii dat ze souboru s tarifní sítí.

Pole Popis

cid

Identifikační číslo státu

pid

Identifikační číslo provozovatele

qid

Identifikační číslo tarifního programu

id

Identifikační číslo sazebníku

jmeno

Jméno sazebníku

plati_od

Začátek platnosti sazebníku. Pokud je uvedena hodnota <= 0, sazebník není časově omezen.

plati_do

Konec platnosti sazebníku. Pokud je uvedena hodnota <= 0, sazebník není časově omezen.

Poznámky:


Tardat 4 - tabulka 'skupiny'

Tabulky programu Tardat 4

Tabulka 'skupiny'

Tabulka obsahuje nastavení skupin poboček. Primárním klíčem tabulky je pole "id". Skupiny jsou společné pro všechny ústředny. Pobočky jsou do skupin zařazeny na základě hodnoty uvedené v poli 'skup' v tabulce 'pobocky'. Speciální význam má skupina s identifikačním číslem 0, standardně pojmenovaná "Ostatní pobočky", do které se automaticky zařazují všechny pobočky, které nepatří do jiné skupiny. Tabulka má podobný význam jako střediska, ale je na nich nezávislá. To umožňuje uživateli v případě potřeby rozdělit pobočky do skupin podle dvou různých kritérií.

Pole Popis

id

Identifikační číslo skupiny

jmeno

Uživatelské jméno skupiny, které se zobrazuje v přehledech.

pozn

Poznámka, libovolný text.

pripl

Příplatek k ceně hovoru v procentech

jepismo

Je-li 1, pak se hovory na pobočkách zařazených do této skupiny zvýrazní v přehledu odlišnou barvou písma, nastavenou v poli 'pismo'

pismo

Barva písma použitá pro hovory na pobočkách zařazených do této skupiny (funkce musí být povolena v poli 'jepismo'), viz poznámky

jepozadi

Je-li 1, pak se hovory na pobočkách zařazených do této skupiny zvýrazní v přehledu odlišnou barvou podkladu, nastavenou v poli 'pozadi'

pozadi

Barva podkladu použitá pro hovory na pobočkách zařazených do této skupiny (funkce musí být povolena v poli 'jepozadi'), viz poznámky

Poznámky:

Barva písma a podkladu se ukládá jako celé číslo, které po převedení do šestnáctkového zápisu lze rozdělit po osmi bitech na hodnoty barevných kanálů R, G a B.


Tardat 4 - tabulka 'sloupce'

Tabulky programu Tardat 4

Tabulka 'sloupce'

Tabulka obsahuje nastavení zobrazovaných údajů v přehledech - tj. jaké sloupce jsou v přehledu zobrazeny, jejich pořadí, šířka apod. Primárním klíčem je dvojice polí "pid" a "cid", z nichž první je identifikační číslo přehledu (viz tabulka 'prehledy') a druhé je identifikační číslo sloupce, které je definováno výčtem uvedeným ve zdrojovém kódu programu.

Pole Popis

pid

Identifikační číslo přehledu

cid

Identifikační číslo sloupce

zarov

Způsob vodorovného zarovnání textu v tabulce (0 = do leva, 1 = na střed, 2 = do prava)

poradi

Pořadí sloupce v tabulce, počítáno od 1, započítávají se i nezobrazné sloupce aby se zachovala jejich poloha vůči zobrazovaným sloupcům

vis

Je-li 1, pak je tento údaj zobrazený

usrw

Je-li 1, pak je tento sloupec zobrazen s uživatelskou šířkou

sirka

Uživatelská šířka sloupce v pixelech

Poznámky:


Tardat 4 - tabulka 'staty'

Tabulky programu Tardat 4

Tabulka 'staty'

Tabulka předdefinovaných mezinárodních předvoleb pro dialog 'Editace vstupního bodu'. Obsahuje kopii dat ze souboru s tarifní sítí.

Pole Popis

id

Identifikační číslo položky

jmeno

Jméno státu

mzncis

Mezinárodní předvolba (např. 00420).

mzmcis

Předvolba pro meziměstská volání (v ČR se nepoužívá, v SR je to nula)

Poznámky:


Tardat 4 - tabulka 'strediska'

Tabulky programu Tardat 4

Tabulka 'strediska'

Tabulka obsahuje nastavení středisek poboček. Primárním klíčem tabulky je pole "id". Střediska jsou společné pro všechny ústředny. Pobočky jsou do středisek zařazeny na základě hodnoty uvedené v poli 'stred' v tabulce 'pobocky'. Speciální význam má položka s identifikačním číslem 0, standardně pojmenovaná "Ostatní pobočky", do které se automaticky zařazují všechny pobočky, které nepatří do jiného střediska. Tabulka má podobný význam jako skupiny, ale je na nich nezávislá. To umožňuje uživateli v případě potřeby rozdělit pobočky do skupin podle dvou různých kritérií.

Pole Popis

id

Identifikační číslo střediska

jmeno

Uživatelské jméno střediska, které se zobrazuje v přehledech.

pozn

Poznámka, libovolný text.

pripl

Příplatek k ceně hovoru v procentech

jepismo

Je-li 1, pak se hovory na pobočkách zařazených do tohoto střediska zvýrazní v přehledu odlišnou barvou písma, nastavenou v poli 'pismo'

pismo

Barva písma použitá pro hovory na pobočkách zařazených do tohoto střediska (funkce musí být povolena v poli 'jepismo'), viz poznámky

jepozadi

Je-li 1, pak se hovory na pobočkách zařazených do tohoto střediska zvýrazní v přehledu odlišnou barvou podkladu, nastavenou v poli 'pozadi'

pozadi

Barva podkladu použitá pro hovory na pobočkách zařazených do tohoto střediska (funkce musí být povolena v poli 'jepozadi'), viz poznámky

Poznámky:

Barva písma a podkladu se ukládá jako celé číslo, které po převedení do šestnáctkového zápisu lze rozdělit po osmi bitech na hodnoty barevných kanálů R, G a B.


Tardat 4 - tabulka 'styly'

Tabulky programu Tardat 4

Tabulka 'styly'

Tabulka obsahuje nastavení stylů - písma, barvy a zarovnání textů používaných v přehledech. Primárním klíčem je dvojice polí "pid" a "sid", z nichž první je identifikační číslo přehledu (viz tabulka 'prehledy') a druhé je identifikační číslo stylu, které je definováno výčtem uvedeným ve zdrojovém kódu programu.

Pole Popis

pid

Identifikační číslo přehledu

sid

Identifikační číslo stylu

font

Nastavení písma, viz poznámky

vzarov

Svislé zarovnání textů na řádcích přehledu (0 = nahoru, 1 = na střed, 2 = dolů)

hzarov

Vodorovné zarovnání textů na řádcích přehledu, ignoruje se u řádků tabulek, protože tam je zarovnání určeno v nastavení sloupce (0 = do leva, 1 = na střed, 2 = do prava)

vyska

Uživatelská výška řádku v pixelech

Poznámky:

Nastavení písma se ukládá jako text, jednotlivé položky jsou odděleny středníkem: Jméno;Velikost;Styl;Číslo znakové sady;Barva. Styl je řetězec 0-4 znaků: (B = tučné, I = kurzíva, U = podtržené, S = přeškrtnuté).


Tardat 4 - tabulka 'svazky'

Tabulky programu Tardat 4

Tabulka 'svazky'

Tabulka obsahuje nastavení svazků linek na ústřednách. Primárním klíčem tabulky je dvojice polí "pbxid" - číslo ústředny do které svazek patří, a "id" - identifikační číslo svazku.

Pole Popis

id

Identifikační číslo svazku

pbxid

Identifikační číslo ústředny

jmeno

Uživatelské jméno svazku, které se zobrazuje v přehledech, např. jméno operátora apod.

pozn

Poznámka, libovolný text

pripl

Příplatek k ceně hovoru v procentech

jepismo

Je-li 1, pak se hovory na přiřazených linkách zvýrazní v přehledu odlišnou barvou písma, nastavenou v poli 'pismo'

pismo

Barva písma použitá pro hovory na přiřazených linkách (funkce musí být povolena v poli 'jepismo'), viz poznámky

jepozadi

Je-li 1, pak se hovory na přiřazených linkách zvýrazní v přehledu odlišnou barvou podkladu, nastavenou v poli 'pozadi'

pozadi

Barva podkladu použitá pro hovory na přiřazených linkách (funkce musí být povolena v poli 'jepozadi'), viz poznámky

ToPtr_DoSite

Odchozí připojení: Je-li 1, jsou linky zapojeny do tarifní sítě. Číslo vstupního bodu musí být nastaveno v poli 'ToPtr_Bod'.

ToPtr_Bod

Odchozí připojení: Identifikační číslo vstupního bodu pro vstup do tarifní sítě. Pole 'ToPtr_DoSite' musí být 1.

ToPtr_DoUSite

Odchozí připojení: Je-li 1, jsou linky zapojeny do uživatelské sítě.

ToPtr_DoTab

Odchozí připojení: Je-li 1, hovory se tarifikují podle tabulky přístupových kódů v této ústředně

ToPtr_DoPSite

Odchozí připojení: Je-li 1, jsou linky zapojeny do průchodové sítě. Číslo sítě musí být nastaveno v poli 'ToPtr_PSit'.

ToPtr_PSit

Odchozí připojení: Identifikační číslo průchodové sítě. Pole 'ToPtr_DoPSite' musí být 1.

ToPtr_DoPbx

Odchozí připojení: Je-li 1, hovory se tarifikují podle tabulky přístupových kódů jiné ústředny. Číslo ústředny musí být nastaveno v poli 'ToPtr_Pbx'.

ToPtr_Pbx

Odchozí připojení: Identifikační číslo ústředny, do které jsou linky připojeny. Pole 'ToPtr_DoPbx' musí být 1.

FmPtr_DoSite

Příchozí připojení: Je-li 1, jsou linky zapojeny do tarifní sítě. Číslo vstupního bodu musí být nastaveno v poli 'FmPtr_Bod'.

FmPtr_Bod

Příchozí připojení: Identifikační číslo vstupního bodu pro vstup do tarifní sítě. Pole 'FmPtr_DoSite' musí být 1.

FmPtr_DoUSite

Příchozí připojení: Je-li 1, jsou linky zapojeny do uživatelské sítě.

FmPtr_DoTab

Příchozí připojení: Je-li 1, hovory se tarifikují podle tabulky přístupových kódů v této ústředně

FmPtr_DoPSite

Příchozí připojení: Je-li 1, jsou linky zapojeny do průchodové sítě. Číslo sítě musí být nastaveno v poli 'FmPtr_PSit'.

FmPtr_PSit

Příchozí připojení: Identifikační číslo průchodové sítě. Pole 'FmPtr_DoPSite' musí být 1.

FmPtr_DoPbx

Příchozí připojení: Je-li 1, hovory se tarifikují podle tabulky přístupových kódů jiné ústředny. Číslo ústředny musí být nastaveno v poli 'FmPtr_Pbx'.

FmPtr_Pbx

Příchozí připojení: Identifikační číslo ústředny, do které jsou linky připojeny. Pole 'FmPtr_DoPbx' musí být 1.

Poznámky:

Barva písma a podkladu se ukládá jako celé číslo, které po převedení do šestnáctkového zápisu lze rozdělit po osmi bitech na hodnoty barevných kanálů R, G a B.


Tardat 4 - tabulka 'tarpasma'

Tabulky programu Tardat 4

Tabulka 'tarpasma'

Pojmenovací tabulka tarifních pásem. Tabulka obsahuje zjednodušenou kopii dat ze souboru s tarifní sítí.

Pole Popis

cid

Identifikační číslo státu

pid

Identifikační číslo provozovatele

qid

Identifikační číslo tarifního programu

tid

Identifikační číslo sazebníku

id

Identifikační číslo tarifního pásma

jmeno

Jméno tarifního pásma

Poznámky:


Tardat 4 - tabulka 'tarprogramy'

Tabulky programu Tardat 4

Tabulka 'tarprogramy'

Pojmenovací tabulka tarifních programů. Obsahuje zjednodušenou kopii dat ze souboru s tarifní sítí.

Pole Popis

cid

Identifikační číslo státu

pid

Identifikační číslo provozovatele

id

Identifikační číslo tarifního programu

jmeno

Jméno tarifního programu

Poznámky:


Tardat 4 - tabulka 'tarprovozy'

Tabulky programu Tardat 4

Tabulka 'tarprovozy'

Pojmenovací tabulka tarifních provozů. Tabulka obsahuje zjednodušenou kopii dat ze souboru s tarifní sítí.

Pole Popis

cid

Identifikační číslo státu

pid

Identifikační číslo provozovatele

qid

Identifikační číslo tarifního programu

tid

Identifikační číslo sazebníku

id

Identifikační číslo tarifního provozu

jmeno

Jméno tarifního provozu

Poznámky:


Tardat 4 - tabulka 'tarsite'

Tabulky programu Tardat 4

Tabulka 'tarsite'

Tabulka s informacemi o nainstalované tarifní síti (verze, datum aktualizace, ...). Tabulka má vždy pouze jeden řádek.

Pole Popis

fileid

Druh tarifní sítě (0 = veřejná, 1 = zákaznická)

version

Číslo verze tarifní sítě. Musí souhlasit s číslem verze programu a s číslem verze uloženým v souboru s tarifní sítí. V opačném případě program nepovolí zpracování nových dat.

date

Datum poslední změny v tarifní síti. Používá se při zjišťování aktualizací na internetu.

Poznámky:


Tardat 4 - tabulka 'ustredny'

Tabulky programu Tardat 4

Tabulka 'ustredny'

Tabulka definovaných ústředen. Obsahuje základní informace o ústředně, nastavení tarifního řádku, apod. Primárním klíčem je pole 'id' -- identifikační číslo ústředny. Časové odečty a filtry jsou uloženy ve zvláštní tabulce 'odefil'.

Pole Popis

id

Identifikační číslo ústředny

jmeno

Uživatelské jméno ústředny

pozn

Poznámka, libovolný text

format

Číslo formátu tarifního řádku, viz přílohy

vyrobcepbx

Název výrobce ústředny, pouze pro orientaci, pro tarifikaci je rozhodující číslo formátu

typpbx

Typ ústředny, případně rozlišení varianty tarifního řádku, pouze pro orientaci, pro tarifikaci je rozhodující číslo formátu

pobautodet

Je-li 1, pak je povolena autodetekce poboček, tj. automatické zařazování nových poboček do tabulky poboček

linautodet

Je-li 1, pak je povolena autodetekce linek, tj. automatické zařazování nových poboček do tabulky linek.

zkautodet

Je-li 1, pak je povolena autodetekce zúčt. kódů, tj. automatické zařazování nových poboček do tabulky zúčt. kódů.

skupautodet

Je-li 1, pak je povolena autodetekce skupin (nákladových středisek), tj. automatické zařazování nových poboček do tabulky skupin

ukautodet

Je-li 1, pak je povolena autodetekce uživ. kódů, tj. automatické zařazování nových poboček do tabulky uživ. kódů.

pobmigrate

Je-li 1, pak je povoleno přesouvání poboček mezi skupinami podle informací předaných z ústředny.

jevolba

Je-li 1, pak ústředna zahrnuje do trvání hovoru také čas potřebný k vytočení čísla.

jetimestart

Je-li 1, pak ústředna dává v tarifním řádku datum a čas zanájení hovoru, v opačném případě dává datum a čas ukončení hovoru.

jetrvod1pulzu

Je-li 1, pak ústředna nuluje počítadlo délky hovory při příchodu prvního 16kHz pulzu.

maxpulzu

Kapacita počítadla tarifních pulzů na ústředně mínus 1. Nejvyšší číslo, které může být zapsáno v řádku.

jeodchozi

Je-li 1, předává ústředna informace o odchozích hovorech (pobocka -- linka)

jeprichozi

Je-li 1, předává ústředna informace o příchozích hovorech (linka -- pobocka)

jetranzitni

Je-li 1, předává ústředna informace o tranzitních hovorech (linka -- linka)

jevnitrni

Je-li 1, předává ústředna informace o vnitřních hovorech (pobocka -- pobocka)

jmenpob

Způsob přebírání jmen poboček v případě, že ústředna předává jména v tarifním řádku (0 = nikdy, 1 = nastavit jméno u nově autodetekovaných položek, 2 = vždy nastavit jméno podle ústředny)

jmenzk

Způsob přebírání jmen zúčtovacích kódů v případě, že ústředna předává jména v tarifním řádku (0 = nikdy, 1 = nastavit jméno u nově autodetekovaných položek, 2 = vždy nastavit jméno podle ústředny)

jmenuk

Způsob přebírání jmen uživatelských kódů v případě, že ústředna předává jména v tarifním řádku (0 = nikdy, 1 = nastavit jméno u nově autodetekovaných položek, 2 = vždy nastavit jméno podle ústředny)

soubory

Povolení dalších výstupů ze zpracování, bitová maska ($01 = záložní textový soubor 'patext.txt')

Poznámky:


Tardat 4 - tabulka 'uzivatele'

Tabulky programu Tardat 4

Tabulka 'uzivatele'

Tabulka obsahuje nastavení uživatelů.

Pole Popis

id

Identifikační číslo uživatele

jmeno

Jméno uživatele

heslo

Otisk přístupového hesla.

pozn

Poznámka, libovolný text

oprav

Oprávnění uživatele. Obsah tohoto pole je zakódován a chráněn kontrolním součtem. Pokud je uživatel zařazen do skupiny, musí obsah v tomto poli souhlasit s oprávněním nastaveným v tabulce role.

dorole

Je-li 1, pak je uživatel zařazen do skupiny, jejíž číslo je uvedeno v poli 'role'.

role

Identifikační číslo role, do které je uživatel zařazen. Platné pouze tehdy, je-li pole 'dorole' nastaveno na 1.

vystavil

Obvykle plné jméno uživatele; tiskne se na faktuře do pole 'vystavil'.

Poznámky:


Tardat 4 - tabulka 'uzivkody'

Tabulky programu Tardat 4

Tabulka 'uzivkody'

Tabulka obsahuje nastavení uživatelských kódů na ústřednách. Primárním klíčem tabulky je dvojice polí "pbxid" - číslo ústředny do které pobočka patří, a "id" - uživatelský kód.

Pole Popis

id

Uživatelský kód (max. 2 místa)

pbxid

Identifikační číslo ústředny

jmeno

Uživatelské jméno kódu, které se zobrazuje v přehledech.

pozn

Poznámka, libovolný text.

pripl

Příplatek k ceně hovoru v procentech

jepismo

Je-li 1, pak se hovory s tímto kódem zvýrazní v přehledu odlišnou barvou písma, nastavenou v poli 'pismo'

pismo

Barva písma použitá pro hovory s tímto kódem (funkce musí být povolena v poli 'jepismo'), viz poznámky

jepozadi

Je-li 1, pak se hovory s tímto kódem zvýrazní v přehledu odlišnou barvou podkladu, nastavenou v poli 'pozadi'

pozadi

Barva podkladu použitá pro hovory s tímto kódem (funkce musí být povolena v poli 'jepozadi'), viz poznámky

maskatyp

Způsob maskování telefonního čísla, funkce musí být povolena v nastavení ústředny - pole 'maskpodle' (0 = Nemaskovat, 1 = Zbytek, 2 = Zbytek max. 4, 3 = 1 místo, 4 = 2 místa, 5 = 3 místa, 6 = 4 místa, 7 = 5 míst, 8 = 6 míst)

Poznámky:

Barva písma a podkladu se ukládá jako celé číslo, které po převedení do šestnáctkového zápisu lze rozdělit po osmi bitech na hodnoty barevných kanálů R, G a B.


Tardat 4 - tabulka 'uzivsit'

Tabulky programu Tardat 4

Tabulka 'uzivsit'

Tabulka obsahuje nastavení uživatelských sazeb. Podle telefonního čísla je možné rozlišit jednotlivé sazby.

Pole Popis

id

Identifikační číslo položky

maska

Maska telefonního čísla, pravidla pro rozlišení hovorů podle telefonního čísla

jmeno

Uživatelské jméno zobrazované v přehledu v poli "Umístění"

pozn

Poznámka, libovolný text

cena

Cena hovoru v korunách. Konkrétní význam záleží na nastavení dalších polí. Jde buď o cenu za minutu, za tarifní jednotku nebo paušální částka za každý hovor.

sekund

Interval v sekundách. Nejmenší účtovaná časová jednotka. Je-li 0, pak je uvedená cena paušální, tj. započítává se bez ohledu na trvání hovoru. Je-li větší než nula, upraví se délka trvání hovoru v sekundách na celé násobky intervalu vždy směrem nahoru, vydělí se 60 pro převod na minuty a vynásobí částkou uvedenou v poli 'cena'.

sdph

Je-li 1, pak je cena uvedená v poli 'cena' včetně daně z přidané hodnoty.

procdph

Sazba daně z přidané hodnoty v desetinách procenta.

typinfo

Způsob interpretace tarifní informace předávané z ústředny

oblast

Číslo tarifního oblasti, do které bude hovor zařazen, hodnoty jsou určeny výčtem ve zdrojovém kódu, nesouvisí s tabulkou 'oblastisite'.

Poznámky:


Tardat 4 - tabulka 'uzlysite'

Tabulky programu Tardat 4

Tabulka 'uzlysite'

Pojmenovací tabulka pro sloupce 'stát', 'umístění' a 'detailní umístění'. Obsahuje zjednodušenou kopii dat ze souboru s tarifní sítí.

Pole Popis

id

Identifikační číslo uzlu

jmeno

Jméno uzlu

Poznámky:


Tardat 4 - tabulka 'vstupnibody'

Tabulky programu Tardat 4

Tabulka 'vstupnibody'

Tabulka obsahuje nastavení vstupních bodů. Vstupní bod obsahuje informace důležité pri ocenění hovoru v tarifní síti -- vlastní telefonní číslo, používaný tarifní program a způsob interpretace tarifních informací. Vstupní body jsou společné pro všechny ústředny.

Pole Popis

id

Identifikační číslo položky

jméno

Uživatelské jméno, obvykle jméno operátora

cislo

Vlastní telefonní číslo v národním formátu. Určuje místo zapojení telefonní linky do veřejné telefonní sítě.

stat

Identifikační číslo státu - viz tabulka 'staty'

prov

Identifikační číslo provozovatele - viz tabulka 'provozovatele'

prog

Identifikační číslo tarifního programu používaného pro ocenění hovorů - viz tabulka 'tarprogramy'

typinfo

Způsob interpretace tarifní informace předávané z ústředny (0 = informace o ceně hovoru, 1 = informace o délce hovoru, 2 = informace o uskutečnění hovoru, 3 = nepoužito)

Poznámky:


Tardat 4 - tabulka 'zuctkody'

Tabulky programu Tardat 4

Tabulka 'zuctkody'

Tabulka obsahuje nastavení zúčtovacích kódů na ústřednách. Primárním klíčem tabulky je dvojice polí "pbxid" - číslo ústředny do které pobočka patří, a "id" - zúčtovací kód.

Pole Popis

id

Zúčtovací kód (max. 16 míst)

pbxid

Identifikační číslo ústředny

jmeno

Uživatelské jméno kódu, které se zobrazuje v přehledech, např. jméno zaměstnance apod.

pozn

Poznámka, libovolný text.

pripl

Příplatek k ceně hovoru v procentech

jepismo

Je-li 1, pak se hovory s tímto kódem zvýrazní v přehledu odlišnou barvou písma, nastavenou v poli 'pismo'

pismo

Barva písma použitá pro hovory s tímto kódem (funkce musí být povolena v poli 'jepismo'), viz poznámky

jepozadi

Je-li 1, pak se hovory s tímto kódem zvýrazní v přehledu odlišnou barvou podkladu, nastavenou v poli 'pozadi'

pozadi

Barva podkladu použitá pro hovory s tímto kódem (funkce musí být povolena v poli 'jepozadi'), viz poznámky

vis

Je-li 0, pak hovory s tímto kódem zobrazují jako by žádný kód nebyl zadán

maskatyp

Způsob maskování telefonního čísla, funkce musí být povolena v nastavení ústředny - pole 'maskpodle' (0 = Nemaskovat, 1 = Zbytek, 2 = Zbytek max. 4, 3 = 1 místo, 4 = 2 místa, 5 = 3 místa, 6 = 4 místa, 7 = 5 míst, 8 = 6 míst)

Poznámky:

Barva písma a podkladu se ukládá jako celé číslo, které po převedení do šestnáctkového zápisu lze rozdělit po osmi bitech na hodnoty barevných kanálů R, G a B.